]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
need chrome/test/data/nacl/nacl_test_data.gyp by chrome/chrome.gyp
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
6c8531c6 10%bcond_without nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
d8ba130c 15%bcond_with tcmalloc # use tcmalloc
2108baf2 16%bcond_with system_sqlite # with system sqlite
32a2443e 17%bcond_without system_flac # with system flac
e8e15592 18%bcond_without system_libwebp # with system libwebp
32a2443e 19%bcond_without system_speex # with system speex
c14cd342 20%bcond_with system_v8 # with system v8
32a2443e 21%bcond_without system_vpx # with system vpx
d617ab39 22%bcond_without system_yasm # with system yasm
4c272135
ER
23# system zlib disabled because of mixed-source.patch
24# https://code.google.com/p/chromium/issues/detail?id=143623
25%bcond_with system_zlib # with system zlib
5997e180 26%bcond_without libjpegturbo # use libjpeg-turbo features
7e136323 27%bcond_without verbose # verbose build (V=1)
0c480b89 28
c6325ea2
ER
29%if %{with nacl}
30# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
31# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
32#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
33#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
34#14:51:06 @baggins> as-needed will take care of unneeded lib
35#14:52:03 @baggins> -lssp comes with gcc
107b55fe 36%define _ssp_cflags %{nil}
c6325ea2
ER
37%endif
38
6d92f81c 39# TODO
f1b276d4 40# - check system sqlite linking problems
2108baf2 41# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 42# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 43# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 44# - use_system_hunspell
32a2443e 45# - use_system_stlport
a3140cd1
ER
46# - other defaults: src/build/common.gypi
47
e53ecfb5 48# NOTES:
4fe038cb
ER
49# - mute BEEP mixer if you do not want to hear horrible system bell when
50# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
51# - build -bp: 1.2G
52# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 53# - build x86_64: ~1.9G
f1b276d4 54# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 55# - to look for new tarball, use update-source.sh script
f1b276d4 56
e68aa7e7 57# NOTE TO USERS:
c8b02491 58# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 59# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 60# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 61
a3140cd1 62%define gyp_rev 1014
11ad81c4 63Summary: A WebKit powered web browser
05f72ae2 64Name: chromium-browser
9516ca97
ER
65Version: 23.0.1271.64
66Release: 1
05f72ae2 67License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 68Group: X11/Applications/Networking
9516ca97
ER
69Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
70# Source0-md5: 6c467affd292ee9a9020ac91147969c8
37ceaf05 71Source1: %{name}.default
8b53130d
ER
72Source2: %{name}.sh
73Source3: %{name}.desktop
56c6e811
ER
74Source5: find-lang.sh
75Source6: update-source.sh
76Source7: clean-source.sh
836b1cac 77Source8: get-source.sh
9516ca97 78#Patch0: system-libs.patch
48b341f5 79Patch1: plugin-searchdirs.patch
80Patch2: gyp-system-minizip.patch
7abc645c 81Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 82Patch4: path-libpdf.patch
48b341f5 83Patch5: options-support.patch
0e5636cb 84Patch6: get-webkit_revision.patch
5aa5df39 85Patch7: dlopen_sonamed_gl.patch
4765ddf1 86Patch8: chromium_useragent.patch.in
c0808220 87Patch9: chromium-ppapi.patch
1347c76c
AM
88# https://bugs.gentoo.org/show_bug.cgi?id=393471
89# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 90Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
91Patch15: nacl-build-irt.patch
92Patch16: nacl-linkingfix.patch
e9abb380 93Patch17: system-icu.patch
9516ca97 94Patch18: nacl-no-untar.patch
750b48f7 95URL: http://www.chromium.org/Home
ae3fe89f 96%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 97BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
98BuildRequires: alsa-lib-devel
99BuildRequires: atk-devel
100BuildRequires: bison
11ad81c4 101BuildRequires: bzip2-devel
5997e180
ER
102%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
103%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
104%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 105%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 106%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 107BuildRequires: dbus-glib-devel
77f32fa3 108BuildRequires: expat-devel
d617ab39 109%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 110BuildRequires: flex
11ad81c4 111BuildRequires: fontconfig-devel
f1b276d4 112BuildRequires: glib2-devel
05f72ae2 113BuildRequires: gperf
8b53130d 114BuildRequires: gtk+2-devel
a3140cd1 115%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 116BuildRequires: hicolor-icon-theme
05f72ae2 117BuildRequires: libevent-devel
7f40f3f4 118%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 119BuildRequires: libicu-devel >= 4.6
39c71b4c 120%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 121%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 122BuildRequires: libpng-devel
e266589e 123%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 124BuildRequires: libstdc++-devel
32a2443e 125%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 126%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 127BuildRequires: libxml2-devel
11ad81c4 128BuildRequires: libxslt-devel
f1b276d4 129BuildRequires: lzma
11ad81c4 130BuildRequires: minizip-devel
05f72ae2 131BuildRequires: nspr-devel
f1b276d4 132BuildRequires: nss-devel >= 1:3.12.3
35902862 133BuildRequires: pam-devel
f1b276d4 134BuildRequires: pango-devel
48b341f5 135BuildRequires: perl-modules
136BuildRequires: pkgconfig
ae3fe89f 137%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 138BuildRequires: python
46cdefee 139#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 140BuildRequires: python-modules
0cad051b 141BuildRequires: rpm >= 4.4.9-56
f1b276d4 142BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 143%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 144BuildRequires: sqlite3-devel >= 3.6.1
89f0dde4 145BuildRequires: subversion
0cad051b 146BuildRequires: tar >= 1:1.22
0a424ee2 147BuildRequires: udev-devel
2303ed45 148BuildRequires: util-linux
c14cd342 149%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 150BuildRequires: which
f1b276d4 151BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
152BuildRequires: xorg-lib-libXt-devel
153BuildRequires: xorg-lib-libXtst-devel
836b1cac 154BuildRequires: xz
a3140cd1 155%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 156%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 157Requires: browser-plugins >= 2.0
0cad051b 158Requires: desktop-file-utils
0eb19b0b 159Requires: hicolor-icon-theme
c1edaafa 160%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 161%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 162Requires: xdg-utils >= 1.0.2-4
e53ecfb5 163Provides: wwwbrowser
c3582150 164Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 165Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 166ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 167BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 168
589d90ea 169%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 170
e7fa0817
ER
171# Usage: gyp_with BCOND_NAME [OPTION_NAME]
172%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 173
6b113615
ER
174%if %{without debuginfo}
175%define _enable_debug_packages 0
176%endif
177
11ad81c4 178%description
80838854
ER
179Chromium is an open-source browser project that aims to build a safer,
180faster, and more stable way for all Internet users to experience the
181web.
182
183Chromium serves as a base for Google Chrome, which is Chromium
184rebranded (name and logo) with very few additions such as usage
185tracking and an auto-updater system.
186
f1b276d4
ER
187%package l10n
188Summary: chromium-browser language packages
189Group: I18n
190Requires: %{name} = %{version}-%{release}
191
192%description l10n
193Chromium is an open-source browser project that aims to build a safer,
194faster, and more stable way for all Internet users to experience the
195web.
196
197This package contains language packages for 50 languages:
198
e7fa0817
ER
199ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
200he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
201pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
202zh-TW
f1b276d4
ER
203
204%prep
836b1cac 205%setup -q
589d90ea 206
05f72ae2
ER
207# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
208# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
209. ./src/chrome/VERSION
210ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
211test "$ver" = %{version}
212
213gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 214test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 215
836b1cac 216v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 217
4765ddf1
ER
218# add chromium and pld to useragent
219%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
220sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
221 -e 's/@BUILD_DIST_NAME@/PLD/g' \
222 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 223 < %{PATCH8} | %{__patch} -p1
4765ddf1 224
56c6e811
ER
225%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
226ln -s %{SOURCE7} src
f1b276d4 227
9516ca97 228#%patch0 -p1
05f72ae2
ER
229%patch1 -p1
230%patch2 -p1
7abc645c 231%patch3 -p1
72cb20c1 232%patch4 -p1
05f72ae2 233%patch5 -p1
0e5636cb 234%patch6 -p1
5aa5df39 235%patch7 -p1
e9abb380 236%patch15 -p1
77f32fa3 237cd src
c0808220 238%patch9 -p0
f4a8da6a 239%{!?with_libjpegturbo:%patch11 -p0}
5997e180 240%patch16 -p1
e9abb380 241%patch17 -p0
1347c76c 242cd ..
9516ca97 243%patch18 -p1
0c480b89 244
828bdd1a 245cd src
e9abb380
ER
246
247# Missing gyp files in tarball.
248# https://code.google.com/p/chromium/issues/detail?id=144823
249if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
250 echo "tarball fixed, please remove workaround"
251 exit 1
252fi
253
254install -d chrome/test/data/nacl
255cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
256{
257 'targets': [
258 {
259 'target_name': 'nacl_tests',
260 'type': 'none',
261 },
262 ],
263}
264EOF
265
4c272135 266sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
164020eb 267
e266589e 268%build
f1b276d4 269cd src
5997e180
ER
270
271%if %{with nacl}
272rm -rf native_client/toolchain/linux_x86_newlib
273# Make symlinks for nacl
274cd native_client/toolchain
275install -d linux_x86_newlib/x86_64-nacl/bin
276install -d linux_x86_newlib/x86_64-nacl/lib
277install -d linux_x86_newlib/x86_64-nacl/lib32
278install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
279install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
280install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
281# link newlib toolchain to glibc as well, see gentoo bug #417019
282#ln -s linux_x86_newlib linux_x86
5997e180
ER
283cd linux_x86_newlib/x86_64-nacl/bin
284ln -s %{_bindir}/x86_64-nacl-gcc gcc
285ln -s %{_bindir}/x86_64-nacl-g++ g++
286ln -s %{_bindir}/x86_64-nacl-ar ar
287ln -s %{_bindir}/x86_64-nacl-as as
288ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
289ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
290ln -s %{_bindir}/x86_64-nacl-strip strip
291ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
292ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
293cd ../nacl/include
294for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
295 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
296done
297cd ../../../../../..
298%endif
299
164020eb 300test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
301%ifarch %{ix86}
302 -Dtarget_arch=ia32 \
303%endif
304%ifarch %{x8664}
0c480b89
ER
305 -Dtarget_arch=x64 \
306%endif
7b454a31
AM
307%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
308 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
309%endif
310%if %{with sandboxing}
311 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
312 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
313%endif
314 %{!?debug:-Dwerror=} \
c980b122 315 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 316 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 317 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
318 -Dffmpeg_branding=Chrome \
319 -Dproprietary_codecs=1 \
c0808220 320%if %{with nacl}
c0808220 321 -Ddisable_glibc=1 \
038f76b9 322 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
323 -Ddisable_glibc_untar=1 \
324 -Ddisable_newlib_untar=1 \
325 -Ddisable_pnacl_untar=1 \
c0808220
ER
326%else
327 -Ddisable_nacl=1 \
328%endif
6c8531c6 329 -Ddisable_pnacl=1 \
a3140cd1
ER
330 %{!?with_sse2:-Ddisable_sse2=1} \
331 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
332 %{gyp_with cups} \
333 %{gyp_with flac} \
334 %{gyp_with gconf} \
335 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
336 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
337 %{gyp_with pulseaudio} \
e8e15592 338 %{gyp_with system_libwebp} \
e7fa0817
ER
339 %{gyp_with system_speex} \
340 %{gyp_with system_sqlite} \
341 %{gyp_with system_v8} \
32a2443e 342 %{gyp_with system_vpx} \
e7fa0817
ER
343 %{gyp_with system_yasm} \
344 %{gyp_with system_zlib} \
0c480b89 345 -Duse_system_bzip2=1 \
0b214002 346 -Duse_system_icu=1 \
f1b276d4 347 -Duse_system_libevent=1 \
0c480b89 348 -Duse_system_libjpeg=1 \
f1b276d4
ER
349 -Duse_system_libpng=1 \
350 -Duse_system_libxml=1 \
351 -Duse_system_libxslt=1 \
7f40f3f4 352 -Duse_system_xdg_utils=1 \
d8ba130c 353 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
354 -Dlinux_use_gold_binary=0 \
355 -Dlinux_use_gold_flags=0
11ad81c4 356
f1b276d4
ER
357%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
358 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
359 %{?with_verbose:V=1} \
360 CC="%{__cc}" \
361 CXX="%{__cxx}" \
b7adf6b1 362 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
363 CC.host="%{__cc}" \
364 CXX.host="%{__cxx}" \
b7adf6b1 365 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
366 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
367 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
368
369%install
370rm -rf $RPM_BUILD_ROOT
56c6e811 371install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 372 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 373
f1b276d4 374cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 375cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
376install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
377%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 378cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 379cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 380install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 381install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 382%if %{with ffmpegsumo}
f1b276d4 383install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 384%endif
e7fa0817 385cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb 386
c0808220
ER
387%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
388
164020eb
ER
389%if %{with nacl}
390# Install Native Client files on platforms that support it.
391install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
392install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
393%ifarch %{x8664}
394install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
395%endif
396%ifarch %{ix86}
397install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
398%endif
399%endif
400
0c480b89
ER
401cd -
402
0eb19b0b
ER
403for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
404 size=${icon##*/product_logo_}
405 size=${size%.png}
406
407 # this will skip non-numeric (22_mono_invert, 22_mono)
408 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
409 test -d "$dir" || continue
410
411 install -d $RPM_BUILD_ROOT$dir
412 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
413done
7f40f3f4 414
13840bc2
AM
415%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
416# http://code.google.com/p/chromium/issues/detail?id=24507
417gecko-mediaplayer*.so
418EOF
11ad81c4 419
589d90ea
ER
420# find locales
421%find_lang %{name}.lang
e7fa0817 422# always package en-US
f1b276d4 423%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 424
11ad81c4
AM
425%clean
426rm -rf $RPM_BUILD_ROOT
427
f1b276d4 428%post
0eb19b0b 429%update_icon_cache hicolor
b7a6e4ee 430%update_desktop_database
f1b276d4
ER
431%update_browser_plugins
432
433%postun
434if [ "$1" = 0 ]; then
0eb19b0b 435 %update_icon_cache hicolor
f1b276d4
ER
436 %update_browser_plugins
437fi
438
1d2b9616 439%files
11ad81c4 440%defattr(644,root,root,755)
f1b276d4
ER
441%{_browserpluginsconfdir}/browsers.d/%{name}.*
442%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
443%dir %{_sysconfdir}/%{name}
444%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
445%attr(755,root,root) %{_bindir}/%{name}
446%{_mandir}/man1/%{name}.1*
11ad81c4 447%{_desktopdir}/*.desktop
0eb19b0b 448%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 449%dir %{_libdir}/%{name}
e9abb380 450%{_libdir}/%{name}/chrome*.pak
c14cd342 451%{_libdir}/%{name}/content_resources.pak
97fac491 452%{_libdir}/%{name}/resources.pak
589d90ea 453%dir %{_libdir}/%{name}/locales
f1b276d4
ER
454%{_libdir}/%{name}/locales/en-US.pak
455%dir %{_libdir}/%{name}/resources
a3140cd1 456%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
457%dir %{_libdir}/%{name}/themes
458%dir %{_libdir}/%{name}/extensions
459%dir %{_libdir}/%{name}/plugins
460%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 461# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 462%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
463
464# ffmpeg libs
d561483d 465%if %{with ffmpegsumo}
f1b276d4 466%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 467%endif
f1b276d4 468
164020eb
ER
469%if %{with nacl}
470%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
471%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
472%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
473%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
474%endif
475
f1b276d4
ER
476%files l10n -f %{name}.lang
477%defattr(644,root,root,755)
This page took 0.13927 seconds and 4 git commands to generate.