]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 26.0.1410.33
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
ba685303
ER
22%bcond_without system_libusb # system libusb-1
23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
25d4e23c 25%bcond_without system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
bbdce24d 29%bcond_with system_re2 # system re2
ba685303
ER
30%bcond_without system_speex # system speex
31%bcond_with system_sqlite # system sqlite
9bd2659c 32%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 33%bcond_with system_v8 # system v8
41d6a4b1 34%bcond_without system_libvpx # system libvpx
ba685303 35%bcond_without system_yasm # system yasm
1c00315b 36%bcond_without system_zlib # system zlib
d2781a31 37%bcond_without tcmalloc # use tcmalloc
7e136323 38%bcond_without verbose # verbose build (V=1)
0c480b89 39
b3fc6cb2
ER
40%ifarch %{ix86}
41# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42%undefine with_system_mesa
43%endif
44
6d92f81c 45# TODO
b363f856 46# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 47# - use_system_skia
a3140cd1 48# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 49# - use_system_stlport (android specific)
7b8f219a 50# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 51
e53ecfb5 52# NOTES:
4fe038cb
ER
53# - mute BEEP mixer if you do not want to hear horrible system bell when
54# pressing home/end in url bar or more ^F search results on page.
7c638678 55# - space considerations:
0bb93ab2 56# - unpacked sources: ~490MiB
c1ecd31f 57# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 58# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 59# - to look for new tarball, use update-source.sh script
f1b276d4 60
e68aa7e7 61# NOTE TO USERS:
c8b02491 62# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 63# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 64# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 65
f2f193c6 66%define branch 26.0.1410
e272851e 67%define basever 33
92fcbe12 68#define patchver 70
a3140cd1 69%define gyp_rev 1014
11ad81c4 70Summary: A WebKit powered web browser
05f72ae2 71Name: chromium-browser
f73369da
ER
72%if "%{?patchver}" != ""
73Version: %{branch}.%{patchver}
74%else
75Version: %{branch}.%{basever}
76%endif
41d6a4b1 77Release: 0.32
05f72ae2 78License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 79Group: X11/Applications/Networking
25d4e23c 80Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
e272851e 81# Source0-md5: e42f86208205701bd23b34ba963e7d83
3c73e180
ER
82%if "%{?patchver}" != ""
83Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
f6284fe2 84# Patch0-md5: 37675cd75c578d26d6210259877f3947
3c73e180 85%endif
37ceaf05 86Source1: %{name}.default
8b53130d
ER
87Source2: %{name}.sh
88Source3: %{name}.desktop
56c6e811
ER
89Source5: find-lang.sh
90Source6: update-source.sh
91Source7: clean-source.sh
836b1cac 92Source8: get-source.sh
0562b864 93Source9: master_preferences.json
48b341f5 94Patch1: plugin-searchdirs.patch
70258ccd 95#Patch2: system-nspr.patch
7abc645c 96Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 97Patch4: path-libpdf.patch
0e5636cb 98Patch6: get-webkit_revision.patch
5aa5df39 99Patch7: dlopen_sonamed_gl.patch
4765ddf1 100Patch8: chromium_useragent.patch.in
c0808220 101Patch9: chromium-ppapi.patch
8456d676 102Patch10: system-libxnvctrl.patch
1347c76c
AM
103# https://bugs.gentoo.org/show_bug.cgi?id=393471
104# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 105Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 106Patch12: system-ffmpeg.patch
5997e180
ER
107Patch15: nacl-build-irt.patch
108Patch16: nacl-linkingfix.patch
9516ca97 109Patch18: nacl-no-untar.patch
08b25440 110Patch19: system-jsoncpp.patch
6897926c 111Patch24: nacl-verbose.patch
c5b396f3
ER
112Patch25: gnome3-volume-control.patch
113Patch26: master-prefs-path.patch
d2781a31 114Patch27: tcmalloc-glibc2.16.patch
25d4e23c 115Patch28: system-mesa.patch
eda1bb04 116Patch29: speechd-0.8.patch
750b48f7 117URL: http://www.chromium.org/Home
ae3fe89f 118%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3
ER
119%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
120%{?with_system_mesa:BuildRequires: Mesa-libGLES-devel >= 9.1}
7b8f219a 121%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 122%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
123BuildRequires: alsa-lib-devel
124BuildRequires: atk-devel
125BuildRequires: bison
11ad81c4 126BuildRequires: bzip2-devel
5997e180
ER
127%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
128%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
129%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 130%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 131%{?with_cups:BuildRequires: cups-devel}
92965b0e 132BuildRequires: elfutils-devel
77f32fa3 133BuildRequires: expat-devel
7d0dbc8d 134%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 135%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 136BuildRequires: fontconfig-devel
f1b276d4 137BuildRequires: glib2-devel
05f72ae2 138BuildRequires: gperf
71d49434 139%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 140BuildRequires: gtest-devel
8b53130d 141BuildRequires: gtk+2-devel
01b4dc8e 142%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 143%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 144BuildRequires: hicolor-icon-theme
ed514974 145%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 146%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 147BuildRequires: libevent-devel
8456d676 148%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 149%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 150BuildRequires: libicu-devel >= 4.6
39c71b4c 151%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 152%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 153%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 154BuildRequires: libpng-devel
e266589e 155%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 156BuildRequires: libstdc++-devel
ba685303 157%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 158%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 159%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 160BuildRequires: libxml2-devel
11ad81c4 161BuildRequires: libxslt-devel
535cb410 162BuildRequires: man-db
62950103 163%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 164BuildRequires: nspr-devel
f1b276d4 165BuildRequires: nss-devel >= 1:3.12.3
8456d676 166%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 167BuildRequires: pam-devel
f1b276d4 168BuildRequires: pango-devel
ef121064 169BuildRequires: pciutils-devel
48b341f5 170BuildRequires: perl-modules
171BuildRequires: pkgconfig
75a27c2e 172%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 173%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 174BuildRequires: python
46cdefee 175#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 176BuildRequires: python-modules
92965b0e 177BuildRequires: python-ply
71d49434 178%{?with_system_re2:BuildRequires: re2-devel}
0cad051b 179BuildRequires: rpm >= 4.4.9-56
f1b276d4 180BuildRequires: rpmbuild(macros) >= 1.453
eda1bb04 181BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 182%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 183BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 184%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 185BuildRequires: subversion
0cad051b 186BuildRequires: tar >= 1:1.22
0a424ee2 187BuildRequires: udev-devel
7d1152d4 188BuildRequires: usbutils
2303ed45 189BuildRequires: util-linux
c14cd342 190%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 191BuildRequires: which
f1b276d4 192BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 193BuildRequires: xz
a3140cd1 194%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 195%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 196Requires: browser-plugins >= 2.0
0cad051b 197Requires: desktop-file-utils
8f5f6775 198%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
199# crashes if no fontconfig font present
200Requires: fonts-Type1-urw
0eb19b0b 201Requires: hicolor-icon-theme
56403697 202Requires: libevent >= 2.0.21
c1edaafa 203%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 204%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 205Requires: lsb-release
3700ba38 206Requires: shared-mime-info
4dc49133 207Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 208Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 209Provides: wwwbrowser
c3582150 210Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 211Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 212ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 213BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 214
589d90ea 215%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 216
e7fa0817
ER
217# Usage: gyp_with BCOND_NAME [OPTION_NAME]
218%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 219
6b113615
ER
220%if %{without debuginfo}
221%define _enable_debug_packages 0
222%endif
223
11ad81c4 224%description
80838854
ER
225Chromium is an open-source browser project that aims to build a safer,
226faster, and more stable way for all Internet users to experience the
227web.
228
229Chromium serves as a base for Google Chrome, which is Chromium
230rebranded (name and logo) with very few additions such as usage
231tracking and an auto-updater system.
232
f1b276d4
ER
233%package l10n
234Summary: chromium-browser language packages
235Group: I18n
236Requires: %{name} = %{version}-%{release}
237
238%description l10n
239Chromium is an open-source browser project that aims to build a safer,
240faster, and more stable way for all Internet users to experience the
241web.
242
243This package contains language packages for 50 languages:
244
e7fa0817
ER
245ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
246he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
247pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
248zh-TW
f1b276d4
ER
249
250%prep
3c73e180
ER
251%setup -qc
252%if "%{?patchver}" != ""
253cd %{name}-%{branch}.%{basever}
254%patch0 -p1
255cd ..
256%endif
257mv %{name}-%{branch}.%{basever}/src .
589d90ea 258
05f72ae2
ER
259# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
260# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
261. ./src/chrome/VERSION
262ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
263test "$ver" = %{version}
264
265gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 266test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 267
836b1cac 268v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 269
4765ddf1
ER
270# add chromium and pld to useragent
271%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
272sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
273 -e 's/@BUILD_DIST_NAME@/PLD/g' \
274 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
275 < %{PATCH8} | %{__patch} -p1
4765ddf1 276
56c6e811
ER
277%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
278ln -s %{SOURCE7} src
f1b276d4 279
05f72ae2 280%patch1 -p1
7abc645c 281%patch3 -p1
72cb20c1 282%patch4 -p1
0e5636cb 283%patch6 -p1
5aa5df39 284%patch7 -p1
42e551c9 285%patch10 -p1
e9abb380 286%patch15 -p1
77f32fa3 287cd src
c0808220 288%patch9 -p0
70258ccd 289#%patch2 -p1
f4a8da6a 290%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 291%patch12 -p1
5997e180 292%patch16 -p1
08b25440 293%patch19 -p1
d2781a31 294%patch27 -p1
41d6a4b1 295%patch28 -p1
1347c76c 296cd ..
f2f193c6 297%patch25 -p1
9516ca97 298%patch18 -p1
6897926c 299%patch24 -p1
c5b396f3 300%patch26 -p1
eda1bb04 301%patch29 -p1
0c480b89 302
828bdd1a 303cd src
e9abb380 304
75a27c2e
ER
305sh -x clean-source.sh \
306 %{!?with_nacl:nacl=0} \
bbdce24d
ER
307 %{!?with_system_libvpx:libvpx=0} \
308 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 309 %{!?with_system_mesa:mesa=0} \
75a27c2e 310 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 311 %{!?with_system_re2:re2=0} \
75a27c2e
ER
312 %{!?with_system_v8:v8=0} \
313 %{!?with_system_zlib:zlib=0} \
314 %{nil}
fded59be 315
e266589e 316%build
f1b276d4 317cd src
5997e180
ER
318
319%if %{with nacl}
108c5f7c 320rm -rf native_client/toolchain/linux_x86_newlib
fded59be 321if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 322# Make symlinks for NaCL
108c5f7c 323install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 324
108c5f7c
ER
325cd native_client/toolchain/linux_x86_newlib
326ln -s x86_64-nacl/bin bin
327cd x86_64-nacl/bin
2e4113fd 328__cc='%{__cc}'
f64e73f6 329if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
330 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
331 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
332 %{__sed} -i -e '1i#!/bin/sh' gcc g++
333 chmod +x gcc g++
334else
335 ln -s %{_bindir}/x86_64-nacl-gcc gcc
336 ln -s %{_bindir}/x86_64-nacl-g++ g++
337fi
108c5f7c
ER
338ln -s gcc x86_64-nacl-gcc
339ln -s g++ x86_64-nacl-g++
340ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
341ln -s %{_bindir}/x86_64-nacl-ar ar
342ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 343ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 344ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 345ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 346ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
347ln -s %{_prefix}/x86_64-nacl/lib ../lib
348ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
349ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
350cd ../../../../..
fded59be 351fi
5997e180
ER
352%endif
353
c5b396f3 354test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
355test -e Makefile || \
356 CC="%{__cc}" \
357 CXX="%{__cxx}" \
358 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
359 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
360 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
361%{__python} build/gyp_chromium \
673aee14
ER
362 --format=make \
363 -Goutput_dir=../out \
364 build/all.gyp \
f1b276d4
ER
365%ifarch %{ix86}
366 -Dtarget_arch=ia32 \
367%endif
368%ifarch %{x8664}
0c480b89
ER
369 -Dtarget_arch=x64 \
370%endif
7b454a31
AM
371%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
372 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
373%endif
374%if %{with sandboxing}
375 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
376 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
377%endif
378 %{!?debug:-Dwerror=} \
c980b122 379 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 380 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 381 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 382 -Dinclude_tests=0 \
c0808220 383%if %{with nacl}
038f76b9 384 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
385 -Ddisable_glibc_untar=1 \
386 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
387 -Ddisable_glibc=1 \
388 -Ddisable_pnacl=1 \
389 -Dbuild_pnacl_newlib=0 \
c0808220 390%else
8fb1dc98 391 -Ddisable_pnacl_untar=1 \
c0808220
ER
392 -Ddisable_nacl=1 \
393%endif
a3140cd1
ER
394 %{!?with_sse2:-Ddisable_sse2=1} \
395 %{?with_selinux:-Dselinux=1} \
7d1152d4 396 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 397 -Dlinux_link_libpci=1 \
bd827d58 398 -Dlinux_link_libspeechd=1 \
05998197 399 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 400 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
401 -Dlinux_use_gold_binary=0 \
402 -Dlinux_use_gold_flags=0 \
e7fa0817 403 %{gyp_with cups} \
8dda6bbc 404 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 405 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
406 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
407 %{gyp_with pulseaudio} \
41d6a4b1 408 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 409 %{gyp_with system_flac} \
01b4dc8e 410 %{gyp_with system_harfbuzz} \
62950103
ER
411 %{gyp_with system_libexif} \
412 %{gyp_with system_libmtp} \
9bd2659c 413 %{gyp_with system_libsrtp} \
581aec44 414 %{gyp_with system_libusb} \
41d6a4b1 415 %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
ba685303 416 %{gyp_with system_libwebp} \
4884fc99 417 %{gyp_with system_libxnvctrl} \
7b8f219a 418 %{gyp_with system_mesa} \
126ea630 419 %{gyp_with system_minizip} \
62950103 420 %{gyp_with system_opus} \
75a27c2e 421 %{gyp_with system_protobuf} \
bbdce24d 422 %{gyp_with system_re2} \
e7fa0817
ER
423 %{gyp_with system_speex} \
424 %{gyp_with system_sqlite} \
425 %{gyp_with system_v8} \
426 %{gyp_with system_yasm} \
427 %{gyp_with system_zlib} \
0c480b89 428 -Duse_system_bzip2=1 \
62950103 429 -Duse_system_expat=1 \
0b214002 430 -Duse_system_icu=1 \
f1b276d4 431 -Duse_system_libevent=1 \
0c480b89 432 -Duse_system_libjpeg=1 \
f1b276d4
ER
433 -Duse_system_libpng=1 \
434 -Duse_system_libxml=1 \
435 -Duse_system_libxslt=1 \
b363f856 436 -Duse_system_nspr=1 \
7f40f3f4 437 -Duse_system_xdg_utils=1 \
11ad81c4 438
b4d75247 439# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 440%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
441 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
442 %{?with_verbose:V=1} \
f1b276d4
ER
443 CC.host="%{__cc}" \
444 CXX.host="%{__cxx}" \
b4d75247 445 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 446
535cb410
ER
447cd ../out/%{!?debug:Release}%{?debug:Debug}
448MANWIDTH=80 man ./chrome.1 > man.out
449%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
450
11ad81c4
AM
451%install
452rm -rf $RPM_BUILD_ROOT
56c6e811 453install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 454 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 455
673aee14 456cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 457cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 458install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
459%{__sed} -i -e '
460 s,@libdir@,%{_libdir}/%{name},
461
462 /@OPTIONS@/ {
463 r options.txt
464 d
465 }
466' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 467cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 468cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 469install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 470install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 471%if %{without system_ffmpeg}
f1b276d4 472install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 473%endif
e7fa0817 474cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 475cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 476
c0808220
ER
477%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
478
164020eb
ER
479%if %{with nacl}
480# Install Native Client files on platforms that support it.
481install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
482install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
483%ifarch %{x8664}
484install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
485%endif
486%ifarch %{ix86}
487install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
488%endif
489%endif
490
0c480b89
ER
491cd -
492
0eb19b0b
ER
493for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
494 size=${icon##*/product_logo_}
495 size=${size%.png}
496
497 # this will skip non-numeric (22_mono_invert, 22_mono)
498 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
499 test -d "$dir" || continue
500
501 install -d $RPM_BUILD_ROOT$dir
502 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
503done
7f40f3f4 504
13840bc2
AM
505%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
506# http://code.google.com/p/chromium/issues/detail?id=24507
507gecko-mediaplayer*.so
508EOF
11ad81c4 509
589d90ea
ER
510# find locales
511%find_lang %{name}.lang
e7fa0817 512# always package en-US
f1b276d4 513%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 514
11ad81c4
AM
515%clean
516rm -rf $RPM_BUILD_ROOT
517
f1b276d4 518%post
0eb19b0b 519%update_icon_cache hicolor
b7a6e4ee 520%update_desktop_database
f1b276d4
ER
521%update_browser_plugins
522
523%postun
524if [ "$1" = 0 ]; then
0eb19b0b 525 %update_icon_cache hicolor
f1b276d4
ER
526 %update_browser_plugins
527fi
528
1d2b9616 529%files
11ad81c4 530%defattr(644,root,root,755)
531537e5 531%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
532%{_browserpluginsconfdir}/browsers.d/%{name}.*
533%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
534%dir %{_sysconfdir}/%{name}
535%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 536%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
537%attr(755,root,root) %{_bindir}/%{name}
538%{_mandir}/man1/%{name}.1*
11ad81c4 539%{_desktopdir}/*.desktop
0eb19b0b 540%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 541%dir %{_libdir}/%{name}
e9abb380 542%{_libdir}/%{name}/chrome*.pak
c14cd342 543%{_libdir}/%{name}/content_resources.pak
97fac491 544%{_libdir}/%{name}/resources.pak
589d90ea 545%dir %{_libdir}/%{name}/locales
f1b276d4
ER
546%{_libdir}/%{name}/locales/en-US.pak
547%dir %{_libdir}/%{name}/resources
a3140cd1 548%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
549%dir %{_libdir}/%{name}/themes
550%dir %{_libdir}/%{name}/extensions
551%dir %{_libdir}/%{name}/plugins
552%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 553# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 554%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
555
556# ffmpeg libs
fcc48c19 557%if %{without system_ffmpeg}
f1b276d4 558%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 559%endif
f1b276d4 560
164020eb
ER
561%if %{with nacl}
562%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
563%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
564%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
565%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
566%endif
567
f1b276d4
ER
568%files l10n -f %{name}.lang
569%defattr(644,root,root,755)
This page took 0.142457 seconds and 4 git commands to generate.