]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
clean gpu/demos
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2
ER
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without ffmpegsumo # build with ffmpegsumo
ba685303 6%bcond_without gconf # with GConf
8171fe68 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303
ER
16%bcond_without system_flac # system flac
17%bcond_without system_jsoncpp # system jsoncpp
18%bcond_without system_libusb # system libusb-1
19%bcond_without system_libwebp # system libwebp
20%bcond_without system_speex # system speex
21%bcond_with system_sqlite # system sqlite
3ee15dec 22%bcond_without system_srtp # system srtp (can be used if using bundled libjingle)
ba685303
ER
23%bcond_with system_v8 # system v8
24%bcond_without system_vpx # system vpx
25%bcond_without system_yasm # system yasm
4c272135
ER
26# system zlib disabled because of mixed-source.patch
27# https://code.google.com/p/chromium/issues/detail?id=143623
ba685303
ER
28%bcond_with system_zlib # system zlib
29%bcond_with tcmalloc # use tcmalloc
7e136323 30%bcond_without verbose # verbose build (V=1)
0c480b89 31
c6325ea2
ER
32%if %{with nacl}
33# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
34# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
35#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
36#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
37#14:51:06 @baggins> as-needed will take care of unneeded lib
38#14:52:03 @baggins> -lssp comes with gcc
107b55fe 39%define _ssp_cflags %{nil}
c6325ea2
ER
40%endif
41
6d92f81c 42# TODO
f1b276d4 43# - check system sqlite linking problems
2108baf2 44# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 45# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 46# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 47# - use_system_hunspell
32a2443e 48# - use_system_stlport
a3140cd1
ER
49# - other defaults: src/build/common.gypi
50
e53ecfb5 51# NOTES:
4fe038cb
ER
52# - mute BEEP mixer if you do not want to hear horrible system bell when
53# pressing home/end in url bar or more ^F search results on page.
7c638678
ER
54# - space considerations:
55# - unpacked sources: ~800MiB
56# - built code: ~1.4GiB (x86_64)
f1b276d4 57# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 58# - to look for new tarball, use update-source.sh script
f1b276d4 59
e68aa7e7 60# NOTE TO USERS:
c8b02491 61# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 62# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 63# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 64
3c73e180
ER
65%define branch 23.0.1271
66%define basever 64
d0d8739b 67%define patchver 97
a3140cd1 68%define gyp_rev 1014
11ad81c4 69Summary: A WebKit powered web browser
05f72ae2 70Name: chromium-browser
3c73e180 71Version: %{branch}.%{patchver}
0562b864 72Release: 2
05f72ae2 73License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 74Group: X11/Applications/Networking
3c73e180 75Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
9516ca97 76# Source0-md5: 6c467affd292ee9a9020ac91147969c8
3c73e180
ER
77%if "%{?patchver}" != ""
78Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
d0d8739b 79# Patch0-md5: 2f4e98e37053705fd86ffcb49f1f2247
3c73e180 80%endif
37ceaf05 81Source1: %{name}.default
8b53130d
ER
82Source2: %{name}.sh
83Source3: %{name}.desktop
56c6e811
ER
84Source5: find-lang.sh
85Source6: update-source.sh
86Source7: clean-source.sh
836b1cac 87Source8: get-source.sh
0562b864 88Source9: master_preferences.json
3c73e180 89#Patch10: system-libs.patch
48b341f5 90Patch1: plugin-searchdirs.patch
91Patch2: gyp-system-minizip.patch
7abc645c 92Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 93Patch4: path-libpdf.patch
48b341f5 94Patch5: options-support.patch
0e5636cb 95Patch6: get-webkit_revision.patch
5aa5df39 96Patch7: dlopen_sonamed_gl.patch
4765ddf1 97Patch8: chromium_useragent.patch.in
c0808220 98Patch9: chromium-ppapi.patch
1347c76c
AM
99# https://bugs.gentoo.org/show_bug.cgi?id=393471
100# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 101Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
102Patch15: nacl-build-irt.patch
103Patch16: nacl-linkingfix.patch
e9abb380 104Patch17: system-icu.patch
9516ca97 105Patch18: nacl-no-untar.patch
08b25440 106Patch19: system-jsoncpp.patch
ed514974 107Patch20: system-speex.patch
3ee15dec 108Patch21: system-srtp.patch
2d6e464b 109Patch22: gnome3-volume-control.patch
0562b864 110Patch23: master-prefs-path.patch
750b48f7 111URL: http://www.chromium.org/Home
ae3fe89f 112%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 113BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
114BuildRequires: alsa-lib-devel
115BuildRequires: atk-devel
116BuildRequires: bison
11ad81c4 117BuildRequires: bzip2-devel
5997e180
ER
118%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
119%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
120%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 121%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 122%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 123BuildRequires: dbus-glib-devel
77f32fa3 124BuildRequires: expat-devel
8f5f6775 125%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 126BuildRequires: flex
11ad81c4 127BuildRequires: fontconfig-devel
f1b276d4 128BuildRequires: glib2-devel
05f72ae2 129BuildRequires: gperf
8b53130d 130BuildRequires: gtk+2-devel
a3140cd1 131%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 132BuildRequires: hicolor-icon-theme
ed514974 133%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
05f72ae2 134BuildRequires: libevent-devel
7f40f3f4 135%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 136BuildRequires: libicu-devel >= 4.6
39c71b4c 137%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 138%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 139BuildRequires: libpng-devel
e266589e 140%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 141BuildRequires: libstdc++-devel
ba685303 142%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
32a2443e 143%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 144%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 145BuildRequires: libxml2-devel
11ad81c4 146BuildRequires: libxslt-devel
f1b276d4 147BuildRequires: lzma
11ad81c4 148BuildRequires: minizip-devel
05f72ae2 149BuildRequires: nspr-devel
f1b276d4 150BuildRequires: nss-devel >= 1:3.12.3
35902862 151BuildRequires: pam-devel
f1b276d4 152BuildRequires: pango-devel
48b341f5 153BuildRequires: perl-modules
154BuildRequires: pkgconfig
ae3fe89f 155%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 156BuildRequires: python
46cdefee 157#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 158BuildRequires: python-modules
0cad051b 159BuildRequires: rpm >= 4.4.9-56
f1b276d4 160BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 161%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 162BuildRequires: sqlite3-devel >= 3.6.1
3ee15dec 163%{?with_system_srtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 164BuildRequires: subversion
0cad051b 165BuildRequires: tar >= 1:1.22
0a424ee2 166BuildRequires: udev-devel
2303ed45 167BuildRequires: util-linux
c14cd342 168%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 169BuildRequires: which
f1b276d4 170BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
171BuildRequires: xorg-lib-libXt-devel
172BuildRequires: xorg-lib-libXtst-devel
836b1cac 173BuildRequires: xz
a3140cd1 174%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 175%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 176Requires: browser-plugins >= 2.0
0cad051b 177Requires: desktop-file-utils
8f5f6775 178%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 179Requires: hicolor-icon-theme
c1edaafa 180%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 181%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 182Requires: xdg-utils >= 1.0.2-4
e53ecfb5 183Provides: wwwbrowser
c3582150 184Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 185Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 186ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 187BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 188
589d90ea 189%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 190
e7fa0817
ER
191# Usage: gyp_with BCOND_NAME [OPTION_NAME]
192%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 193
6b113615
ER
194%if %{without debuginfo}
195%define _enable_debug_packages 0
196%endif
197
11ad81c4 198%description
80838854
ER
199Chromium is an open-source browser project that aims to build a safer,
200faster, and more stable way for all Internet users to experience the
201web.
202
203Chromium serves as a base for Google Chrome, which is Chromium
204rebranded (name and logo) with very few additions such as usage
205tracking and an auto-updater system.
206
f1b276d4
ER
207%package l10n
208Summary: chromium-browser language packages
209Group: I18n
210Requires: %{name} = %{version}-%{release}
211
212%description l10n
213Chromium is an open-source browser project that aims to build a safer,
214faster, and more stable way for all Internet users to experience the
215web.
216
217This package contains language packages for 50 languages:
218
e7fa0817
ER
219ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
220he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
221pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
222zh-TW
f1b276d4
ER
223
224%prep
3c73e180
ER
225%setup -qc
226%if "%{?patchver}" != ""
227cd %{name}-%{branch}.%{basever}
228%patch0 -p1
229cd ..
230%endif
231mv %{name}-%{branch}.%{basever}/src .
589d90ea 232
05f72ae2
ER
233# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
234# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
235. ./src/chrome/VERSION
236ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
237test "$ver" = %{version}
238
239gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 240test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 241
836b1cac 242v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 243
4765ddf1
ER
244# add chromium and pld to useragent
245%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
246sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
247 -e 's/@BUILD_DIST_NAME@/PLD/g' \
248 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 249 < %{PATCH8} | %{__patch} -p1
4765ddf1 250
56c6e811
ER
251%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
252ln -s %{SOURCE7} src
f1b276d4 253
3c73e180 254#%patch10 -p1
05f72ae2
ER
255%patch1 -p1
256%patch2 -p1
7abc645c 257%patch3 -p1
72cb20c1 258%patch4 -p1
05f72ae2 259%patch5 -p1
0e5636cb 260%patch6 -p1
5aa5df39 261%patch7 -p1
e9abb380 262%patch15 -p1
77f32fa3 263cd src
c0808220 264%patch9 -p0
f4a8da6a 265%{!?with_libjpegturbo:%patch11 -p0}
5997e180 266%patch16 -p1
e9abb380 267%patch17 -p0
08b25440 268%patch19 -p1
3ee15dec 269%patch21 -p1
2d6e464b 270%patch22 -p1
1347c76c 271cd ..
9516ca97 272%patch18 -p1
ed514974 273%patch20 -p1
0562b864 274%patch23 -p1
0c480b89 275
828bdd1a 276cd src
e9abb380
ER
277
278# Missing gyp files in tarball.
279# https://code.google.com/p/chromium/issues/detail?id=144823
280if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
281 echo "tarball fixed, please remove workaround"
282 exit 1
283fi
284
285install -d chrome/test/data/nacl
286cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
287{
288 'targets': [
289 {
290 'target_name': 'nacl_tests',
291 'type': 'none',
292 },
293 ],
294}
295EOF
296
4c272135 297sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
164020eb 298
e266589e 299%build
f1b276d4 300cd src
5997e180
ER
301
302%if %{with nacl}
303rm -rf native_client/toolchain/linux_x86_newlib
304# Make symlinks for nacl
305cd native_client/toolchain
306install -d linux_x86_newlib/x86_64-nacl/bin
307install -d linux_x86_newlib/x86_64-nacl/lib
308install -d linux_x86_newlib/x86_64-nacl/lib32
309install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
310install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
311install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
312# link newlib toolchain to glibc as well, see gentoo bug #417019
313#ln -s linux_x86_newlib linux_x86
5997e180
ER
314cd linux_x86_newlib/x86_64-nacl/bin
315ln -s %{_bindir}/x86_64-nacl-gcc gcc
316ln -s %{_bindir}/x86_64-nacl-g++ g++
317ln -s %{_bindir}/x86_64-nacl-ar ar
318ln -s %{_bindir}/x86_64-nacl-as as
319ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
320ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
321ln -s %{_bindir}/x86_64-nacl-strip strip
322ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
323ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
324cd ../nacl/include
325for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
326 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
327done
328cd ../../../../../..
329%endif
330
673aee14
ER
331test -e Makefile || %{__python} build/gyp_chromium \
332 --format=make \
333 -Goutput_dir=../out \
334 build/all.gyp \
f1b276d4
ER
335%ifarch %{ix86}
336 -Dtarget_arch=ia32 \
337%endif
338%ifarch %{x8664}
0c480b89
ER
339 -Dtarget_arch=x64 \
340%endif
7b454a31
AM
341%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
342 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
343%endif
344%if %{with sandboxing}
345 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
346 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
347%endif
348 %{!?debug:-Dwerror=} \
c980b122 349 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 350 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 351 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1 352 -Dffmpeg_branding=Chrome \
1fde0856 353 -Dremove_webcore_debug_symbols=1 \
a3140cd1 354 -Dproprietary_codecs=1 \
c0808220 355%if %{with nacl}
c0808220 356 -Ddisable_glibc=1 \
038f76b9 357 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
358 -Ddisable_glibc_untar=1 \
359 -Ddisable_newlib_untar=1 \
360 -Ddisable_pnacl_untar=1 \
c0808220
ER
361%else
362 -Ddisable_nacl=1 \
363%endif
6c8531c6 364 -Ddisable_pnacl=1 \
a3140cd1
ER
365 %{!?with_sse2:-Ddisable_sse2=1} \
366 %{?with_selinux:-Dselinux=1} \
e7fa0817 367 %{gyp_with cups} \
e7fa0817
ER
368 %{gyp_with gconf} \
369 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
370 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
371 %{gyp_with pulseaudio} \
8f5f6775 372 %{gyp_with system_flac} \
581aec44 373 %{gyp_with system_libusb} \
ba685303 374 %{gyp_with system_libwebp} \
e7fa0817
ER
375 %{gyp_with system_speex} \
376 %{gyp_with system_sqlite} \
377 %{gyp_with system_v8} \
32a2443e 378 %{gyp_with system_vpx} \
e7fa0817
ER
379 %{gyp_with system_yasm} \
380 %{gyp_with system_zlib} \
0c480b89 381 -Duse_system_bzip2=1 \
0b214002 382 -Duse_system_icu=1 \
f1b276d4 383 -Duse_system_libevent=1 \
0c480b89 384 -Duse_system_libjpeg=1 \
f1b276d4
ER
385 -Duse_system_libpng=1 \
386 -Duse_system_libxml=1 \
387 -Duse_system_libxslt=1 \
7f40f3f4 388 -Duse_system_xdg_utils=1 \
d8ba130c 389 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
390 -Dlinux_use_gold_binary=0 \
391 -Dlinux_use_gold_flags=0
11ad81c4 392
f1b276d4
ER
393%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
394 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
395 %{?with_verbose:V=1} \
396 CC="%{__cc}" \
397 CXX="%{__cxx}" \
b7adf6b1 398 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
399 CC.host="%{__cc}" \
400 CXX.host="%{__cxx}" \
b7adf6b1 401 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
402 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
403 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
404
405%install
406rm -rf $RPM_BUILD_ROOT
56c6e811 407install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 408 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 409
673aee14 410cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 411cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
412install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
413%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 414cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 415cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 416install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 417install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 418%if %{with ffmpegsumo}
f1b276d4 419install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 420%endif
e7fa0817 421cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 422cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 423
c0808220
ER
424%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
425
164020eb
ER
426%if %{with nacl}
427# Install Native Client files on platforms that support it.
428install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
429install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
430%ifarch %{x8664}
431install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
432%endif
433%ifarch %{ix86}
434install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
435%endif
436%endif
437
0c480b89
ER
438cd -
439
0eb19b0b
ER
440for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
441 size=${icon##*/product_logo_}
442 size=${size%.png}
443
444 # this will skip non-numeric (22_mono_invert, 22_mono)
445 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
446 test -d "$dir" || continue
447
448 install -d $RPM_BUILD_ROOT$dir
449 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
450done
7f40f3f4 451
13840bc2
AM
452%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
453# http://code.google.com/p/chromium/issues/detail?id=24507
454gecko-mediaplayer*.so
455EOF
11ad81c4 456
589d90ea
ER
457# find locales
458%find_lang %{name}.lang
e7fa0817 459# always package en-US
f1b276d4 460%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 461
11ad81c4
AM
462%clean
463rm -rf $RPM_BUILD_ROOT
464
f1b276d4 465%post
0eb19b0b 466%update_icon_cache hicolor
b7a6e4ee 467%update_desktop_database
f1b276d4
ER
468%update_browser_plugins
469
470%postun
471if [ "$1" = 0 ]; then
0eb19b0b 472 %update_icon_cache hicolor
f1b276d4
ER
473 %update_browser_plugins
474fi
475
1d2b9616 476%files
11ad81c4 477%defattr(644,root,root,755)
531537e5 478%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
479%{_browserpluginsconfdir}/browsers.d/%{name}.*
480%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
481%dir %{_sysconfdir}/%{name}
482%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 483%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
484%attr(755,root,root) %{_bindir}/%{name}
485%{_mandir}/man1/%{name}.1*
11ad81c4 486%{_desktopdir}/*.desktop
0eb19b0b 487%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 488%dir %{_libdir}/%{name}
e9abb380 489%{_libdir}/%{name}/chrome*.pak
c14cd342 490%{_libdir}/%{name}/content_resources.pak
97fac491 491%{_libdir}/%{name}/resources.pak
589d90ea 492%dir %{_libdir}/%{name}/locales
f1b276d4
ER
493%{_libdir}/%{name}/locales/en-US.pak
494%dir %{_libdir}/%{name}/resources
a3140cd1 495%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
496%dir %{_libdir}/%{name}/themes
497%dir %{_libdir}/%{name}/extensions
498%dir %{_libdir}/%{name}/plugins
499%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 500# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 501%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
502
503# ffmpeg libs
d561483d 504%if %{with ffmpegsumo}
f1b276d4 505%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 506%endif
f1b276d4 507
164020eb
ER
508%if %{with nacl}
509%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
510%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
511%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
512%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
513%endif
514
f1b276d4
ER
515%files l10n -f %{name}.lang
516%defattr(644,root,root,755)
This page took 0.18583 seconds and 4 git commands to generate.