]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- rel 2
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
5997e180 10%bcond_without nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
d8ba130c 15%bcond_with tcmalloc # use tcmalloc
2108baf2 16%bcond_with system_sqlite # with system sqlite
32a2443e 17%bcond_without system_flac # with system flac
e8e15592 18%bcond_without system_libwebp # with system libwebp
32a2443e 19%bcond_without system_speex # with system speex
c14cd342 20%bcond_with system_v8 # with system v8
32a2443e 21%bcond_without system_vpx # with system vpx
d617ab39 22%bcond_without system_yasm # with system yasm
2108baf2 23%bcond_without system_zlib # with system zlib
5997e180 24%bcond_without libjpegturbo # use libjpeg-turbo features
2108baf2 25%bcond_with verbose # verbose build (V=1)
0c480b89 26
6d92f81c 27# TODO
f1b276d4 28# - check system sqlite linking problems
2108baf2 29# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 30# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 31# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 32# - use_system_hunspell
32a2443e 33# - use_system_stlport
a3140cd1
ER
34# - other defaults: src/build/common.gypi
35
e53ecfb5 36# NOTES:
4fe038cb
ER
37# - mute BEEP mixer if you do not want to hear horrible system bell when
38# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
39# - build -bp: 1.2G
40# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 41# - build x86_64: ~1.9G
f1b276d4 42# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 43# - to look for new tarball, use update-source.sh script
f1b276d4 44
e68aa7e7 45# NOTE TO USERS:
a3cc7091
ER
46# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
47# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 48# or:
a3cc7091 49# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 50
a3140cd1 51%define gyp_rev 1014
11ad81c4 52Summary: A WebKit powered web browser
05f72ae2 53Name: chromium-browser
daa4a66c 54Version: 20.0.1132.57
bde600d2 55Release: 2
05f72ae2 56License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 57Group: X11/Applications/Networking
daa4a66c
ER
58Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
59# Source0-md5: 49ca9c418a10d99196951ecef01bcb5a
37ceaf05 60Source1: %{name}.default
8b53130d
ER
61Source2: %{name}.sh
62Source3: %{name}.desktop
56c6e811
ER
63Source5: find-lang.sh
64Source6: update-source.sh
65Source7: clean-source.sh
836b1cac 66Source8: get-source.sh
48b341f5 67Patch0: system-libs.patch
68Patch1: plugin-searchdirs.patch
69Patch2: gyp-system-minizip.patch
7abc645c 70Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 71Patch4: path-libpdf.patch
48b341f5 72Patch5: options-support.patch
0e5636cb 73Patch6: get-webkit_revision.patch
5aa5df39 74Patch7: dlopen_sonamed_gl.patch
4765ddf1 75Patch8: chromium_useragent.patch.in
77f32fa3 76Patch9: system-expat.patch
f4a8da6a 77Patch10: %{name}-pulse.patch
1347c76c
AM
78# https://bugs.gentoo.org/show_bug.cgi?id=393471
79# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 80Patch11: chromium-revert-jpeg-swizzle-r2.patch
d8ba130c 81Patch12: tcmalloc.patch
b908b8b2 82Patch13: %{name}-c++.patch
c6045fc4 83Patch14: chromium-alignment-r0.patch
5997e180
ER
84Patch15: nacl-build-irt.patch
85Patch16: nacl-linkingfix.patch
750b48f7 86URL: http://www.chromium.org/Home
ae3fe89f 87%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 88BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
89BuildRequires: alsa-lib-devel
90BuildRequires: atk-devel
91BuildRequires: bison
11ad81c4 92BuildRequires: bzip2-devel
5997e180
ER
93%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
94%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
95%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
96%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.18.0}
ae3fe89f 97%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 98BuildRequires: dbus-glib-devel
77f32fa3 99BuildRequires: expat-devel
d617ab39 100%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 101BuildRequires: flex
11ad81c4 102BuildRequires: fontconfig-devel
f1b276d4 103BuildRequires: glib2-devel
05f72ae2 104BuildRequires: gperf
8b53130d 105BuildRequires: gtk+2-devel
a3140cd1 106%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 107BuildRequires: hicolor-icon-theme
05f72ae2 108BuildRequires: libevent-devel
7f40f3f4 109%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 110BuildRequires: libicu-devel >= 4.6
39c71b4c 111%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 112%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 113BuildRequires: libpng-devel
e266589e 114%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 115BuildRequires: libstdc++-devel
32a2443e 116%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
71b67d16 117%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.3}
f1b276d4 118BuildRequires: libxml2-devel
11ad81c4 119BuildRequires: libxslt-devel
f1b276d4 120BuildRequires: lzma
11ad81c4 121BuildRequires: minizip-devel
05f72ae2 122BuildRequires: nspr-devel
f1b276d4 123BuildRequires: nss-devel >= 1:3.12.3
35902862 124BuildRequires: pam-devel
f1b276d4 125BuildRequires: pango-devel
48b341f5 126BuildRequires: perl-modules
127BuildRequires: pkgconfig
ae3fe89f 128%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 129BuildRequires: python
46cdefee 130#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 131BuildRequires: python-modules
0cad051b 132BuildRequires: rpm >= 4.4.9-56
f1b276d4 133BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 134%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 135BuildRequires: sqlite3-devel >= 3.6.1
89f0dde4 136BuildRequires: subversion
0cad051b 137BuildRequires: tar >= 1:1.22
0a424ee2 138BuildRequires: udev-devel
2303ed45 139BuildRequires: util-linux
c14cd342 140%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 141BuildRequires: which
f1b276d4 142BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
143BuildRequires: xorg-lib-libXt-devel
144BuildRequires: xorg-lib-libXtst-devel
836b1cac 145BuildRequires: xz
a3140cd1 146%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 147%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 148Requires: browser-plugins >= 2.0
0cad051b 149Requires: desktop-file-utils
0eb19b0b 150Requires: hicolor-icon-theme
c1edaafa 151%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 152%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 153Requires: xdg-utils >= 1.0.2-4
e53ecfb5 154Provides: wwwbrowser
c3582150 155Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 156Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 157ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 158BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 159
589d90ea 160%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
161# Usage: gyp_with BCOND_NAME [OPTION_NAME]
162%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 163
6b113615
ER
164%if %{without debuginfo}
165%define _enable_debug_packages 0
166%endif
167
11ad81c4 168%description
80838854
ER
169Chromium is an open-source browser project that aims to build a safer,
170faster, and more stable way for all Internet users to experience the
171web.
172
173Chromium serves as a base for Google Chrome, which is Chromium
174rebranded (name and logo) with very few additions such as usage
175tracking and an auto-updater system.
176
f1b276d4
ER
177%package l10n
178Summary: chromium-browser language packages
179Group: I18n
180Requires: %{name} = %{version}-%{release}
181
182%description l10n
183Chromium is an open-source browser project that aims to build a safer,
184faster, and more stable way for all Internet users to experience the
185web.
186
187This package contains language packages for 50 languages:
188
e7fa0817
ER
189ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
190he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
191pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
192zh-TW
f1b276d4
ER
193
194%prep
836b1cac 195%setup -q
589d90ea 196
05f72ae2
ER
197# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
198# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
199. ./src/chrome/VERSION
200ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
201test "$ver" = %{version}
202
203gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 204test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 205
836b1cac 206v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 207
f1b276d4 208# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
836b1cac 209#echo "%{svnver}" > src/build/LASTCHANGE.in
f1b276d4 210
4765ddf1
ER
211# add chromium and pld to useragent
212%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
213sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
214 -e 's/@BUILD_DIST_NAME@/PLD/g' \
215 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 216 < %{PATCH8} | %{__patch} -p1
4765ddf1 217
56c6e811
ER
218%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
219ln -s %{SOURCE7} src
f1b276d4 220
05f72ae2
ER
221%patch0 -p1
222%patch1 -p1
223%patch2 -p1
7abc645c 224%patch3 -p1
72cb20c1 225%patch4 -p1
05f72ae2 226%patch5 -p1
0e5636cb 227%patch6 -p1
5aa5df39 228%patch7 -p1
77f32fa3
ER
229cd src
230%patch9 -p1
bdbf9a94 231%patch10 -p1
f4a8da6a 232%{!?with_libjpegturbo:%patch11 -p0}
d8ba130c 233%patch12 -p0
b908b8b2 234%patch13 -p0
c6045fc4 235%patch14 -p0
5997e180
ER
236%patch15 -p1
237%patch16 -p1
1347c76c 238cd ..
0c480b89 239
828bdd1a 240cd src
f8e29f37 241sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0
164020eb 242
e266589e 243%build
f1b276d4 244cd src
5997e180
ER
245
246%if %{with nacl}
247rm -rf native_client/toolchain/linux_x86_newlib
248# Make symlinks for nacl
249cd native_client/toolchain
250install -d linux_x86_newlib/x86_64-nacl/bin
251install -d linux_x86_newlib/x86_64-nacl/lib
252install -d linux_x86_newlib/x86_64-nacl/lib32
253install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
254install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
255install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
256cd linux_x86_newlib/x86_64-nacl/bin
257ln -s %{_bindir}/x86_64-nacl-gcc gcc
258ln -s %{_bindir}/x86_64-nacl-g++ g++
259ln -s %{_bindir}/x86_64-nacl-ar ar
260ln -s %{_bindir}/x86_64-nacl-as as
261ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
262ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
263ln -s %{_bindir}/x86_64-nacl-strip strip
264ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
265ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
266cd ../nacl/include
267for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
268 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
269done
270cd ../../../../../..
271%endif
272
164020eb 273test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
274%ifarch %{ix86}
275 -Dtarget_arch=ia32 \
276%endif
277%ifarch %{x8664}
0c480b89
ER
278 -Dtarget_arch=x64 \
279%endif
7b454a31
AM
280%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
281 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
282%endif
283%if %{with sandboxing}
284 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
285 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
286%endif
287 %{!?debug:-Dwerror=} \
c980b122 288 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 289 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 290 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
291 -Dffmpeg_branding=Chrome \
292 -Dproprietary_codecs=1 \
5a6de706 293 %{!?with_nacl:-Ddisable_nacl=1} \
a3140cd1
ER
294 %{!?with_sse2:-Ddisable_sse2=1} \
295 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
296 %{gyp_with cups} \
297 %{gyp_with flac} \
298 %{gyp_with gconf} \
299 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
300 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
301 %{gyp_with pulseaudio} \
e8e15592 302 %{gyp_with system_libwebp} \
e7fa0817
ER
303 %{gyp_with system_speex} \
304 %{gyp_with system_sqlite} \
305 %{gyp_with system_v8} \
32a2443e 306 %{gyp_with system_vpx} \
e7fa0817
ER
307 %{gyp_with system_yasm} \
308 %{gyp_with system_zlib} \
0c480b89 309 -Duse_system_bzip2=1 \
0b214002 310 -Duse_system_icu=1 \
f1b276d4 311 -Duse_system_libevent=1 \
0c480b89 312 -Duse_system_libjpeg=1 \
f1b276d4
ER
313 -Duse_system_libpng=1 \
314 -Duse_system_libxml=1 \
315 -Duse_system_libxslt=1 \
7f40f3f4 316 -Duse_system_xdg_utils=1 \
d8ba130c 317 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
318 -Dlinux_use_gold_binary=0 \
319 -Dlinux_use_gold_flags=0
11ad81c4 320
f1b276d4
ER
321%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
322 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
323 %{?with_verbose:V=1} \
324 CC="%{__cc}" \
325 CXX="%{__cxx}" \
b7adf6b1 326 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
327 CC.host="%{__cc}" \
328 CXX.host="%{__cxx}" \
b7adf6b1 329 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
330 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
331 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
332
333%install
334rm -rf $RPM_BUILD_ROOT
56c6e811 335install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 336 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 337
f1b276d4 338cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 339cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
340install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
341%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 342cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 343cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 344install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 345install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 346%if %{with ffmpegsumo}
f1b276d4 347install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 348%endif
e7fa0817 349cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb
ER
350
351%if %{with nacl}
352# Install Native Client files on platforms that support it.
353install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
354install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
355%ifarch %{x8664}
356install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
357%endif
358%ifarch %{ix86}
359install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
360%endif
361%endif
362
0c480b89
ER
363cd -
364
0eb19b0b
ER
365for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
366 size=${icon##*/product_logo_}
367 size=${size%.png}
368
369 # this will skip non-numeric (22_mono_invert, 22_mono)
370 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
371 test -d "$dir" || continue
372
373 install -d $RPM_BUILD_ROOT$dir
374 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
375done
7f40f3f4 376
13840bc2
AM
377%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
378# http://code.google.com/p/chromium/issues/detail?id=24507
379gecko-mediaplayer*.so
380EOF
11ad81c4 381
589d90ea
ER
382# find locales
383%find_lang %{name}.lang
e7fa0817 384# always package en-US
f1b276d4 385%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 386
11ad81c4
AM
387%clean
388rm -rf $RPM_BUILD_ROOT
389
f1b276d4 390%post
0eb19b0b 391%update_icon_cache hicolor
b7a6e4ee 392%update_desktop_database
f1b276d4
ER
393%update_browser_plugins
394
395%postun
396if [ "$1" = 0 ]; then
0eb19b0b 397 %update_icon_cache hicolor
f1b276d4
ER
398 %update_browser_plugins
399fi
400
589d90ea 401%files -f %{name}.lang
11ad81c4 402%defattr(644,root,root,755)
f1b276d4
ER
403%{_browserpluginsconfdir}/browsers.d/%{name}.*
404%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
405%dir %{_sysconfdir}/%{name}
406%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
407%attr(755,root,root) %{_bindir}/%{name}
408%{_mandir}/man1/%{name}.1*
11ad81c4 409%{_desktopdir}/*.desktop
0eb19b0b 410%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89
ER
411%dir %{_libdir}/%{name}
412%{_libdir}/%{name}/chrome.pak
c14cd342 413%{_libdir}/%{name}/content_resources.pak
97fac491 414%{_libdir}/%{name}/resources.pak
bbe92394
AM
415%{_libdir}/%{name}/theme_resources_standard.pak
416%{_libdir}/%{name}/ui_resources_standard.pak
589d90ea 417%dir %{_libdir}/%{name}/locales
f1b276d4
ER
418%{_libdir}/%{name}/locales/en-US.pak
419%dir %{_libdir}/%{name}/resources
a3140cd1 420%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
421%dir %{_libdir}/%{name}/themes
422%dir %{_libdir}/%{name}/extensions
423%dir %{_libdir}/%{name}/plugins
424%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 425# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 426%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
427
428# ffmpeg libs
d561483d 429%if %{with ffmpegsumo}
f1b276d4 430%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 431%endif
f1b276d4 432
164020eb
ER
433%if %{with nacl}
434%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
435%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
436%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
437%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
438%endif
439
f1b276d4
ER
440%files l10n -f %{name}.lang
441%defattr(644,root,root,755)
This page took 0.119445 seconds and 4 git commands to generate.