]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
Requires gtest-devel for the headers
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
7d0dbc8d 16%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
01b4dc8e 17%bcond_with system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
75a27c2e 26%bcond_with system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
4b411ffe 31%bcond_without system_libvpx # system libvpx
ba685303 32%bcond_without system_yasm # system yasm
1c00315b 33%bcond_without system_zlib # system zlib
d2781a31 34%bcond_without tcmalloc # use tcmalloc
7e136323 35%bcond_without verbose # verbose build (V=1)
0c480b89 36
c6325ea2
ER
37%if %{with nacl}
38# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42#14:51:06 @baggins> as-needed will take care of unneeded lib
43#14:52:03 @baggins> -lssp comes with gcc
107b55fe 44%define _ssp_cflags %{nil}
c6325ea2
ER
45%endif
46
6d92f81c 47# TODO
f1b276d4 48# - check system sqlite linking problems
2108baf2 49# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 50# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 51# - use_system_hunspell
32a2443e 52# - use_system_stlport
a3140cd1
ER
53# - other defaults: src/build/common.gypi
54
e53ecfb5 55# NOTES:
4fe038cb
ER
56# - mute BEEP mixer if you do not want to hear horrible system bell when
57# pressing home/end in url bar or more ^F search results on page.
7c638678 58# - space considerations:
43238759 59# - unpacked sources: ~644MiB
c1ecd31f 60# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 61# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 62# - to look for new tarball, use update-source.sh script
f1b276d4 63
e68aa7e7 64# NOTE TO USERS:
c8b02491 65# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 66# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 67# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 68
a3140cd1 69%define gyp_rev 1014
11ad81c4 70Summary: A WebKit powered web browser
05f72ae2 71Name: chromium-browser
a435d242 72Version: 24.0.1312.49
d2781a31 73Release: 0.24
05f72ae2 74License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 75Group: X11/Applications/Networking
c1ecd31f 76Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
126ea630 77# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
37ceaf05 78Source1: %{name}.default
8b53130d
ER
79Source2: %{name}.sh
80Source3: %{name}.desktop
56c6e811
ER
81Source5: find-lang.sh
82Source6: update-source.sh
83Source7: clean-source.sh
836b1cac 84Source8: get-source.sh
0562b864 85Source9: master_preferences.json
48b341f5 86Patch1: plugin-searchdirs.patch
70258ccd 87#Patch2: system-nspr.patch
7abc645c 88Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 89Patch4: path-libpdf.patch
0e5636cb 90Patch6: get-webkit_revision.patch
5aa5df39 91Patch7: dlopen_sonamed_gl.patch
4765ddf1 92Patch8: chromium_useragent.patch.in
c0808220 93Patch9: chromium-ppapi.patch
8456d676 94Patch10: system-libxnvctrl.patch
1347c76c
AM
95# https://bugs.gentoo.org/show_bug.cgi?id=393471
96# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 97Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
98Patch15: nacl-build-irt.patch
99Patch16: nacl-linkingfix.patch
9516ca97 100Patch18: nacl-no-untar.patch
08b25440 101Patch19: system-jsoncpp.patch
126ea630 102Patch22: pulse_fix-157876.patch
8fb1dc98 103Patch23: no-pnacl.patch
6897926c 104Patch24: nacl-verbose.patch
c5b396f3
ER
105Patch25: gnome3-volume-control.patch
106Patch26: master-prefs-path.patch
d2781a31 107Patch27: tcmalloc-glibc2.16.patch
750b48f7 108URL: http://www.chromium.org/Home
ae3fe89f 109%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 110BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
111BuildRequires: alsa-lib-devel
112BuildRequires: atk-devel
113BuildRequires: bison
11ad81c4 114BuildRequires: bzip2-devel
5997e180
ER
115%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
116%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
117%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 118%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 119%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 120BuildRequires: dbus-glib-devel
77f32fa3 121BuildRequires: expat-devel
7d0dbc8d 122%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 123%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 124BuildRequires: flex
11ad81c4 125BuildRequires: fontconfig-devel
f1b276d4 126BuildRequires: glib2-devel
05f72ae2 127BuildRequires: gperf
bbad64b7 128BuildRequires: gtest-devel
8b53130d 129BuildRequires: gtk+2-devel
01b4dc8e 130%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 131%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 132BuildRequires: hicolor-icon-theme
ed514974 133%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
8456d676 134%{?with_system_libxvnctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 135BuildRequires: libevent-devel
8456d676 136%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 137%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 138BuildRequires: libicu-devel >= 4.6
39c71b4c 139%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 140%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 141%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 142BuildRequires: libpng-devel
e266589e 143%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 144BuildRequires: libstdc++-devel
ba685303 145%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 146%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 147%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 148BuildRequires: libxml2-devel
11ad81c4 149BuildRequires: libxslt-devel
f1b276d4 150BuildRequires: lzma
62950103 151%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 152BuildRequires: nspr-devel
f1b276d4 153BuildRequires: nss-devel >= 1:3.12.3
8456d676 154%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 155BuildRequires: pam-devel
f1b276d4 156BuildRequires: pango-devel
48b341f5 157BuildRequires: perl-modules
158BuildRequires: pkgconfig
75a27c2e 159%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 160%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 161BuildRequires: python
46cdefee 162#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 163BuildRequires: python-modules
0cad051b 164BuildRequires: rpm >= 4.4.9-56
f1b276d4 165BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 166%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 167BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 168%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 169BuildRequires: subversion
0cad051b 170BuildRequires: tar >= 1:1.22
0a424ee2 171BuildRequires: udev-devel
2303ed45 172BuildRequires: util-linux
c14cd342 173%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 174BuildRequires: which
f1b276d4 175BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
176BuildRequires: xorg-lib-libXt-devel
177BuildRequires: xorg-lib-libXtst-devel
836b1cac 178BuildRequires: xz
a3140cd1 179%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 180%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 181Requires: browser-plugins >= 2.0
0cad051b 182Requires: desktop-file-utils
8f5f6775 183%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 184Requires: hicolor-icon-theme
c1edaafa 185%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 186%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
4dc49133 187Requires: xdg-utils >= 1.0.2-4
e53ecfb5 188Provides: wwwbrowser
c3582150 189Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 190Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 191ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 192BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 193
589d90ea 194%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 195
e7fa0817
ER
196# Usage: gyp_with BCOND_NAME [OPTION_NAME]
197%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 198
6b113615
ER
199%if %{without debuginfo}
200%define _enable_debug_packages 0
201%endif
202
11ad81c4 203%description
80838854
ER
204Chromium is an open-source browser project that aims to build a safer,
205faster, and more stable way for all Internet users to experience the
206web.
207
208Chromium serves as a base for Google Chrome, which is Chromium
209rebranded (name and logo) with very few additions such as usage
210tracking and an auto-updater system.
211
f1b276d4
ER
212%package l10n
213Summary: chromium-browser language packages
214Group: I18n
215Requires: %{name} = %{version}-%{release}
216
217%description l10n
218Chromium is an open-source browser project that aims to build a safer,
219faster, and more stable way for all Internet users to experience the
220web.
221
222This package contains language packages for 50 languages:
223
e7fa0817
ER
224ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
225he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
226pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
227zh-TW
f1b276d4
ER
228
229%prep
836b1cac 230%setup -q
589d90ea 231
05f72ae2
ER
232# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
233# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
234. ./src/chrome/VERSION
235ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
236test "$ver" = %{version}
237
238gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 239test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 240
836b1cac 241v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 242
4765ddf1
ER
243# add chromium and pld to useragent
244%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
245sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
246 -e 's/@BUILD_DIST_NAME@/PLD/g' \
247 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 248 < %{PATCH8} | %{__patch} -p1
4765ddf1 249
56c6e811
ER
250%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
251ln -s %{SOURCE7} src
f1b276d4 252
05f72ae2 253%patch1 -p1
7abc645c 254%patch3 -p1
72cb20c1 255%patch4 -p1
0e5636cb 256%patch6 -p1
5aa5df39 257%patch7 -p1
e9abb380 258%patch15 -p1
77f32fa3 259cd src
c0808220 260%patch9 -p0
70258ccd 261#%patch2 -p1
f4a8da6a 262%{!?with_libjpegturbo:%patch11 -p0}
5997e180 263%patch16 -p1
08b25440 264%patch19 -p1
126ea630 265%patch22 -p1
c5b396f3 266%patch25 -p1
d2781a31 267%patch27 -p1
1347c76c 268cd ..
9516ca97 269%patch18 -p1
8fb1dc98 270%patch23 -p1
6897926c 271%patch24 -p1
c5b396f3 272%patch26 -p1
0c480b89 273
828bdd1a 274cd src
e9abb380
ER
275
276# Missing gyp files in tarball.
277# https://code.google.com/p/chromium/issues/detail?id=144823
278if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
279 echo "tarball fixed, please remove workaround"
280 exit 1
281fi
282
283install -d chrome/test/data/nacl
284cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
285{
286 'targets': [
287 {
288 'target_name': 'nacl_tests',
289 'type': 'none',
290 },
291 ],
292}
293EOF
294
75a27c2e
ER
295sh -x clean-source.sh \
296 %{!?with_nacl:nacl=0} \
297 %{!?with_system_protobuf:protobuf=0} \
298 %{!?with_system_v8:v8=0} \
299 %{!?with_system_zlib:zlib=0} \
300 %{nil}
164020eb 301
e266589e 302%build
f1b276d4 303cd src
5997e180
ER
304
305%if %{with nacl}
fded59be 306if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b
ER
307# Make symlinks for NaCL
308install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
2e4113fd 309
dcea0d6b 310cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
2e4113fd 311__cc='%{__cc}'
f64e73f6 312if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
313 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
314 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
315 %{__sed} -i -e '1i#!/bin/sh' gcc g++
316 chmod +x gcc g++
317else
318 ln -s %{_bindir}/x86_64-nacl-gcc gcc
319 ln -s %{_bindir}/x86_64-nacl-g++ g++
320fi
5997e180
ER
321ln -s %{_bindir}/x86_64-nacl-ar ar
322ln -s %{_bindir}/x86_64-nacl-as as
323ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
324ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
325ln -s %{_bindir}/x86_64-nacl-strip strip
dcea0d6b
ER
326ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
327ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
328ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
329cd ../../../../..
fded59be 330fi
5997e180
ER
331%endif
332
c5b396f3 333test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
334test -e Makefile || %{__python} build/gyp_chromium \
335 --format=make \
336 -Goutput_dir=../out \
337 build/all.gyp \
f1b276d4
ER
338%ifarch %{ix86}
339 -Dtarget_arch=ia32 \
340%endif
341%ifarch %{x8664}
0c480b89
ER
342 -Dtarget_arch=x64 \
343%endif
7b454a31
AM
344%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
345 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
346%endif
347%if %{with sandboxing}
348 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
349 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
350%endif
351 %{!?debug:-Dwerror=} \
c980b122 352 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 353 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 354 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 355 -Dinclude_tests=0 \
c0808220 356%if %{with nacl}
038f76b9 357 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
358 -Ddisable_glibc_untar=1 \
359 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
360 -Ddisable_glibc=1 \
361 -Ddisable_pnacl=1 \
362 -Dbuild_pnacl_newlib=0 \
c0808220 363%else
8fb1dc98 364 -Ddisable_pnacl_untar=1 \
c0808220
ER
365 -Ddisable_nacl=1 \
366%endif
a3140cd1
ER
367 %{!?with_sse2:-Ddisable_sse2=1} \
368 %{?with_selinux:-Dselinux=1} \
e7fa0817 369 %{gyp_with cups} \
8dda6bbc 370 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
371 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
372 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
373 %{gyp_with pulseaudio} \
7d0dbc8d 374 %{gyp_with system_ffmpeg} \
8f5f6775 375 %{gyp_with system_flac} \
01b4dc8e 376 %{gyp_with system_harfbuzz} \
62950103
ER
377 %{gyp_with system_libexif} \
378 %{gyp_with system_libmtp} \
9bd2659c 379 %{gyp_with system_libsrtp} \
581aec44 380 %{gyp_with system_libusb} \
4b411ffe 381 %{gyp_with system_libvpx} \
ba685303 382 %{gyp_with system_libwebp} \
4884fc99 383 %{gyp_with system_libxnvctrl} \
126ea630 384 %{gyp_with system_minizip} \
62950103 385 %{gyp_with system_opus} \
75a27c2e 386 %{gyp_with system_protobuf} \
e7fa0817
ER
387 %{gyp_with system_speex} \
388 %{gyp_with system_sqlite} \
389 %{gyp_with system_v8} \
390 %{gyp_with system_yasm} \
391 %{gyp_with system_zlib} \
0c480b89 392 -Duse_system_bzip2=1 \
62950103 393 -Duse_system_expat=1 \
0b214002 394 -Duse_system_icu=1 \
f1b276d4 395 -Duse_system_libevent=1 \
0c480b89 396 -Duse_system_libjpeg=1 \
f1b276d4
ER
397 -Duse_system_libpng=1 \
398 -Duse_system_libxml=1 \
399 -Duse_system_libxslt=1 \
7f40f3f4 400 -Duse_system_xdg_utils=1 \
d8ba130c 401 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
402 -Dlinux_use_gold_binary=0 \
403 -Dlinux_use_gold_flags=0
11ad81c4 404
48ffbc5e 405%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
406 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
407 %{?with_verbose:V=1} \
408 CC="%{__cc}" \
409 CXX="%{__cxx}" \
b7adf6b1 410 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
411 CC.host="%{__cc}" \
412 CXX.host="%{__cxx}" \
b7adf6b1 413 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
414 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
415 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
416
417%install
418rm -rf $RPM_BUILD_ROOT
56c6e811 419install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 420 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 421
673aee14 422cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 423cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
424install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
425%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 426cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 427cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 428install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 429install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 430%if %{without system_ffmpeg}
f1b276d4 431install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 432%endif
e7fa0817 433cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 434cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 435
c0808220
ER
436%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
437
164020eb
ER
438%if %{with nacl}
439# Install Native Client files on platforms that support it.
440install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
441install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
442%ifarch %{x8664}
443install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
444%endif
445%ifarch %{ix86}
446install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
447%endif
448%endif
449
0c480b89
ER
450cd -
451
0eb19b0b
ER
452for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
453 size=${icon##*/product_logo_}
454 size=${size%.png}
455
456 # this will skip non-numeric (22_mono_invert, 22_mono)
457 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
458 test -d "$dir" || continue
459
460 install -d $RPM_BUILD_ROOT$dir
461 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
462done
7f40f3f4 463
13840bc2
AM
464%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
465# http://code.google.com/p/chromium/issues/detail?id=24507
466gecko-mediaplayer*.so
467EOF
11ad81c4 468
589d90ea
ER
469# find locales
470%find_lang %{name}.lang
e7fa0817 471# always package en-US
f1b276d4 472%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 473
11ad81c4
AM
474%clean
475rm -rf $RPM_BUILD_ROOT
476
f1b276d4 477%post
0eb19b0b 478%update_icon_cache hicolor
b7a6e4ee 479%update_desktop_database
f1b276d4
ER
480%update_browser_plugins
481
482%postun
483if [ "$1" = 0 ]; then
0eb19b0b 484 %update_icon_cache hicolor
f1b276d4
ER
485 %update_browser_plugins
486fi
487
1d2b9616 488%files
11ad81c4 489%defattr(644,root,root,755)
531537e5 490%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
491%{_browserpluginsconfdir}/browsers.d/%{name}.*
492%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
493%dir %{_sysconfdir}/%{name}
494%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 495%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
496%attr(755,root,root) %{_bindir}/%{name}
497%{_mandir}/man1/%{name}.1*
11ad81c4 498%{_desktopdir}/*.desktop
0eb19b0b 499%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 500%dir %{_libdir}/%{name}
e9abb380 501%{_libdir}/%{name}/chrome*.pak
c14cd342 502%{_libdir}/%{name}/content_resources.pak
97fac491 503%{_libdir}/%{name}/resources.pak
589d90ea 504%dir %{_libdir}/%{name}/locales
f1b276d4
ER
505%{_libdir}/%{name}/locales/en-US.pak
506%dir %{_libdir}/%{name}/resources
a3140cd1 507%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
508%dir %{_libdir}/%{name}/themes
509%dir %{_libdir}/%{name}/extensions
510%dir %{_libdir}/%{name}/plugins
511%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 512# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 513%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
514
515# ffmpeg libs
fcc48c19 516%if %{without system_ffmpeg}
f1b276d4 517%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 518%endif
f1b276d4 519
164020eb
ER
520%if %{with nacl}
521%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
522%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
523%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
524%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
525%endif
526
f1b276d4
ER
527%files l10n -f %{name}.lang
528%defattr(644,root,root,755)
This page took 0.130916 seconds and 4 git commands to generate.