]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 29.0.1547.62
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
ba685303
ER
22%bcond_without system_libusb # system libusb-1
23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 25%bcond_with system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
543e99ac 29%bcond_without system_re2 # system re2
7e634b46 30%bcond_without system_snappy # system snappy
ba685303 31%bcond_without system_speex # system speex
a8f4f3ac 32%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 33%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 34%bcond_with system_v8 # system v8
4b411ffe 35%bcond_without system_libvpx # system libvpx
ba685303 36%bcond_without system_yasm # system yasm
1c00315b 37%bcond_without system_zlib # system zlib
d2781a31 38%bcond_without tcmalloc # use tcmalloc
7e136323 39%bcond_without verbose # verbose build (V=1)
0c480b89 40
b3fc6cb2
ER
41%ifarch %{ix86}
42# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43%undefine with_system_mesa
44%endif
45
6d92f81c 46# TODO
b363f856 47# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 48# - use_system_skia
a3140cd1 49# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 50# - use_system_stlport (android specific)
7b8f219a 51# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 52
e53ecfb5 53# NOTES:
4fe038cb
ER
54# - mute BEEP mixer if you do not want to hear horrible system bell when
55# pressing home/end in url bar or more ^F search results on page.
7c638678 56# - space considerations:
0bb93ab2 57# - unpacked sources: ~490MiB
c1ecd31f 58# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 59# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 60# - to look for new tarball, use update-source.sh script
f1b276d4 61
71581184
ER
62%define branch 29.0.1547
63%define basever 57
ba2d1b40 64%define patchver 62
a3140cd1 65%define gyp_rev 1014
11ad81c4 66Summary: A WebKit powered web browser
05f72ae2 67Name: chromium-browser
f73369da
ER
68%if "%{?patchver}" != ""
69Version: %{branch}.%{patchver}
70%else
71Version: %{branch}.%{basever}
72%endif
8174fe8c 73Release: 1
5bb99ef4 74License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 75Group: X11/Applications/Networking
3c73e180 76Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
5c001b32 77# Source0-md5: fcdeb8cb650d64e326d4ae84ca491432
3c73e180
ER
78%if "%{?patchver}" != ""
79Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
ba2d1b40 80# Patch0-md5: 4fb8054c537e4e0aa85d594b5c64dc73
3c73e180 81%endif
37ceaf05 82Source1: %{name}.default
8b53130d
ER
83Source2: %{name}.sh
84Source3: %{name}.desktop
56c6e811
ER
85Source5: find-lang.sh
86Source6: update-source.sh
87Source7: clean-source.sh
836b1cac 88Source8: get-source.sh
0562b864 89Source9: master_preferences.json
48b341f5 90Patch1: plugin-searchdirs.patch
72cb20c1 91Patch4: path-libpdf.patch
5aa5df39 92Patch7: dlopen_sonamed_gl.patch
4765ddf1 93Patch8: chromium_useragent.patch.in
8456d676 94Patch10: system-libxnvctrl.patch
1347c76c
AM
95# https://bugs.gentoo.org/show_bug.cgi?id=393471
96# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 97Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 98Patch12: system-ffmpeg.patch
5997e180
ER
99Patch15: nacl-build-irt.patch
100Patch16: nacl-linkingfix.patch
9516ca97 101Patch18: nacl-no-untar.patch
6897926c 102Patch24: nacl-verbose.patch
c5b396f3
ER
103Patch25: gnome3-volume-control.patch
104Patch26: master-prefs-path.patch
25d4e23c 105Patch28: system-mesa.patch
750b48f7 106URL: http://www.chromium.org/Home
ae3fe89f 107%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3
ER
108%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
109%{?with_system_mesa:BuildRequires: Mesa-libGLES-devel >= 9.1}
7b8f219a 110%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 111%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2 112BuildRequires: alsa-lib-devel
71581184 113BuildRequires: perl-JSON
05f72ae2
ER
114BuildRequires: atk-devel
115BuildRequires: bison
11ad81c4 116BuildRequires: bzip2-devel
5997e180
ER
117%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
118%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
119%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 120%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 121%{?with_cups:BuildRequires: cups-devel}
92965b0e 122BuildRequires: elfutils-devel
77f32fa3 123BuildRequires: expat-devel
7d0dbc8d 124%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 125%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 126BuildRequires: fontconfig-devel
f1b276d4 127BuildRequires: glib2-devel
05f72ae2 128BuildRequires: gperf
71d49434 129%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 130BuildRequires: gtest-devel
8b53130d 131BuildRequires: gtk+2-devel
01b4dc8e 132%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 133%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 134%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 135BuildRequires: hicolor-icon-theme
ed514974 136%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 137%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 138BuildRequires: libevent-devel
8456d676 139%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 140%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 141BuildRequires: libicu-devel >= 4.6
39c71b4c 142%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 143%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 144%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 145BuildRequires: libpng-devel
e266589e 146%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 147BuildRequires: libstdc++-devel
ba685303 148%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 149%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 150%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 151BuildRequires: libxml2-devel
11ad81c4 152BuildRequires: libxslt-devel
535cb410 153BuildRequires: man-db
62950103 154%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 155BuildRequires: nspr-devel
f1b276d4 156BuildRequires: nss-devel >= 1:3.12.3
8456d676 157%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 158BuildRequires: pam-devel
f1b276d4 159BuildRequires: pango-devel
ef121064 160BuildRequires: pciutils-devel
48b341f5 161BuildRequires: perl-modules
162BuildRequires: pkgconfig
75a27c2e 163%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 164%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 165BuildRequires: python
46cdefee 166#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 167BuildRequires: python-modules
92965b0e 168BuildRequires: python-ply
543e99ac 169%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 170BuildRequires: rpm >= 4.4.9-56
f1b276d4 171BuildRequires: rpmbuild(macros) >= 1.453
f099161f 172%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 173BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 174%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 175%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 176%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 177BuildRequires: subversion
0cad051b 178BuildRequires: tar >= 1:1.22
0a424ee2 179BuildRequires: udev-devel
7d1152d4 180BuildRequires: usbutils
2303ed45 181BuildRequires: util-linux
c14cd342 182%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 183BuildRequires: which
f1b276d4 184BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 185BuildRequires: xz
a3140cd1 186%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 187%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 188Requires: browser-plugins >= 2.0
0cad051b 189Requires: desktop-file-utils
8f5f6775 190%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
191# crashes if no fontconfig font present
192Requires: fonts-Type1-urw
0eb19b0b 193Requires: hicolor-icon-theme
56403697 194Requires: libevent >= 2.0.21
c1edaafa 195%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 196%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 197Requires: lsb-release
b2c4ae39 198%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 199Requires: shared-mime-info
f7b16691 200%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 201Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 202Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 203Provides: wwwbrowser
c3582150 204Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 205Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 206ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 207BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 208
319f81f7
ER
209# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
210# Note: these are for PLD Linux use ONLY.
211# For your own distribution, please get your own set of keys.
212%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
213%define google_default_client_id 724288223830.apps.googleusercontent.com
214%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
215
7ebeabb6 216%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 217
e7fa0817
ER
218# Usage: gyp_with BCOND_NAME [OPTION_NAME]
219%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 220
6b113615
ER
221%if %{without debuginfo}
222%define _enable_debug_packages 0
223%endif
224
11ad81c4 225%description
80838854
ER
226Chromium is an open-source browser project that aims to build a safer,
227faster, and more stable way for all Internet users to experience the
228web.
229
230Chromium serves as a base for Google Chrome, which is Chromium
231rebranded (name and logo) with very few additions such as usage
232tracking and an auto-updater system.
233
f1b276d4
ER
234%package l10n
235Summary: chromium-browser language packages
236Group: I18n
237Requires: %{name} = %{version}-%{release}
8da7b90b
ER
238%if "%{_rpmversion}" >= "5"
239BuildArch: noarch
240%endif
f1b276d4
ER
241
242%description l10n
243Chromium is an open-source browser project that aims to build a safer,
244faster, and more stable way for all Internet users to experience the
245web.
246
247This package contains language packages for 50 languages:
248
e7fa0817
ER
249ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
250he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
251pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
252zh-TW
f1b276d4
ER
253
254%prep
3c73e180
ER
255%setup -qc
256%if "%{?patchver}" != ""
257cd %{name}-%{branch}.%{basever}
258%patch0 -p1
259cd ..
260%endif
75f96a39 261mv %{name}-%{branch}.%{basever}/* .
589d90ea 262
05f72ae2
ER
263# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
264# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 265. ./chrome/VERSION
e00e4177
ER
266chrome=$MAJOR.$MINOR.$BUILD.$PATCH
267test "$chrome" = %{version}
a3140cd1 268
75f96a39 269gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 270test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 271
e00e4177
ER
272. ./v8.sh
273v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
33b04c7d 274
4765ddf1
ER
275# add chromium and pld to useragent
276%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
277sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
278 -e 's/@BUILD_DIST_NAME@/PLD/g' \
279 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 280 < %{PATCH8} | %{__patch} -p1
4765ddf1 281
8da7b90b 282%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
283ln -s %{SOURCE7} .
284
285%patch1 -p2
75f96a39 286%patch4 -p3
7879021e
ER
287%patch7 -p1
288%patch10 -p1
75f96a39 289%patch15 -p2
f4a8da6a 290%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 291%patch12 -p1
5997e180 292%patch16 -p1
41d6a4b1 293%patch28 -p1
75f96a39 294%patch25 -p2
1ed01da3 295%patch18 -p1
75f96a39
ER
296%patch24 -p2
297%patch26 -p2
e9abb380 298
75a27c2e
ER
299sh -x clean-source.sh \
300 %{!?with_nacl:nacl=0} \
bbdce24d
ER
301 %{!?with_system_libvpx:libvpx=0} \
302 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 303 %{!?with_system_mesa:mesa=0} \
75a27c2e 304 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 305 %{!?with_system_re2:re2=0} \
7e634b46 306 %{!?with_system_snappy:snappy=0} \
5048b37a 307 %{!?with_system_sqlite:sqlite=0} \
75a27c2e
ER
308 %{!?with_system_v8:v8=0} \
309 %{!?with_system_zlib:zlib=0} \
310 %{nil}
fded59be 311
e266589e 312%build
5997e180 313%if %{with nacl}
108c5f7c 314rm -rf native_client/toolchain/linux_x86_newlib
fded59be 315if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 316# Make symlinks for NaCL
108c5f7c 317install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 318
108c5f7c
ER
319cd native_client/toolchain/linux_x86_newlib
320ln -s x86_64-nacl/bin bin
321cd x86_64-nacl/bin
2e4113fd 322__cc='%{__cc}'
f64e73f6 323if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
324 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
325 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
326 %{__sed} -i -e '1i#!/bin/sh' gcc g++
327 chmod +x gcc g++
328else
329 ln -s %{_bindir}/x86_64-nacl-gcc gcc
330 ln -s %{_bindir}/x86_64-nacl-g++ g++
331fi
108c5f7c
ER
332ln -s gcc x86_64-nacl-gcc
333ln -s g++ x86_64-nacl-g++
334ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
335ln -s %{_bindir}/x86_64-nacl-ar ar
336ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 337ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 338ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 339ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 340ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 341ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
342ln -s %{_prefix}/x86_64-nacl/lib ../lib
343ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
344ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
345cd ../../../../..
fded59be 346fi
5997e180
ER
347%endif
348
7879021e 349flags="
f1b276d4
ER
350%ifarch %{ix86}
351 -Dtarget_arch=ia32 \
352%endif
353%ifarch %{x8664}
0c480b89
ER
354 -Dtarget_arch=x64 \
355%endif
7b454a31
AM
356%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
357 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
358%endif
359%if %{with sandboxing}
360 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
361 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
362%endif
363 %{!?debug:-Dwerror=} \
c980b122 364 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 365 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 366 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
b5a3dda3 367 -Dinclude_tests=0 \
c0808220 368%if %{with nacl}
038f76b9 369 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
370 -Ddisable_glibc_untar=1 \
371 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
372 -Ddisable_glibc=1 \
373 -Ddisable_pnacl=1 \
374 -Dbuild_pnacl_newlib=0 \
c0808220 375%else
8fb1dc98 376 -Ddisable_pnacl_untar=1 \
c0808220
ER
377 -Ddisable_nacl=1 \
378%endif
a3140cd1
ER
379 %{!?with_sse2:-Ddisable_sse2=1} \
380 %{?with_selinux:-Dselinux=1} \
7d1152d4 381 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 382 -Dlinux_link_libpci=1 \
7879021e 383 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
05998197 384 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 385 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
386 -Dlinux_use_gold_binary=0 \
387 -Dlinux_use_gold_flags=0 \
71581184 388 -Dlogging_like_official_build=1 \
319f81f7
ER
389 -Dgoogle_api_key=%{google_api_key} \
390 -Dgoogle_default_client_id=%{google_default_client_id} \
391 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 392 %{gyp_with cups} \
8dda6bbc 393 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 394 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
395 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
396 %{gyp_with pulseaudio} \
41d6a4b1 397 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 398 %{gyp_with system_flac} \
01b4dc8e 399 %{gyp_with system_harfbuzz} \
2d65d095 400 %{gyp_with system_jsoncpp} \
62950103
ER
401 %{gyp_with system_libexif} \
402 %{gyp_with system_libmtp} \
9bd2659c 403 %{gyp_with system_libsrtp} \
581aec44 404 %{gyp_with system_libusb} \
41d6a4b1 405 %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
ba685303 406 %{gyp_with system_libwebp} \
4884fc99 407 %{gyp_with system_libxnvctrl} \
7b8f219a 408 %{gyp_with system_mesa} \
126ea630 409 %{gyp_with system_minizip} \
62950103 410 %{gyp_with system_opus} \
75a27c2e 411 %{gyp_with system_protobuf} \
bbdce24d 412 %{gyp_with system_re2} \
7e634b46 413 %{gyp_with system_snappy} \
e7fa0817 414 %{gyp_with system_speex} \
914ee37c 415 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
416 %{gyp_with system_v8} \
417 %{gyp_with system_yasm} \
418 %{gyp_with system_zlib} \
0c480b89 419 -Duse_system_bzip2=1 \
62950103 420 -Duse_system_expat=1 \
0b214002 421 -Duse_system_icu=1 \
f1b276d4 422 -Duse_system_libevent=1 \
0c480b89 423 -Duse_system_libjpeg=1 \
f1b276d4
ER
424 -Duse_system_libpng=1 \
425 -Duse_system_libxml=1 \
426 -Duse_system_libxslt=1 \
b363f856 427 -Duse_system_nspr=1 \
7f40f3f4 428 -Duse_system_xdg_utils=1 \
7879021e
ER
429"
430
431build/linux/unbundle/replace_gyp_files.py $flags
432
433test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
434test -e Makefile || \
435 CC="%{__cc}" \
436 CXX="%{__cxx}" \
437 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
438 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
439 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
440 CC_host="%{__cc}" \
441 CXX_host="%{__cxx}" \
442 LD_host="%{__cxx}" \
443%{__python} build/gyp_chromium \
444 --format=make \
445 --depth=. \
446 build/all.gyp \
447 $flags
11ad81c4 448
b4d75247 449# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 450%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
451 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
452 %{?with_verbose:V=1} \
f1b276d4
ER
453 CC.host="%{__cc}" \
454 CXX.host="%{__cxx}" \
b4d75247 455 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 456
75f96a39 457cd out/%{!?debug:Release}%{?debug:Debug}
535cb410
ER
458MANWIDTH=80 man ./chrome.1 > man.out
459%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
460
11ad81c4
AM
461%install
462rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
463install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
464 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
37ceaf05 465 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 466
673aee14 467cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 468cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 469install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
470%{__sed} -i -e '
471 s,@libdir@,%{_libdir}/%{name},
472
473 /@OPTIONS@/ {
474 r options.txt
475 d
476 }
477' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b
ER
478cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
479cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
480ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
481ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 482cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 483install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 484install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 485%if %{without system_ffmpeg}
f1b276d4 486install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 487%endif
e7fa0817 488cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 489cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 490
8da7b90b 491%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 492
164020eb
ER
493%if %{with nacl}
494# Install Native Client files on platforms that support it.
495install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
496install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
497%ifarch %{x8664}
498install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
499%endif
500%ifarch %{ix86}
501install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
502%endif
503%endif
504
0c480b89
ER
505cd -
506
75f96a39 507for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
508 size=${icon##*/product_logo_}
509 size=${size%.png}
510
511 # this will skip non-numeric (22_mono_invert, 22_mono)
512 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
513 test -d "$dir" || continue
514
515 install -d $RPM_BUILD_ROOT$dir
516 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
517done
7f40f3f4 518
13840bc2
AM
519%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
520# http://code.google.com/p/chromium/issues/detail?id=24507
521gecko-mediaplayer*.so
522EOF
11ad81c4 523
589d90ea
ER
524# find locales
525%find_lang %{name}.lang
e7fa0817 526# always package en-US
f1b276d4 527%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 528
11ad81c4
AM
529%clean
530rm -rf $RPM_BUILD_ROOT
531
8da7b90b
ER
532%pretrans
533for d in locales resources; do
534 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
535 install -d %{_datadir}/%{name}
536 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
537 fi
538done
539exit 0
540
f1b276d4 541%post
0eb19b0b 542%update_icon_cache hicolor
b7a6e4ee 543%update_desktop_database
f1b276d4
ER
544%update_browser_plugins
545
546%postun
547if [ "$1" = 0 ]; then
0eb19b0b 548 %update_icon_cache hicolor
f1b276d4
ER
549 %update_browser_plugins
550fi
551
1d2b9616 552%files
11ad81c4 553%defattr(644,root,root,755)
75f96a39 554%doc AUTHORS LICENSE
f1b276d4
ER
555%{_browserpluginsconfdir}/browsers.d/%{name}.*
556%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
557%dir %{_sysconfdir}/%{name}
558%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 559%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
560%attr(755,root,root) %{_bindir}/%{name}
561%{_mandir}/man1/%{name}.1*
11ad81c4 562%{_desktopdir}/*.desktop
0eb19b0b 563%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 564%dir %{_libdir}/%{name}
e9abb380 565%{_libdir}/%{name}/chrome*.pak
c14cd342 566%{_libdir}/%{name}/content_resources.pak
97fac491 567%{_libdir}/%{name}/resources.pak
8da7b90b
ER
568%{_libdir}/%{name}/locales
569%{_libdir}/%{name}/resources
570
571%dir %{_datadir}/%{name}
572%dir %{_datadir}/%{name}/locales
573%{_datadir}/%{name}/locales/en-US.pak
574%dir %{_datadir}/%{name}/resources
575%{_datadir}/%{name}/resources/inspector
576
f1b276d4
ER
577%dir %{_libdir}/%{name}/plugins
578%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 579# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 580%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
581
582# ffmpeg libs
fcc48c19 583%if %{without system_ffmpeg}
f1b276d4 584%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 585%endif
f1b276d4 586
164020eb
ER
587%if %{with nacl}
588%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
589%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
590%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
591%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
592%endif
593
f1b276d4
ER
594%files l10n -f %{name}.lang
595%defattr(644,root,root,755)
This page took 0.220245 seconds and 4 git commands to generate.