]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
fix build with system flac
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
6c8531c6 10%bcond_without nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
d8ba130c 15%bcond_with tcmalloc # use tcmalloc
2108baf2 16%bcond_with system_sqlite # with system sqlite
32a2443e 17%bcond_without system_flac # with system flac
08b25440 18%bcond_without system_jsoncpp # with system jsoncpp
e8e15592 19%bcond_without system_libwebp # with system libwebp
32a2443e 20%bcond_without system_speex # with system speex
c14cd342 21%bcond_with system_v8 # with system v8
32a2443e 22%bcond_without system_vpx # with system vpx
d617ab39 23%bcond_without system_yasm # with system yasm
4c272135
ER
24# system zlib disabled because of mixed-source.patch
25# https://code.google.com/p/chromium/issues/detail?id=143623
26%bcond_with system_zlib # with system zlib
5997e180 27%bcond_without libjpegturbo # use libjpeg-turbo features
7e136323 28%bcond_without verbose # verbose build (V=1)
0c480b89 29
c6325ea2
ER
30%if %{with nacl}
31# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
32# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
33#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
34#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
35#14:51:06 @baggins> as-needed will take care of unneeded lib
36#14:52:03 @baggins> -lssp comes with gcc
107b55fe 37%define _ssp_cflags %{nil}
c6325ea2
ER
38%endif
39
6d92f81c 40# TODO
f1b276d4 41# - check system sqlite linking problems
2108baf2 42# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 43# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 44# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 45# - use_system_hunspell
32a2443e 46# - use_system_stlport
a3140cd1
ER
47# - other defaults: src/build/common.gypi
48
e53ecfb5 49# NOTES:
4fe038cb
ER
50# - mute BEEP mixer if you do not want to hear horrible system bell when
51# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
52# - build -bp: 1.2G
53# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 54# - build x86_64: ~1.9G
f1b276d4 55# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 56# - to look for new tarball, use update-source.sh script
f1b276d4 57
e68aa7e7 58# NOTE TO USERS:
c8b02491 59# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 60# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 61# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 62
a3140cd1 63%define gyp_rev 1014
11ad81c4 64Summary: A WebKit powered web browser
05f72ae2 65Name: chromium-browser
9516ca97 66Version: 23.0.1271.64
9fdabe76 67Release: 2
05f72ae2 68License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 69Group: X11/Applications/Networking
9516ca97
ER
70Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
71# Source0-md5: 6c467affd292ee9a9020ac91147969c8
37ceaf05 72Source1: %{name}.default
8b53130d
ER
73Source2: %{name}.sh
74Source3: %{name}.desktop
56c6e811
ER
75Source5: find-lang.sh
76Source6: update-source.sh
77Source7: clean-source.sh
836b1cac 78Source8: get-source.sh
9516ca97 79#Patch0: system-libs.patch
48b341f5 80Patch1: plugin-searchdirs.patch
81Patch2: gyp-system-minizip.patch
7abc645c 82Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 83Patch4: path-libpdf.patch
48b341f5 84Patch5: options-support.patch
0e5636cb 85Patch6: get-webkit_revision.patch
5aa5df39 86Patch7: dlopen_sonamed_gl.patch
4765ddf1 87Patch8: chromium_useragent.patch.in
c0808220 88Patch9: chromium-ppapi.patch
1347c76c
AM
89# https://bugs.gentoo.org/show_bug.cgi?id=393471
90# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 91Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
92Patch15: nacl-build-irt.patch
93Patch16: nacl-linkingfix.patch
e9abb380 94Patch17: system-icu.patch
9516ca97 95Patch18: nacl-no-untar.patch
08b25440 96Patch19: system-jsoncpp.patch
750b48f7 97URL: http://www.chromium.org/Home
ae3fe89f 98%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 99BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
100BuildRequires: alsa-lib-devel
101BuildRequires: atk-devel
102BuildRequires: bison
11ad81c4 103BuildRequires: bzip2-devel
5997e180
ER
104%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
105%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
106%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 107%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 108%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 109BuildRequires: dbus-glib-devel
77f32fa3 110BuildRequires: expat-devel
8f5f6775 111%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 112BuildRequires: flex
11ad81c4 113BuildRequires: fontconfig-devel
f1b276d4 114BuildRequires: glib2-devel
05f72ae2 115BuildRequires: gperf
8b53130d 116BuildRequires: gtk+2-devel
a3140cd1 117%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 118BuildRequires: hicolor-icon-theme
05f72ae2 119BuildRequires: libevent-devel
7f40f3f4 120%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 121BuildRequires: libicu-devel >= 4.6
39c71b4c 122%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 123%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 124BuildRequires: libpng-devel
e266589e 125%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 126BuildRequires: libstdc++-devel
32a2443e 127%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 128%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 129BuildRequires: libxml2-devel
11ad81c4 130BuildRequires: libxslt-devel
f1b276d4 131BuildRequires: lzma
11ad81c4 132BuildRequires: minizip-devel
05f72ae2 133BuildRequires: nspr-devel
f1b276d4 134BuildRequires: nss-devel >= 1:3.12.3
35902862 135BuildRequires: pam-devel
f1b276d4 136BuildRequires: pango-devel
48b341f5 137BuildRequires: perl-modules
138BuildRequires: pkgconfig
ae3fe89f 139%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 140BuildRequires: python
46cdefee 141#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 142BuildRequires: python-modules
0cad051b 143BuildRequires: rpm >= 4.4.9-56
f1b276d4 144BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 145%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
08b25440 146%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
f1b276d4 147BuildRequires: sqlite3-devel >= 3.6.1
89f0dde4 148BuildRequires: subversion
0cad051b 149BuildRequires: tar >= 1:1.22
0a424ee2 150BuildRequires: udev-devel
2303ed45 151BuildRequires: util-linux
c14cd342 152%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 153BuildRequires: which
f1b276d4 154BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
155BuildRequires: xorg-lib-libXt-devel
156BuildRequires: xorg-lib-libXtst-devel
836b1cac 157BuildRequires: xz
a3140cd1 158%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 159%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 160Requires: browser-plugins >= 2.0
0cad051b 161Requires: desktop-file-utils
8f5f6775 162%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 163Requires: hicolor-icon-theme
c1edaafa 164%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 165%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 166Requires: xdg-utils >= 1.0.2-4
e53ecfb5 167Provides: wwwbrowser
c3582150 168Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 169Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 170ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 171BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 172
589d90ea 173%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 174
e7fa0817
ER
175# Usage: gyp_with BCOND_NAME [OPTION_NAME]
176%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 177
6b113615
ER
178%if %{without debuginfo}
179%define _enable_debug_packages 0
180%endif
181
11ad81c4 182%description
80838854
ER
183Chromium is an open-source browser project that aims to build a safer,
184faster, and more stable way for all Internet users to experience the
185web.
186
187Chromium serves as a base for Google Chrome, which is Chromium
188rebranded (name and logo) with very few additions such as usage
189tracking and an auto-updater system.
190
f1b276d4
ER
191%package l10n
192Summary: chromium-browser language packages
193Group: I18n
194Requires: %{name} = %{version}-%{release}
195
196%description l10n
197Chromium is an open-source browser project that aims to build a safer,
198faster, and more stable way for all Internet users to experience the
199web.
200
201This package contains language packages for 50 languages:
202
e7fa0817
ER
203ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
204he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
205pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
206zh-TW
f1b276d4
ER
207
208%prep
836b1cac 209%setup -q
589d90ea 210
05f72ae2
ER
211# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
212# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
213. ./src/chrome/VERSION
214ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
215test "$ver" = %{version}
216
217gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 218test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 219
836b1cac 220v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 221
4765ddf1
ER
222# add chromium and pld to useragent
223%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
224sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
225 -e 's/@BUILD_DIST_NAME@/PLD/g' \
226 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 227 < %{PATCH8} | %{__patch} -p1
4765ddf1 228
56c6e811
ER
229%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
230ln -s %{SOURCE7} src
f1b276d4 231
9516ca97 232#%patch0 -p1
05f72ae2
ER
233%patch1 -p1
234%patch2 -p1
7abc645c 235%patch3 -p1
72cb20c1 236%patch4 -p1
05f72ae2 237%patch5 -p1
0e5636cb 238%patch6 -p1
5aa5df39 239%patch7 -p1
e9abb380 240%patch15 -p1
77f32fa3 241cd src
c0808220 242%patch9 -p0
f4a8da6a 243%{!?with_libjpegturbo:%patch11 -p0}
5997e180 244%patch16 -p1
e9abb380 245%patch17 -p0
08b25440 246%patch19 -p1
1347c76c 247cd ..
9516ca97 248%patch18 -p1
0c480b89 249
828bdd1a 250cd src
e9abb380
ER
251
252# Missing gyp files in tarball.
253# https://code.google.com/p/chromium/issues/detail?id=144823
254if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
255 echo "tarball fixed, please remove workaround"
256 exit 1
257fi
258
259install -d chrome/test/data/nacl
260cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
261{
262 'targets': [
263 {
264 'target_name': 'nacl_tests',
265 'type': 'none',
266 },
267 ],
268}
269EOF
270
4c272135 271sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
164020eb 272
e266589e 273%build
f1b276d4 274cd src
5997e180
ER
275
276%if %{with nacl}
277rm -rf native_client/toolchain/linux_x86_newlib
278# Make symlinks for nacl
279cd native_client/toolchain
280install -d linux_x86_newlib/x86_64-nacl/bin
281install -d linux_x86_newlib/x86_64-nacl/lib
282install -d linux_x86_newlib/x86_64-nacl/lib32
283install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
284install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
285install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
286# link newlib toolchain to glibc as well, see gentoo bug #417019
287#ln -s linux_x86_newlib linux_x86
5997e180
ER
288cd linux_x86_newlib/x86_64-nacl/bin
289ln -s %{_bindir}/x86_64-nacl-gcc gcc
290ln -s %{_bindir}/x86_64-nacl-g++ g++
291ln -s %{_bindir}/x86_64-nacl-ar ar
292ln -s %{_bindir}/x86_64-nacl-as as
293ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
294ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
295ln -s %{_bindir}/x86_64-nacl-strip strip
296ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
297ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
298cd ../nacl/include
299for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
300 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
301done
302cd ../../../../../..
303%endif
304
164020eb 305test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
306%ifarch %{ix86}
307 -Dtarget_arch=ia32 \
308%endif
309%ifarch %{x8664}
0c480b89
ER
310 -Dtarget_arch=x64 \
311%endif
7b454a31
AM
312%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
313 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
314%endif
315%if %{with sandboxing}
316 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
317 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
318%endif
319 %{!?debug:-Dwerror=} \
c980b122 320 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 321 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 322 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
323 -Dffmpeg_branding=Chrome \
324 -Dproprietary_codecs=1 \
c0808220 325%if %{with nacl}
c0808220 326 -Ddisable_glibc=1 \
038f76b9 327 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
328 -Ddisable_glibc_untar=1 \
329 -Ddisable_newlib_untar=1 \
330 -Ddisable_pnacl_untar=1 \
c0808220
ER
331%else
332 -Ddisable_nacl=1 \
333%endif
6c8531c6 334 -Ddisable_pnacl=1 \
a3140cd1
ER
335 %{!?with_sse2:-Ddisable_sse2=1} \
336 %{?with_selinux:-Dselinux=1} \
e7fa0817 337 %{gyp_with cups} \
e7fa0817
ER
338 %{gyp_with gconf} \
339 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
340 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
341 %{gyp_with pulseaudio} \
8f5f6775 342 %{gyp_with system_flac} \
e8e15592 343 %{gyp_with system_libwebp} \
e7fa0817
ER
344 %{gyp_with system_speex} \
345 %{gyp_with system_sqlite} \
346 %{gyp_with system_v8} \
32a2443e 347 %{gyp_with system_vpx} \
e7fa0817
ER
348 %{gyp_with system_yasm} \
349 %{gyp_with system_zlib} \
0c480b89 350 -Duse_system_bzip2=1 \
0b214002 351 -Duse_system_icu=1 \
f1b276d4 352 -Duse_system_libevent=1 \
0c480b89 353 -Duse_system_libjpeg=1 \
f1b276d4
ER
354 -Duse_system_libpng=1 \
355 -Duse_system_libxml=1 \
356 -Duse_system_libxslt=1 \
7f40f3f4 357 -Duse_system_xdg_utils=1 \
d8ba130c 358 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
359 -Dlinux_use_gold_binary=0 \
360 -Dlinux_use_gold_flags=0
11ad81c4 361
f1b276d4
ER
362%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
363 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
364 %{?with_verbose:V=1} \
365 CC="%{__cc}" \
366 CXX="%{__cxx}" \
b7adf6b1 367 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
368 CC.host="%{__cc}" \
369 CXX.host="%{__cxx}" \
b7adf6b1 370 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
371 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
372 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
373
374%install
375rm -rf $RPM_BUILD_ROOT
56c6e811 376install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 377 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 378
f1b276d4 379cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 380cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
381install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
382%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 383cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 384cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 385install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 386install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 387%if %{with ffmpegsumo}
f1b276d4 388install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 389%endif
e7fa0817 390cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb 391
c0808220
ER
392%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
393
164020eb
ER
394%if %{with nacl}
395# Install Native Client files on platforms that support it.
396install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
397install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
398%ifarch %{x8664}
399install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
400%endif
401%ifarch %{ix86}
402install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
403%endif
404%endif
405
0c480b89
ER
406cd -
407
0eb19b0b
ER
408for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
409 size=${icon##*/product_logo_}
410 size=${size%.png}
411
412 # this will skip non-numeric (22_mono_invert, 22_mono)
413 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
414 test -d "$dir" || continue
415
416 install -d $RPM_BUILD_ROOT$dir
417 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
418done
7f40f3f4 419
13840bc2
AM
420%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
421# http://code.google.com/p/chromium/issues/detail?id=24507
422gecko-mediaplayer*.so
423EOF
11ad81c4 424
589d90ea
ER
425# find locales
426%find_lang %{name}.lang
e7fa0817 427# always package en-US
f1b276d4 428%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 429
11ad81c4
AM
430%clean
431rm -rf $RPM_BUILD_ROOT
432
f1b276d4 433%post
0eb19b0b 434%update_icon_cache hicolor
b7a6e4ee 435%update_desktop_database
f1b276d4
ER
436%update_browser_plugins
437
438%postun
439if [ "$1" = 0 ]; then
0eb19b0b 440 %update_icon_cache hicolor
f1b276d4
ER
441 %update_browser_plugins
442fi
443
1d2b9616 444%files
11ad81c4 445%defattr(644,root,root,755)
f1b276d4
ER
446%{_browserpluginsconfdir}/browsers.d/%{name}.*
447%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
448%dir %{_sysconfdir}/%{name}
449%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
450%attr(755,root,root) %{_bindir}/%{name}
451%{_mandir}/man1/%{name}.1*
11ad81c4 452%{_desktopdir}/*.desktop
0eb19b0b 453%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 454%dir %{_libdir}/%{name}
e9abb380 455%{_libdir}/%{name}/chrome*.pak
c14cd342 456%{_libdir}/%{name}/content_resources.pak
97fac491 457%{_libdir}/%{name}/resources.pak
589d90ea 458%dir %{_libdir}/%{name}/locales
f1b276d4
ER
459%{_libdir}/%{name}/locales/en-US.pak
460%dir %{_libdir}/%{name}/resources
a3140cd1 461%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
462%dir %{_libdir}/%{name}/themes
463%dir %{_libdir}/%{name}/extensions
464%dir %{_libdir}/%{name}/plugins
465%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 466# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 467%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
468
469# ffmpeg libs
d561483d 470%if %{with ffmpegsumo}
f1b276d4 471%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 472%endif
f1b276d4 473
164020eb
ER
474%if %{with nacl}
475%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
476%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
477%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
478%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
479%endif
480
f1b276d4
ER
481%files l10n -f %{name}.lang
482%defattr(644,root,root,755)
This page took 0.127003 seconds and 4 git commands to generate.