]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
add -g and --temp-profile to chromium launcher
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
7d0dbc8d 16%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
01b4dc8e 17%bcond_with system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
75a27c2e 26%bcond_with system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
4b411ffe 31%bcond_without system_libvpx # system libvpx
ba685303 32%bcond_without system_yasm # system yasm
1c00315b 33%bcond_without system_zlib # system zlib
d2781a31 34%bcond_without tcmalloc # use tcmalloc
7e136323 35%bcond_without verbose # verbose build (V=1)
0c480b89 36
c6325ea2
ER
37%if %{with nacl}
38# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42#14:51:06 @baggins> as-needed will take care of unneeded lib
43#14:52:03 @baggins> -lssp comes with gcc
107b55fe 44%define _ssp_cflags %{nil}
c6325ea2
ER
45%endif
46
6d92f81c 47# TODO
f1b276d4 48# - check system sqlite linking problems
2108baf2 49# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 50# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 51# - use_system_hunspell
32a2443e 52# - use_system_stlport
a3140cd1
ER
53# - other defaults: src/build/common.gypi
54
e53ecfb5 55# NOTES:
4fe038cb
ER
56# - mute BEEP mixer if you do not want to hear horrible system bell when
57# pressing home/end in url bar or more ^F search results on page.
7c638678 58# - space considerations:
6d877f0c 59# - unpacked sources: ~574MiB
c1ecd31f 60# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 61# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 62# - to look for new tarball, use update-source.sh script
f1b276d4 63
e68aa7e7 64# NOTE TO USERS:
c8b02491 65# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 66# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 67# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 68
2a415062
ER
69%define branch 24.0.1312
70%define basever 52
0320ccad 71%define patchver 69
a3140cd1 72%define gyp_rev 1014
11ad81c4 73Summary: A WebKit powered web browser
05f72ae2 74Name: chromium-browser
f73369da
ER
75%if "%{?patchver}" != ""
76Version: %{branch}.%{patchver}
77%else
78Version: %{branch}.%{basever}
79%endif
80Release: 1
05f72ae2 81License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 82Group: X11/Applications/Networking
3c73e180 83Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
24623500 84# Source0-md5: bcc3976e61b9ce715ba9c85d46df72f1
3c73e180
ER
85%if "%{?patchver}" != ""
86Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
0320ccad 87# Patch0-md5: 130262d245d6833200cef43e61b641c2
3c73e180 88%endif
37ceaf05 89Source1: %{name}.default
8b53130d
ER
90Source2: %{name}.sh
91Source3: %{name}.desktop
56c6e811
ER
92Source5: find-lang.sh
93Source6: update-source.sh
94Source7: clean-source.sh
836b1cac 95Source8: get-source.sh
0562b864 96Source9: master_preferences.json
48b341f5 97Patch1: plugin-searchdirs.patch
70258ccd 98#Patch2: system-nspr.patch
7abc645c 99Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 100Patch4: path-libpdf.patch
0e5636cb 101Patch6: get-webkit_revision.patch
5aa5df39 102Patch7: dlopen_sonamed_gl.patch
4765ddf1 103Patch8: chromium_useragent.patch.in
c0808220 104Patch9: chromium-ppapi.patch
8456d676 105Patch10: system-libxnvctrl.patch
1347c76c
AM
106# https://bugs.gentoo.org/show_bug.cgi?id=393471
107# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 108Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
109Patch15: nacl-build-irt.patch
110Patch16: nacl-linkingfix.patch
9516ca97 111Patch18: nacl-no-untar.patch
08b25440 112Patch19: system-jsoncpp.patch
126ea630 113Patch22: pulse_fix-157876.patch
8fb1dc98 114Patch23: no-pnacl.patch
6897926c 115Patch24: nacl-verbose.patch
c5b396f3
ER
116Patch25: gnome3-volume-control.patch
117Patch26: master-prefs-path.patch
d2781a31 118Patch27: tcmalloc-glibc2.16.patch
750b48f7 119URL: http://www.chromium.org/Home
ae3fe89f 120%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 121BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
122BuildRequires: alsa-lib-devel
123BuildRequires: atk-devel
124BuildRequires: bison
11ad81c4 125BuildRequires: bzip2-devel
5997e180
ER
126%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
127%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
128%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 129%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 130%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 131BuildRequires: dbus-glib-devel
92965b0e 132BuildRequires: elfutils-devel
77f32fa3 133BuildRequires: expat-devel
7d0dbc8d 134%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 135%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 136BuildRequires: flex
11ad81c4 137BuildRequires: fontconfig-devel
f1b276d4 138BuildRequires: glib2-devel
05f72ae2 139BuildRequires: gperf
bbad64b7 140BuildRequires: gtest-devel
8b53130d 141BuildRequires: gtk+2-devel
01b4dc8e 142%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 143%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 144BuildRequires: hicolor-icon-theme
ed514974 145%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
8456d676 146%{?with_system_libxvnctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 147BuildRequires: libevent-devel
8456d676 148%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 149%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 150BuildRequires: libicu-devel >= 4.6
39c71b4c 151%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 152%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 153%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 154BuildRequires: libpng-devel
e266589e 155%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 156BuildRequires: libstdc++-devel
ba685303 157%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 158%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 159%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 160BuildRequires: libxml2-devel
11ad81c4 161BuildRequires: libxslt-devel
f1b276d4 162BuildRequires: lzma
62950103 163%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 164BuildRequires: nspr-devel
f1b276d4 165BuildRequires: nss-devel >= 1:3.12.3
8456d676 166%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 167BuildRequires: pam-devel
f1b276d4 168BuildRequires: pango-devel
48b341f5 169BuildRequires: perl-modules
170BuildRequires: pkgconfig
75a27c2e 171%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 172%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 173BuildRequires: python
46cdefee 174#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 175BuildRequires: python-modules
92965b0e 176BuildRequires: python-ply
0cad051b 177BuildRequires: rpm >= 4.4.9-56
f1b276d4 178BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 179%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 180BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 181%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 182BuildRequires: subversion
0cad051b 183BuildRequires: tar >= 1:1.22
0a424ee2 184BuildRequires: udev-devel
2303ed45 185BuildRequires: util-linux
c14cd342 186%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 187BuildRequires: which
f1b276d4 188BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
189BuildRequires: xorg-lib-libXt-devel
190BuildRequires: xorg-lib-libXtst-devel
836b1cac 191BuildRequires: xz
a3140cd1 192%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 193%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 194Requires: browser-plugins >= 2.0
0cad051b 195Requires: desktop-file-utils
8f5f6775 196%{?with_system_flac:Requires: flac >= 1.2.1-7}
6f5daa23
ER
197# requires any TTF font actually
198Requires: fonts-TTF-bitstream-vera
0eb19b0b 199Requires: hicolor-icon-theme
c1edaafa 200%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 201%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 202Requires: lsb-release
4dc49133 203Requires: xdg-utils >= 1.0.2-4
e53ecfb5 204Provides: wwwbrowser
c3582150 205Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 206Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 207ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 208BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 209
589d90ea 210%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 211
e7fa0817
ER
212# Usage: gyp_with BCOND_NAME [OPTION_NAME]
213%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 214
6b113615
ER
215%if %{without debuginfo}
216%define _enable_debug_packages 0
217%endif
218
11ad81c4 219%description
80838854
ER
220Chromium is an open-source browser project that aims to build a safer,
221faster, and more stable way for all Internet users to experience the
222web.
223
224Chromium serves as a base for Google Chrome, which is Chromium
225rebranded (name and logo) with very few additions such as usage
226tracking and an auto-updater system.
227
f1b276d4
ER
228%package l10n
229Summary: chromium-browser language packages
230Group: I18n
231Requires: %{name} = %{version}-%{release}
232
233%description l10n
234Chromium is an open-source browser project that aims to build a safer,
235faster, and more stable way for all Internet users to experience the
236web.
237
238This package contains language packages for 50 languages:
239
e7fa0817
ER
240ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
241he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
242pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
243zh-TW
f1b276d4
ER
244
245%prep
3c73e180
ER
246%setup -qc
247%if "%{?patchver}" != ""
248cd %{name}-%{branch}.%{basever}
249%patch0 -p1
250cd ..
251%endif
252mv %{name}-%{branch}.%{basever}/src .
589d90ea 253
05f72ae2
ER
254# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
255# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
256. ./src/chrome/VERSION
257ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
258test "$ver" = %{version}
259
260gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 261test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 262
836b1cac 263v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 264
4765ddf1
ER
265# add chromium and pld to useragent
266%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
267sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
268 -e 's/@BUILD_DIST_NAME@/PLD/g' \
269 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 270 < %{PATCH8} | %{__patch} -p1
4765ddf1 271
56c6e811
ER
272%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
273ln -s %{SOURCE7} src
f1b276d4 274
05f72ae2 275%patch1 -p1
7abc645c 276%patch3 -p1
72cb20c1 277%patch4 -p1
0e5636cb 278%patch6 -p1
5aa5df39 279%patch7 -p1
e9abb380 280%patch15 -p1
77f32fa3 281cd src
c0808220 282%patch9 -p0
70258ccd 283#%patch2 -p1
f4a8da6a 284%{!?with_libjpegturbo:%patch11 -p0}
5997e180 285%patch16 -p1
08b25440 286%patch19 -p1
2d6e464b 287%patch22 -p1
c5b396f3 288%patch25 -p1
d2781a31 289%patch27 -p1
1347c76c 290cd ..
9516ca97 291%patch18 -p1
0562b864 292%patch23 -p1
6897926c 293%patch24 -p1
c5b396f3 294%patch26 -p1
0c480b89 295
828bdd1a 296cd src
e9abb380
ER
297
298# Missing gyp files in tarball.
299# https://code.google.com/p/chromium/issues/detail?id=144823
300if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
301 echo "tarball fixed, please remove workaround"
302 exit 1
303fi
304
305install -d chrome/test/data/nacl
306cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
307{
308 'targets': [
309 {
310 'target_name': 'nacl_tests',
311 'type': 'none',
312 },
313 ],
314}
315EOF
316
75a27c2e
ER
317sh -x clean-source.sh \
318 %{!?with_nacl:nacl=0} \
319 %{!?with_system_protobuf:protobuf=0} \
320 %{!?with_system_v8:v8=0} \
321 %{!?with_system_zlib:zlib=0} \
322 %{nil}
fded59be 323
e266589e 324%build
f1b276d4 325cd src
5997e180
ER
326
327%if %{with nacl}
fded59be 328if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b
ER
329# Make symlinks for NaCL
330install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
2e4113fd 331
dcea0d6b 332cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
2e4113fd 333__cc='%{__cc}'
f64e73f6 334if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
335 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
336 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
337 %{__sed} -i -e '1i#!/bin/sh' gcc g++
338 chmod +x gcc g++
339else
340 ln -s %{_bindir}/x86_64-nacl-gcc gcc
341 ln -s %{_bindir}/x86_64-nacl-g++ g++
342fi
5997e180
ER
343ln -s %{_bindir}/x86_64-nacl-ar ar
344ln -s %{_bindir}/x86_64-nacl-as as
345ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
346ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
347ln -s %{_bindir}/x86_64-nacl-strip strip
dcea0d6b
ER
348ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
349ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
350ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
351cd ../../../../..
fded59be 352fi
5997e180
ER
353%endif
354
c5b396f3 355test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
356test -e Makefile || %{__python} build/gyp_chromium \
357 --format=make \
358 -Goutput_dir=../out \
359 build/all.gyp \
f1b276d4
ER
360%ifarch %{ix86}
361 -Dtarget_arch=ia32 \
362%endif
363%ifarch %{x8664}
0c480b89
ER
364 -Dtarget_arch=x64 \
365%endif
7b454a31
AM
366%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
367 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
368%endif
369%if %{with sandboxing}
370 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
371 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
372%endif
373 %{!?debug:-Dwerror=} \
c980b122 374 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 375 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 376 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 377 -Dinclude_tests=0 \
c0808220 378%if %{with nacl}
038f76b9 379 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
380 -Ddisable_glibc_untar=1 \
381 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
382 -Ddisable_glibc=1 \
383 -Ddisable_pnacl=1 \
384 -Dbuild_pnacl_newlib=0 \
c0808220 385%else
8fb1dc98 386 -Ddisable_pnacl_untar=1 \
c0808220
ER
387 -Ddisable_nacl=1 \
388%endif
a3140cd1
ER
389 %{!?with_sse2:-Ddisable_sse2=1} \
390 %{?with_selinux:-Dselinux=1} \
e7fa0817 391 %{gyp_with cups} \
8dda6bbc 392 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
393 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
394 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
395 %{gyp_with pulseaudio} \
7d0dbc8d 396 %{gyp_with system_ffmpeg} \
8f5f6775 397 %{gyp_with system_flac} \
01b4dc8e 398 %{gyp_with system_harfbuzz} \
62950103
ER
399 %{gyp_with system_libexif} \
400 %{gyp_with system_libmtp} \
9bd2659c 401 %{gyp_with system_libsrtp} \
581aec44 402 %{gyp_with system_libusb} \
4b411ffe 403 %{gyp_with system_libvpx} \
ba685303 404 %{gyp_with system_libwebp} \
4884fc99 405 %{gyp_with system_libxnvctrl} \
126ea630 406 %{gyp_with system_minizip} \
62950103 407 %{gyp_with system_opus} \
75a27c2e 408 %{gyp_with system_protobuf} \
e7fa0817
ER
409 %{gyp_with system_speex} \
410 %{gyp_with system_sqlite} \
411 %{gyp_with system_v8} \
412 %{gyp_with system_yasm} \
413 %{gyp_with system_zlib} \
0c480b89 414 -Duse_system_bzip2=1 \
62950103 415 -Duse_system_expat=1 \
0b214002 416 -Duse_system_icu=1 \
f1b276d4 417 -Duse_system_libevent=1 \
0c480b89 418 -Duse_system_libjpeg=1 \
f1b276d4
ER
419 -Duse_system_libpng=1 \
420 -Duse_system_libxml=1 \
421 -Duse_system_libxslt=1 \
7f40f3f4 422 -Duse_system_xdg_utils=1 \
d8ba130c 423 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
424 -Dlinux_use_gold_binary=0 \
425 -Dlinux_use_gold_flags=0
11ad81c4 426
48ffbc5e 427%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
428 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
429 %{?with_verbose:V=1} \
430 CC="%{__cc}" \
431 CXX="%{__cxx}" \
b7adf6b1 432 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
433 CC.host="%{__cc}" \
434 CXX.host="%{__cxx}" \
b7adf6b1 435 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
436 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
437 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
438
439%install
440rm -rf $RPM_BUILD_ROOT
56c6e811 441install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 442 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 443
673aee14 444cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 445cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
446install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
447%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 448cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 449cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 450install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 451install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 452%if %{without system_ffmpeg}
f1b276d4 453install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 454%endif
e7fa0817 455cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 456cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 457
c0808220
ER
458%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
459
164020eb
ER
460%if %{with nacl}
461# Install Native Client files on platforms that support it.
462install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
463install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
464%ifarch %{x8664}
465install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
466%endif
467%ifarch %{ix86}
468install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
469%endif
470%endif
471
0c480b89
ER
472cd -
473
0eb19b0b
ER
474for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
475 size=${icon##*/product_logo_}
476 size=${size%.png}
477
478 # this will skip non-numeric (22_mono_invert, 22_mono)
479 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
480 test -d "$dir" || continue
481
482 install -d $RPM_BUILD_ROOT$dir
483 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
484done
7f40f3f4 485
13840bc2
AM
486%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
487# http://code.google.com/p/chromium/issues/detail?id=24507
488gecko-mediaplayer*.so
489EOF
11ad81c4 490
589d90ea
ER
491# find locales
492%find_lang %{name}.lang
e7fa0817 493# always package en-US
f1b276d4 494%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 495
11ad81c4
AM
496%clean
497rm -rf $RPM_BUILD_ROOT
498
f1b276d4 499%post
0eb19b0b 500%update_icon_cache hicolor
b7a6e4ee 501%update_desktop_database
f1b276d4
ER
502%update_browser_plugins
503
504%postun
505if [ "$1" = 0 ]; then
0eb19b0b 506 %update_icon_cache hicolor
f1b276d4
ER
507 %update_browser_plugins
508fi
509
1d2b9616 510%files
11ad81c4 511%defattr(644,root,root,755)
531537e5 512%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
513%{_browserpluginsconfdir}/browsers.d/%{name}.*
514%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
515%dir %{_sysconfdir}/%{name}
516%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 517%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
518%attr(755,root,root) %{_bindir}/%{name}
519%{_mandir}/man1/%{name}.1*
11ad81c4 520%{_desktopdir}/*.desktop
0eb19b0b 521%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 522%dir %{_libdir}/%{name}
e9abb380 523%{_libdir}/%{name}/chrome*.pak
c14cd342 524%{_libdir}/%{name}/content_resources.pak
97fac491 525%{_libdir}/%{name}/resources.pak
589d90ea 526%dir %{_libdir}/%{name}/locales
f1b276d4
ER
527%{_libdir}/%{name}/locales/en-US.pak
528%dir %{_libdir}/%{name}/resources
a3140cd1 529%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
530%dir %{_libdir}/%{name}/themes
531%dir %{_libdir}/%{name}/extensions
532%dir %{_libdir}/%{name}/plugins
533%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 534# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 535%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
536
537# ffmpeg libs
fcc48c19 538%if %{without system_ffmpeg}
f1b276d4 539%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 540%endif
f1b276d4 541
164020eb
ER
542%if %{with nacl}
543%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
544%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
545%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
546%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
547%endif
548
f1b276d4
ER
549%files l10n -f %{name}.lang
550%defattr(644,root,root,755)
This page took 0.145644 seconds and 4 git commands to generate.