]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- up to 23.0.1271.95
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2
ER
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without ffmpegsumo # build with ffmpegsumo
ba685303 6%bcond_without gconf # with GConf
8171fe68 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303
ER
16%bcond_without system_flac # system flac
17%bcond_without system_jsoncpp # system jsoncpp
18%bcond_without system_libusb # system libusb-1
19%bcond_without system_libwebp # system libwebp
20%bcond_without system_speex # system speex
21%bcond_with system_sqlite # system sqlite
3ee15dec 22%bcond_without system_srtp # system srtp (can be used if using bundled libjingle)
ba685303
ER
23%bcond_with system_v8 # system v8
24%bcond_without system_vpx # system vpx
25%bcond_without system_yasm # system yasm
4c272135
ER
26# system zlib disabled because of mixed-source.patch
27# https://code.google.com/p/chromium/issues/detail?id=143623
ba685303
ER
28%bcond_with system_zlib # system zlib
29%bcond_with tcmalloc # use tcmalloc
7e136323 30%bcond_without verbose # verbose build (V=1)
0c480b89 31
c6325ea2
ER
32%if %{with nacl}
33# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
34# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
35#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
36#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
37#14:51:06 @baggins> as-needed will take care of unneeded lib
38#14:52:03 @baggins> -lssp comes with gcc
107b55fe 39%define _ssp_cflags %{nil}
c6325ea2
ER
40%endif
41
6d92f81c 42# TODO
f1b276d4 43# - check system sqlite linking problems
2108baf2 44# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 45# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 46# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 47# - use_system_hunspell
32a2443e 48# - use_system_stlport
a3140cd1
ER
49# - other defaults: src/build/common.gypi
50
e53ecfb5 51# NOTES:
4fe038cb
ER
52# - mute BEEP mixer if you do not want to hear horrible system bell when
53# pressing home/end in url bar or more ^F search results on page.
7c638678
ER
54# - space considerations:
55# - unpacked sources: ~800MiB
56# - built code: ~1.4GiB (x86_64)
f1b276d4 57# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 58# - to look for new tarball, use update-source.sh script
f1b276d4 59
e68aa7e7 60# NOTE TO USERS:
c8b02491 61# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 62# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 63# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 64
3c73e180
ER
65%define branch 23.0.1271
66%define basever 64
7c638678 67%define patchver 95
a3140cd1 68%define gyp_rev 1014
11ad81c4 69Summary: A WebKit powered web browser
05f72ae2 70Name: chromium-browser
3c73e180
ER
71Version: %{branch}.%{patchver}
72Release: 1
05f72ae2 73License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 74Group: X11/Applications/Networking
3c73e180 75Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
9516ca97 76# Source0-md5: 6c467affd292ee9a9020ac91147969c8
3c73e180
ER
77%if "%{?patchver}" != ""
78Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
7c638678 79# Patch0-md5: e5888c698c310a87bf395f089332955f
3c73e180 80%endif
37ceaf05 81Source1: %{name}.default
8b53130d
ER
82Source2: %{name}.sh
83Source3: %{name}.desktop
56c6e811
ER
84Source5: find-lang.sh
85Source6: update-source.sh
86Source7: clean-source.sh
836b1cac 87Source8: get-source.sh
3c73e180 88#Patch10: system-libs.patch
48b341f5 89Patch1: plugin-searchdirs.patch
90Patch2: gyp-system-minizip.patch
7abc645c 91Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 92Patch4: path-libpdf.patch
48b341f5 93Patch5: options-support.patch
0e5636cb 94Patch6: get-webkit_revision.patch
5aa5df39 95Patch7: dlopen_sonamed_gl.patch
4765ddf1 96Patch8: chromium_useragent.patch.in
c0808220 97Patch9: chromium-ppapi.patch
1347c76c
AM
98# https://bugs.gentoo.org/show_bug.cgi?id=393471
99# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 100Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
101Patch15: nacl-build-irt.patch
102Patch16: nacl-linkingfix.patch
e9abb380 103Patch17: system-icu.patch
9516ca97 104Patch18: nacl-no-untar.patch
08b25440 105Patch19: system-jsoncpp.patch
ed514974 106Patch20: system-speex.patch
3ee15dec 107Patch21: system-srtp.patch
2d6e464b 108Patch22: gnome3-volume-control.patch
750b48f7 109URL: http://www.chromium.org/Home
ae3fe89f 110%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 111BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
112BuildRequires: alsa-lib-devel
113BuildRequires: atk-devel
114BuildRequires: bison
11ad81c4 115BuildRequires: bzip2-devel
5997e180
ER
116%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
117%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
118%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 119%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 120%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 121BuildRequires: dbus-glib-devel
77f32fa3 122BuildRequires: expat-devel
8f5f6775 123%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 124BuildRequires: flex
11ad81c4 125BuildRequires: fontconfig-devel
f1b276d4 126BuildRequires: glib2-devel
05f72ae2 127BuildRequires: gperf
8b53130d 128BuildRequires: gtk+2-devel
a3140cd1 129%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 130BuildRequires: hicolor-icon-theme
ed514974 131%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
05f72ae2 132BuildRequires: libevent-devel
7f40f3f4 133%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 134BuildRequires: libicu-devel >= 4.6
39c71b4c 135%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 136%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 137BuildRequires: libpng-devel
e266589e 138%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 139BuildRequires: libstdc++-devel
ba685303 140%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
32a2443e 141%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 142%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 143BuildRequires: libxml2-devel
11ad81c4 144BuildRequires: libxslt-devel
f1b276d4 145BuildRequires: lzma
11ad81c4 146BuildRequires: minizip-devel
05f72ae2 147BuildRequires: nspr-devel
f1b276d4 148BuildRequires: nss-devel >= 1:3.12.3
35902862 149BuildRequires: pam-devel
f1b276d4 150BuildRequires: pango-devel
48b341f5 151BuildRequires: perl-modules
152BuildRequires: pkgconfig
ae3fe89f 153%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 154BuildRequires: python
46cdefee 155#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 156BuildRequires: python-modules
0cad051b 157BuildRequires: rpm >= 4.4.9-56
f1b276d4 158BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 159%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 160BuildRequires: sqlite3-devel >= 3.6.1
3ee15dec 161%{?with_system_srtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 162BuildRequires: subversion
0cad051b 163BuildRequires: tar >= 1:1.22
0a424ee2 164BuildRequires: udev-devel
2303ed45 165BuildRequires: util-linux
c14cd342 166%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 167BuildRequires: which
f1b276d4 168BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
169BuildRequires: xorg-lib-libXt-devel
170BuildRequires: xorg-lib-libXtst-devel
836b1cac 171BuildRequires: xz
a3140cd1 172%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 173%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 174Requires: browser-plugins >= 2.0
0cad051b 175Requires: desktop-file-utils
8f5f6775 176%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 177Requires: hicolor-icon-theme
c1edaafa 178%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 179%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 180Requires: xdg-utils >= 1.0.2-4
e53ecfb5 181Provides: wwwbrowser
c3582150 182Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 183Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 184ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 185BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 186
589d90ea 187%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 188
e7fa0817
ER
189# Usage: gyp_with BCOND_NAME [OPTION_NAME]
190%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 191
6b113615
ER
192%if %{without debuginfo}
193%define _enable_debug_packages 0
194%endif
195
11ad81c4 196%description
80838854
ER
197Chromium is an open-source browser project that aims to build a safer,
198faster, and more stable way for all Internet users to experience the
199web.
200
201Chromium serves as a base for Google Chrome, which is Chromium
202rebranded (name and logo) with very few additions such as usage
203tracking and an auto-updater system.
204
f1b276d4
ER
205%package l10n
206Summary: chromium-browser language packages
207Group: I18n
208Requires: %{name} = %{version}-%{release}
209
210%description l10n
211Chromium is an open-source browser project that aims to build a safer,
212faster, and more stable way for all Internet users to experience the
213web.
214
215This package contains language packages for 50 languages:
216
e7fa0817
ER
217ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
218he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
219pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
220zh-TW
f1b276d4
ER
221
222%prep
3c73e180
ER
223%setup -qc
224%if "%{?patchver}" != ""
225cd %{name}-%{branch}.%{basever}
226%patch0 -p1
227cd ..
228%endif
229mv %{name}-%{branch}.%{basever}/src .
589d90ea 230
05f72ae2
ER
231# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
232# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
233. ./src/chrome/VERSION
234ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
235test "$ver" = %{version}
236
237gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 238test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 239
836b1cac 240v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 241
4765ddf1
ER
242# add chromium and pld to useragent
243%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
244sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
245 -e 's/@BUILD_DIST_NAME@/PLD/g' \
246 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 247 < %{PATCH8} | %{__patch} -p1
4765ddf1 248
56c6e811
ER
249%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
250ln -s %{SOURCE7} src
f1b276d4 251
3c73e180 252#%patch10 -p1
05f72ae2
ER
253%patch1 -p1
254%patch2 -p1
7abc645c 255%patch3 -p1
72cb20c1 256%patch4 -p1
05f72ae2 257%patch5 -p1
0e5636cb 258%patch6 -p1
5aa5df39 259%patch7 -p1
e9abb380 260%patch15 -p1
77f32fa3 261cd src
c0808220 262%patch9 -p0
f4a8da6a 263%{!?with_libjpegturbo:%patch11 -p0}
5997e180 264%patch16 -p1
e9abb380 265%patch17 -p0
08b25440 266%patch19 -p1
3ee15dec 267%patch21 -p1
2d6e464b 268%patch22 -p1
1347c76c 269cd ..
9516ca97 270%patch18 -p1
ed514974 271%patch20 -p1
0c480b89 272
828bdd1a 273cd src
e9abb380
ER
274
275# Missing gyp files in tarball.
276# https://code.google.com/p/chromium/issues/detail?id=144823
277if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
278 echo "tarball fixed, please remove workaround"
279 exit 1
280fi
281
282install -d chrome/test/data/nacl
283cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
284{
285 'targets': [
286 {
287 'target_name': 'nacl_tests',
288 'type': 'none',
289 },
290 ],
291}
292EOF
293
4c272135 294sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
164020eb 295
e266589e 296%build
f1b276d4 297cd src
5997e180
ER
298
299%if %{with nacl}
300rm -rf native_client/toolchain/linux_x86_newlib
301# Make symlinks for nacl
302cd native_client/toolchain
303install -d linux_x86_newlib/x86_64-nacl/bin
304install -d linux_x86_newlib/x86_64-nacl/lib
305install -d linux_x86_newlib/x86_64-nacl/lib32
306install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
307install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
308install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
309# link newlib toolchain to glibc as well, see gentoo bug #417019
310#ln -s linux_x86_newlib linux_x86
5997e180
ER
311cd linux_x86_newlib/x86_64-nacl/bin
312ln -s %{_bindir}/x86_64-nacl-gcc gcc
313ln -s %{_bindir}/x86_64-nacl-g++ g++
314ln -s %{_bindir}/x86_64-nacl-ar ar
315ln -s %{_bindir}/x86_64-nacl-as as
316ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
317ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
318ln -s %{_bindir}/x86_64-nacl-strip strip
319ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
320ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
321cd ../nacl/include
322for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
323 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
324done
325cd ../../../../../..
326%endif
327
164020eb 328test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
329%ifarch %{ix86}
330 -Dtarget_arch=ia32 \
331%endif
332%ifarch %{x8664}
0c480b89
ER
333 -Dtarget_arch=x64 \
334%endif
7b454a31
AM
335%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
336 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
337%endif
338%if %{with sandboxing}
339 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
340 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
341%endif
342 %{!?debug:-Dwerror=} \
c980b122 343 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 344 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 345 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
346 -Dffmpeg_branding=Chrome \
347 -Dproprietary_codecs=1 \
c0808220 348%if %{with nacl}
c0808220 349 -Ddisable_glibc=1 \
038f76b9 350 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
351 -Ddisable_glibc_untar=1 \
352 -Ddisable_newlib_untar=1 \
353 -Ddisable_pnacl_untar=1 \
c0808220
ER
354%else
355 -Ddisable_nacl=1 \
356%endif
6c8531c6 357 -Ddisable_pnacl=1 \
a3140cd1
ER
358 %{!?with_sse2:-Ddisable_sse2=1} \
359 %{?with_selinux:-Dselinux=1} \
e7fa0817 360 %{gyp_with cups} \
e7fa0817
ER
361 %{gyp_with gconf} \
362 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
363 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
364 %{gyp_with pulseaudio} \
8f5f6775 365 %{gyp_with system_flac} \
581aec44 366 %{gyp_with system_libusb} \
ba685303 367 %{gyp_with system_libwebp} \
e7fa0817
ER
368 %{gyp_with system_speex} \
369 %{gyp_with system_sqlite} \
370 %{gyp_with system_v8} \
32a2443e 371 %{gyp_with system_vpx} \
e7fa0817
ER
372 %{gyp_with system_yasm} \
373 %{gyp_with system_zlib} \
0c480b89 374 -Duse_system_bzip2=1 \
0b214002 375 -Duse_system_icu=1 \
f1b276d4 376 -Duse_system_libevent=1 \
0c480b89 377 -Duse_system_libjpeg=1 \
f1b276d4
ER
378 -Duse_system_libpng=1 \
379 -Duse_system_libxml=1 \
380 -Duse_system_libxslt=1 \
7f40f3f4 381 -Duse_system_xdg_utils=1 \
d8ba130c 382 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
383 -Dlinux_use_gold_binary=0 \
384 -Dlinux_use_gold_flags=0
11ad81c4 385
f1b276d4
ER
386%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
387 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
388 %{?with_verbose:V=1} \
389 CC="%{__cc}" \
390 CXX="%{__cxx}" \
b7adf6b1 391 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
392 CC.host="%{__cc}" \
393 CXX.host="%{__cxx}" \
b7adf6b1 394 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
395 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
396 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
397
398%install
399rm -rf $RPM_BUILD_ROOT
56c6e811 400install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 401 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 402
f1b276d4 403cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 404cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
405install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
406%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 407cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 408cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 409install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 410install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 411%if %{with ffmpegsumo}
f1b276d4 412install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 413%endif
e7fa0817 414cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb 415
c0808220
ER
416%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
417
164020eb
ER
418%if %{with nacl}
419# Install Native Client files on platforms that support it.
420install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
421install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
422%ifarch %{x8664}
423install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
424%endif
425%ifarch %{ix86}
426install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
427%endif
428%endif
429
0c480b89
ER
430cd -
431
0eb19b0b
ER
432for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
433 size=${icon##*/product_logo_}
434 size=${size%.png}
435
436 # this will skip non-numeric (22_mono_invert, 22_mono)
437 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
438 test -d "$dir" || continue
439
440 install -d $RPM_BUILD_ROOT$dir
441 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
442done
7f40f3f4 443
13840bc2
AM
444%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
445# http://code.google.com/p/chromium/issues/detail?id=24507
446gecko-mediaplayer*.so
447EOF
11ad81c4 448
589d90ea
ER
449# find locales
450%find_lang %{name}.lang
e7fa0817 451# always package en-US
f1b276d4 452%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 453
11ad81c4
AM
454%clean
455rm -rf $RPM_BUILD_ROOT
456
f1b276d4 457%post
0eb19b0b 458%update_icon_cache hicolor
b7a6e4ee 459%update_desktop_database
f1b276d4
ER
460%update_browser_plugins
461
462%postun
463if [ "$1" = 0 ]; then
0eb19b0b 464 %update_icon_cache hicolor
f1b276d4
ER
465 %update_browser_plugins
466fi
467
1d2b9616 468%files
11ad81c4 469%defattr(644,root,root,755)
f1b276d4
ER
470%{_browserpluginsconfdir}/browsers.d/%{name}.*
471%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
472%dir %{_sysconfdir}/%{name}
473%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
474%attr(755,root,root) %{_bindir}/%{name}
475%{_mandir}/man1/%{name}.1*
11ad81c4 476%{_desktopdir}/*.desktop
0eb19b0b 477%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 478%dir %{_libdir}/%{name}
e9abb380 479%{_libdir}/%{name}/chrome*.pak
c14cd342 480%{_libdir}/%{name}/content_resources.pak
97fac491 481%{_libdir}/%{name}/resources.pak
589d90ea 482%dir %{_libdir}/%{name}/locales
f1b276d4
ER
483%{_libdir}/%{name}/locales/en-US.pak
484%dir %{_libdir}/%{name}/resources
a3140cd1 485%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
486%dir %{_libdir}/%{name}/themes
487%dir %{_libdir}/%{name}/extensions
488%dir %{_libdir}/%{name}/plugins
489%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 490# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 491%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
492
493# ffmpeg libs
d561483d 494%if %{with ffmpegsumo}
f1b276d4 495%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 496%endif
f1b276d4 497
164020eb
ER
498%if %{with nacl}
499%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
500%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
501%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
502%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
503%endif
504
f1b276d4
ER
505%files l10n -f %{name}.lang
506%defattr(644,root,root,755)
This page took 0.15295 seconds and 4 git commands to generate.