]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 28.0.1500.95
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
ba685303
ER
22%bcond_without system_libusb # system libusb-1
23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
25d4e23c 25%bcond_without system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
543e99ac 29%bcond_without system_re2 # system re2
7e634b46 30%bcond_without system_snappy # system snappy
ba685303 31%bcond_without system_speex # system speex
a8f4f3ac 32%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 33%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 34%bcond_with system_v8 # system v8
4b411ffe 35%bcond_without system_libvpx # system libvpx
ba685303 36%bcond_without system_yasm # system yasm
1c00315b 37%bcond_without system_zlib # system zlib
d2781a31 38%bcond_without tcmalloc # use tcmalloc
7e136323 39%bcond_without verbose # verbose build (V=1)
0c480b89 40
b3fc6cb2
ER
41%ifarch %{ix86}
42# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43%undefine with_system_mesa
44%endif
45
6d92f81c 46# TODO
b363f856 47# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 48# - use_system_skia
a3140cd1 49# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 50# - use_system_stlport (android specific)
7b8f219a 51# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 52
e53ecfb5 53# NOTES:
4fe038cb
ER
54# - mute BEEP mixer if you do not want to hear horrible system bell when
55# pressing home/end in url bar or more ^F search results on page.
7c638678 56# - space considerations:
0bb93ab2 57# - unpacked sources: ~490MiB
c1ecd31f 58# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 59# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 60# - to look for new tarball, use update-source.sh script
f1b276d4 61
7879021e 62%define branch 28.0.1500
d26b6bbe 63%define basever 45
63333d27 64%define patchver 95
a3140cd1 65%define gyp_rev 1014
11ad81c4 66Summary: A WebKit powered web browser
05f72ae2 67Name: chromium-browser
f73369da
ER
68%if "%{?patchver}" != ""
69Version: %{branch}.%{patchver}
70%else
71Version: %{branch}.%{basever}
72%endif
8174fe8c 73Release: 1
5bb99ef4 74License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 75Group: X11/Applications/Networking
3c73e180 76Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
0b40b042 77# Source0-md5: 040b9e7d8ae75d20d63621aca84962bf
3c73e180
ER
78%if "%{?patchver}" != ""
79Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
63333d27 80# Patch0-md5: 120491e7e2df40182793081b7ea7e41a
3c73e180 81%endif
37ceaf05 82Source1: %{name}.default
8b53130d
ER
83Source2: %{name}.sh
84Source3: %{name}.desktop
56c6e811
ER
85Source5: find-lang.sh
86Source6: update-source.sh
87Source7: clean-source.sh
836b1cac 88Source8: get-source.sh
0562b864 89Source9: master_preferences.json
48b341f5 90Patch1: plugin-searchdirs.patch
7abc645c 91Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 92Patch4: path-libpdf.patch
0e5636cb 93Patch6: get-webkit_revision.patch
5aa5df39 94Patch7: dlopen_sonamed_gl.patch
4765ddf1 95Patch8: chromium_useragent.patch.in
8456d676 96Patch10: system-libxnvctrl.patch
1347c76c
AM
97# https://bugs.gentoo.org/show_bug.cgi?id=393471
98# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 99Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 100Patch12: system-ffmpeg.patch
5997e180
ER
101Patch15: nacl-build-irt.patch
102Patch16: nacl-linkingfix.patch
9516ca97 103Patch18: nacl-no-untar.patch
6897926c 104Patch24: nacl-verbose.patch
c5b396f3
ER
105Patch25: gnome3-volume-control.patch
106Patch26: master-prefs-path.patch
25d4e23c 107Patch28: system-mesa.patch
06e6d11b 108Patch31: sync-session-name.patch
7ebeabb6 109Patch32: nss.patch
7a1e74db 110Patch33: harfbuzz-icu.patch
750b48f7 111URL: http://www.chromium.org/Home
ae3fe89f 112%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3
ER
113%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
114%{?with_system_mesa:BuildRequires: Mesa-libGLES-devel >= 9.1}
7b8f219a 115%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 116%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
117BuildRequires: alsa-lib-devel
118BuildRequires: atk-devel
119BuildRequires: bison
11ad81c4 120BuildRequires: bzip2-devel
5997e180
ER
121%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
122%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
123%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 124%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 125%{?with_cups:BuildRequires: cups-devel}
92965b0e 126BuildRequires: elfutils-devel
77f32fa3 127BuildRequires: expat-devel
7d0dbc8d 128%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 129%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 130BuildRequires: fontconfig-devel
f1b276d4 131BuildRequires: glib2-devel
05f72ae2 132BuildRequires: gperf
71d49434 133%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 134BuildRequires: gtest-devel
8b53130d 135BuildRequires: gtk+2-devel
01b4dc8e 136%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 137%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 138%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 139BuildRequires: hicolor-icon-theme
ed514974 140%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 141%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 142BuildRequires: libevent-devel
8456d676 143%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 144%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 145BuildRequires: libicu-devel >= 4.6
39c71b4c 146%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 147%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 148%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 149BuildRequires: libpng-devel
e266589e 150%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 151BuildRequires: libstdc++-devel
ba685303 152%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 153%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 154%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 155BuildRequires: libxml2-devel
11ad81c4 156BuildRequires: libxslt-devel
535cb410 157BuildRequires: man-db
62950103 158%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 159BuildRequires: nspr-devel
f1b276d4 160BuildRequires: nss-devel >= 1:3.12.3
8456d676 161%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 162BuildRequires: pam-devel
f1b276d4 163BuildRequires: pango-devel
ef121064 164BuildRequires: pciutils-devel
48b341f5 165BuildRequires: perl-modules
166BuildRequires: pkgconfig
75a27c2e 167%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 168%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 169BuildRequires: python
46cdefee 170#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 171BuildRequires: python-modules
92965b0e 172BuildRequires: python-ply
543e99ac 173%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 174BuildRequires: rpm >= 4.4.9-56
f1b276d4 175BuildRequires: rpmbuild(macros) >= 1.453
f099161f 176%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 177BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 178%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 179%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 180%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 181BuildRequires: subversion
0cad051b 182BuildRequires: tar >= 1:1.22
0a424ee2 183BuildRequires: udev-devel
7d1152d4 184BuildRequires: usbutils
2303ed45 185BuildRequires: util-linux
c14cd342 186%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 187BuildRequires: which
f1b276d4 188BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 189BuildRequires: xz
a3140cd1 190%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 191%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 192Requires: browser-plugins >= 2.0
0cad051b 193Requires: desktop-file-utils
8f5f6775 194%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
195# crashes if no fontconfig font present
196Requires: fonts-Type1-urw
0eb19b0b 197Requires: hicolor-icon-theme
56403697 198Requires: libevent >= 2.0.21
c1edaafa 199%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 200%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 201Requires: lsb-release
b2c4ae39 202%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 203Requires: shared-mime-info
f7b16691 204%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 205Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 206Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 207Provides: wwwbrowser
c3582150 208Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 209Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 210ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 211BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 212
319f81f7
ER
213# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
214# Note: these are for PLD Linux use ONLY.
215# For your own distribution, please get your own set of keys.
216%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
217%define google_default_client_id 724288223830.apps.googleusercontent.com
218%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
219
7ebeabb6 220%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 221
e7fa0817
ER
222# Usage: gyp_with BCOND_NAME [OPTION_NAME]
223%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 224
6b113615
ER
225%if %{without debuginfo}
226%define _enable_debug_packages 0
227%endif
228
11ad81c4 229%description
80838854
ER
230Chromium is an open-source browser project that aims to build a safer,
231faster, and more stable way for all Internet users to experience the
232web.
233
234Chromium serves as a base for Google Chrome, which is Chromium
235rebranded (name and logo) with very few additions such as usage
236tracking and an auto-updater system.
237
f1b276d4
ER
238%package l10n
239Summary: chromium-browser language packages
240Group: I18n
241Requires: %{name} = %{version}-%{release}
8da7b90b
ER
242%if "%{_rpmversion}" >= "5"
243BuildArch: noarch
244%endif
f1b276d4
ER
245
246%description l10n
247Chromium is an open-source browser project that aims to build a safer,
248faster, and more stable way for all Internet users to experience the
249web.
250
251This package contains language packages for 50 languages:
252
e7fa0817
ER
253ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
254he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
255pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
256zh-TW
f1b276d4
ER
257
258%prep
3c73e180
ER
259%setup -qc
260%if "%{?patchver}" != ""
261cd %{name}-%{branch}.%{basever}
262%patch0 -p1
263cd ..
264%endif
75f96a39 265mv %{name}-%{branch}.%{basever}/* .
589d90ea 266
05f72ae2
ER
267# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
268# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 269. ./chrome/VERSION
e00e4177
ER
270chrome=$MAJOR.$MINOR.$BUILD.$PATCH
271test "$chrome" = %{version}
a3140cd1 272
75f96a39 273gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 274test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 275
e00e4177
ER
276. ./v8.sh
277v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
33b04c7d 278
4765ddf1
ER
279# add chromium and pld to useragent
280%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
281sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
282 -e 's/@BUILD_DIST_NAME@/PLD/g' \
283 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
75f96a39 284 < %{PATCH8} | %{__patch} -p2
4765ddf1 285
8da7b90b 286%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
287ln -s %{SOURCE7} .
288
289%patch1 -p2
290%patch3 -p2
291%patch4 -p3
292%patch6 -p2
7879021e
ER
293%patch7 -p1
294%patch10 -p1
75f96a39 295%patch15 -p2
f4a8da6a 296%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 297%patch12 -p1
5997e180 298%patch16 -p1
41d6a4b1 299%patch28 -p1
75f96a39 300%patch25 -p2
1ed01da3 301%patch18 -p1
75f96a39
ER
302%patch24 -p2
303%patch26 -p2
effb85eb 304%patch31 -p0
f099161f 305%patch32 -p2
7a1e74db 306%patch33 -p2
e9abb380 307
75a27c2e
ER
308sh -x clean-source.sh \
309 %{!?with_nacl:nacl=0} \
bbdce24d
ER
310 %{!?with_system_libvpx:libvpx=0} \
311 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 312 %{!?with_system_mesa:mesa=0} \
75a27c2e 313 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 314 %{!?with_system_re2:re2=0} \
7e634b46 315 %{!?with_system_snappy:snappy=0} \
5048b37a 316 %{!?with_system_sqlite:sqlite=0} \
75a27c2e
ER
317 %{!?with_system_v8:v8=0} \
318 %{!?with_system_zlib:zlib=0} \
319 %{nil}
fded59be 320
e266589e 321%build
5997e180 322%if %{with nacl}
108c5f7c 323rm -rf native_client/toolchain/linux_x86_newlib
fded59be 324if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 325# Make symlinks for NaCL
108c5f7c 326install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 327
108c5f7c
ER
328cd native_client/toolchain/linux_x86_newlib
329ln -s x86_64-nacl/bin bin
330cd x86_64-nacl/bin
2e4113fd 331__cc='%{__cc}'
f64e73f6 332if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
333 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
334 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
335 %{__sed} -i -e '1i#!/bin/sh' gcc g++
336 chmod +x gcc g++
337else
338 ln -s %{_bindir}/x86_64-nacl-gcc gcc
339 ln -s %{_bindir}/x86_64-nacl-g++ g++
340fi
108c5f7c
ER
341ln -s gcc x86_64-nacl-gcc
342ln -s g++ x86_64-nacl-g++
343ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
344ln -s %{_bindir}/x86_64-nacl-ar ar
345ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 346ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 347ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 348ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 349ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 350ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
351ln -s %{_prefix}/x86_64-nacl/lib ../lib
352ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
353ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
354cd ../../../../..
fded59be 355fi
5997e180
ER
356%endif
357
7879021e 358flags="
f1b276d4
ER
359%ifarch %{ix86}
360 -Dtarget_arch=ia32 \
361%endif
362%ifarch %{x8664}
0c480b89
ER
363 -Dtarget_arch=x64 \
364%endif
7b454a31
AM
365%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
366 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
367%endif
368%if %{with sandboxing}
369 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
370 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
371%endif
372 %{!?debug:-Dwerror=} \
c980b122 373 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 374 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 375 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
b5a3dda3 376 -Dinclude_tests=0 \
c0808220 377%if %{with nacl}
038f76b9 378 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
379 -Ddisable_glibc_untar=1 \
380 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
381 -Ddisable_glibc=1 \
382 -Ddisable_pnacl=1 \
383 -Dbuild_pnacl_newlib=0 \
c0808220 384%else
8fb1dc98 385 -Ddisable_pnacl_untar=1 \
c0808220
ER
386 -Ddisable_nacl=1 \
387%endif
a3140cd1
ER
388 %{!?with_sse2:-Ddisable_sse2=1} \
389 %{?with_selinux:-Dselinux=1} \
7d1152d4 390 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 391 -Dlinux_link_libpci=1 \
7879021e 392 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
05998197 393 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 394 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
395 -Dlinux_use_gold_binary=0 \
396 -Dlinux_use_gold_flags=0 \
319f81f7
ER
397 -Dgoogle_api_key=%{google_api_key} \
398 -Dgoogle_default_client_id=%{google_default_client_id} \
399 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 400 %{gyp_with cups} \
8dda6bbc 401 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 402 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
403 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
404 %{gyp_with pulseaudio} \
41d6a4b1 405 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 406 %{gyp_with system_flac} \
01b4dc8e 407 %{gyp_with system_harfbuzz} \
2d65d095 408 %{gyp_with system_jsoncpp} \
62950103
ER
409 %{gyp_with system_libexif} \
410 %{gyp_with system_libmtp} \
9bd2659c 411 %{gyp_with system_libsrtp} \
581aec44 412 %{gyp_with system_libusb} \
41d6a4b1 413 %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
ba685303 414 %{gyp_with system_libwebp} \
4884fc99 415 %{gyp_with system_libxnvctrl} \
7b8f219a 416 %{gyp_with system_mesa} \
126ea630 417 %{gyp_with system_minizip} \
62950103 418 %{gyp_with system_opus} \
75a27c2e 419 %{gyp_with system_protobuf} \
bbdce24d 420 %{gyp_with system_re2} \
7e634b46 421 %{gyp_with system_snappy} \
e7fa0817 422 %{gyp_with system_speex} \
914ee37c 423 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
424 %{gyp_with system_v8} \
425 %{gyp_with system_yasm} \
426 %{gyp_with system_zlib} \
0c480b89 427 -Duse_system_bzip2=1 \
62950103 428 -Duse_system_expat=1 \
0b214002 429 -Duse_system_icu=1 \
f1b276d4 430 -Duse_system_libevent=1 \
0c480b89 431 -Duse_system_libjpeg=1 \
f1b276d4
ER
432 -Duse_system_libpng=1 \
433 -Duse_system_libxml=1 \
434 -Duse_system_libxslt=1 \
b363f856 435 -Duse_system_nspr=1 \
7f40f3f4 436 -Duse_system_xdg_utils=1 \
7879021e
ER
437"
438
439build/linux/unbundle/replace_gyp_files.py $flags
440
441test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
442test -e Makefile || \
443 CC="%{__cc}" \
444 CXX="%{__cxx}" \
445 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
446 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
447 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
448 CC_host="%{__cc}" \
449 CXX_host="%{__cxx}" \
450 LD_host="%{__cxx}" \
451%{__python} build/gyp_chromium \
452 --format=make \
453 --depth=. \
454 build/all.gyp \
455 $flags
11ad81c4 456
b4d75247 457# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 458%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
459 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
460 %{?with_verbose:V=1} \
f1b276d4
ER
461 CC.host="%{__cc}" \
462 CXX.host="%{__cxx}" \
b4d75247 463 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 464
75f96a39 465cd out/%{!?debug:Release}%{?debug:Debug}
535cb410
ER
466MANWIDTH=80 man ./chrome.1 > man.out
467%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
468
11ad81c4
AM
469%install
470rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
471install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
472 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
37ceaf05 473 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 474
673aee14 475cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 476cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 477install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
478%{__sed} -i -e '
479 s,@libdir@,%{_libdir}/%{name},
480
481 /@OPTIONS@/ {
482 r options.txt
483 d
484 }
485' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b
ER
486cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
487cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
488ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
489ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 490cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 491install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 492install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 493%if %{without system_ffmpeg}
f1b276d4 494install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 495%endif
e7fa0817 496cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 497cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 498
8da7b90b 499%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 500
164020eb
ER
501%if %{with nacl}
502# Install Native Client files on platforms that support it.
503install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
504install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
505%ifarch %{x8664}
506install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
507%endif
508%ifarch %{ix86}
509install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
510%endif
511%endif
512
0c480b89
ER
513cd -
514
75f96a39 515for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
516 size=${icon##*/product_logo_}
517 size=${size%.png}
518
519 # this will skip non-numeric (22_mono_invert, 22_mono)
520 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
521 test -d "$dir" || continue
522
523 install -d $RPM_BUILD_ROOT$dir
524 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
525done
7f40f3f4 526
13840bc2
AM
527%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
528# http://code.google.com/p/chromium/issues/detail?id=24507
529gecko-mediaplayer*.so
530EOF
11ad81c4 531
589d90ea
ER
532# find locales
533%find_lang %{name}.lang
e7fa0817 534# always package en-US
f1b276d4 535%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 536
11ad81c4
AM
537%clean
538rm -rf $RPM_BUILD_ROOT
539
8da7b90b
ER
540%pretrans
541for d in locales resources; do
542 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
543 install -d %{_datadir}/%{name}
544 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
545 fi
546done
547exit 0
548
f1b276d4 549%post
0eb19b0b 550%update_icon_cache hicolor
b7a6e4ee 551%update_desktop_database
f1b276d4
ER
552%update_browser_plugins
553
554%postun
555if [ "$1" = 0 ]; then
0eb19b0b 556 %update_icon_cache hicolor
f1b276d4
ER
557 %update_browser_plugins
558fi
559
1d2b9616 560%files
11ad81c4 561%defattr(644,root,root,755)
75f96a39 562%doc AUTHORS LICENSE
f1b276d4
ER
563%{_browserpluginsconfdir}/browsers.d/%{name}.*
564%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
565%dir %{_sysconfdir}/%{name}
566%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 567%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
568%attr(755,root,root) %{_bindir}/%{name}
569%{_mandir}/man1/%{name}.1*
11ad81c4 570%{_desktopdir}/*.desktop
0eb19b0b 571%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 572%dir %{_libdir}/%{name}
e9abb380 573%{_libdir}/%{name}/chrome*.pak
c14cd342 574%{_libdir}/%{name}/content_resources.pak
97fac491 575%{_libdir}/%{name}/resources.pak
8da7b90b
ER
576%{_libdir}/%{name}/locales
577%{_libdir}/%{name}/resources
578
579%dir %{_datadir}/%{name}
580%dir %{_datadir}/%{name}/locales
581%{_datadir}/%{name}/locales/en-US.pak
582%dir %{_datadir}/%{name}/resources
583%{_datadir}/%{name}/resources/inspector
584
f1b276d4
ER
585%dir %{_libdir}/%{name}/plugins
586%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 587# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 588%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
589
590# ffmpeg libs
fcc48c19 591%if %{without system_ffmpeg}
f1b276d4 592%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 593%endif
f1b276d4 594
164020eb
ER
595%if %{with nacl}
596%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
597%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
598%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
599%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
600%endif
601
f1b276d4
ER
602%files l10n -f %{name}.lang
603%defattr(644,root,root,755)
This page took 0.173643 seconds and 4 git commands to generate.