]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- add chromium-service.desktop to autostart
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
a3140cd1 10%bcond_with nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
15%bcond_with system_sqlite # with system sqlite
32a2443e 16%bcond_without system_flac # with system flac
e8e15592 17%bcond_without system_libwebp # with system libwebp
32a2443e 18%bcond_without system_speex # with system speex
bf00cc26 19%bcond_without system_v8 # with system v8
32a2443e 20%bcond_without system_vpx # with system vpx
d617ab39 21%bcond_without system_yasm # with system yasm
2108baf2
ER
22%bcond_without system_zlib # with system zlib
23%bcond_with verbose # verbose build (V=1)
0c480b89 24
6d92f81c 25# TODO
f1b276d4 26# - check system sqlite linking problems
2108baf2 27# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 28# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 29# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 30# - use_system_hunspell
32a2443e 31# - use_system_stlport
a3140cd1
ER
32# - other defaults: src/build/common.gypi
33
e53ecfb5 34# NOTES:
4fe038cb
ER
35# - mute BEEP mixer if you do not want to hear horrible system bell when
36# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
37# - build -bp: 1.2G
38# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 39# - build x86_64: ~1.9G
f1b276d4 40# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 41# - to look for new tarball, use update-source.sh script
f1b276d4 42
e68aa7e7 43# NOTE TO USERS:
a3cc7091
ER
44# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
45# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 46# or:
a3cc7091 47# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 48
0cad051b 49%define svndate %{nil}
3cc320dc 50%define svnver 113337
a09d5528 51%define rel 1
11ad81c4 52
a3140cd1 53%define gyp_rev 1014
11ad81c4 54Summary: A WebKit powered web browser
05f72ae2 55Name: chromium-browser
3cc320dc 56Version: 16.0.912.63
cf823a7a 57Release: 0.%{svnver}.%{rel}
05f72ae2 58License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 59Group: X11/Applications/Networking
0cad051b 60Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}_%{version}~r%{svnver}.orig.tar.gz
3cc320dc 61# Source0-md5: c01869f276a9bf5f651771d93b07dac8
5e25f560 62#SourceX: http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
8b53130d
ER
63Source2: %{name}.sh
64Source3: %{name}.desktop
56c6e811
ER
65Source4: chromium-service.desktop
66Source5: find-lang.sh
67Source6: update-source.sh
68Source7: clean-source.sh
48b341f5 69Patch0: system-libs.patch
70Patch1: plugin-searchdirs.patch
71Patch2: gyp-system-minizip.patch
7abc645c 72Patch3: disable_dlog_and_dcheck_in_release_builds.patch
48b341f5 73Patch5: options-support.patch
0e5636cb 74Patch6: get-webkit_revision.patch
5aa5df39 75Patch7: dlopen_sonamed_gl.patch
4765ddf1 76Patch8: chromium_useragent.patch.in
77f32fa3 77Patch9: system-expat.patch
750b48f7 78URL: http://www.chromium.org/Home
ae3fe89f 79%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 80BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
81BuildRequires: alsa-lib-devel
82BuildRequires: atk-devel
83BuildRequires: bison
11ad81c4 84BuildRequires: bzip2-devel
ae3fe89f 85%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 86BuildRequires: dbus-glib-devel
77f32fa3 87BuildRequires: expat-devel
d617ab39 88%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 89BuildRequires: flex
11ad81c4 90BuildRequires: fontconfig-devel
f1b276d4 91BuildRequires: glib2-devel
05f72ae2 92BuildRequires: gperf
8b53130d 93BuildRequires: gtk+2-devel
a3140cd1 94%{?with_kerberos:BuildRequires: heimdal-devel}
05f72ae2 95BuildRequires: libevent-devel
7f40f3f4 96%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 97BuildRequires: libicu-devel >= 4.6
05f72ae2
ER
98BuildRequires: libjpeg-devel
99BuildRequires: libpng-devel
e266589e 100%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 101BuildRequires: libstdc++-devel
32a2443e 102%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
e8e15592 103%{?with_system_libwebp:BuildRequires: libwebp-devel}
f1b276d4 104BuildRequires: libxml2-devel
11ad81c4 105BuildRequires: libxslt-devel
f1b276d4 106BuildRequires: lzma
11ad81c4 107BuildRequires: minizip-devel
164020eb 108%{?with_nacl:BuildRequires: nacl-toolchain-newlib >= 0.6941}
05f72ae2 109BuildRequires: nspr-devel
f1b276d4 110BuildRequires: nss-devel >= 1:3.12.3
35902862 111BuildRequires: pam-devel
f1b276d4 112BuildRequires: pango-devel
48b341f5 113BuildRequires: perl-modules
114BuildRequires: pkgconfig
ae3fe89f 115%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 116BuildRequires: python
46cdefee 117#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 118BuildRequires: python-modules
0cad051b 119BuildRequires: rpm >= 4.4.9-56
f1b276d4 120BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 121%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 122BuildRequires: sqlite3-devel >= 3.6.1
0cad051b 123BuildRequires: tar >= 1:1.22
2303ed45 124BuildRequires: util-linux
9c06a87f 125%{?with_system_v8:BuildRequires: v8-devel >= 3.6}
0826c245 126BuildRequires: which
f1b276d4 127BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
128BuildRequires: xorg-lib-libXt-devel
129BuildRequires: xorg-lib-libXtst-devel
a3140cd1 130%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 131%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 132Requires: browser-plugins >= 2.0
0cad051b 133Requires: desktop-file-utils
32a2443e 134%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 135Requires: xdg-utils >= 1.0.2-4
e53ecfb5 136Provides: wwwbrowser
c3582150 137Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 138Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 139ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 140BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 141
589d90ea 142%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
143# Usage: gyp_with BCOND_NAME [OPTION_NAME]
144%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 145
6b113615
ER
146%if %{without debuginfo}
147%define _enable_debug_packages 0
148%endif
149
0cad051b
ER
150# undefine if empty, makes prep simplier
151%if "%{svndate}" == "%{nil}"
152%undefine svndate
153%endif
154
11ad81c4 155%description
80838854
ER
156Chromium is an open-source browser project that aims to build a safer,
157faster, and more stable way for all Internet users to experience the
158web.
159
160Chromium serves as a base for Google Chrome, which is Chromium
161rebranded (name and logo) with very few additions such as usage
162tracking and an auto-updater system.
163
f1b276d4
ER
164%package l10n
165Summary: chromium-browser language packages
166Group: I18n
167Requires: %{name} = %{version}-%{release}
168
169%description l10n
170Chromium is an open-source browser project that aims to build a safer,
171faster, and more stable way for all Internet users to experience the
172web.
173
174This package contains language packages for 50 languages:
175
e7fa0817
ER
176ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
177he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
178pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
179zh-TW
f1b276d4
ER
180
181%prep
0cad051b
ER
182%setup -q -n %{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}
183SRC=%{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}-source.tar.*
184tar xf $SRC
185%{__rm} $SRC
589d90ea 186
05f72ae2
ER
187# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
188# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
189. ./src/chrome/VERSION
190ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
191test "$ver" = %{version}
192
193gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 194test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 195
33b04c7d
ER
196v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog)
197
f1b276d4
ER
198# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
199echo "%{svnver}" > src/build/LASTCHANGE.in
200
4765ddf1
ER
201# add chromium and pld to useragent
202%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
203sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
204 -e 's/@BUILD_DIST_NAME@/PLD/g' \
205 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 206 < %{PATCH8} | %{__patch} -p1
4765ddf1 207
56c6e811
ER
208%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
209ln -s %{SOURCE7} src
f1b276d4 210
05f72ae2
ER
211%patch0 -p1
212%patch1 -p1
213%patch2 -p1
7abc645c 214%patch3 -p1
05f72ae2 215%patch5 -p1
0e5636cb 216%patch6 -p1
5aa5df39 217%patch7 -p1
77f32fa3
ER
218cd src
219%patch9 -p1
220cd ..
0c480b89 221
828bdd1a 222cd src
fe547a32 223sh -x clean-source.sh %{?with_system_v8:v8=1} %{?with_nacl:nacl=1}
164020eb 224
e266589e 225%build
f1b276d4 226cd src
164020eb 227test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
228%ifarch %{ix86}
229 -Dtarget_arch=ia32 \
230%endif
231%ifarch %{x8664}
0c480b89
ER
232 -Dtarget_arch=x64 \
233%endif
7b454a31
AM
234%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
235 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
236%endif
237%if %{with sandboxing}
238 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
239 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
240%endif
241 %{!?debug:-Dwerror=} \
c980b122 242 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 243 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 244 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
245 -Dffmpeg_branding=Chrome \
246 -Dproprietary_codecs=1 \
5a6de706 247 %{!?with_nacl:-Ddisable_nacl=1} \
a3140cd1
ER
248 %{!?with_sse2:-Ddisable_sse2=1} \
249 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
250 %{gyp_with cups} \
251 %{gyp_with flac} \
252 %{gyp_with gconf} \
253 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
254 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
255 %{gyp_with pulseaudio} \
e8e15592 256 %{gyp_with system_libwebp} \
e7fa0817
ER
257 %{gyp_with system_speex} \
258 %{gyp_with system_sqlite} \
259 %{gyp_with system_v8} \
32a2443e 260 %{gyp_with system_vpx} \
e7fa0817
ER
261 %{gyp_with system_yasm} \
262 %{gyp_with system_zlib} \
0c480b89 263 -Duse_system_bzip2=1 \
0b214002 264 -Duse_system_icu=1 \
f1b276d4 265 -Duse_system_libevent=1 \
0c480b89 266 -Duse_system_libjpeg=1 \
f1b276d4
ER
267 -Duse_system_libpng=1 \
268 -Duse_system_libxml=1 \
269 -Duse_system_libxslt=1 \
7f40f3f4 270 -Duse_system_xdg_utils=1 \
11ad81c4 271
f1b276d4
ER
272%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
273 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
274 %{?with_verbose:V=1} \
275 CC="%{__cc}" \
276 CXX="%{__cxx}" \
b7adf6b1 277 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
278 CC.host="%{__cc}" \
279 CXX.host="%{__cxx}" \
b7adf6b1 280 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
281 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
282 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
283
284%install
285rm -rf $RPM_BUILD_ROOT
56c6e811
ER
286install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
287 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir},/etc/xdg/autostart}
e266589e 288
f1b276d4 289cd src/out/%{!?debug:Release}%{?debug:Debug}
f1b276d4
ER
290install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
291%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 292cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 293cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 294install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 295install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 296%if %{with ffmpegsumo}
f1b276d4 297install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 298%endif
e7fa0817 299cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
56c6e811 300cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/xdg/autostart
164020eb
ER
301
302%if %{with nacl}
303# Install Native Client files on platforms that support it.
304install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
305install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
306%ifarch %{x8664}
307install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
308%endif
309%ifarch %{ix86}
310install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
311%endif
312%endif
313
0c480b89
ER
314cd -
315
7f40f3f4
ER
316cp -p src/chrome/app/theme/chromium/product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
317
13840bc2
AM
318%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
319# http://code.google.com/p/chromium/issues/detail?id=24507
320gecko-mediaplayer*.so
321EOF
11ad81c4 322
589d90ea
ER
323# find locales
324%find_lang %{name}.lang
e7fa0817 325# always package en-US
f1b276d4 326%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 327
11ad81c4
AM
328%clean
329rm -rf $RPM_BUILD_ROOT
330
f1b276d4 331%post
b7a6e4ee 332%update_desktop_database
f1b276d4
ER
333%update_browser_plugins
334
335%postun
336if [ "$1" = 0 ]; then
337 %update_browser_plugins
338fi
339
589d90ea 340%files -f %{name}.lang
11ad81c4 341%defattr(644,root,root,755)
f1b276d4
ER
342%{_browserpluginsconfdir}/browsers.d/%{name}.*
343%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
344%attr(755,root,root) %{_bindir}/%{name}
345%{_mandir}/man1/%{name}.1*
346%{_pixmapsdir}/%{name}.png
11ad81c4 347%{_desktopdir}/*.desktop
56c6e811 348/etc/xdg/autostart/*.desktop
0c480b89
ER
349%dir %{_libdir}/%{name}
350%{_libdir}/%{name}/chrome.pak
97fac491 351%{_libdir}/%{name}/resources.pak
589d90ea 352%dir %{_libdir}/%{name}/locales
f1b276d4
ER
353%{_libdir}/%{name}/locales/en-US.pak
354%dir %{_libdir}/%{name}/resources
a3140cd1 355%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
356%dir %{_libdir}/%{name}/themes
357%dir %{_libdir}/%{name}/extensions
358%dir %{_libdir}/%{name}/plugins
359%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 360# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 361%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
362
363# ffmpeg libs
d561483d 364%if %{with ffmpegsumo}
f1b276d4 365%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 366%endif
f1b276d4 367
164020eb
ER
368%if %{with nacl}
369%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
370%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
371%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
372%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
373%endif
374
f1b276d4
ER
375%files l10n -f %{name}.lang
376%defattr(644,root,root,755)
This page took 0.087626 seconds and 4 git commands to generate.