]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
cleanup unused third party
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
7d0dbc8d 16%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
01b4dc8e 17%bcond_with system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
75a27c2e 26%bcond_with system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
4b411ffe 31%bcond_without system_libvpx # system libvpx
ba685303 32%bcond_without system_yasm # system yasm
1c00315b 33%bcond_without system_zlib # system zlib
ba685303 34%bcond_with tcmalloc # use tcmalloc
7e136323 35%bcond_without verbose # verbose build (V=1)
0c480b89 36
c6325ea2
ER
37%if %{with nacl}
38# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42#14:51:06 @baggins> as-needed will take care of unneeded lib
43#14:52:03 @baggins> -lssp comes with gcc
107b55fe 44%define _ssp_cflags %{nil}
c6325ea2
ER
45%endif
46
6d92f81c 47# TODO
f1b276d4 48# - check system sqlite linking problems
2108baf2 49# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 50# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 51# - use_system_hunspell
32a2443e 52# - use_system_stlport
a3140cd1
ER
53# - other defaults: src/build/common.gypi
54
e53ecfb5 55# NOTES:
4fe038cb
ER
56# - mute BEEP mixer if you do not want to hear horrible system bell when
57# pressing home/end in url bar or more ^F search results on page.
7c638678 58# - space considerations:
43238759 59# - unpacked sources: ~644MiB
c1ecd31f 60# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 61# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 62# - to look for new tarball, use update-source.sh script
f1b276d4 63
e68aa7e7 64# NOTE TO USERS:
c8b02491 65# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 66# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 67# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 68
a3140cd1 69%define gyp_rev 1014
11ad81c4 70Summary: A WebKit powered web browser
05f72ae2 71Name: chromium-browser
126ea630 72Version: 24.0.1312.45
01b4dc8e 73Release: 0.23
05f72ae2 74License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 75Group: X11/Applications/Networking
c1ecd31f 76Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
126ea630 77# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
37ceaf05 78Source1: %{name}.default
8b53130d
ER
79Source2: %{name}.sh
80Source3: %{name}.desktop
56c6e811
ER
81Source5: find-lang.sh
82Source6: update-source.sh
83Source7: clean-source.sh
836b1cac 84Source8: get-source.sh
0562b864 85Source9: master_preferences.json
48b341f5 86Patch1: plugin-searchdirs.patch
70258ccd 87#Patch2: system-nspr.patch
7abc645c 88Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 89Patch4: path-libpdf.patch
0e5636cb 90Patch6: get-webkit_revision.patch
5aa5df39 91Patch7: dlopen_sonamed_gl.patch
4765ddf1 92Patch8: chromium_useragent.patch.in
c0808220 93Patch9: chromium-ppapi.patch
8456d676 94Patch10: system-libxnvctrl.patch
1347c76c
AM
95# https://bugs.gentoo.org/show_bug.cgi?id=393471
96# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 97Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
98Patch15: nacl-build-irt.patch
99Patch16: nacl-linkingfix.patch
9516ca97 100Patch18: nacl-no-untar.patch
08b25440 101Patch19: system-jsoncpp.patch
126ea630 102Patch22: pulse_fix-157876.patch
8fb1dc98 103Patch23: no-pnacl.patch
6897926c 104Patch24: nacl-verbose.patch
c5b396f3
ER
105Patch25: gnome3-volume-control.patch
106Patch26: master-prefs-path.patch
750b48f7 107URL: http://www.chromium.org/Home
ae3fe89f 108%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 109BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
110BuildRequires: alsa-lib-devel
111BuildRequires: atk-devel
112BuildRequires: bison
11ad81c4 113BuildRequires: bzip2-devel
5997e180
ER
114%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
115%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
116%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 117%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 118%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 119BuildRequires: dbus-glib-devel
77f32fa3 120BuildRequires: expat-devel
7d0dbc8d 121%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 122%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 123BuildRequires: flex
11ad81c4 124BuildRequires: fontconfig-devel
f1b276d4 125BuildRequires: glib2-devel
05f72ae2 126BuildRequires: gperf
8b53130d 127BuildRequires: gtk+2-devel
01b4dc8e 128%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 129%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 130BuildRequires: hicolor-icon-theme
ed514974 131%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
8456d676 132%{?with_system_libxvnctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 133BuildRequires: libevent-devel
8456d676 134%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 135%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 136BuildRequires: libicu-devel >= 4.6
39c71b4c 137%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 138%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 139%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 140BuildRequires: libpng-devel
e266589e 141%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 142BuildRequires: libstdc++-devel
ba685303 143%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 144%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 145%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 146BuildRequires: libxml2-devel
11ad81c4 147BuildRequires: libxslt-devel
f1b276d4 148BuildRequires: lzma
62950103 149%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 150BuildRequires: nspr-devel
f1b276d4 151BuildRequires: nss-devel >= 1:3.12.3
8456d676 152%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 153BuildRequires: pam-devel
f1b276d4 154BuildRequires: pango-devel
48b341f5 155BuildRequires: perl-modules
156BuildRequires: pkgconfig
75a27c2e 157%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 158%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 159BuildRequires: python
46cdefee 160#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 161BuildRequires: python-modules
0cad051b 162BuildRequires: rpm >= 4.4.9-56
f1b276d4 163BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 164%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 165BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 166%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 167BuildRequires: subversion
0cad051b 168BuildRequires: tar >= 1:1.22
0a424ee2 169BuildRequires: udev-devel
2303ed45 170BuildRequires: util-linux
c14cd342 171%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 172BuildRequires: which
f1b276d4 173BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
174BuildRequires: xorg-lib-libXt-devel
175BuildRequires: xorg-lib-libXtst-devel
836b1cac 176BuildRequires: xz
a3140cd1 177%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 178%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 179Requires: browser-plugins >= 2.0
0cad051b 180Requires: desktop-file-utils
8f5f6775 181%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 182Requires: hicolor-icon-theme
c1edaafa 183%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 184%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
4dc49133 185Requires: xdg-utils >= 1.0.2-4
e53ecfb5 186Provides: wwwbrowser
c3582150 187Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 188Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 189ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 190BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 191
589d90ea 192%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 193
e7fa0817
ER
194# Usage: gyp_with BCOND_NAME [OPTION_NAME]
195%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 196
6b113615
ER
197%if %{without debuginfo}
198%define _enable_debug_packages 0
199%endif
200
11ad81c4 201%description
80838854
ER
202Chromium is an open-source browser project that aims to build a safer,
203faster, and more stable way for all Internet users to experience the
204web.
205
206Chromium serves as a base for Google Chrome, which is Chromium
207rebranded (name and logo) with very few additions such as usage
208tracking and an auto-updater system.
209
f1b276d4
ER
210%package l10n
211Summary: chromium-browser language packages
212Group: I18n
213Requires: %{name} = %{version}-%{release}
214
215%description l10n
216Chromium is an open-source browser project that aims to build a safer,
217faster, and more stable way for all Internet users to experience the
218web.
219
220This package contains language packages for 50 languages:
221
e7fa0817
ER
222ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
223he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
224pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
225zh-TW
f1b276d4
ER
226
227%prep
836b1cac 228%setup -q
589d90ea 229
05f72ae2
ER
230# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
231# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
232. ./src/chrome/VERSION
233ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
234test "$ver" = %{version}
235
236gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 237test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 238
836b1cac 239v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 240
4765ddf1
ER
241# add chromium and pld to useragent
242%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
243sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
244 -e 's/@BUILD_DIST_NAME@/PLD/g' \
245 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 246 < %{PATCH8} | %{__patch} -p1
4765ddf1 247
56c6e811
ER
248%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
249ln -s %{SOURCE7} src
f1b276d4 250
05f72ae2 251%patch1 -p1
7abc645c 252%patch3 -p1
72cb20c1 253%patch4 -p1
0e5636cb 254%patch6 -p1
5aa5df39 255%patch7 -p1
e9abb380 256%patch15 -p1
77f32fa3 257cd src
c0808220 258%patch9 -p0
70258ccd 259#%patch2 -p1
f4a8da6a 260%{!?with_libjpegturbo:%patch11 -p0}
5997e180 261%patch16 -p1
08b25440 262%patch19 -p1
126ea630 263%patch22 -p1
c5b396f3 264%patch25 -p1
1347c76c 265cd ..
9516ca97 266%patch18 -p1
8fb1dc98 267%patch23 -p1
6897926c 268%patch24 -p1
c5b396f3 269%patch26 -p1
0c480b89 270
828bdd1a 271cd src
e9abb380
ER
272
273# Missing gyp files in tarball.
274# https://code.google.com/p/chromium/issues/detail?id=144823
275if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
276 echo "tarball fixed, please remove workaround"
277 exit 1
278fi
279
280install -d chrome/test/data/nacl
281cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
282{
283 'targets': [
284 {
285 'target_name': 'nacl_tests',
286 'type': 'none',
287 },
288 ],
289}
290EOF
291
75a27c2e
ER
292sh -x clean-source.sh \
293 %{!?with_nacl:nacl=0} \
294 %{!?with_system_protobuf:protobuf=0} \
295 %{!?with_system_v8:v8=0} \
296 %{!?with_system_zlib:zlib=0} \
297 %{nil}
164020eb 298
e266589e 299%build
f1b276d4 300cd src
5997e180
ER
301
302%if %{with nacl}
fded59be 303if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b
ER
304# Make symlinks for NaCL
305install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
2e4113fd 306
dcea0d6b 307cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
2e4113fd
ER
308__cc='%{__cc}'
309if [ "${__cc}#ccache}" != "$__cc" ]; then
310 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
311 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
312 %{__sed} -i -e '1i#!/bin/sh' gcc g++
313 chmod +x gcc g++
314else
315 ln -s %{_bindir}/x86_64-nacl-gcc gcc
316 ln -s %{_bindir}/x86_64-nacl-g++ g++
317fi
5997e180
ER
318ln -s %{_bindir}/x86_64-nacl-ar ar
319ln -s %{_bindir}/x86_64-nacl-as as
320ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
321ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
322ln -s %{_bindir}/x86_64-nacl-strip strip
dcea0d6b
ER
323ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
324ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
325ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
326cd ../../../../..
fded59be 327fi
5997e180
ER
328%endif
329
c5b396f3 330test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
331test -e Makefile || %{__python} build/gyp_chromium \
332 --format=make \
333 -Goutput_dir=../out \
334 build/all.gyp \
f1b276d4
ER
335%ifarch %{ix86}
336 -Dtarget_arch=ia32 \
337%endif
338%ifarch %{x8664}
0c480b89
ER
339 -Dtarget_arch=x64 \
340%endif
7b454a31
AM
341%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
342 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
343%endif
344%if %{with sandboxing}
345 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
346 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
347%endif
348 %{!?debug:-Dwerror=} \
c980b122 349 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 350 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 351 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 352 -Dinclude_tests=0 \
c0808220 353%if %{with nacl}
038f76b9 354 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
355 -Ddisable_glibc_untar=1 \
356 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
357 -Ddisable_glibc=1 \
358 -Ddisable_pnacl=1 \
359 -Dbuild_pnacl_newlib=0 \
c0808220 360%else
8fb1dc98 361 -Ddisable_pnacl_untar=1 \
c0808220
ER
362 -Ddisable_nacl=1 \
363%endif
a3140cd1
ER
364 %{!?with_sse2:-Ddisable_sse2=1} \
365 %{?with_selinux:-Dselinux=1} \
e7fa0817 366 %{gyp_with cups} \
8dda6bbc 367 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
368 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
369 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
370 %{gyp_with pulseaudio} \
7d0dbc8d 371 %{gyp_with system_ffmpeg} \
8f5f6775 372 %{gyp_with system_flac} \
01b4dc8e 373 %{gyp_with system_harfbuzz} \
62950103
ER
374 %{gyp_with system_libexif} \
375 %{gyp_with system_libmtp} \
9bd2659c 376 %{gyp_with system_libsrtp} \
581aec44 377 %{gyp_with system_libusb} \
4b411ffe 378 %{gyp_with system_libvpx} \
ba685303 379 %{gyp_with system_libwebp} \
4884fc99 380 %{gyp_with system_libxnvctrl} \
126ea630 381 %{gyp_with system_minizip} \
62950103 382 %{gyp_with system_opus} \
75a27c2e 383 %{gyp_with system_protobuf} \
e7fa0817
ER
384 %{gyp_with system_speex} \
385 %{gyp_with system_sqlite} \
386 %{gyp_with system_v8} \
387 %{gyp_with system_yasm} \
388 %{gyp_with system_zlib} \
0c480b89 389 -Duse_system_bzip2=1 \
62950103 390 -Duse_system_expat=1 \
0b214002 391 -Duse_system_icu=1 \
f1b276d4 392 -Duse_system_libevent=1 \
0c480b89 393 -Duse_system_libjpeg=1 \
f1b276d4
ER
394 -Duse_system_libpng=1 \
395 -Duse_system_libxml=1 \
396 -Duse_system_libxslt=1 \
7f40f3f4 397 -Duse_system_xdg_utils=1 \
d8ba130c 398 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
399 -Dlinux_use_gold_binary=0 \
400 -Dlinux_use_gold_flags=0
11ad81c4 401
48ffbc5e 402%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
403 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
404 %{?with_verbose:V=1} \
405 CC="%{__cc}" \
406 CXX="%{__cxx}" \
b7adf6b1 407 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
408 CC.host="%{__cc}" \
409 CXX.host="%{__cxx}" \
b7adf6b1 410 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
411 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
412 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
413
414%install
415rm -rf $RPM_BUILD_ROOT
56c6e811 416install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 417 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 418
673aee14 419cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 420cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
421install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
422%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 423cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 424cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 425install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 426install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 427%if %{without system_ffmpeg}
f1b276d4 428install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 429%endif
e7fa0817 430cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 431cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 432
c0808220
ER
433%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
434
164020eb
ER
435%if %{with nacl}
436# Install Native Client files on platforms that support it.
437install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
438install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
439%ifarch %{x8664}
440install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
441%endif
442%ifarch %{ix86}
443install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
444%endif
445%endif
446
0c480b89
ER
447cd -
448
0eb19b0b
ER
449for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
450 size=${icon##*/product_logo_}
451 size=${size%.png}
452
453 # this will skip non-numeric (22_mono_invert, 22_mono)
454 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
455 test -d "$dir" || continue
456
457 install -d $RPM_BUILD_ROOT$dir
458 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
459done
7f40f3f4 460
13840bc2
AM
461%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
462# http://code.google.com/p/chromium/issues/detail?id=24507
463gecko-mediaplayer*.so
464EOF
11ad81c4 465
589d90ea
ER
466# find locales
467%find_lang %{name}.lang
e7fa0817 468# always package en-US
f1b276d4 469%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 470
11ad81c4
AM
471%clean
472rm -rf $RPM_BUILD_ROOT
473
f1b276d4 474%post
0eb19b0b 475%update_icon_cache hicolor
b7a6e4ee 476%update_desktop_database
f1b276d4
ER
477%update_browser_plugins
478
479%postun
480if [ "$1" = 0 ]; then
0eb19b0b 481 %update_icon_cache hicolor
f1b276d4
ER
482 %update_browser_plugins
483fi
484
1d2b9616 485%files
11ad81c4 486%defattr(644,root,root,755)
531537e5 487%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
488%{_browserpluginsconfdir}/browsers.d/%{name}.*
489%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
490%dir %{_sysconfdir}/%{name}
491%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 492%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
493%attr(755,root,root) %{_bindir}/%{name}
494%{_mandir}/man1/%{name}.1*
11ad81c4 495%{_desktopdir}/*.desktop
0eb19b0b 496%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 497%dir %{_libdir}/%{name}
e9abb380 498%{_libdir}/%{name}/chrome*.pak
c14cd342 499%{_libdir}/%{name}/content_resources.pak
97fac491 500%{_libdir}/%{name}/resources.pak
589d90ea 501%dir %{_libdir}/%{name}/locales
f1b276d4
ER
502%{_libdir}/%{name}/locales/en-US.pak
503%dir %{_libdir}/%{name}/resources
a3140cd1 504%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
505%dir %{_libdir}/%{name}/themes
506%dir %{_libdir}/%{name}/extensions
507%dir %{_libdir}/%{name}/plugins
508%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 509# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 510%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
511
512# ffmpeg libs
fcc48c19 513%if %{without system_ffmpeg}
f1b276d4 514%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 515%endif
f1b276d4 516
164020eb
ER
517%if %{with nacl}
518%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
519%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
520%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
521%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
522%endif
523
f1b276d4
ER
524%files l10n -f %{name}.lang
525%defattr(644,root,root,755)
This page took 0.135335 seconds and 4 git commands to generate.