]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- --password-store=detect is default since 12.x
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
a3140cd1 10%bcond_with nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
15%bcond_with system_sqlite # with system sqlite
32a2443e 16%bcond_without system_flac # with system flac
e8e15592 17%bcond_without system_libwebp # with system libwebp
32a2443e 18%bcond_without system_speex # with system speex
bf00cc26 19%bcond_without system_v8 # with system v8
32a2443e 20%bcond_without system_vpx # with system vpx
d617ab39 21%bcond_without system_yasm # with system yasm
2108baf2
ER
22%bcond_without system_zlib # with system zlib
23%bcond_with verbose # verbose build (V=1)
0c480b89 24
6d92f81c 25# TODO
f1b276d4 26# - check system sqlite linking problems
2108baf2 27# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 28# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 29# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 30# - use_system_hunspell
32a2443e 31# - use_system_stlport
a3140cd1
ER
32# - other defaults: src/build/common.gypi
33
e53ecfb5 34# NOTES:
4fe038cb
ER
35# - mute BEEP mixer if you do not want to hear horrible system bell when
36# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
37# - build -bp: 1.2G
38# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 39# - build x86_64: ~1.9G
f1b276d4 40# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 41# - to look for new tarball, use update-source.sh script
f1b276d4 42
e68aa7e7 43# NOTE TO USERS:
a3cc7091
ER
44# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
45# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 46# or:
a3cc7091 47# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 48
0cad051b 49%define svndate %{nil}
7cffe7ae 50%define svnver 112386
a09d5528 51%define rel 1
11ad81c4 52
a3140cd1 53%define gyp_rev 1014
11ad81c4 54Summary: A WebKit powered web browser
05f72ae2 55Name: chromium-browser
7cffe7ae 56Version: 16.0.912.59
cf823a7a 57Release: 0.%{svnver}.%{rel}
05f72ae2 58License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 59Group: X11/Applications/Networking
0cad051b 60Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}_%{version}~r%{svnver}.orig.tar.gz
7cffe7ae 61# Source0-md5: 79d7767698b1522ddf5f7cf725e0594f
5e25f560 62#SourceX: http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
8b53130d
ER
63Source2: %{name}.sh
64Source3: %{name}.desktop
589d90ea 65Source4: find-lang.sh
fe043a0f 66Source5: update-source.sh
fe547a32 67Source6: clean-source.sh
48b341f5 68Patch0: system-libs.patch
69Patch1: plugin-searchdirs.patch
70Patch2: gyp-system-minizip.patch
7abc645c 71Patch3: disable_dlog_and_dcheck_in_release_builds.patch
48b341f5 72Patch5: options-support.patch
0e5636cb 73Patch6: get-webkit_revision.patch
5aa5df39 74Patch7: dlopen_sonamed_gl.patch
4765ddf1 75Patch8: chromium_useragent.patch.in
77f32fa3 76Patch9: system-expat.patch
750b48f7 77URL: http://www.chromium.org/Home
ae3fe89f 78%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 79BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
80BuildRequires: alsa-lib-devel
81BuildRequires: atk-devel
82BuildRequires: bison
11ad81c4 83BuildRequires: bzip2-devel
ae3fe89f 84%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 85BuildRequires: dbus-glib-devel
77f32fa3 86BuildRequires: expat-devel
d617ab39 87%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 88BuildRequires: flex
11ad81c4 89BuildRequires: fontconfig-devel
f1b276d4 90BuildRequires: glib2-devel
05f72ae2 91BuildRequires: gperf
8b53130d 92BuildRequires: gtk+2-devel
a3140cd1 93%{?with_kerberos:BuildRequires: heimdal-devel}
05f72ae2 94BuildRequires: libevent-devel
7f40f3f4 95%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 96BuildRequires: libicu-devel >= 4.6
05f72ae2
ER
97BuildRequires: libjpeg-devel
98BuildRequires: libpng-devel
e266589e 99%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 100BuildRequires: libstdc++-devel
32a2443e 101%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
e8e15592 102%{?with_system_libwebp:BuildRequires: libwebp-devel}
f1b276d4 103BuildRequires: libxml2-devel
11ad81c4 104BuildRequires: libxslt-devel
f1b276d4 105BuildRequires: lzma
11ad81c4 106BuildRequires: minizip-devel
164020eb 107%{?with_nacl:BuildRequires: nacl-toolchain-newlib >= 0.6941}
05f72ae2 108BuildRequires: nspr-devel
f1b276d4 109BuildRequires: nss-devel >= 1:3.12.3
35902862 110BuildRequires: pam-devel
f1b276d4 111BuildRequires: pango-devel
48b341f5 112BuildRequires: perl-modules
113BuildRequires: pkgconfig
ae3fe89f 114%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 115BuildRequires: python
46cdefee 116#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 117BuildRequires: python-modules
0cad051b 118BuildRequires: rpm >= 4.4.9-56
f1b276d4 119BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 120%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 121BuildRequires: sqlite3-devel >= 3.6.1
0cad051b 122BuildRequires: tar >= 1:1.22
2303ed45 123BuildRequires: util-linux
9c06a87f 124%{?with_system_v8:BuildRequires: v8-devel >= 3.6}
0826c245 125BuildRequires: which
f1b276d4 126BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
127BuildRequires: xorg-lib-libXt-devel
128BuildRequires: xorg-lib-libXtst-devel
a3140cd1 129%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 130%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 131Requires: browser-plugins >= 2.0
0cad051b 132Requires: desktop-file-utils
32a2443e 133%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 134Requires: xdg-utils >= 1.0.2-4
e53ecfb5 135Provides: wwwbrowser
c3582150 136Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 137Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 138ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 139BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 140
589d90ea 141%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
142# Usage: gyp_with BCOND_NAME [OPTION_NAME]
143%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 144
6b113615
ER
145%if %{without debuginfo}
146%define _enable_debug_packages 0
147%endif
148
0cad051b
ER
149# undefine if empty, makes prep simplier
150%if "%{svndate}" == "%{nil}"
151%undefine svndate
152%endif
153
11ad81c4 154%description
80838854
ER
155Chromium is an open-source browser project that aims to build a safer,
156faster, and more stable way for all Internet users to experience the
157web.
158
159Chromium serves as a base for Google Chrome, which is Chromium
160rebranded (name and logo) with very few additions such as usage
161tracking and an auto-updater system.
162
f1b276d4
ER
163%package l10n
164Summary: chromium-browser language packages
165Group: I18n
166Requires: %{name} = %{version}-%{release}
167
168%description l10n
169Chromium is an open-source browser project that aims to build a safer,
170faster, and more stable way for all Internet users to experience the
171web.
172
173This package contains language packages for 50 languages:
174
e7fa0817
ER
175ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
176he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
177pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
178zh-TW
f1b276d4
ER
179
180%prep
0cad051b
ER
181%setup -q -n %{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}
182SRC=%{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}-source.tar.*
183tar xf $SRC
184%{__rm} $SRC
589d90ea 185
05f72ae2
ER
186# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
187# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
188. ./src/chrome/VERSION
189ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
190test "$ver" = %{version}
191
192gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 193test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 194
33b04c7d
ER
195v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog)
196
f1b276d4
ER
197# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
198echo "%{svnver}" > src/build/LASTCHANGE.in
199
4765ddf1
ER
200# add chromium and pld to useragent
201%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
202sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
203 -e 's/@BUILD_DIST_NAME@/PLD/g' \
204 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 205 < %{PATCH8} | %{__patch} -p1
4765ddf1 206
2bc5cf47 207%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
fe547a32 208ln -s %{SOURCE6} src
f1b276d4 209
05f72ae2
ER
210%patch0 -p1
211%patch1 -p1
212%patch2 -p1
7abc645c 213%patch3 -p1
05f72ae2 214%patch5 -p1
0e5636cb 215%patch6 -p1
5aa5df39 216%patch7 -p1
77f32fa3
ER
217cd src
218%patch9 -p1
219cd ..
0c480b89 220
828bdd1a 221cd src
fe547a32 222sh -x clean-source.sh %{?with_system_v8:v8=1} %{?with_nacl:nacl=1}
164020eb 223
e266589e 224%build
f1b276d4 225cd src
164020eb 226test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
227%ifarch %{ix86}
228 -Dtarget_arch=ia32 \
229%endif
230%ifarch %{x8664}
0c480b89
ER
231 -Dtarget_arch=x64 \
232%endif
7b454a31
AM
233%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
234 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
235%endif
236%if %{with sandboxing}
237 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
238 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
239%endif
240 %{!?debug:-Dwerror=} \
2303ed45 241 %{!?debuginfo:-Dfastbuild=1} \
f1b276d4 242 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 243 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
244 -Dffmpeg_branding=Chrome \
245 -Dproprietary_codecs=1 \
5a6de706 246 %{!?with_nacl:-Ddisable_nacl=1} \
a3140cd1
ER
247 %{!?with_sse2:-Ddisable_sse2=1} \
248 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
249 %{gyp_with cups} \
250 %{gyp_with flac} \
251 %{gyp_with gconf} \
252 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
253 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
254 %{gyp_with pulseaudio} \
e8e15592 255 %{gyp_with system_libwebp} \
e7fa0817
ER
256 %{gyp_with system_speex} \
257 %{gyp_with system_sqlite} \
258 %{gyp_with system_v8} \
32a2443e 259 %{gyp_with system_vpx} \
e7fa0817
ER
260 %{gyp_with system_yasm} \
261 %{gyp_with system_zlib} \
0c480b89 262 -Duse_system_bzip2=1 \
0b214002 263 -Duse_system_icu=1 \
f1b276d4 264 -Duse_system_libevent=1 \
0c480b89 265 -Duse_system_libjpeg=1 \
f1b276d4
ER
266 -Duse_system_libpng=1 \
267 -Duse_system_libxml=1 \
268 -Duse_system_libxslt=1 \
7f40f3f4 269 -Duse_system_xdg_utils=1 \
11ad81c4 270
f1b276d4
ER
271%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
272 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
273 %{?with_verbose:V=1} \
274 CC="%{__cc}" \
275 CXX="%{__cxx}" \
276 CC.host="%{__cc}" \
277 CXX.host="%{__cxx}" \
7b454a31
AM
278 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
279 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
280
281%install
282rm -rf $RPM_BUILD_ROOT
f1b276d4 283install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{themes,locales,plugins,extensions,resources},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
e266589e 284
f1b276d4 285cd src/out/%{!?debug:Release}%{?debug:Debug}
f1b276d4
ER
286install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
287%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 288cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 289cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 290install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 291install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 292%if %{with ffmpegsumo}
f1b276d4 293install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 294%endif
e7fa0817 295cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb
ER
296
297%if %{with nacl}
298# Install Native Client files on platforms that support it.
299install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
300install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
301%ifarch %{x8664}
302install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
303%endif
304%ifarch %{ix86}
305install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
306%endif
307%endif
308
0c480b89
ER
309cd -
310
7f40f3f4
ER
311cp -p src/chrome/app/theme/chromium/product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
312
13840bc2
AM
313%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
314# http://code.google.com/p/chromium/issues/detail?id=24507
315gecko-mediaplayer*.so
316EOF
11ad81c4 317
589d90ea
ER
318# find locales
319%find_lang %{name}.lang
e7fa0817 320# always package en-US
f1b276d4 321%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 322
11ad81c4
AM
323%clean
324rm -rf $RPM_BUILD_ROOT
325
f1b276d4 326%post
b7a6e4ee 327%update_desktop_database
f1b276d4
ER
328%update_browser_plugins
329
330%postun
331if [ "$1" = 0 ]; then
332 %update_browser_plugins
333fi
334
589d90ea 335%files -f %{name}.lang
11ad81c4 336%defattr(644,root,root,755)
f1b276d4
ER
337%{_browserpluginsconfdir}/browsers.d/%{name}.*
338%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
339%attr(755,root,root) %{_bindir}/%{name}
340%{_mandir}/man1/%{name}.1*
341%{_pixmapsdir}/%{name}.png
11ad81c4 342%{_desktopdir}/*.desktop
0c480b89
ER
343%dir %{_libdir}/%{name}
344%{_libdir}/%{name}/chrome.pak
97fac491 345%{_libdir}/%{name}/resources.pak
589d90ea 346%dir %{_libdir}/%{name}/locales
f1b276d4
ER
347%{_libdir}/%{name}/locales/en-US.pak
348%dir %{_libdir}/%{name}/resources
a3140cd1 349%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
350%dir %{_libdir}/%{name}/themes
351%dir %{_libdir}/%{name}/extensions
352%dir %{_libdir}/%{name}/plugins
353%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 354# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 355%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
356
357# ffmpeg libs
d561483d 358%if %{with ffmpegsumo}
f1b276d4 359%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 360%endif
f1b276d4 361
164020eb
ER
362%if %{with nacl}
363%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
364%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
365%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
366%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
367%endif
368
f1b276d4
ER
369%files l10n -f %{name}.lang
370%defattr(644,root,root,755)
This page took 0.128454 seconds and 4 git commands to generate.