]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
update third_party/ clean list from gentoo
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2
ER
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without ffmpegsumo # build with ffmpegsumo
ba685303 6%bcond_without gconf # with GConf
8171fe68 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303
ER
16%bcond_without system_flac # system flac
17%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
18%bcond_without system_libexif # system libexif
19%bcond_without system_libmtp # system libmtp
ba685303
ER
20%bcond_without system_libusb # system libusb-1
21%bcond_without system_libwebp # system libwebp
126ea630 22%bcond_without system_minizip # system minizip
62950103 23%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
ba685303
ER
24%bcond_without system_speex # system speex
25%bcond_with system_sqlite # system sqlite
3ee15dec 26%bcond_without system_srtp # system srtp (can be used if using bundled libjingle)
ba685303 27%bcond_with system_v8 # system v8
4b411ffe 28%bcond_without system_libvpx # system libvpx
ba685303 29%bcond_without system_yasm # system yasm
1c00315b 30%bcond_without system_zlib # system zlib
ba685303 31%bcond_with tcmalloc # use tcmalloc
7e136323 32%bcond_without verbose # verbose build (V=1)
0c480b89 33
c6325ea2
ER
34%if %{with nacl}
35# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
36# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
37#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
38#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
39#14:51:06 @baggins> as-needed will take care of unneeded lib
40#14:52:03 @baggins> -lssp comes with gcc
107b55fe 41%define _ssp_cflags %{nil}
c6325ea2
ER
42%endif
43
6d92f81c 44# TODO
f1b276d4 45# - check system sqlite linking problems
2108baf2 46# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 47# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 48# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 49# - use_system_hunspell
32a2443e 50# - use_system_stlport
a3140cd1 51# - other defaults: src/build/common.gypi
62950103
ER
52# - use_system_libmtp
53# - use_system_libexif
54# - use_system_opus
55# - use_system_libjpeg==1 use_libjpeg_turbo==0
a3140cd1 56
e53ecfb5 57# NOTES:
4fe038cb
ER
58# - mute BEEP mixer if you do not want to hear horrible system bell when
59# pressing home/end in url bar or more ^F search results on page.
7c638678
ER
60# - space considerations:
61# - unpacked sources: ~800MiB
62# - built code: ~1.4GiB (x86_64)
f1b276d4 63# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 64# - to look for new tarball, use update-source.sh script
f1b276d4 65
e68aa7e7 66# NOTE TO USERS:
c8b02491 67# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 68# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 69# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 70
a3140cd1 71%define gyp_rev 1014
11ad81c4 72Summary: A WebKit powered web browser
05f72ae2 73Name: chromium-browser
126ea630 74Version: 24.0.1312.45
4b411ffe 75Release: 0.8
05f72ae2 76License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 77Group: X11/Applications/Networking
126ea630
ER
78Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
79# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
37ceaf05 80Source1: %{name}.default
8b53130d
ER
81Source2: %{name}.sh
82Source3: %{name}.desktop
56c6e811
ER
83Source5: find-lang.sh
84Source6: update-source.sh
85Source7: clean-source.sh
836b1cac 86Source8: get-source.sh
0562b864 87Source9: master_preferences.json
3c73e180 88#Patch10: system-libs.patch
48b341f5 89Patch1: plugin-searchdirs.patch
7abc645c 90Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 91Patch4: path-libpdf.patch
48b341f5 92Patch5: options-support.patch
0e5636cb 93Patch6: get-webkit_revision.patch
5aa5df39 94Patch7: dlopen_sonamed_gl.patch
4765ddf1 95Patch8: chromium_useragent.patch.in
c0808220 96Patch9: chromium-ppapi.patch
1347c76c
AM
97# https://bugs.gentoo.org/show_bug.cgi?id=393471
98# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 99Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
100Patch15: nacl-build-irt.patch
101Patch16: nacl-linkingfix.patch
9516ca97 102Patch18: nacl-no-untar.patch
08b25440 103Patch19: system-jsoncpp.patch
3ee15dec 104Patch21: system-srtp.patch
126ea630 105Patch22: pulse_fix-157876.patch
8fb1dc98 106Patch23: no-pnacl.patch
6897926c 107Patch24: nacl-verbose.patch
c5b396f3
ER
108Patch25: gnome3-volume-control.patch
109Patch26: master-prefs-path.patch
750b48f7 110URL: http://www.chromium.org/Home
ae3fe89f 111%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 112BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
113BuildRequires: alsa-lib-devel
114BuildRequires: atk-devel
115BuildRequires: bison
11ad81c4 116BuildRequires: bzip2-devel
5997e180
ER
117%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
118%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
119%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 120%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 121%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 122BuildRequires: dbus-glib-devel
77f32fa3 123BuildRequires: expat-devel
8f5f6775 124%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 125BuildRequires: flex
11ad81c4 126BuildRequires: fontconfig-devel
f1b276d4 127BuildRequires: glib2-devel
05f72ae2 128BuildRequires: gperf
8b53130d 129BuildRequires: gtk+2-devel
a3140cd1 130%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 131BuildRequires: hicolor-icon-theme
ed514974 132%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
05f72ae2 133BuildRequires: libevent-devel
7f40f3f4 134%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 135BuildRequires: libicu-devel >= 4.6
39c71b4c 136%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 137%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 138BuildRequires: libpng-devel
e266589e 139%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 140BuildRequires: libstdc++-devel
ba685303 141%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 142%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 143%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 144BuildRequires: libxml2-devel
11ad81c4 145BuildRequires: libxslt-devel
f1b276d4 146BuildRequires: lzma
62950103
ER
147%{?with_system_minizip:BuildRequires: minizip-devel}
148%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
149%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
150%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
05f72ae2 151BuildRequires: nspr-devel
f1b276d4 152BuildRequires: nss-devel >= 1:3.12.3
35902862 153BuildRequires: pam-devel
f1b276d4 154BuildRequires: pango-devel
48b341f5 155BuildRequires: perl-modules
156BuildRequires: pkgconfig
ae3fe89f 157%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 158BuildRequires: python
46cdefee 159#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 160BuildRequires: python-modules
0cad051b 161BuildRequires: rpm >= 4.4.9-56
f1b276d4 162BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 163%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 164BuildRequires: sqlite3-devel >= 3.6.1
3ee15dec 165%{?with_system_srtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 166BuildRequires: subversion
0cad051b 167BuildRequires: tar >= 1:1.22
0a424ee2 168BuildRequires: udev-devel
2303ed45 169BuildRequires: util-linux
c14cd342 170%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 171BuildRequires: which
f1b276d4 172BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
173BuildRequires: xorg-lib-libXt-devel
174BuildRequires: xorg-lib-libXtst-devel
836b1cac 175BuildRequires: xz
a3140cd1 176%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 177%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 178Requires: browser-plugins >= 2.0
0cad051b 179Requires: desktop-file-utils
8f5f6775 180%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 181Requires: hicolor-icon-theme
c1edaafa 182%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 183%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
4dc49133 184Requires: xdg-utils >= 1.0.2-4
e53ecfb5 185Provides: wwwbrowser
c3582150 186Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 187Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 188ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 189BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 190
589d90ea 191%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 192
e7fa0817
ER
193# Usage: gyp_with BCOND_NAME [OPTION_NAME]
194%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 195
6b113615
ER
196%if %{without debuginfo}
197%define _enable_debug_packages 0
198%endif
199
11ad81c4 200%description
80838854
ER
201Chromium is an open-source browser project that aims to build a safer,
202faster, and more stable way for all Internet users to experience the
203web.
204
205Chromium serves as a base for Google Chrome, which is Chromium
206rebranded (name and logo) with very few additions such as usage
207tracking and an auto-updater system.
208
f1b276d4
ER
209%package l10n
210Summary: chromium-browser language packages
211Group: I18n
212Requires: %{name} = %{version}-%{release}
213
214%description l10n
215Chromium is an open-source browser project that aims to build a safer,
216faster, and more stable way for all Internet users to experience the
217web.
218
219This package contains language packages for 50 languages:
220
e7fa0817
ER
221ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
222he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
223pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
224zh-TW
f1b276d4
ER
225
226%prep
836b1cac 227%setup -q
589d90ea 228
05f72ae2
ER
229# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
230# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
231. ./src/chrome/VERSION
232ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
233test "$ver" = %{version}
234
235gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 236test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 237
836b1cac 238v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 239
4765ddf1
ER
240# add chromium and pld to useragent
241%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
242sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
243 -e 's/@BUILD_DIST_NAME@/PLD/g' \
244 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 245 < %{PATCH8} | %{__patch} -p1
4765ddf1 246
56c6e811
ER
247%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
248ln -s %{SOURCE7} src
f1b276d4 249
3c73e180 250#%patch10 -p1
05f72ae2 251%patch1 -p1
7abc645c 252%patch3 -p1
72cb20c1 253%patch4 -p1
05f72ae2 254%patch5 -p1
0e5636cb 255%patch6 -p1
5aa5df39 256%patch7 -p1
e9abb380 257%patch15 -p1
77f32fa3 258cd src
c0808220 259%patch9 -p0
f4a8da6a 260%{!?with_libjpegturbo:%patch11 -p0}
5997e180 261%patch16 -p1
08b25440 262%patch19 -p1
3ee15dec 263%patch21 -p1
126ea630 264%patch22 -p1
c5b396f3 265%patch25 -p1
1347c76c 266cd ..
9516ca97 267%patch18 -p1
8fb1dc98 268%patch23 -p1
6897926c 269%patch24 -p1
c5b396f3 270%patch26 -p1
0c480b89 271
828bdd1a 272cd src
e9abb380
ER
273
274# Missing gyp files in tarball.
275# https://code.google.com/p/chromium/issues/detail?id=144823
276if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
277 echo "tarball fixed, please remove workaround"
278 exit 1
279fi
280
281install -d chrome/test/data/nacl
282cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
283{
284 'targets': [
285 {
286 'target_name': 'nacl_tests',
287 'type': 'none',
288 },
289 ],
290}
291EOF
292
30022680 293sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} %{!?with_system_zlib:zlib=0}
164020eb 294
fded59be
ER
295rm -rf native_client/toolchain/linux_x86_newlib
296
e266589e 297%build
f1b276d4 298cd src
5997e180
ER
299
300%if %{with nacl}
fded59be 301if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
5997e180
ER
302# Make symlinks for nacl
303cd native_client/toolchain
304install -d linux_x86_newlib/x86_64-nacl/bin
305install -d linux_x86_newlib/x86_64-nacl/lib
306install -d linux_x86_newlib/x86_64-nacl/lib32
307install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
308install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
309install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
310# link newlib toolchain to glibc as well, see gentoo bug #417019
311#ln -s linux_x86_newlib linux_x86
5997e180 312cd linux_x86_newlib/x86_64-nacl/bin
2e4113fd
ER
313
314__cc='%{__cc}'
315if [ "${__cc}#ccache}" != "$__cc" ]; then
316 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
317 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
318 %{__sed} -i -e '1i#!/bin/sh' gcc g++
319 chmod +x gcc g++
320else
321 ln -s %{_bindir}/x86_64-nacl-gcc gcc
322 ln -s %{_bindir}/x86_64-nacl-g++ g++
323fi
324
5997e180
ER
325ln -s %{_bindir}/x86_64-nacl-ar ar
326ln -s %{_bindir}/x86_64-nacl-as as
327ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
328ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
329ln -s %{_bindir}/x86_64-nacl-strip strip
330ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
331ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
332cd ../nacl/include
333for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
334 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
335done
336cd ../../../../../..
fded59be 337fi
5997e180
ER
338%endif
339
c5b396f3 340test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
341test -e Makefile || %{__python} build/gyp_chromium \
342 --format=make \
343 -Goutput_dir=../out \
344 build/all.gyp \
f1b276d4
ER
345%ifarch %{ix86}
346 -Dtarget_arch=ia32 \
347%endif
348%ifarch %{x8664}
0c480b89
ER
349 -Dtarget_arch=x64 \
350%endif
7b454a31
AM
351%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
352 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
353%endif
354%if %{with sandboxing}
355 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
356 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
357%endif
358 %{!?debug:-Dwerror=} \
c980b122 359 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 360 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 361 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1 362 -Dffmpeg_branding=Chrome \
1fde0856 363 -Dremove_webcore_debug_symbols=1 \
a3140cd1 364 -Dproprietary_codecs=1 \
c0808220 365%if %{with nacl}
038f76b9 366 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
367 -Ddisable_glibc_untar=1 \
368 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
369 -Ddisable_glibc=1 \
370 -Ddisable_pnacl=1 \
371 -Dbuild_pnacl_newlib=0 \
c0808220 372%else
8fb1dc98 373 -Ddisable_pnacl_untar=1 \
c0808220
ER
374 -Ddisable_nacl=1 \
375%endif
a3140cd1
ER
376 %{!?with_sse2:-Ddisable_sse2=1} \
377 %{?with_selinux:-Dselinux=1} \
e7fa0817 378 %{gyp_with cups} \
8dda6bbc 379 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
380 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
381 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
382 %{gyp_with pulseaudio} \
8f5f6775 383 %{gyp_with system_flac} \
62950103
ER
384 %{gyp_with system_libexif} \
385 %{gyp_with system_libmtp} \
581aec44 386 %{gyp_with system_libusb} \
4b411ffe 387 %{gyp_with system_libvpx} \
ba685303 388 %{gyp_with system_libwebp} \
126ea630 389 %{gyp_with system_minizip} \
62950103 390 %{gyp_with system_opus} \
e7fa0817
ER
391 %{gyp_with system_speex} \
392 %{gyp_with system_sqlite} \
393 %{gyp_with system_v8} \
394 %{gyp_with system_yasm} \
395 %{gyp_with system_zlib} \
0c480b89 396 -Duse_system_bzip2=1 \
62950103 397 -Duse_system_expat=1 \
0b214002 398 -Duse_system_icu=1 \
f1b276d4 399 -Duse_system_libevent=1 \
0c480b89 400 -Duse_system_libjpeg=1 \
f1b276d4
ER
401 -Duse_system_libpng=1 \
402 -Duse_system_libxml=1 \
403 -Duse_system_libxslt=1 \
7f40f3f4 404 -Duse_system_xdg_utils=1 \
d8ba130c 405 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
406 -Dlinux_use_gold_binary=0 \
407 -Dlinux_use_gold_flags=0
11ad81c4 408
48ffbc5e 409%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
410 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
411 %{?with_verbose:V=1} \
412 CC="%{__cc}" \
413 CXX="%{__cxx}" \
b7adf6b1 414 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
415 CC.host="%{__cc}" \
416 CXX.host="%{__cxx}" \
b7adf6b1 417 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
418 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
419 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
420
421%install
422rm -rf $RPM_BUILD_ROOT
56c6e811 423install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 424 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 425
673aee14 426cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 427cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
428install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
429%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 430cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 431cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 432install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 433install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 434%if %{with ffmpegsumo}
f1b276d4 435install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 436%endif
e7fa0817 437cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 438cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 439
c0808220
ER
440%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
441
164020eb
ER
442%if %{with nacl}
443# Install Native Client files on platforms that support it.
444install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
445install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
446%ifarch %{x8664}
447install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
448%endif
449%ifarch %{ix86}
450install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
451%endif
452%endif
453
0c480b89
ER
454cd -
455
0eb19b0b
ER
456for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
457 size=${icon##*/product_logo_}
458 size=${size%.png}
459
460 # this will skip non-numeric (22_mono_invert, 22_mono)
461 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
462 test -d "$dir" || continue
463
464 install -d $RPM_BUILD_ROOT$dir
465 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
466done
7f40f3f4 467
13840bc2
AM
468%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
469# http://code.google.com/p/chromium/issues/detail?id=24507
470gecko-mediaplayer*.so
471EOF
11ad81c4 472
589d90ea
ER
473# find locales
474%find_lang %{name}.lang
e7fa0817 475# always package en-US
f1b276d4 476%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 477
11ad81c4
AM
478%clean
479rm -rf $RPM_BUILD_ROOT
480
f1b276d4 481%post
0eb19b0b 482%update_icon_cache hicolor
b7a6e4ee 483%update_desktop_database
f1b276d4
ER
484%update_browser_plugins
485
486%postun
487if [ "$1" = 0 ]; then
0eb19b0b 488 %update_icon_cache hicolor
f1b276d4
ER
489 %update_browser_plugins
490fi
491
1d2b9616 492%files
11ad81c4 493%defattr(644,root,root,755)
531537e5 494%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
495%{_browserpluginsconfdir}/browsers.d/%{name}.*
496%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
497%dir %{_sysconfdir}/%{name}
498%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 499%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
500%attr(755,root,root) %{_bindir}/%{name}
501%{_mandir}/man1/%{name}.1*
11ad81c4 502%{_desktopdir}/*.desktop
0eb19b0b 503%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 504%dir %{_libdir}/%{name}
e9abb380 505%{_libdir}/%{name}/chrome*.pak
c14cd342 506%{_libdir}/%{name}/content_resources.pak
97fac491 507%{_libdir}/%{name}/resources.pak
589d90ea 508%dir %{_libdir}/%{name}/locales
f1b276d4
ER
509%{_libdir}/%{name}/locales/en-US.pak
510%dir %{_libdir}/%{name}/resources
a3140cd1 511%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
512%dir %{_libdir}/%{name}/themes
513%dir %{_libdir}/%{name}/extensions
514%dir %{_libdir}/%{name}/plugins
515%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 516# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 517%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
518
519# ffmpeg libs
d561483d 520%if %{with ffmpegsumo}
f1b276d4 521%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 522%endif
f1b276d4 523
164020eb
ER
524%if %{with nacl}
525%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
526%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
527%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
528%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
529%endif
530
f1b276d4
ER
531%files l10n -f %{name}.lang
532%defattr(644,root,root,755)
This page took 0.170712 seconds and 4 git commands to generate.