]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- BR: udev-devel
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
a3140cd1 10%bcond_with nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
d8ba130c 15%bcond_with tcmalloc # use tcmalloc
2108baf2 16%bcond_with system_sqlite # with system sqlite
32a2443e 17%bcond_without system_flac # with system flac
e8e15592 18%bcond_without system_libwebp # with system libwebp
32a2443e 19%bcond_without system_speex # with system speex
c14cd342 20%bcond_with system_v8 # with system v8
32a2443e 21%bcond_without system_vpx # with system vpx
d617ab39 22%bcond_without system_yasm # with system yasm
2108baf2 23%bcond_without system_zlib # with system zlib
f4a8da6a 24%bcond_without libjpegturbo # use libjpeg-turbo features
2108baf2 25%bcond_with verbose # verbose build (V=1)
0c480b89 26
6d92f81c 27# TODO
f1b276d4 28# - check system sqlite linking problems
2108baf2 29# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 30# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 31# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 32# - use_system_hunspell
32a2443e 33# - use_system_stlport
a3140cd1
ER
34# - other defaults: src/build/common.gypi
35
e53ecfb5 36# NOTES:
4fe038cb
ER
37# - mute BEEP mixer if you do not want to hear horrible system bell when
38# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
39# - build -bp: 1.2G
40# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 41# - build x86_64: ~1.9G
f1b276d4 42# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 43# - to look for new tarball, use update-source.sh script
f1b276d4 44
e68aa7e7 45# NOTE TO USERS:
a3cc7091
ER
46# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
47# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 48# or:
a3cc7091 49# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 50
a3140cd1 51%define gyp_rev 1014
11ad81c4 52Summary: A WebKit powered web browser
05f72ae2 53Name: chromium-browser
d81028b2 54Version: 20.0.1132.21
3cbdf9e3 55Release: 0.1
05f72ae2 56License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 57Group: X11/Applications/Networking
53366f87 58Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
d81028b2 59# Source0-md5: 4a0c114b0fb86f5f4d0daa02fdd33c89
37ceaf05 60Source1: %{name}.default
8b53130d
ER
61Source2: %{name}.sh
62Source3: %{name}.desktop
56c6e811
ER
63Source5: find-lang.sh
64Source6: update-source.sh
65Source7: clean-source.sh
836b1cac 66Source8: get-source.sh
48b341f5 67Patch0: system-libs.patch
68Patch1: plugin-searchdirs.patch
69Patch2: gyp-system-minizip.patch
7abc645c 70Patch3: disable_dlog_and_dcheck_in_release_builds.patch
48b341f5 71Patch5: options-support.patch
0e5636cb 72Patch6: get-webkit_revision.patch
5aa5df39 73Patch7: dlopen_sonamed_gl.patch
4765ddf1 74Patch8: chromium_useragent.patch.in
77f32fa3 75Patch9: system-expat.patch
f4a8da6a 76Patch10: %{name}-pulse.patch
1347c76c
AM
77# https://bugs.gentoo.org/show_bug.cgi?id=393471
78# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 79Patch11: chromium-revert-jpeg-swizzle-r2.patch
d8ba130c 80Patch12: tcmalloc.patch
750b48f7 81URL: http://www.chromium.org/Home
ae3fe89f 82%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 83BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
84BuildRequires: alsa-lib-devel
85BuildRequires: atk-devel
86BuildRequires: bison
11ad81c4 87BuildRequires: bzip2-devel
ae3fe89f 88%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 89BuildRequires: dbus-glib-devel
77f32fa3 90BuildRequires: expat-devel
d617ab39 91%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 92BuildRequires: flex
11ad81c4 93BuildRequires: fontconfig-devel
f1b276d4 94BuildRequires: glib2-devel
05f72ae2 95BuildRequires: gperf
8b53130d 96BuildRequires: gtk+2-devel
a3140cd1 97%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 98BuildRequires: hicolor-icon-theme
05f72ae2 99BuildRequires: libevent-devel
7f40f3f4 100%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 101BuildRequires: libicu-devel >= 4.6
05f72ae2 102BuildRequires: libjpeg-devel
f4a8da6a 103%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 104BuildRequires: libpng-devel
e266589e 105%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 106BuildRequires: libstdc++-devel
32a2443e 107%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
71b67d16 108%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.3}
f1b276d4 109BuildRequires: libxml2-devel
11ad81c4 110BuildRequires: libxslt-devel
f1b276d4 111BuildRequires: lzma
11ad81c4 112BuildRequires: minizip-devel
164020eb 113%{?with_nacl:BuildRequires: nacl-toolchain-newlib >= 0.6941}
05f72ae2 114BuildRequires: nspr-devel
f1b276d4 115BuildRequires: nss-devel >= 1:3.12.3
35902862 116BuildRequires: pam-devel
f1b276d4 117BuildRequires: pango-devel
48b341f5 118BuildRequires: perl-modules
119BuildRequires: pkgconfig
ae3fe89f 120%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 121BuildRequires: python
46cdefee 122#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 123BuildRequires: python-modules
0cad051b 124BuildRequires: rpm >= 4.4.9-56
f1b276d4 125BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 126%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 127BuildRequires: sqlite3-devel >= 3.6.1
0cad051b 128BuildRequires: tar >= 1:1.22
0a424ee2 129BuildRequires: udev-devel
2303ed45 130BuildRequires: util-linux
c14cd342 131%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 132BuildRequires: which
f1b276d4 133BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
134BuildRequires: xorg-lib-libXt-devel
135BuildRequires: xorg-lib-libXtst-devel
836b1cac 136BuildRequires: xz
a3140cd1 137%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 138%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 139Requires: browser-plugins >= 2.0
0cad051b 140Requires: desktop-file-utils
0eb19b0b 141Requires: hicolor-icon-theme
c1edaafa 142%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 143%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 144Requires: xdg-utils >= 1.0.2-4
e53ecfb5 145Provides: wwwbrowser
c3582150 146Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 147Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 148ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 149BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 150
589d90ea 151%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
152# Usage: gyp_with BCOND_NAME [OPTION_NAME]
153%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 154
6b113615
ER
155%if %{without debuginfo}
156%define _enable_debug_packages 0
157%endif
158
11ad81c4 159%description
80838854
ER
160Chromium is an open-source browser project that aims to build a safer,
161faster, and more stable way for all Internet users to experience the
162web.
163
164Chromium serves as a base for Google Chrome, which is Chromium
165rebranded (name and logo) with very few additions such as usage
166tracking and an auto-updater system.
167
f1b276d4
ER
168%package l10n
169Summary: chromium-browser language packages
170Group: I18n
171Requires: %{name} = %{version}-%{release}
172
173%description l10n
174Chromium is an open-source browser project that aims to build a safer,
175faster, and more stable way for all Internet users to experience the
176web.
177
178This package contains language packages for 50 languages:
179
e7fa0817
ER
180ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
181he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
182pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
183zh-TW
f1b276d4
ER
184
185%prep
836b1cac 186%setup -q
589d90ea 187
05f72ae2
ER
188# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
189# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
190. ./src/chrome/VERSION
191ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
192test "$ver" = %{version}
193
194gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 195test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 196
836b1cac 197v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 198
f1b276d4 199# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
836b1cac 200#echo "%{svnver}" > src/build/LASTCHANGE.in
f1b276d4 201
4765ddf1
ER
202# add chromium and pld to useragent
203%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
204sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
205 -e 's/@BUILD_DIST_NAME@/PLD/g' \
206 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 207 < %{PATCH8} | %{__patch} -p1
4765ddf1 208
56c6e811
ER
209%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
210ln -s %{SOURCE7} src
f1b276d4 211
05f72ae2
ER
212%patch0 -p1
213%patch1 -p1
214%patch2 -p1
7abc645c 215%patch3 -p1
05f72ae2 216%patch5 -p1
0e5636cb 217%patch6 -p1
5aa5df39 218%patch7 -p1
77f32fa3
ER
219cd src
220%patch9 -p1
bdbf9a94 221%patch10 -p1
f4a8da6a 222%{!?with_libjpegturbo:%patch11 -p0}
d8ba130c 223%patch12 -p0
1347c76c 224cd ..
0c480b89 225
828bdd1a 226cd src
f8e29f37 227sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0
164020eb 228
e266589e 229%build
f1b276d4 230cd src
164020eb 231test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
232%ifarch %{ix86}
233 -Dtarget_arch=ia32 \
234%endif
235%ifarch %{x8664}
0c480b89
ER
236 -Dtarget_arch=x64 \
237%endif
7b454a31
AM
238%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
239 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
240%endif
241%if %{with sandboxing}
242 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
243 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
244%endif
245 %{!?debug:-Dwerror=} \
c980b122 246 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 247 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 248 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
249 -Dffmpeg_branding=Chrome \
250 -Dproprietary_codecs=1 \
5a6de706 251 %{!?with_nacl:-Ddisable_nacl=1} \
a3140cd1
ER
252 %{!?with_sse2:-Ddisable_sse2=1} \
253 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
254 %{gyp_with cups} \
255 %{gyp_with flac} \
256 %{gyp_with gconf} \
257 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
258 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
259 %{gyp_with pulseaudio} \
e8e15592 260 %{gyp_with system_libwebp} \
e7fa0817
ER
261 %{gyp_with system_speex} \
262 %{gyp_with system_sqlite} \
263 %{gyp_with system_v8} \
32a2443e 264 %{gyp_with system_vpx} \
e7fa0817
ER
265 %{gyp_with system_yasm} \
266 %{gyp_with system_zlib} \
0c480b89 267 -Duse_system_bzip2=1 \
0b214002 268 -Duse_system_icu=1 \
f1b276d4 269 -Duse_system_libevent=1 \
0c480b89 270 -Duse_system_libjpeg=1 \
f1b276d4
ER
271 -Duse_system_libpng=1 \
272 -Duse_system_libxml=1 \
273 -Duse_system_libxslt=1 \
7f40f3f4 274 -Duse_system_xdg_utils=1 \
d8ba130c 275 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
276 -Dlinux_use_gold_binary=0 \
277 -Dlinux_use_gold_flags=0
11ad81c4 278
f1b276d4
ER
279%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
280 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
281 %{?with_verbose:V=1} \
282 CC="%{__cc}" \
283 CXX="%{__cxx}" \
b7adf6b1 284 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
285 CC.host="%{__cc}" \
286 CXX.host="%{__cxx}" \
b7adf6b1 287 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
288 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
289 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
290
291%install
292rm -rf $RPM_BUILD_ROOT
56c6e811 293install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 294 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 295
f1b276d4 296cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 297cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
298install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
299%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 300cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 301cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 302install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 303install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 304%if %{with ffmpegsumo}
f1b276d4 305install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 306%endif
e7fa0817 307cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb
ER
308
309%if %{with nacl}
310# Install Native Client files on platforms that support it.
311install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
312install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
313%ifarch %{x8664}
314install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
315%endif
316%ifarch %{ix86}
317install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
318%endif
319%endif
320
0c480b89
ER
321cd -
322
0eb19b0b
ER
323for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
324 size=${icon##*/product_logo_}
325 size=${size%.png}
326
327 # this will skip non-numeric (22_mono_invert, 22_mono)
328 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
329 test -d "$dir" || continue
330
331 install -d $RPM_BUILD_ROOT$dir
332 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
333done
7f40f3f4 334
13840bc2
AM
335%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
336# http://code.google.com/p/chromium/issues/detail?id=24507
337gecko-mediaplayer*.so
338EOF
11ad81c4 339
589d90ea
ER
340# find locales
341%find_lang %{name}.lang
e7fa0817 342# always package en-US
f1b276d4 343%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 344
11ad81c4
AM
345%clean
346rm -rf $RPM_BUILD_ROOT
347
f1b276d4 348%post
0eb19b0b 349%update_icon_cache hicolor
b7a6e4ee 350%update_desktop_database
f1b276d4
ER
351%update_browser_plugins
352
353%postun
354if [ "$1" = 0 ]; then
0eb19b0b 355 %update_icon_cache hicolor
f1b276d4
ER
356 %update_browser_plugins
357fi
358
589d90ea 359%files -f %{name}.lang
11ad81c4 360%defattr(644,root,root,755)
f1b276d4
ER
361%{_browserpluginsconfdir}/browsers.d/%{name}.*
362%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
363%dir %{_sysconfdir}/%{name}
364%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
365%attr(755,root,root) %{_bindir}/%{name}
366%{_mandir}/man1/%{name}.1*
11ad81c4 367%{_desktopdir}/*.desktop
0eb19b0b 368%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89
ER
369%dir %{_libdir}/%{name}
370%{_libdir}/%{name}/chrome.pak
c14cd342 371%{_libdir}/%{name}/content_resources.pak
97fac491 372%{_libdir}/%{name}/resources.pak
bbe92394
AM
373%{_libdir}/%{name}/theme_resources_standard.pak
374%{_libdir}/%{name}/ui_resources_standard.pak
589d90ea 375%dir %{_libdir}/%{name}/locales
f1b276d4
ER
376%{_libdir}/%{name}/locales/en-US.pak
377%dir %{_libdir}/%{name}/resources
a3140cd1 378%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
379%dir %{_libdir}/%{name}/themes
380%dir %{_libdir}/%{name}/extensions
381%dir %{_libdir}/%{name}/plugins
382%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 383# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 384%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
385
386# ffmpeg libs
d561483d 387%if %{with ffmpegsumo}
f1b276d4 388%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 389%endif
f1b276d4 390
164020eb
ER
391%if %{with nacl}
392%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
393%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
394%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
395%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
396%endif
397
f1b276d4
ER
398%files l10n -f %{name}.lang
399%defattr(644,root,root,755)
This page took 0.108488 seconds and 4 git commands to generate.