]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- up to 19.0.1084.46
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
a3140cd1 10%bcond_with nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
15%bcond_with system_sqlite # with system sqlite
32a2443e 16%bcond_without system_flac # with system flac
e8e15592 17%bcond_without system_libwebp # with system libwebp
32a2443e 18%bcond_without system_speex # with system speex
c14cd342 19%bcond_with system_v8 # with system v8
32a2443e 20%bcond_without system_vpx # with system vpx
d617ab39 21%bcond_without system_yasm # with system yasm
2108baf2 22%bcond_without system_zlib # with system zlib
f4a8da6a 23%bcond_without libjpegturbo # use libjpeg-turbo features
2108baf2 24%bcond_with verbose # verbose build (V=1)
0c480b89 25
6d92f81c 26# TODO
f1b276d4 27# - check system sqlite linking problems
2108baf2 28# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 29# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 30# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 31# - use_system_hunspell
32a2443e 32# - use_system_stlport
a3140cd1
ER
33# - other defaults: src/build/common.gypi
34
e53ecfb5 35# NOTES:
4fe038cb
ER
36# - mute BEEP mixer if you do not want to hear horrible system bell when
37# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
38# - build -bp: 1.2G
39# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 40# - build x86_64: ~1.9G
f1b276d4 41# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 42# - to look for new tarball, use update-source.sh script
f1b276d4 43
e68aa7e7 44# NOTE TO USERS:
a3cc7091
ER
45# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
46# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 47# or:
a3cc7091 48# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 49
a3140cd1 50%define gyp_rev 1014
11ad81c4 51Summary: A WebKit powered web browser
05f72ae2 52Name: chromium-browser
f97b357d 53Version: 19.0.1084.46
53366f87 54Release: 0.1
05f72ae2 55License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 56Group: X11/Applications/Networking
53366f87 57Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
f97b357d 58# Source0-md5: 6119a345de59252ba219f8b2ed9d71a4
8b53130d
ER
59Source2: %{name}.sh
60Source3: %{name}.desktop
56c6e811
ER
61Source5: find-lang.sh
62Source6: update-source.sh
63Source7: clean-source.sh
836b1cac 64Source8: get-source.sh
48b341f5 65Patch0: system-libs.patch
66Patch1: plugin-searchdirs.patch
67Patch2: gyp-system-minizip.patch
7abc645c 68Patch3: disable_dlog_and_dcheck_in_release_builds.patch
48b341f5 69Patch5: options-support.patch
0e5636cb 70Patch6: get-webkit_revision.patch
5aa5df39 71Patch7: dlopen_sonamed_gl.patch
4765ddf1 72Patch8: chromium_useragent.patch.in
77f32fa3 73Patch9: system-expat.patch
f4a8da6a 74Patch10: %{name}-pulse.patch
1347c76c
AM
75# https://bugs.gentoo.org/show_bug.cgi?id=393471
76# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 77Patch11: chromium-revert-jpeg-swizzle-r2.patch
1b73dacf
ER
78# https://code.google.com/p/chromium/issues/detail?id=119903
79Patch12: http://archrepo.jeago.com/sources/chromium-dev/pulse_output_fix.diff
80# Patch12-md5: e3a9539e16fc6c2336b8e709ac76b0f2
750b48f7 81URL: http://www.chromium.org/Home
ae3fe89f 82%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 83BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
84BuildRequires: alsa-lib-devel
85BuildRequires: atk-devel
86BuildRequires: bison
11ad81c4 87BuildRequires: bzip2-devel
ae3fe89f 88%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 89BuildRequires: dbus-glib-devel
77f32fa3 90BuildRequires: expat-devel
d617ab39 91%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 92BuildRequires: flex
11ad81c4 93BuildRequires: fontconfig-devel
f1b276d4 94BuildRequires: glib2-devel
05f72ae2 95BuildRequires: gperf
8b53130d 96BuildRequires: gtk+2-devel
a3140cd1 97%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 98BuildRequires: hicolor-icon-theme
05f72ae2 99BuildRequires: libevent-devel
7f40f3f4 100%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 101BuildRequires: libicu-devel >= 4.6
05f72ae2 102BuildRequires: libjpeg-devel
f4a8da6a 103%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 104BuildRequires: libpng-devel
e266589e 105%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 106BuildRequires: libstdc++-devel
32a2443e 107%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
e8e15592 108%{?with_system_libwebp:BuildRequires: libwebp-devel}
f1b276d4 109BuildRequires: libxml2-devel
11ad81c4 110BuildRequires: libxslt-devel
f1b276d4 111BuildRequires: lzma
11ad81c4 112BuildRequires: minizip-devel
164020eb 113%{?with_nacl:BuildRequires: nacl-toolchain-newlib >= 0.6941}
05f72ae2 114BuildRequires: nspr-devel
f1b276d4 115BuildRequires: nss-devel >= 1:3.12.3
35902862 116BuildRequires: pam-devel
f1b276d4 117BuildRequires: pango-devel
48b341f5 118BuildRequires: perl-modules
119BuildRequires: pkgconfig
ae3fe89f 120%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 121BuildRequires: python
46cdefee 122#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 123BuildRequires: python-modules
0cad051b 124BuildRequires: rpm >= 4.4.9-56
f1b276d4 125BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 126%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 127BuildRequires: sqlite3-devel >= 3.6.1
0cad051b 128BuildRequires: tar >= 1:1.22
2303ed45 129BuildRequires: util-linux
c14cd342 130%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 131BuildRequires: which
f1b276d4 132BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
133BuildRequires: xorg-lib-libXt-devel
134BuildRequires: xorg-lib-libXtst-devel
836b1cac 135BuildRequires: xz
a3140cd1 136%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 137%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 138Requires: browser-plugins >= 2.0
0cad051b 139Requires: desktop-file-utils
0eb19b0b 140Requires: hicolor-icon-theme
32a2443e 141%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 142Requires: xdg-utils >= 1.0.2-4
f4a8da6a 143%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
e53ecfb5 144Provides: wwwbrowser
c3582150 145Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 146Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 147ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 148BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 149
589d90ea 150%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
151# Usage: gyp_with BCOND_NAME [OPTION_NAME]
152%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 153
6b113615
ER
154%if %{without debuginfo}
155%define _enable_debug_packages 0
156%endif
157
11ad81c4 158%description
80838854
ER
159Chromium is an open-source browser project that aims to build a safer,
160faster, and more stable way for all Internet users to experience the
161web.
162
163Chromium serves as a base for Google Chrome, which is Chromium
164rebranded (name and logo) with very few additions such as usage
165tracking and an auto-updater system.
166
f1b276d4
ER
167%package l10n
168Summary: chromium-browser language packages
169Group: I18n
170Requires: %{name} = %{version}-%{release}
171
172%description l10n
173Chromium is an open-source browser project that aims to build a safer,
174faster, and more stable way for all Internet users to experience the
175web.
176
177This package contains language packages for 50 languages:
178
e7fa0817
ER
179ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
180he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
181pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
182zh-TW
f1b276d4
ER
183
184%prep
836b1cac 185%setup -q
589d90ea 186
05f72ae2
ER
187# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
188# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
189. ./src/chrome/VERSION
190ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
191test "$ver" = %{version}
192
193gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 194test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 195
836b1cac 196v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 197
f1b276d4 198# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
836b1cac 199#echo "%{svnver}" > src/build/LASTCHANGE.in
f1b276d4 200
4765ddf1
ER
201# add chromium and pld to useragent
202%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
203sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
204 -e 's/@BUILD_DIST_NAME@/PLD/g' \
205 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 206 < %{PATCH8} | %{__patch} -p1
4765ddf1 207
56c6e811
ER
208%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
209ln -s %{SOURCE7} src
f1b276d4 210
05f72ae2
ER
211%patch0 -p1
212%patch1 -p1
213%patch2 -p1
7abc645c 214%patch3 -p1
05f72ae2 215%patch5 -p1
0e5636cb 216%patch6 -p1
5aa5df39 217%patch7 -p1
77f32fa3
ER
218cd src
219%patch9 -p1
bdbf9a94 220%patch10 -p1
f4a8da6a 221%{!?with_libjpegturbo:%patch11 -p0}
1b73dacf 222%patch12 -p0
1347c76c 223cd ..
0c480b89 224
828bdd1a 225cd src
cd09b941 226sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0}
164020eb 227
e266589e 228%build
f1b276d4 229cd src
164020eb 230test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
231%ifarch %{ix86}
232 -Dtarget_arch=ia32 \
233%endif
234%ifarch %{x8664}
0c480b89
ER
235 -Dtarget_arch=x64 \
236%endif
7b454a31
AM
237%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
238 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
239%endif
240%if %{with sandboxing}
241 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
242 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
243%endif
244 %{!?debug:-Dwerror=} \
c980b122 245 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 246 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 247 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
248 -Dffmpeg_branding=Chrome \
249 -Dproprietary_codecs=1 \
5a6de706 250 %{!?with_nacl:-Ddisable_nacl=1} \
a3140cd1
ER
251 %{!?with_sse2:-Ddisable_sse2=1} \
252 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
253 %{gyp_with cups} \
254 %{gyp_with flac} \
255 %{gyp_with gconf} \
256 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
257 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
258 %{gyp_with pulseaudio} \
e8e15592 259 %{gyp_with system_libwebp} \
e7fa0817
ER
260 %{gyp_with system_speex} \
261 %{gyp_with system_sqlite} \
262 %{gyp_with system_v8} \
32a2443e 263 %{gyp_with system_vpx} \
e7fa0817
ER
264 %{gyp_with system_yasm} \
265 %{gyp_with system_zlib} \
0c480b89 266 -Duse_system_bzip2=1 \
0b214002 267 -Duse_system_icu=1 \
f1b276d4 268 -Duse_system_libevent=1 \
0c480b89 269 -Duse_system_libjpeg=1 \
f1b276d4
ER
270 -Duse_system_libpng=1 \
271 -Duse_system_libxml=1 \
272 -Duse_system_libxslt=1 \
7f40f3f4 273 -Duse_system_xdg_utils=1 \
44f353ec
AM
274 -Dlinux_use_gold_binary=0 \
275 -Dlinux_use_gold_flags=0
11ad81c4 276
f1b276d4
ER
277%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
278 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
279 %{?with_verbose:V=1} \
280 CC="%{__cc}" \
281 CXX="%{__cxx}" \
b7adf6b1 282 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
283 CC.host="%{__cc}" \
284 CXX.host="%{__cxx}" \
b7adf6b1 285 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
286 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
287 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
288
289%install
290rm -rf $RPM_BUILD_ROOT
56c6e811 291install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
0eb19b0b 292 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}}
e266589e 293
f1b276d4 294cd src/out/%{!?debug:Release}%{?debug:Debug}
f1b276d4
ER
295install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
296%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 297cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 298cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 299install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 300install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 301%if %{with ffmpegsumo}
f1b276d4 302install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 303%endif
e7fa0817 304cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb
ER
305
306%if %{with nacl}
307# Install Native Client files on platforms that support it.
308install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
309install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
310%ifarch %{x8664}
311install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
312%endif
313%ifarch %{ix86}
314install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
315%endif
316%endif
317
0c480b89
ER
318cd -
319
0eb19b0b
ER
320for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
321 size=${icon##*/product_logo_}
322 size=${size%.png}
323
324 # this will skip non-numeric (22_mono_invert, 22_mono)
325 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
326 test -d "$dir" || continue
327
328 install -d $RPM_BUILD_ROOT$dir
329 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
330done
7f40f3f4 331
13840bc2
AM
332%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
333# http://code.google.com/p/chromium/issues/detail?id=24507
334gecko-mediaplayer*.so
335EOF
11ad81c4 336
589d90ea
ER
337# find locales
338%find_lang %{name}.lang
e7fa0817 339# always package en-US
f1b276d4 340%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 341
11ad81c4
AM
342%clean
343rm -rf $RPM_BUILD_ROOT
344
f1b276d4 345%post
0eb19b0b 346%update_icon_cache hicolor
b7a6e4ee 347%update_desktop_database
f1b276d4
ER
348%update_browser_plugins
349
350%postun
351if [ "$1" = 0 ]; then
0eb19b0b 352 %update_icon_cache hicolor
f1b276d4
ER
353 %update_browser_plugins
354fi
355
589d90ea 356%files -f %{name}.lang
11ad81c4 357%defattr(644,root,root,755)
f1b276d4
ER
358%{_browserpluginsconfdir}/browsers.d/%{name}.*
359%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
360%attr(755,root,root) %{_bindir}/%{name}
361%{_mandir}/man1/%{name}.1*
11ad81c4 362%{_desktopdir}/*.desktop
0eb19b0b 363%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89
ER
364%dir %{_libdir}/%{name}
365%{_libdir}/%{name}/chrome.pak
c14cd342 366%{_libdir}/%{name}/content_resources.pak
97fac491 367%{_libdir}/%{name}/resources.pak
589d90ea 368%dir %{_libdir}/%{name}/locales
f1b276d4
ER
369%{_libdir}/%{name}/locales/en-US.pak
370%dir %{_libdir}/%{name}/resources
a3140cd1 371%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
372%dir %{_libdir}/%{name}/themes
373%dir %{_libdir}/%{name}/extensions
374%dir %{_libdir}/%{name}/plugins
375%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 376# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 377%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
378
379# ffmpeg libs
d561483d 380%if %{with ffmpegsumo}
f1b276d4 381%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 382%endif
f1b276d4 383
164020eb
ER
384%if %{with nacl}
385%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
386%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
387%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
388%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
389%endif
390
f1b276d4
ER
391%files l10n -f %{name}.lang
392%defattr(644,root,root,755)
This page took 0.091697 seconds and 4 git commands to generate.