]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
xz -e
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2
ER
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without ffmpegsumo # build with ffmpegsumo
ba685303 6%bcond_without gconf # with GConf
8171fe68 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303
ER
16%bcond_without system_flac # system flac
17%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
18%bcond_without system_libexif # system libexif
19%bcond_without system_libmtp # system libmtp
ba685303
ER
20%bcond_without system_libusb # system libusb-1
21%bcond_without system_libwebp # system libwebp
126ea630 22%bcond_without system_minizip # system minizip
62950103 23%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
ba685303
ER
24%bcond_without system_speex # system speex
25%bcond_with system_sqlite # system sqlite
3ee15dec 26%bcond_without system_srtp # system srtp (can be used if using bundled libjingle)
ba685303 27%bcond_with system_v8 # system v8
4b411ffe 28%bcond_without system_libvpx # system libvpx
ba685303 29%bcond_without system_yasm # system yasm
1c00315b 30%bcond_without system_zlib # system zlib
ba685303 31%bcond_with tcmalloc # use tcmalloc
7e136323 32%bcond_without verbose # verbose build (V=1)
0c480b89 33
c6325ea2
ER
34%if %{with nacl}
35# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
36# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
37#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
38#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
39#14:51:06 @baggins> as-needed will take care of unneeded lib
40#14:52:03 @baggins> -lssp comes with gcc
107b55fe 41%define _ssp_cflags %{nil}
c6325ea2
ER
42%endif
43
6d92f81c 44# TODO
f1b276d4 45# - check system sqlite linking problems
2108baf2 46# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 47# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 48# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 49# - use_system_hunspell
32a2443e 50# - use_system_stlport
a3140cd1
ER
51# - other defaults: src/build/common.gypi
52
e53ecfb5 53# NOTES:
4fe038cb
ER
54# - mute BEEP mixer if you do not want to hear horrible system bell when
55# pressing home/end in url bar or more ^F search results on page.
7c638678 56# - space considerations:
c1ecd31f
ER
57# - unpacked sources: ~668MiB
58# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 59# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 60# - to look for new tarball, use update-source.sh script
f1b276d4 61
e68aa7e7 62# NOTE TO USERS:
c8b02491 63# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 64# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 65# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 66
a3140cd1 67%define gyp_rev 1014
11ad81c4 68Summary: A WebKit powered web browser
05f72ae2 69Name: chromium-browser
126ea630 70Version: 24.0.1312.45
c1ecd31f 71Release: 0.15
05f72ae2 72License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 73Group: X11/Applications/Networking
c1ecd31f 74Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
126ea630 75# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
37ceaf05 76Source1: %{name}.default
8b53130d
ER
77Source2: %{name}.sh
78Source3: %{name}.desktop
56c6e811
ER
79Source5: find-lang.sh
80Source6: update-source.sh
81Source7: clean-source.sh
836b1cac 82Source8: get-source.sh
0562b864 83Source9: master_preferences.json
3c73e180 84#Patch10: system-libs.patch
48b341f5 85Patch1: plugin-searchdirs.patch
7abc645c 86Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 87Patch4: path-libpdf.patch
48b341f5 88Patch5: options-support.patch
0e5636cb 89Patch6: get-webkit_revision.patch
5aa5df39 90Patch7: dlopen_sonamed_gl.patch
4765ddf1 91Patch8: chromium_useragent.patch.in
c0808220 92Patch9: chromium-ppapi.patch
1347c76c
AM
93# https://bugs.gentoo.org/show_bug.cgi?id=393471
94# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 95Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
96Patch15: nacl-build-irt.patch
97Patch16: nacl-linkingfix.patch
9516ca97 98Patch18: nacl-no-untar.patch
08b25440 99Patch19: system-jsoncpp.patch
3ee15dec 100Patch21: system-srtp.patch
126ea630 101Patch22: pulse_fix-157876.patch
8fb1dc98 102Patch23: no-pnacl.patch
6897926c 103Patch24: nacl-verbose.patch
c5b396f3
ER
104Patch25: gnome3-volume-control.patch
105Patch26: master-prefs-path.patch
750b48f7 106URL: http://www.chromium.org/Home
ae3fe89f 107%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 108BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
109BuildRequires: alsa-lib-devel
110BuildRequires: atk-devel
111BuildRequires: bison
11ad81c4 112BuildRequires: bzip2-devel
5997e180
ER
113%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
114%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
115%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 116%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 117%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 118BuildRequires: dbus-glib-devel
77f32fa3 119BuildRequires: expat-devel
8f5f6775 120%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 121BuildRequires: flex
11ad81c4 122BuildRequires: fontconfig-devel
f1b276d4 123BuildRequires: glib2-devel
05f72ae2 124BuildRequires: gperf
8b53130d 125BuildRequires: gtk+2-devel
a3140cd1 126%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 127BuildRequires: hicolor-icon-theme
ed514974 128%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
05f72ae2 129BuildRequires: libevent-devel
7f40f3f4 130%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 131BuildRequires: libicu-devel >= 4.6
39c71b4c 132%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 133%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 134BuildRequires: libpng-devel
e266589e 135%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 136BuildRequires: libstdc++-devel
ba685303 137%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 138%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 139%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 140BuildRequires: libxml2-devel
11ad81c4 141BuildRequires: libxslt-devel
f1b276d4 142BuildRequires: lzma
62950103
ER
143%{?with_system_minizip:BuildRequires: minizip-devel}
144%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
145%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
146%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
05f72ae2 147BuildRequires: nspr-devel
f1b276d4 148BuildRequires: nss-devel >= 1:3.12.3
35902862 149BuildRequires: pam-devel
f1b276d4 150BuildRequires: pango-devel
48b341f5 151BuildRequires: perl-modules
152BuildRequires: pkgconfig
ae3fe89f 153%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 154BuildRequires: python
46cdefee 155#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 156BuildRequires: python-modules
0cad051b 157BuildRequires: rpm >= 4.4.9-56
f1b276d4 158BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 159%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 160BuildRequires: sqlite3-devel >= 3.6.1
3ee15dec 161%{?with_system_srtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 162BuildRequires: subversion
0cad051b 163BuildRequires: tar >= 1:1.22
0a424ee2 164BuildRequires: udev-devel
2303ed45 165BuildRequires: util-linux
c14cd342 166%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 167BuildRequires: which
f1b276d4 168BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
169BuildRequires: xorg-lib-libXt-devel
170BuildRequires: xorg-lib-libXtst-devel
836b1cac 171BuildRequires: xz
a3140cd1 172%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 173%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 174Requires: browser-plugins >= 2.0
0cad051b 175Requires: desktop-file-utils
8f5f6775 176%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 177Requires: hicolor-icon-theme
c1edaafa 178%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 179%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
4dc49133 180Requires: xdg-utils >= 1.0.2-4
e53ecfb5 181Provides: wwwbrowser
c3582150 182Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 183Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 184ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 185BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 186
589d90ea 187%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 188
e7fa0817
ER
189# Usage: gyp_with BCOND_NAME [OPTION_NAME]
190%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 191
6b113615
ER
192%if %{without debuginfo}
193%define _enable_debug_packages 0
194%endif
195
11ad81c4 196%description
80838854
ER
197Chromium is an open-source browser project that aims to build a safer,
198faster, and more stable way for all Internet users to experience the
199web.
200
201Chromium serves as a base for Google Chrome, which is Chromium
202rebranded (name and logo) with very few additions such as usage
203tracking and an auto-updater system.
204
f1b276d4
ER
205%package l10n
206Summary: chromium-browser language packages
207Group: I18n
208Requires: %{name} = %{version}-%{release}
209
210%description l10n
211Chromium is an open-source browser project that aims to build a safer,
212faster, and more stable way for all Internet users to experience the
213web.
214
215This package contains language packages for 50 languages:
216
e7fa0817
ER
217ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
218he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
219pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
220zh-TW
f1b276d4
ER
221
222%prep
836b1cac 223%setup -q
589d90ea 224
05f72ae2
ER
225# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
226# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
227. ./src/chrome/VERSION
228ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
229test "$ver" = %{version}
230
231gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 232test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 233
836b1cac 234v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 235
4765ddf1
ER
236# add chromium and pld to useragent
237%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
238sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
239 -e 's/@BUILD_DIST_NAME@/PLD/g' \
240 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 241 < %{PATCH8} | %{__patch} -p1
4765ddf1 242
56c6e811
ER
243%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
244ln -s %{SOURCE7} src
f1b276d4 245
3c73e180 246#%patch10 -p1
05f72ae2 247%patch1 -p1
7abc645c 248%patch3 -p1
72cb20c1 249%patch4 -p1
05f72ae2 250%patch5 -p1
0e5636cb 251%patch6 -p1
5aa5df39 252%patch7 -p1
e9abb380 253%patch15 -p1
77f32fa3 254cd src
c0808220 255%patch9 -p0
f4a8da6a 256%{!?with_libjpegturbo:%patch11 -p0}
5997e180 257%patch16 -p1
08b25440 258%patch19 -p1
3ee15dec 259%patch21 -p1
126ea630 260%patch22 -p1
c5b396f3 261%patch25 -p1
1347c76c 262cd ..
9516ca97 263%patch18 -p1
8fb1dc98 264%patch23 -p1
6897926c 265%patch24 -p1
c5b396f3 266%patch26 -p1
0c480b89 267
828bdd1a 268cd src
e9abb380
ER
269
270# Missing gyp files in tarball.
271# https://code.google.com/p/chromium/issues/detail?id=144823
272if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
273 echo "tarball fixed, please remove workaround"
274 exit 1
275fi
276
277install -d chrome/test/data/nacl
278cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
279{
280 'targets': [
281 {
282 'target_name': 'nacl_tests',
283 'type': 'none',
284 },
285 ],
286}
287EOF
288
30022680 289sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} %{!?with_system_zlib:zlib=0}
164020eb 290
e266589e 291%build
f1b276d4 292cd src
5997e180
ER
293
294%if %{with nacl}
fded59be 295if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b
ER
296# Make symlinks for NaCL
297install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
2e4113fd 298
dcea0d6b 299cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
2e4113fd
ER
300__cc='%{__cc}'
301if [ "${__cc}#ccache}" != "$__cc" ]; then
302 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
303 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
304 %{__sed} -i -e '1i#!/bin/sh' gcc g++
305 chmod +x gcc g++
306else
307 ln -s %{_bindir}/x86_64-nacl-gcc gcc
308 ln -s %{_bindir}/x86_64-nacl-g++ g++
309fi
5997e180
ER
310ln -s %{_bindir}/x86_64-nacl-ar ar
311ln -s %{_bindir}/x86_64-nacl-as as
312ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
313ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
314ln -s %{_bindir}/x86_64-nacl-strip strip
dcea0d6b
ER
315ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
316ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
317ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
318cd ../../../../..
fded59be 319fi
5997e180
ER
320%endif
321
c5b396f3 322test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
323test -e Makefile || %{__python} build/gyp_chromium \
324 --format=make \
325 -Goutput_dir=../out \
326 build/all.gyp \
f1b276d4
ER
327%ifarch %{ix86}
328 -Dtarget_arch=ia32 \
329%endif
330%ifarch %{x8664}
0c480b89
ER
331 -Dtarget_arch=x64 \
332%endif
7b454a31
AM
333%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
334 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
335%endif
336%if %{with sandboxing}
337 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
338 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
339%endif
340 %{!?debug:-Dwerror=} \
c980b122 341 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 342 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 343 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1 344 -Dffmpeg_branding=Chrome \
1fde0856 345 -Dremove_webcore_debug_symbols=1 \
a3140cd1 346 -Dproprietary_codecs=1 \
b5a3dda3 347 -Dinclude_tests=0 \
c0808220 348%if %{with nacl}
038f76b9 349 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
350 -Ddisable_glibc_untar=1 \
351 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
352 -Ddisable_glibc=1 \
353 -Ddisable_pnacl=1 \
354 -Dbuild_pnacl_newlib=0 \
c0808220 355%else
8fb1dc98 356 -Ddisable_pnacl_untar=1 \
c0808220
ER
357 -Ddisable_nacl=1 \
358%endif
a3140cd1
ER
359 %{!?with_sse2:-Ddisable_sse2=1} \
360 %{?with_selinux:-Dselinux=1} \
e7fa0817 361 %{gyp_with cups} \
8dda6bbc 362 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
363 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
364 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
365 %{gyp_with pulseaudio} \
8f5f6775 366 %{gyp_with system_flac} \
62950103
ER
367 %{gyp_with system_libexif} \
368 %{gyp_with system_libmtp} \
581aec44 369 %{gyp_with system_libusb} \
4b411ffe 370 %{gyp_with system_libvpx} \
ba685303 371 %{gyp_with system_libwebp} \
126ea630 372 %{gyp_with system_minizip} \
62950103 373 %{gyp_with system_opus} \
e7fa0817
ER
374 %{gyp_with system_speex} \
375 %{gyp_with system_sqlite} \
376 %{gyp_with system_v8} \
377 %{gyp_with system_yasm} \
378 %{gyp_with system_zlib} \
0c480b89 379 -Duse_system_bzip2=1 \
62950103 380 -Duse_system_expat=1 \
0b214002 381 -Duse_system_icu=1 \
f1b276d4 382 -Duse_system_libevent=1 \
0c480b89 383 -Duse_system_libjpeg=1 \
f1b276d4
ER
384 -Duse_system_libpng=1 \
385 -Duse_system_libxml=1 \
386 -Duse_system_libxslt=1 \
7f40f3f4 387 -Duse_system_xdg_utils=1 \
d8ba130c 388 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
389 -Dlinux_use_gold_binary=0 \
390 -Dlinux_use_gold_flags=0
11ad81c4 391
48ffbc5e 392%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
393 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
394 %{?with_verbose:V=1} \
395 CC="%{__cc}" \
396 CXX="%{__cxx}" \
b7adf6b1 397 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
398 CC.host="%{__cc}" \
399 CXX.host="%{__cxx}" \
b7adf6b1 400 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
401 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
402 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
403
404%install
405rm -rf $RPM_BUILD_ROOT
56c6e811 406install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 407 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 408
673aee14 409cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 410cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
411install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
412%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 413cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 414cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 415install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 416install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 417%if %{with ffmpegsumo}
f1b276d4 418install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 419%endif
e7fa0817 420cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 421cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 422
c0808220
ER
423%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
424
164020eb
ER
425%if %{with nacl}
426# Install Native Client files on platforms that support it.
427install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
428install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
429%ifarch %{x8664}
430install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
431%endif
432%ifarch %{ix86}
433install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
434%endif
435%endif
436
0c480b89
ER
437cd -
438
0eb19b0b
ER
439for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
440 size=${icon##*/product_logo_}
441 size=${size%.png}
442
443 # this will skip non-numeric (22_mono_invert, 22_mono)
444 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
445 test -d "$dir" || continue
446
447 install -d $RPM_BUILD_ROOT$dir
448 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
449done
7f40f3f4 450
13840bc2
AM
451%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
452# http://code.google.com/p/chromium/issues/detail?id=24507
453gecko-mediaplayer*.so
454EOF
11ad81c4 455
589d90ea
ER
456# find locales
457%find_lang %{name}.lang
e7fa0817 458# always package en-US
f1b276d4 459%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 460
11ad81c4
AM
461%clean
462rm -rf $RPM_BUILD_ROOT
463
f1b276d4 464%post
0eb19b0b 465%update_icon_cache hicolor
b7a6e4ee 466%update_desktop_database
f1b276d4
ER
467%update_browser_plugins
468
469%postun
470if [ "$1" = 0 ]; then
0eb19b0b 471 %update_icon_cache hicolor
f1b276d4
ER
472 %update_browser_plugins
473fi
474
1d2b9616 475%files
11ad81c4 476%defattr(644,root,root,755)
531537e5 477%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
478%{_browserpluginsconfdir}/browsers.d/%{name}.*
479%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
480%dir %{_sysconfdir}/%{name}
481%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 482%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
483%attr(755,root,root) %{_bindir}/%{name}
484%{_mandir}/man1/%{name}.1*
11ad81c4 485%{_desktopdir}/*.desktop
0eb19b0b 486%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 487%dir %{_libdir}/%{name}
e9abb380 488%{_libdir}/%{name}/chrome*.pak
c14cd342 489%{_libdir}/%{name}/content_resources.pak
97fac491 490%{_libdir}/%{name}/resources.pak
589d90ea 491%dir %{_libdir}/%{name}/locales
f1b276d4
ER
492%{_libdir}/%{name}/locales/en-US.pak
493%dir %{_libdir}/%{name}/resources
a3140cd1 494%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
495%dir %{_libdir}/%{name}/themes
496%dir %{_libdir}/%{name}/extensions
497%dir %{_libdir}/%{name}/plugins
498%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 499# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 500%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
501
502# ffmpeg libs
d561483d 503%if %{with ffmpegsumo}
f1b276d4 504%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 505%endif
f1b276d4 506
164020eb
ER
507%if %{with nacl}
508%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
509%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
510%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
511%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
512%endif
513
f1b276d4
ER
514%files l10n -f %{name}.lang
515%defattr(644,root,root,755)
This page took 0.165825 seconds and 4 git commands to generate.