]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 25.0.1364.97
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
4e881737 16%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 17%bcond_without system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 26%bcond_without system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
4b411ffe 31%bcond_without system_libvpx # system libvpx
ba685303 32%bcond_without system_yasm # system yasm
1c00315b 33%bcond_without system_zlib # system zlib
d2781a31 34%bcond_without tcmalloc # use tcmalloc
7e136323 35%bcond_without verbose # verbose build (V=1)
0c480b89 36
6d92f81c 37# TODO
f1b276d4 38# - check system sqlite linking problems
2108baf2 39# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 40# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 41# - use_system_hunspell
32a2443e 42# - use_system_stlport
a3140cd1
ER
43# - other defaults: src/build/common.gypi
44
e53ecfb5 45# NOTES:
4fe038cb
ER
46# - mute BEEP mixer if you do not want to hear horrible system bell when
47# pressing home/end in url bar or more ^F search results on page.
7c638678 48# - space considerations:
0bb93ab2 49# - unpacked sources: ~490MiB
c1ecd31f 50# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 51# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 52# - to look for new tarball, use update-source.sh script
f1b276d4 53
e68aa7e7 54# NOTE TO USERS:
c8b02491 55# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 56# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 57# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 58
92fcbe12
ER
59%define branch 25.0.1364
60%define basever 97
61#define patchver 70
a3140cd1 62%define gyp_rev 1014
11ad81c4 63Summary: A WebKit powered web browser
05f72ae2 64Name: chromium-browser
f73369da
ER
65%if "%{?patchver}" != ""
66Version: %{branch}.%{patchver}
67%else
68Version: %{branch}.%{basever}
69%endif
f6284fe2 70Release: 1
05f72ae2 71License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 72Group: X11/Applications/Networking
3c73e180 73Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
92fcbe12 74# Source0-md5: 07a041c89f2e44219fff4e3553ae8c02
3c73e180
ER
75%if "%{?patchver}" != ""
76Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
f6284fe2 77# Patch0-md5: 37675cd75c578d26d6210259877f3947
3c73e180 78%endif
37ceaf05 79Source1: %{name}.default
8b53130d
ER
80Source2: %{name}.sh
81Source3: %{name}.desktop
56c6e811
ER
82Source5: find-lang.sh
83Source6: update-source.sh
84Source7: clean-source.sh
836b1cac 85Source8: get-source.sh
0562b864 86Source9: master_preferences.json
48b341f5 87Patch1: plugin-searchdirs.patch
70258ccd 88#Patch2: system-nspr.patch
7abc645c 89Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 90Patch4: path-libpdf.patch
0e5636cb 91Patch6: get-webkit_revision.patch
5aa5df39 92Patch7: dlopen_sonamed_gl.patch
4765ddf1 93Patch8: chromium_useragent.patch.in
c0808220 94Patch9: chromium-ppapi.patch
8456d676 95Patch10: system-libxnvctrl.patch
1347c76c
AM
96# https://bugs.gentoo.org/show_bug.cgi?id=393471
97# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 98Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c
ER
99Patch12: system-ffmpeg.patch
100Patch13: system-libpng.patch
101Patch14: system-opus.patch
5997e180
ER
102Patch15: nacl-build-irt.patch
103Patch16: nacl-linkingfix.patch
9516ca97 104Patch18: nacl-no-untar.patch
08b25440 105Patch19: system-jsoncpp.patch
8fb1dc98 106Patch23: no-pnacl.patch
6897926c 107Patch24: nacl-verbose.patch
c5b396f3
ER
108Patch25: gnome3-volume-control.patch
109Patch26: master-prefs-path.patch
d2781a31 110Patch27: tcmalloc-glibc2.16.patch
750b48f7 111URL: http://www.chromium.org/Home
ae3fe89f 112%{?with_gconf:BuildRequires: GConf2-devel}
05f72ae2
ER
113BuildRequires: alsa-lib-devel
114BuildRequires: atk-devel
115BuildRequires: bison
11ad81c4 116BuildRequires: bzip2-devel
5997e180
ER
117%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
118%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
119%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 120%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 121%{?with_cups:BuildRequires: cups-devel}
92965b0e 122BuildRequires: elfutils-devel
77f32fa3 123BuildRequires: expat-devel
7d0dbc8d 124%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 125%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 126BuildRequires: fontconfig-devel
f1b276d4 127BuildRequires: glib2-devel
05f72ae2 128BuildRequires: gperf
bbad64b7 129BuildRequires: gtest-devel
8b53130d 130BuildRequires: gtk+2-devel
01b4dc8e 131%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 132%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 133BuildRequires: hicolor-icon-theme
ed514974 134%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 135%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 136BuildRequires: libevent-devel
8456d676 137%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 138%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 139BuildRequires: libicu-devel >= 4.6
39c71b4c 140%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 141%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 142%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 143BuildRequires: libpng-devel
e266589e 144%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 145BuildRequires: libstdc++-devel
ba685303 146%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 147%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 148%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 149BuildRequires: libxml2-devel
11ad81c4 150BuildRequires: libxslt-devel
535cb410 151BuildRequires: man-db
62950103 152%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 153BuildRequires: nspr-devel
f1b276d4 154BuildRequires: nss-devel >= 1:3.12.3
8456d676 155%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 156BuildRequires: pam-devel
f1b276d4 157BuildRequires: pango-devel
ef121064 158BuildRequires: pciutils-devel
48b341f5 159BuildRequires: perl-modules
160BuildRequires: pkgconfig
75a27c2e 161%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 162%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 163BuildRequires: python
46cdefee 164#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 165BuildRequires: python-modules
92965b0e 166BuildRequires: python-ply
0cad051b 167BuildRequires: rpm >= 4.4.9-56
f1b276d4 168BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 169%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 170BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 171%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 172BuildRequires: subversion
0cad051b 173BuildRequires: tar >= 1:1.22
0a424ee2 174BuildRequires: udev-devel
7d1152d4 175BuildRequires: usbutils
2303ed45 176BuildRequires: util-linux
c14cd342 177%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 178BuildRequires: which
f1b276d4 179BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 180BuildRequires: xz
a3140cd1 181%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 182%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 183Requires: browser-plugins >= 2.0
0cad051b 184Requires: desktop-file-utils
8f5f6775 185%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
186# crashes if no fontconfig font present
187Requires: fonts-Type1-urw
0eb19b0b 188Requires: hicolor-icon-theme
56403697 189Requires: libevent >= 2.0.21
c1edaafa 190%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 191%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 192Requires: lsb-release
3700ba38 193Requires: shared-mime-info
4dc49133 194Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 195Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 196Provides: wwwbrowser
c3582150 197Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 198Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 199ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 200BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 201
589d90ea 202%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 203
e7fa0817
ER
204# Usage: gyp_with BCOND_NAME [OPTION_NAME]
205%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 206
6b113615
ER
207%if %{without debuginfo}
208%define _enable_debug_packages 0
209%endif
210
11ad81c4 211%description
80838854
ER
212Chromium is an open-source browser project that aims to build a safer,
213faster, and more stable way for all Internet users to experience the
214web.
215
216Chromium serves as a base for Google Chrome, which is Chromium
217rebranded (name and logo) with very few additions such as usage
218tracking and an auto-updater system.
219
f1b276d4
ER
220%package l10n
221Summary: chromium-browser language packages
222Group: I18n
223Requires: %{name} = %{version}-%{release}
224
225%description l10n
226Chromium is an open-source browser project that aims to build a safer,
227faster, and more stable way for all Internet users to experience the
228web.
229
230This package contains language packages for 50 languages:
231
e7fa0817
ER
232ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
233he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
234pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
235zh-TW
f1b276d4
ER
236
237%prep
3c73e180
ER
238%setup -qc
239%if "%{?patchver}" != ""
240cd %{name}-%{branch}.%{basever}
241%patch0 -p1
242cd ..
243%endif
244mv %{name}-%{branch}.%{basever}/src .
589d90ea 245
05f72ae2
ER
246# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
247# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
248. ./src/chrome/VERSION
249ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
250test "$ver" = %{version}
251
252gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 253test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 254
836b1cac 255v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 256
4765ddf1
ER
257# add chromium and pld to useragent
258%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
259sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
260 -e 's/@BUILD_DIST_NAME@/PLD/g' \
261 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 262 < %{PATCH8} | %{__patch} -p1
4765ddf1 263
56c6e811
ER
264%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
265ln -s %{SOURCE7} src
f1b276d4 266
05f72ae2 267%patch1 -p1
7abc645c 268%patch3 -p1
72cb20c1 269%patch4 -p1
0e5636cb 270%patch6 -p1
5aa5df39 271%patch7 -p1
42e551c9 272%patch10 -p1
e9abb380 273%patch15 -p1
77f32fa3 274cd src
c0808220 275%patch9 -p0
70258ccd 276#%patch2 -p1
f4a8da6a 277%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c
ER
278%patch12 -p1
279%patch13 -p0
280%patch14 -p2
5997e180 281%patch16 -p1
08b25440 282%patch19 -p1
c5b396f3 283%patch25 -p1
d2781a31 284%patch27 -p1
1347c76c 285cd ..
9516ca97 286%patch18 -p1
0562b864 287%patch23 -p1
6897926c 288%patch24 -p1
c5b396f3 289%patch26 -p1
0c480b89 290
828bdd1a 291cd src
e9abb380
ER
292
293# Missing gyp files in tarball.
294# https://code.google.com/p/chromium/issues/detail?id=144823
295if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
296 echo "tarball fixed, please remove workaround"
297 exit 1
298fi
299
300install -d chrome/test/data/nacl
301cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
302{
303 'targets': [
304 {
305 'target_name': 'nacl_tests',
306 'type': 'none',
307 },
308 ],
309}
310EOF
311
75a27c2e
ER
312sh -x clean-source.sh \
313 %{!?with_nacl:nacl=0} \
314 %{!?with_system_protobuf:protobuf=0} \
315 %{!?with_system_v8:v8=0} \
316 %{!?with_system_zlib:zlib=0} \
ef121064 317 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
75a27c2e 318 %{nil}
fded59be 319
e266589e 320%build
f1b276d4 321cd src
5997e180
ER
322
323%if %{with nacl}
108c5f7c 324rm -rf native_client/toolchain/linux_x86_newlib
fded59be 325if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 326# Make symlinks for NaCL
108c5f7c 327install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 328
108c5f7c
ER
329cd native_client/toolchain/linux_x86_newlib
330ln -s x86_64-nacl/bin bin
331cd x86_64-nacl/bin
2e4113fd 332__cc='%{__cc}'
f64e73f6 333if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
334 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
335 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
336 %{__sed} -i -e '1i#!/bin/sh' gcc g++
337 chmod +x gcc g++
338else
339 ln -s %{_bindir}/x86_64-nacl-gcc gcc
340 ln -s %{_bindir}/x86_64-nacl-g++ g++
341fi
108c5f7c
ER
342ln -s gcc x86_64-nacl-gcc
343ln -s g++ x86_64-nacl-g++
344ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
345ln -s %{_bindir}/x86_64-nacl-ar ar
346ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 347ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 348ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 349ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 350ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
351ln -s %{_prefix}/x86_64-nacl/lib ../lib
352ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
353ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
354cd ../../../../..
fded59be 355fi
5997e180
ER
356%endif
357
c5b396f3 358test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
359test -e Makefile || \
360 CC="%{__cc}" \
361 CXX="%{__cxx}" \
362 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
363 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
364 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
365%{__python} build/gyp_chromium \
673aee14
ER
366 --format=make \
367 -Goutput_dir=../out \
368 build/all.gyp \
f1b276d4
ER
369%ifarch %{ix86}
370 -Dtarget_arch=ia32 \
371%endif
372%ifarch %{x8664}
0c480b89
ER
373 -Dtarget_arch=x64 \
374%endif
7b454a31
AM
375%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
376 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
377%endif
378%if %{with sandboxing}
379 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
380 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
381%endif
382 %{!?debug:-Dwerror=} \
c980b122 383 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 384 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 385 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 386 -Dinclude_tests=0 \
c0808220 387%if %{with nacl}
038f76b9 388 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
389 -Ddisable_glibc_untar=1 \
390 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
391 -Ddisable_glibc=1 \
392 -Ddisable_pnacl=1 \
393 -Dbuild_pnacl_newlib=0 \
c0808220 394%else
8fb1dc98 395 -Ddisable_pnacl_untar=1 \
c0808220
ER
396 -Ddisable_nacl=1 \
397%endif
a3140cd1
ER
398 %{!?with_sse2:-Ddisable_sse2=1} \
399 %{?with_selinux:-Dselinux=1} \
7d1152d4 400 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197
ER
401 -Dlinux_link_libpci=1 \
402 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
403 -Dlinux_use_gold_binary=0 \
404 -Dlinux_use_gold_flags=0 \
e7fa0817 405 %{gyp_with cups} \
8dda6bbc 406 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
407 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
408 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
409 %{gyp_with pulseaudio} \
7d0dbc8d 410 %{gyp_with system_ffmpeg} \
8f5f6775 411 %{gyp_with system_flac} \
01b4dc8e 412 %{gyp_with system_harfbuzz} \
62950103
ER
413 %{gyp_with system_libexif} \
414 %{gyp_with system_libmtp} \
9bd2659c 415 %{gyp_with system_libsrtp} \
581aec44 416 %{gyp_with system_libusb} \
4b411ffe 417 %{gyp_with system_libvpx} \
ba685303 418 %{gyp_with system_libwebp} \
4884fc99 419 %{gyp_with system_libxnvctrl} \
126ea630 420 %{gyp_with system_minizip} \
62950103 421 %{gyp_with system_opus} \
75a27c2e 422 %{gyp_with system_protobuf} \
e7fa0817
ER
423 %{gyp_with system_speex} \
424 %{gyp_with system_sqlite} \
425 %{gyp_with system_v8} \
426 %{gyp_with system_yasm} \
427 %{gyp_with system_zlib} \
0c480b89 428 -Duse_system_bzip2=1 \
62950103 429 -Duse_system_expat=1 \
0b214002 430 -Duse_system_icu=1 \
f1b276d4 431 -Duse_system_libevent=1 \
0c480b89 432 -Duse_system_libjpeg=1 \
f1b276d4
ER
433 -Duse_system_libpng=1 \
434 -Duse_system_libxml=1 \
435 -Duse_system_libxslt=1 \
7f40f3f4 436 -Duse_system_xdg_utils=1 \
11ad81c4 437
b4d75247 438# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 439%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
440 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
441 %{?with_verbose:V=1} \
f1b276d4
ER
442 CC.host="%{__cc}" \
443 CXX.host="%{__cxx}" \
b4d75247 444 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 445
535cb410
ER
446cd ../out/%{!?debug:Release}%{?debug:Debug}
447MANWIDTH=80 man ./chrome.1 > man.out
448%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
449
11ad81c4
AM
450%install
451rm -rf $RPM_BUILD_ROOT
56c6e811 452install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 453 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 454
673aee14 455cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 456cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 457install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
458%{__sed} -i -e '
459 s,@libdir@,%{_libdir}/%{name},
460
461 /@OPTIONS@/ {
462 r options.txt
463 d
464 }
465' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 466cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 467cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 468install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 469install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 470%if %{without system_ffmpeg}
f1b276d4 471install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 472%endif
e7fa0817 473cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 474cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 475
c0808220
ER
476%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
477
164020eb
ER
478%if %{with nacl}
479# Install Native Client files on platforms that support it.
480install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
481install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
482%ifarch %{x8664}
483install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
484%endif
485%ifarch %{ix86}
486install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
487%endif
488%endif
489
0c480b89
ER
490cd -
491
0eb19b0b
ER
492for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
493 size=${icon##*/product_logo_}
494 size=${size%.png}
495
496 # this will skip non-numeric (22_mono_invert, 22_mono)
497 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
498 test -d "$dir" || continue
499
500 install -d $RPM_BUILD_ROOT$dir
501 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
502done
7f40f3f4 503
13840bc2
AM
504%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
505# http://code.google.com/p/chromium/issues/detail?id=24507
506gecko-mediaplayer*.so
507EOF
11ad81c4 508
589d90ea
ER
509# find locales
510%find_lang %{name}.lang
e7fa0817 511# always package en-US
f1b276d4 512%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 513
11ad81c4
AM
514%clean
515rm -rf $RPM_BUILD_ROOT
516
f1b276d4 517%post
0eb19b0b 518%update_icon_cache hicolor
b7a6e4ee 519%update_desktop_database
f1b276d4
ER
520%update_browser_plugins
521
522%postun
523if [ "$1" = 0 ]; then
0eb19b0b 524 %update_icon_cache hicolor
f1b276d4
ER
525 %update_browser_plugins
526fi
527
1d2b9616 528%files
11ad81c4 529%defattr(644,root,root,755)
531537e5 530%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
531%{_browserpluginsconfdir}/browsers.d/%{name}.*
532%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
533%dir %{_sysconfdir}/%{name}
534%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 535%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
536%attr(755,root,root) %{_bindir}/%{name}
537%{_mandir}/man1/%{name}.1*
11ad81c4 538%{_desktopdir}/*.desktop
0eb19b0b 539%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 540%dir %{_libdir}/%{name}
e9abb380 541%{_libdir}/%{name}/chrome*.pak
c14cd342 542%{_libdir}/%{name}/content_resources.pak
97fac491 543%{_libdir}/%{name}/resources.pak
589d90ea 544%dir %{_libdir}/%{name}/locales
f1b276d4
ER
545%{_libdir}/%{name}/locales/en-US.pak
546%dir %{_libdir}/%{name}/resources
a3140cd1 547%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
548%dir %{_libdir}/%{name}/themes
549%dir %{_libdir}/%{name}/extensions
550%dir %{_libdir}/%{name}/plugins
551%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 552# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 553%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
554
555# ffmpeg libs
fcc48c19 556%if %{without system_ffmpeg}
f1b276d4 557%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 558%endif
f1b276d4 559
164020eb
ER
560%if %{with nacl}
561%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
562%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
563%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
564%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
565%endif
566
f1b276d4
ER
567%files l10n -f %{name}.lang
568%defattr(644,root,root,755)
This page took 0.181552 seconds and 4 git commands to generate.