]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- add x-scheme-handler/mailto; x-scheme-handler/webcal; see http://bugs.gentoo.org...
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
a3140cd1 10%bcond_with nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
d8ba130c 15%bcond_with tcmalloc # use tcmalloc
2108baf2 16%bcond_with system_sqlite # with system sqlite
32a2443e 17%bcond_without system_flac # with system flac
e8e15592 18%bcond_without system_libwebp # with system libwebp
32a2443e 19%bcond_without system_speex # with system speex
c14cd342 20%bcond_with system_v8 # with system v8
32a2443e 21%bcond_without system_vpx # with system vpx
d617ab39 22%bcond_without system_yasm # with system yasm
2108baf2 23%bcond_without system_zlib # with system zlib
f4a8da6a 24%bcond_without libjpegturbo # use libjpeg-turbo features
2108baf2 25%bcond_with verbose # verbose build (V=1)
0c480b89 26
6d92f81c 27# TODO
f1b276d4 28# - check system sqlite linking problems
2108baf2 29# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 30# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 31# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 32# - use_system_hunspell
32a2443e 33# - use_system_stlport
a3140cd1
ER
34# - other defaults: src/build/common.gypi
35
e53ecfb5 36# NOTES:
4fe038cb
ER
37# - mute BEEP mixer if you do not want to hear horrible system bell when
38# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
39# - build -bp: 1.2G
40# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 41# - build x86_64: ~1.9G
f1b276d4 42# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 43# - to look for new tarball, use update-source.sh script
f1b276d4 44
e68aa7e7 45# NOTE TO USERS:
a3cc7091
ER
46# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
47# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 48# or:
a3cc7091 49# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 50
a3140cd1 51%define gyp_rev 1014
11ad81c4 52Summary: A WebKit powered web browser
05f72ae2 53Name: chromium-browser
10b6678d 54Version: 20.0.1132.17
3cbdf9e3 55Release: 0.1
05f72ae2 56License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 57Group: X11/Applications/Networking
53366f87 58Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
10b6678d 59# Source0-md5: f7e2293dc8edeb47f4057ef1f9ad7dd0
37ceaf05 60Source1: %{name}.default
8b53130d
ER
61Source2: %{name}.sh
62Source3: %{name}.desktop
56c6e811
ER
63Source5: find-lang.sh
64Source6: update-source.sh
65Source7: clean-source.sh
836b1cac 66Source8: get-source.sh
48b341f5 67Patch0: system-libs.patch
68Patch1: plugin-searchdirs.patch
69Patch2: gyp-system-minizip.patch
7abc645c 70Patch3: disable_dlog_and_dcheck_in_release_builds.patch
48b341f5 71Patch5: options-support.patch
0e5636cb 72Patch6: get-webkit_revision.patch
5aa5df39 73Patch7: dlopen_sonamed_gl.patch
4765ddf1 74Patch8: chromium_useragent.patch.in
77f32fa3 75Patch9: system-expat.patch
f4a8da6a 76Patch10: %{name}-pulse.patch
1347c76c
AM
77# https://bugs.gentoo.org/show_bug.cgi?id=393471
78# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 79Patch11: chromium-revert-jpeg-swizzle-r2.patch
d8ba130c 80Patch12: tcmalloc.patch
750b48f7 81URL: http://www.chromium.org/Home
ae3fe89f 82%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 83BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
84BuildRequires: alsa-lib-devel
85BuildRequires: atk-devel
86BuildRequires: bison
11ad81c4 87BuildRequires: bzip2-devel
ae3fe89f 88%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 89BuildRequires: dbus-glib-devel
77f32fa3 90BuildRequires: expat-devel
d617ab39 91%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 92BuildRequires: flex
11ad81c4 93BuildRequires: fontconfig-devel
f1b276d4 94BuildRequires: glib2-devel
05f72ae2 95BuildRequires: gperf
8b53130d 96BuildRequires: gtk+2-devel
a3140cd1 97%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 98BuildRequires: hicolor-icon-theme
05f72ae2 99BuildRequires: libevent-devel
7f40f3f4 100%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 101BuildRequires: libicu-devel >= 4.6
05f72ae2 102BuildRequires: libjpeg-devel
f4a8da6a 103%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 104BuildRequires: libpng-devel
e266589e 105%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 106BuildRequires: libstdc++-devel
32a2443e 107%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
71b67d16 108%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.3}
f1b276d4 109BuildRequires: libxml2-devel
11ad81c4 110BuildRequires: libxslt-devel
f1b276d4 111BuildRequires: lzma
11ad81c4 112BuildRequires: minizip-devel
164020eb 113%{?with_nacl:BuildRequires: nacl-toolchain-newlib >= 0.6941}
05f72ae2 114BuildRequires: nspr-devel
f1b276d4 115BuildRequires: nss-devel >= 1:3.12.3
35902862 116BuildRequires: pam-devel
f1b276d4 117BuildRequires: pango-devel
48b341f5 118BuildRequires: perl-modules
119BuildRequires: pkgconfig
ae3fe89f 120%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 121BuildRequires: python
46cdefee 122#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 123BuildRequires: python-modules
0cad051b 124BuildRequires: rpm >= 4.4.9-56
f1b276d4 125BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 126%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 127BuildRequires: sqlite3-devel >= 3.6.1
0cad051b 128BuildRequires: tar >= 1:1.22
2303ed45 129BuildRequires: util-linux
c14cd342 130%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 131BuildRequires: which
f1b276d4 132BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
133BuildRequires: xorg-lib-libXt-devel
134BuildRequires: xorg-lib-libXtst-devel
836b1cac 135BuildRequires: xz
a3140cd1 136%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 137%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 138Requires: browser-plugins >= 2.0
0cad051b 139Requires: desktop-file-utils
0eb19b0b 140Requires: hicolor-icon-theme
c1edaafa 141%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 142%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 143Requires: xdg-utils >= 1.0.2-4
e53ecfb5 144Provides: wwwbrowser
c3582150 145Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 146Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 147ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 148BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 149
589d90ea 150%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
151# Usage: gyp_with BCOND_NAME [OPTION_NAME]
152%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 153
6b113615
ER
154%if %{without debuginfo}
155%define _enable_debug_packages 0
156%endif
157
11ad81c4 158%description
80838854
ER
159Chromium is an open-source browser project that aims to build a safer,
160faster, and more stable way for all Internet users to experience the
161web.
162
163Chromium serves as a base for Google Chrome, which is Chromium
164rebranded (name and logo) with very few additions such as usage
165tracking and an auto-updater system.
166
f1b276d4
ER
167%package l10n
168Summary: chromium-browser language packages
169Group: I18n
170Requires: %{name} = %{version}-%{release}
171
172%description l10n
173Chromium is an open-source browser project that aims to build a safer,
174faster, and more stable way for all Internet users to experience the
175web.
176
177This package contains language packages for 50 languages:
178
e7fa0817
ER
179ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
180he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
181pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
182zh-TW
f1b276d4
ER
183
184%prep
836b1cac 185%setup -q
589d90ea 186
05f72ae2
ER
187# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
188# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
189. ./src/chrome/VERSION
190ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
191test "$ver" = %{version}
192
193gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 194test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 195
836b1cac 196v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 197
f1b276d4 198# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
836b1cac 199#echo "%{svnver}" > src/build/LASTCHANGE.in
f1b276d4 200
4765ddf1
ER
201# add chromium and pld to useragent
202%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
203sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
204 -e 's/@BUILD_DIST_NAME@/PLD/g' \
205 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 206 < %{PATCH8} | %{__patch} -p1
4765ddf1 207
56c6e811
ER
208%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
209ln -s %{SOURCE7} src
f1b276d4 210
05f72ae2
ER
211%patch0 -p1
212%patch1 -p1
213%patch2 -p1
7abc645c 214%patch3 -p1
05f72ae2 215%patch5 -p1
0e5636cb 216%patch6 -p1
5aa5df39 217%patch7 -p1
77f32fa3
ER
218cd src
219%patch9 -p1
bdbf9a94 220%patch10 -p1
f4a8da6a 221%{!?with_libjpegturbo:%patch11 -p0}
d8ba130c 222%patch12 -p0
1347c76c 223cd ..
0c480b89 224
828bdd1a 225cd src
cd09b941 226sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0}
164020eb 227
e266589e 228%build
f1b276d4 229cd src
164020eb 230test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
231%ifarch %{ix86}
232 -Dtarget_arch=ia32 \
233%endif
234%ifarch %{x8664}
0c480b89
ER
235 -Dtarget_arch=x64 \
236%endif
7b454a31
AM
237%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
238 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
239%endif
240%if %{with sandboxing}
241 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
242 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
243%endif
244 %{!?debug:-Dwerror=} \
c980b122 245 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 246 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 247 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
248 -Dffmpeg_branding=Chrome \
249 -Dproprietary_codecs=1 \
5a6de706 250 %{!?with_nacl:-Ddisable_nacl=1} \
a3140cd1
ER
251 %{!?with_sse2:-Ddisable_sse2=1} \
252 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
253 %{gyp_with cups} \
254 %{gyp_with flac} \
255 %{gyp_with gconf} \
256 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
257 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
258 %{gyp_with pulseaudio} \
e8e15592 259 %{gyp_with system_libwebp} \
e7fa0817
ER
260 %{gyp_with system_speex} \
261 %{gyp_with system_sqlite} \
262 %{gyp_with system_v8} \
32a2443e 263 %{gyp_with system_vpx} \
e7fa0817
ER
264 %{gyp_with system_yasm} \
265 %{gyp_with system_zlib} \
0c480b89 266 -Duse_system_bzip2=1 \
0b214002 267 -Duse_system_icu=1 \
f1b276d4 268 -Duse_system_libevent=1 \
0c480b89 269 -Duse_system_libjpeg=1 \
f1b276d4
ER
270 -Duse_system_libpng=1 \
271 -Duse_system_libxml=1 \
272 -Duse_system_libxslt=1 \
7f40f3f4 273 -Duse_system_xdg_utils=1 \
d8ba130c 274 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
275 -Dlinux_use_gold_binary=0 \
276 -Dlinux_use_gold_flags=0
11ad81c4 277
f1b276d4
ER
278%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
279 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
280 %{?with_verbose:V=1} \
281 CC="%{__cc}" \
282 CXX="%{__cxx}" \
b7adf6b1 283 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
284 CC.host="%{__cc}" \
285 CXX.host="%{__cxx}" \
b7adf6b1 286 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
287 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
288 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
289
290%install
291rm -rf $RPM_BUILD_ROOT
56c6e811 292install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 293 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 294
f1b276d4 295cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 296cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
297install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
298%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 299cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 300cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 301install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 302install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 303%if %{with ffmpegsumo}
f1b276d4 304install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 305%endif
e7fa0817 306cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb
ER
307
308%if %{with nacl}
309# Install Native Client files on platforms that support it.
310install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
311install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
312%ifarch %{x8664}
313install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
314%endif
315%ifarch %{ix86}
316install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
317%endif
318%endif
319
0c480b89
ER
320cd -
321
0eb19b0b
ER
322for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
323 size=${icon##*/product_logo_}
324 size=${size%.png}
325
326 # this will skip non-numeric (22_mono_invert, 22_mono)
327 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
328 test -d "$dir" || continue
329
330 install -d $RPM_BUILD_ROOT$dir
331 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
332done
7f40f3f4 333
13840bc2
AM
334%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
335# http://code.google.com/p/chromium/issues/detail?id=24507
336gecko-mediaplayer*.so
337EOF
11ad81c4 338
589d90ea
ER
339# find locales
340%find_lang %{name}.lang
e7fa0817 341# always package en-US
f1b276d4 342%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 343
11ad81c4
AM
344%clean
345rm -rf $RPM_BUILD_ROOT
346
f1b276d4 347%post
0eb19b0b 348%update_icon_cache hicolor
b7a6e4ee 349%update_desktop_database
f1b276d4
ER
350%update_browser_plugins
351
352%postun
353if [ "$1" = 0 ]; then
0eb19b0b 354 %update_icon_cache hicolor
f1b276d4
ER
355 %update_browser_plugins
356fi
357
589d90ea 358%files -f %{name}.lang
11ad81c4 359%defattr(644,root,root,755)
f1b276d4
ER
360%{_browserpluginsconfdir}/browsers.d/%{name}.*
361%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
362%dir %{_sysconfdir}/%{name}
363%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
364%attr(755,root,root) %{_bindir}/%{name}
365%{_mandir}/man1/%{name}.1*
11ad81c4 366%{_desktopdir}/*.desktop
0eb19b0b 367%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89
ER
368%dir %{_libdir}/%{name}
369%{_libdir}/%{name}/chrome.pak
c14cd342 370%{_libdir}/%{name}/content_resources.pak
97fac491 371%{_libdir}/%{name}/resources.pak
589d90ea 372%dir %{_libdir}/%{name}/locales
f1b276d4
ER
373%{_libdir}/%{name}/locales/en-US.pak
374%dir %{_libdir}/%{name}/resources
a3140cd1 375%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
376%dir %{_libdir}/%{name}/themes
377%dir %{_libdir}/%{name}/extensions
378%dir %{_libdir}/%{name}/plugins
379%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 380# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 381%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
382
383# ffmpeg libs
d561483d 384%if %{with ffmpegsumo}
f1b276d4 385%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 386%endif
f1b276d4 387
164020eb
ER
388%if %{with nacl}
389%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
390%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
391%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
392%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
393%endif
394
f1b276d4
ER
395%files l10n -f %{name}.lang
396%defattr(644,root,root,755)
This page took 0.098216 seconds and 4 git commands to generate.