]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
fix vpx bcond. now builds with system libvpx
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2
ER
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without ffmpegsumo # build with ffmpegsumo
ba685303 6%bcond_without gconf # with GConf
8171fe68 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303
ER
16%bcond_without system_flac # system flac
17%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
18%bcond_without system_libexif # system libexif
19%bcond_without system_libmtp # system libmtp
ba685303
ER
20%bcond_without system_libusb # system libusb-1
21%bcond_without system_libwebp # system libwebp
126ea630 22%bcond_without system_minizip # system minizip
62950103 23%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
ba685303
ER
24%bcond_without system_speex # system speex
25%bcond_with system_sqlite # system sqlite
3ee15dec 26%bcond_without system_srtp # system srtp (can be used if using bundled libjingle)
ba685303 27%bcond_with system_v8 # system v8
4b411ffe 28%bcond_without system_libvpx # system libvpx
ba685303 29%bcond_without system_yasm # system yasm
4c272135
ER
30# system zlib disabled because of mixed-source.patch
31# https://code.google.com/p/chromium/issues/detail?id=143623
ba685303
ER
32%bcond_with system_zlib # system zlib
33%bcond_with tcmalloc # use tcmalloc
7e136323 34%bcond_without verbose # verbose build (V=1)
0c480b89 35
c6325ea2
ER
36%if %{with nacl}
37# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
38# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
39#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
40#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
41#14:51:06 @baggins> as-needed will take care of unneeded lib
42#14:52:03 @baggins> -lssp comes with gcc
107b55fe 43%define _ssp_cflags %{nil}
c6325ea2
ER
44%endif
45
6d92f81c 46# TODO
f1b276d4 47# - check system sqlite linking problems
2108baf2 48# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 49# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 50# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 51# - use_system_hunspell
32a2443e 52# - use_system_stlport
a3140cd1 53# - other defaults: src/build/common.gypi
62950103
ER
54# - use_system_libmtp
55# - use_system_libexif
56# - use_system_opus
57# - use_system_libjpeg==1 use_libjpeg_turbo==0
a3140cd1 58
e53ecfb5 59# NOTES:
4fe038cb
ER
60# - mute BEEP mixer if you do not want to hear horrible system bell when
61# pressing home/end in url bar or more ^F search results on page.
7c638678
ER
62# - space considerations:
63# - unpacked sources: ~800MiB
64# - built code: ~1.4GiB (x86_64)
f1b276d4 65# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 66# - to look for new tarball, use update-source.sh script
f1b276d4 67
e68aa7e7 68# NOTE TO USERS:
c8b02491 69# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 70# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 71# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 72
a3140cd1 73%define gyp_rev 1014
11ad81c4 74Summary: A WebKit powered web browser
05f72ae2 75Name: chromium-browser
126ea630 76Version: 24.0.1312.45
4b411ffe 77Release: 0.8
05f72ae2 78License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 79Group: X11/Applications/Networking
126ea630
ER
80Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
81# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
37ceaf05 82Source1: %{name}.default
8b53130d
ER
83Source2: %{name}.sh
84Source3: %{name}.desktop
56c6e811
ER
85Source5: find-lang.sh
86Source6: update-source.sh
87Source7: clean-source.sh
836b1cac 88Source8: get-source.sh
0562b864 89Source9: master_preferences.json
3c73e180 90#Patch10: system-libs.patch
48b341f5 91Patch1: plugin-searchdirs.patch
7abc645c 92Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 93Patch4: path-libpdf.patch
48b341f5 94Patch5: options-support.patch
0e5636cb 95Patch6: get-webkit_revision.patch
5aa5df39 96Patch7: dlopen_sonamed_gl.patch
4765ddf1 97Patch8: chromium_useragent.patch.in
c0808220 98Patch9: chromium-ppapi.patch
1347c76c
AM
99# https://bugs.gentoo.org/show_bug.cgi?id=393471
100# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 101Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
102Patch15: nacl-build-irt.patch
103Patch16: nacl-linkingfix.patch
9516ca97 104Patch18: nacl-no-untar.patch
08b25440 105Patch19: system-jsoncpp.patch
3ee15dec 106Patch21: system-srtp.patch
126ea630 107Patch22: pulse_fix-157876.patch
8fb1dc98 108Patch23: no-pnacl.patch
6897926c 109Patch24: nacl-verbose.patch
c5b396f3
ER
110Patch25: gnome3-volume-control.patch
111Patch26: master-prefs-path.patch
750b48f7 112URL: http://www.chromium.org/Home
ae3fe89f 113%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 114BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
115BuildRequires: alsa-lib-devel
116BuildRequires: atk-devel
117BuildRequires: bison
11ad81c4 118BuildRequires: bzip2-devel
5997e180
ER
119%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
120%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
121%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 122%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 123%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 124BuildRequires: dbus-glib-devel
77f32fa3 125BuildRequires: expat-devel
8f5f6775 126%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 127BuildRequires: flex
11ad81c4 128BuildRequires: fontconfig-devel
f1b276d4 129BuildRequires: glib2-devel
05f72ae2 130BuildRequires: gperf
8b53130d 131BuildRequires: gtk+2-devel
a3140cd1 132%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 133BuildRequires: hicolor-icon-theme
ed514974 134%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
05f72ae2 135BuildRequires: libevent-devel
7f40f3f4 136%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 137BuildRequires: libicu-devel >= 4.6
39c71b4c 138%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 139%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 140BuildRequires: libpng-devel
e266589e 141%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 142BuildRequires: libstdc++-devel
ba685303 143%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 144%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 145%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 146BuildRequires: libxml2-devel
11ad81c4 147BuildRequires: libxslt-devel
f1b276d4 148BuildRequires: lzma
62950103
ER
149%{?with_system_minizip:BuildRequires: minizip-devel}
150%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
151%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
152%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
05f72ae2 153BuildRequires: nspr-devel
f1b276d4 154BuildRequires: nss-devel >= 1:3.12.3
35902862 155BuildRequires: pam-devel
f1b276d4 156BuildRequires: pango-devel
48b341f5 157BuildRequires: perl-modules
158BuildRequires: pkgconfig
ae3fe89f 159%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 160BuildRequires: python
46cdefee 161#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 162BuildRequires: python-modules
0cad051b 163BuildRequires: rpm >= 4.4.9-56
f1b276d4 164BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 165%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 166BuildRequires: sqlite3-devel >= 3.6.1
3ee15dec 167%{?with_system_srtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 168BuildRequires: subversion
0cad051b 169BuildRequires: tar >= 1:1.22
0a424ee2 170BuildRequires: udev-devel
2303ed45 171BuildRequires: util-linux
c14cd342 172%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 173BuildRequires: which
f1b276d4 174BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
175BuildRequires: xorg-lib-libXt-devel
176BuildRequires: xorg-lib-libXtst-devel
836b1cac 177BuildRequires: xz
a3140cd1 178%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 179%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 180Requires: browser-plugins >= 2.0
0cad051b 181Requires: desktop-file-utils
8f5f6775 182%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 183Requires: hicolor-icon-theme
c1edaafa 184%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 185%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
4dc49133 186Requires: xdg-utils >= 1.0.2-4
e53ecfb5 187Provides: wwwbrowser
c3582150 188Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 189Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 190ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 191BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 192
589d90ea 193%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 194
e7fa0817
ER
195# Usage: gyp_with BCOND_NAME [OPTION_NAME]
196%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 197
6b113615
ER
198%if %{without debuginfo}
199%define _enable_debug_packages 0
200%endif
201
11ad81c4 202%description
80838854
ER
203Chromium is an open-source browser project that aims to build a safer,
204faster, and more stable way for all Internet users to experience the
205web.
206
207Chromium serves as a base for Google Chrome, which is Chromium
208rebranded (name and logo) with very few additions such as usage
209tracking and an auto-updater system.
210
f1b276d4
ER
211%package l10n
212Summary: chromium-browser language packages
213Group: I18n
214Requires: %{name} = %{version}-%{release}
215
216%description l10n
217Chromium is an open-source browser project that aims to build a safer,
218faster, and more stable way for all Internet users to experience the
219web.
220
221This package contains language packages for 50 languages:
222
e7fa0817
ER
223ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
224he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
225pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
226zh-TW
f1b276d4
ER
227
228%prep
836b1cac 229%setup -q
589d90ea 230
05f72ae2
ER
231# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
232# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
233. ./src/chrome/VERSION
234ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
235test "$ver" = %{version}
236
237gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 238test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 239
836b1cac 240v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 241
4765ddf1
ER
242# add chromium and pld to useragent
243%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
244sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
245 -e 's/@BUILD_DIST_NAME@/PLD/g' \
246 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 247 < %{PATCH8} | %{__patch} -p1
4765ddf1 248
56c6e811
ER
249%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
250ln -s %{SOURCE7} src
f1b276d4 251
3c73e180 252#%patch10 -p1
05f72ae2 253%patch1 -p1
7abc645c 254%patch3 -p1
72cb20c1 255%patch4 -p1
05f72ae2 256%patch5 -p1
0e5636cb 257%patch6 -p1
5aa5df39 258%patch7 -p1
e9abb380 259%patch15 -p1
77f32fa3 260cd src
c0808220 261%patch9 -p0
f4a8da6a 262%{!?with_libjpegturbo:%patch11 -p0}
5997e180 263%patch16 -p1
08b25440 264%patch19 -p1
3ee15dec 265%patch21 -p1
126ea630 266%patch22 -p1
c5b396f3 267%patch25 -p1
1347c76c 268cd ..
9516ca97 269%patch18 -p1
8fb1dc98 270%patch23 -p1
6897926c 271%patch24 -p1
c5b396f3 272%patch26 -p1
0c480b89 273
828bdd1a 274cd src
e9abb380
ER
275
276# Missing gyp files in tarball.
277# https://code.google.com/p/chromium/issues/detail?id=144823
278if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
279 echo "tarball fixed, please remove workaround"
280 exit 1
281fi
282
283install -d chrome/test/data/nacl
284cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
285{
286 'targets': [
287 {
288 'target_name': 'nacl_tests',
289 'type': 'none',
290 },
291 ],
292}
293EOF
294
4c272135 295sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
164020eb 296
fded59be
ER
297rm -rf native_client/toolchain/linux_x86_newlib
298
e266589e 299%build
f1b276d4 300cd src
5997e180
ER
301
302%if %{with nacl}
fded59be 303if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
5997e180
ER
304# Make symlinks for nacl
305cd native_client/toolchain
306install -d linux_x86_newlib/x86_64-nacl/bin
307install -d linux_x86_newlib/x86_64-nacl/lib
308install -d linux_x86_newlib/x86_64-nacl/lib32
309install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
310install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
311install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
312# link newlib toolchain to glibc as well, see gentoo bug #417019
313#ln -s linux_x86_newlib linux_x86
5997e180 314cd linux_x86_newlib/x86_64-nacl/bin
2e4113fd
ER
315
316__cc='%{__cc}'
317if [ "${__cc}#ccache}" != "$__cc" ]; then
318 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
319 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
320 %{__sed} -i -e '1i#!/bin/sh' gcc g++
321 chmod +x gcc g++
322else
323 ln -s %{_bindir}/x86_64-nacl-gcc gcc
324 ln -s %{_bindir}/x86_64-nacl-g++ g++
325fi
326
5997e180
ER
327ln -s %{_bindir}/x86_64-nacl-ar ar
328ln -s %{_bindir}/x86_64-nacl-as as
329ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
330ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
331ln -s %{_bindir}/x86_64-nacl-strip strip
332ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
333ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
334cd ../nacl/include
335for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
336 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
337done
338cd ../../../../../..
fded59be 339fi
5997e180
ER
340%endif
341
c5b396f3 342test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
343test -e Makefile || %{__python} build/gyp_chromium \
344 --format=make \
345 -Goutput_dir=../out \
346 build/all.gyp \
f1b276d4
ER
347%ifarch %{ix86}
348 -Dtarget_arch=ia32 \
349%endif
350%ifarch %{x8664}
0c480b89
ER
351 -Dtarget_arch=x64 \
352%endif
7b454a31
AM
353%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
354 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
355%endif
356%if %{with sandboxing}
357 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
358 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
359%endif
360 %{!?debug:-Dwerror=} \
c980b122 361 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 362 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 363 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1 364 -Dffmpeg_branding=Chrome \
1fde0856 365 -Dremove_webcore_debug_symbols=1 \
a3140cd1 366 -Dproprietary_codecs=1 \
c0808220 367%if %{with nacl}
038f76b9 368 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
369 -Ddisable_glibc_untar=1 \
370 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
371 -Ddisable_glibc=1 \
372 -Ddisable_pnacl=1 \
373 -Dbuild_pnacl_newlib=0 \
c0808220 374%else
8fb1dc98 375 -Ddisable_pnacl_untar=1 \
c0808220
ER
376 -Ddisable_nacl=1 \
377%endif
a3140cd1
ER
378 %{!?with_sse2:-Ddisable_sse2=1} \
379 %{?with_selinux:-Dselinux=1} \
e7fa0817 380 %{gyp_with cups} \
8dda6bbc 381 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
382 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
383 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
384 %{gyp_with pulseaudio} \
8f5f6775 385 %{gyp_with system_flac} \
62950103
ER
386 %{gyp_with system_libexif} \
387 %{gyp_with system_libmtp} \
581aec44 388 %{gyp_with system_libusb} \
4b411ffe 389 %{gyp_with system_libvpx} \
ba685303 390 %{gyp_with system_libwebp} \
126ea630 391 %{gyp_with system_minizip} \
62950103 392 %{gyp_with system_opus} \
e7fa0817
ER
393 %{gyp_with system_speex} \
394 %{gyp_with system_sqlite} \
395 %{gyp_with system_v8} \
396 %{gyp_with system_yasm} \
397 %{gyp_with system_zlib} \
0c480b89 398 -Duse_system_bzip2=1 \
62950103 399 -Duse_system_expat=1 \
0b214002 400 -Duse_system_icu=1 \
f1b276d4 401 -Duse_system_libevent=1 \
0c480b89 402 -Duse_system_libjpeg=1 \
f1b276d4
ER
403 -Duse_system_libpng=1 \
404 -Duse_system_libxml=1 \
405 -Duse_system_libxslt=1 \
7f40f3f4 406 -Duse_system_xdg_utils=1 \
d8ba130c 407 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
408 -Dlinux_use_gold_binary=0 \
409 -Dlinux_use_gold_flags=0
11ad81c4 410
48ffbc5e 411%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
412 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
413 %{?with_verbose:V=1} \
414 CC="%{__cc}" \
415 CXX="%{__cxx}" \
b7adf6b1 416 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
417 CC.host="%{__cc}" \
418 CXX.host="%{__cxx}" \
b7adf6b1 419 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
420 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
421 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
422
423%install
424rm -rf $RPM_BUILD_ROOT
56c6e811 425install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 426 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 427
673aee14 428cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 429cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
430install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
431%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 432cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 433cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 434install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 435install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 436%if %{with ffmpegsumo}
f1b276d4 437install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 438%endif
e7fa0817 439cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 440cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 441
c0808220
ER
442%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
443
164020eb
ER
444%if %{with nacl}
445# Install Native Client files on platforms that support it.
446install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
447install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
448%ifarch %{x8664}
449install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
450%endif
451%ifarch %{ix86}
452install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
453%endif
454%endif
455
0c480b89
ER
456cd -
457
0eb19b0b
ER
458for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
459 size=${icon##*/product_logo_}
460 size=${size%.png}
461
462 # this will skip non-numeric (22_mono_invert, 22_mono)
463 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
464 test -d "$dir" || continue
465
466 install -d $RPM_BUILD_ROOT$dir
467 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
468done
7f40f3f4 469
13840bc2
AM
470%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
471# http://code.google.com/p/chromium/issues/detail?id=24507
472gecko-mediaplayer*.so
473EOF
11ad81c4 474
589d90ea
ER
475# find locales
476%find_lang %{name}.lang
e7fa0817 477# always package en-US
f1b276d4 478%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 479
11ad81c4
AM
480%clean
481rm -rf $RPM_BUILD_ROOT
482
f1b276d4 483%post
0eb19b0b 484%update_icon_cache hicolor
b7a6e4ee 485%update_desktop_database
f1b276d4
ER
486%update_browser_plugins
487
488%postun
489if [ "$1" = 0 ]; then
0eb19b0b 490 %update_icon_cache hicolor
f1b276d4
ER
491 %update_browser_plugins
492fi
493
1d2b9616 494%files
11ad81c4 495%defattr(644,root,root,755)
531537e5 496%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
497%{_browserpluginsconfdir}/browsers.d/%{name}.*
498%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
499%dir %{_sysconfdir}/%{name}
500%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 501%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
502%attr(755,root,root) %{_bindir}/%{name}
503%{_mandir}/man1/%{name}.1*
11ad81c4 504%{_desktopdir}/*.desktop
0eb19b0b 505%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 506%dir %{_libdir}/%{name}
e9abb380 507%{_libdir}/%{name}/chrome*.pak
c14cd342 508%{_libdir}/%{name}/content_resources.pak
97fac491 509%{_libdir}/%{name}/resources.pak
589d90ea 510%dir %{_libdir}/%{name}/locales
f1b276d4
ER
511%{_libdir}/%{name}/locales/en-US.pak
512%dir %{_libdir}/%{name}/resources
a3140cd1 513%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
514%dir %{_libdir}/%{name}/themes
515%dir %{_libdir}/%{name}/extensions
516%dir %{_libdir}/%{name}/plugins
517%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 518# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 519%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
520
521# ffmpeg libs
d561483d 522%if %{with ffmpegsumo}
f1b276d4 523%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 524%endif
f1b276d4 525
164020eb
ER
526%if %{with nacl}
527%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
528%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
529%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
530%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
531%endif
532
f1b276d4
ER
533%files l10n -f %{name}.lang
534%defattr(644,root,root,755)
This page took 0.220421 seconds and 4 git commands to generate.