]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- build nacl with crossnacl toolchain
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
5997e180 10%bcond_without nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
d8ba130c 15%bcond_with tcmalloc # use tcmalloc
2108baf2 16%bcond_with system_sqlite # with system sqlite
32a2443e 17%bcond_without system_flac # with system flac
e8e15592 18%bcond_without system_libwebp # with system libwebp
32a2443e 19%bcond_without system_speex # with system speex
c14cd342 20%bcond_with system_v8 # with system v8
32a2443e 21%bcond_without system_vpx # with system vpx
d617ab39 22%bcond_without system_yasm # with system yasm
2108baf2 23%bcond_without system_zlib # with system zlib
5997e180 24%bcond_without libjpegturbo # use libjpeg-turbo features
2108baf2 25%bcond_with verbose # verbose build (V=1)
0c480b89 26
6d92f81c 27# TODO
f1b276d4 28# - check system sqlite linking problems
2108baf2 29# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 30# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 31# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 32# - use_system_hunspell
32a2443e 33# - use_system_stlport
a3140cd1
ER
34# - other defaults: src/build/common.gypi
35
e53ecfb5 36# NOTES:
4fe038cb
ER
37# - mute BEEP mixer if you do not want to hear horrible system bell when
38# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
39# - build -bp: 1.2G
40# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 41# - build x86_64: ~1.9G
f1b276d4 42# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 43# - to look for new tarball, use update-source.sh script
f1b276d4 44
e68aa7e7 45# NOTE TO USERS:
a3cc7091
ER
46# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
47# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 48# or:
a3cc7091 49# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 50
a3140cd1 51%define gyp_rev 1014
11ad81c4 52Summary: A WebKit powered web browser
05f72ae2 53Name: chromium-browser
bf06c739 54Version: 20.0.1132.47
5997e180 55Release: 2
05f72ae2 56License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 57Group: X11/Applications/Networking
53366f87 58Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
bf06c739 59# Source0-md5: 282c717fbfaee8acd6d5bf4f676019a2
37ceaf05 60Source1: %{name}.default
8b53130d
ER
61Source2: %{name}.sh
62Source3: %{name}.desktop
56c6e811
ER
63Source5: find-lang.sh
64Source6: update-source.sh
65Source7: clean-source.sh
836b1cac 66Source8: get-source.sh
48b341f5 67Patch0: system-libs.patch
68Patch1: plugin-searchdirs.patch
69Patch2: gyp-system-minizip.patch
7abc645c 70Patch3: disable_dlog_and_dcheck_in_release_builds.patch
48b341f5 71Patch5: options-support.patch
0e5636cb 72Patch6: get-webkit_revision.patch
5aa5df39 73Patch7: dlopen_sonamed_gl.patch
4765ddf1 74Patch8: chromium_useragent.patch.in
77f32fa3 75Patch9: system-expat.patch
f4a8da6a 76Patch10: %{name}-pulse.patch
1347c76c
AM
77# https://bugs.gentoo.org/show_bug.cgi?id=393471
78# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 79Patch11: chromium-revert-jpeg-swizzle-r2.patch
d8ba130c 80Patch12: tcmalloc.patch
b908b8b2 81Patch13: %{name}-c++.patch
c6045fc4 82Patch14: chromium-alignment-r0.patch
5997e180
ER
83Patch15: nacl-build-irt.patch
84Patch16: nacl-linkingfix.patch
750b48f7 85URL: http://www.chromium.org/Home
ae3fe89f 86%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 87BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
88BuildRequires: alsa-lib-devel
89BuildRequires: atk-devel
90BuildRequires: bison
11ad81c4 91BuildRequires: bzip2-devel
5997e180
ER
92%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
93%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
94%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
95%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.18.0}
ae3fe89f 96%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 97BuildRequires: dbus-glib-devel
77f32fa3 98BuildRequires: expat-devel
d617ab39 99%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 100BuildRequires: flex
11ad81c4 101BuildRequires: fontconfig-devel
f1b276d4 102BuildRequires: glib2-devel
05f72ae2 103BuildRequires: gperf
8b53130d 104BuildRequires: gtk+2-devel
a3140cd1 105%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 106BuildRequires: hicolor-icon-theme
05f72ae2 107BuildRequires: libevent-devel
7f40f3f4 108%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 109BuildRequires: libicu-devel >= 4.6
39c71b4c 110%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 111%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 112BuildRequires: libpng-devel
e266589e 113%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 114BuildRequires: libstdc++-devel
32a2443e 115%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
71b67d16 116%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.3}
f1b276d4 117BuildRequires: libxml2-devel
11ad81c4 118BuildRequires: libxslt-devel
f1b276d4 119BuildRequires: lzma
11ad81c4 120BuildRequires: minizip-devel
05f72ae2 121BuildRequires: nspr-devel
f1b276d4 122BuildRequires: nss-devel >= 1:3.12.3
35902862 123BuildRequires: pam-devel
f1b276d4 124BuildRequires: pango-devel
48b341f5 125BuildRequires: perl-modules
126BuildRequires: pkgconfig
ae3fe89f 127%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 128BuildRequires: python
46cdefee 129#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 130BuildRequires: python-modules
0cad051b 131BuildRequires: rpm >= 4.4.9-56
f1b276d4 132BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 133%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 134BuildRequires: sqlite3-devel >= 3.6.1
89f0dde4 135BuildRequires: subversion
0cad051b 136BuildRequires: tar >= 1:1.22
0a424ee2 137BuildRequires: udev-devel
2303ed45 138BuildRequires: util-linux
c14cd342 139%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 140BuildRequires: which
f1b276d4 141BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
142BuildRequires: xorg-lib-libXt-devel
143BuildRequires: xorg-lib-libXtst-devel
836b1cac 144BuildRequires: xz
a3140cd1 145%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 146%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 147Requires: browser-plugins >= 2.0
0cad051b 148Requires: desktop-file-utils
0eb19b0b 149Requires: hicolor-icon-theme
c1edaafa 150%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 151%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 152Requires: xdg-utils >= 1.0.2-4
e53ecfb5 153Provides: wwwbrowser
c3582150 154Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 155Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 156ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 157BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 158
589d90ea 159%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
160# Usage: gyp_with BCOND_NAME [OPTION_NAME]
161%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 162
6b113615
ER
163%if %{without debuginfo}
164%define _enable_debug_packages 0
165%endif
166
11ad81c4 167%description
80838854
ER
168Chromium is an open-source browser project that aims to build a safer,
169faster, and more stable way for all Internet users to experience the
170web.
171
172Chromium serves as a base for Google Chrome, which is Chromium
173rebranded (name and logo) with very few additions such as usage
174tracking and an auto-updater system.
175
f1b276d4
ER
176%package l10n
177Summary: chromium-browser language packages
178Group: I18n
179Requires: %{name} = %{version}-%{release}
180
181%description l10n
182Chromium is an open-source browser project that aims to build a safer,
183faster, and more stable way for all Internet users to experience the
184web.
185
186This package contains language packages for 50 languages:
187
e7fa0817
ER
188ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
189he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
190pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
191zh-TW
f1b276d4
ER
192
193%prep
836b1cac 194%setup -q
589d90ea 195
05f72ae2
ER
196# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
197# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
198. ./src/chrome/VERSION
199ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
200test "$ver" = %{version}
201
202gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 203test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 204
836b1cac 205v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 206
f1b276d4 207# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
836b1cac 208#echo "%{svnver}" > src/build/LASTCHANGE.in
f1b276d4 209
4765ddf1
ER
210# add chromium and pld to useragent
211%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
212sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
213 -e 's/@BUILD_DIST_NAME@/PLD/g' \
214 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 215 < %{PATCH8} | %{__patch} -p1
4765ddf1 216
56c6e811
ER
217%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
218ln -s %{SOURCE7} src
f1b276d4 219
05f72ae2
ER
220%patch0 -p1
221%patch1 -p1
222%patch2 -p1
7abc645c 223%patch3 -p1
05f72ae2 224%patch5 -p1
0e5636cb 225%patch6 -p1
5aa5df39 226%patch7 -p1
77f32fa3
ER
227cd src
228%patch9 -p1
bdbf9a94 229%patch10 -p1
f4a8da6a 230%{!?with_libjpegturbo:%patch11 -p0}
d8ba130c 231%patch12 -p0
b908b8b2 232%patch13 -p0
c6045fc4 233%patch14 -p0
5997e180
ER
234%patch15 -p1
235%patch16 -p1
1347c76c 236cd ..
0c480b89 237
828bdd1a 238cd src
f8e29f37 239sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0
164020eb 240
e266589e 241%build
f1b276d4 242cd src
5997e180
ER
243
244%if %{with nacl}
245rm -rf native_client/toolchain/linux_x86_newlib
246# Make symlinks for nacl
247cd native_client/toolchain
248install -d linux_x86_newlib/x86_64-nacl/bin
249install -d linux_x86_newlib/x86_64-nacl/lib
250install -d linux_x86_newlib/x86_64-nacl/lib32
251install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
252install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
253install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
254cd linux_x86_newlib/x86_64-nacl/bin
255ln -s %{_bindir}/x86_64-nacl-gcc gcc
256ln -s %{_bindir}/x86_64-nacl-g++ g++
257ln -s %{_bindir}/x86_64-nacl-ar ar
258ln -s %{_bindir}/x86_64-nacl-as as
259ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
260ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
261ln -s %{_bindir}/x86_64-nacl-strip strip
262ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
263ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
264cd ../nacl/include
265for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
266 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
267done
268cd ../../../../../..
269%endif
270
164020eb 271test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
272%ifarch %{ix86}
273 -Dtarget_arch=ia32 \
274%endif
275%ifarch %{x8664}
0c480b89
ER
276 -Dtarget_arch=x64 \
277%endif
7b454a31
AM
278%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
279 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
280%endif
281%if %{with sandboxing}
282 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
283 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
284%endif
285 %{!?debug:-Dwerror=} \
c980b122 286 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 287 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 288 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
289 -Dffmpeg_branding=Chrome \
290 -Dproprietary_codecs=1 \
5a6de706 291 %{!?with_nacl:-Ddisable_nacl=1} \
a3140cd1
ER
292 %{!?with_sse2:-Ddisable_sse2=1} \
293 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
294 %{gyp_with cups} \
295 %{gyp_with flac} \
296 %{gyp_with gconf} \
297 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
298 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
299 %{gyp_with pulseaudio} \
e8e15592 300 %{gyp_with system_libwebp} \
e7fa0817
ER
301 %{gyp_with system_speex} \
302 %{gyp_with system_sqlite} \
303 %{gyp_with system_v8} \
32a2443e 304 %{gyp_with system_vpx} \
e7fa0817
ER
305 %{gyp_with system_yasm} \
306 %{gyp_with system_zlib} \
0c480b89 307 -Duse_system_bzip2=1 \
0b214002 308 -Duse_system_icu=1 \
f1b276d4 309 -Duse_system_libevent=1 \
0c480b89 310 -Duse_system_libjpeg=1 \
f1b276d4
ER
311 -Duse_system_libpng=1 \
312 -Duse_system_libxml=1 \
313 -Duse_system_libxslt=1 \
7f40f3f4 314 -Duse_system_xdg_utils=1 \
d8ba130c 315 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
316 -Dlinux_use_gold_binary=0 \
317 -Dlinux_use_gold_flags=0
11ad81c4 318
f1b276d4
ER
319%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
320 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
321 %{?with_verbose:V=1} \
322 CC="%{__cc}" \
323 CXX="%{__cxx}" \
b7adf6b1 324 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
325 CC.host="%{__cc}" \
326 CXX.host="%{__cxx}" \
b7adf6b1 327 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
328 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
329 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
330
331%install
332rm -rf $RPM_BUILD_ROOT
56c6e811 333install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 334 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 335
f1b276d4 336cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 337cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
338install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
339%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 340cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 341cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 342install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 343install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 344%if %{with ffmpegsumo}
f1b276d4 345install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 346%endif
e7fa0817 347cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb
ER
348
349%if %{with nacl}
350# Install Native Client files on platforms that support it.
351install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
352install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
353%ifarch %{x8664}
354install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
355%endif
356%ifarch %{ix86}
357install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
358%endif
359%endif
360
0c480b89
ER
361cd -
362
0eb19b0b
ER
363for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
364 size=${icon##*/product_logo_}
365 size=${size%.png}
366
367 # this will skip non-numeric (22_mono_invert, 22_mono)
368 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
369 test -d "$dir" || continue
370
371 install -d $RPM_BUILD_ROOT$dir
372 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
373done
7f40f3f4 374
13840bc2
AM
375%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
376# http://code.google.com/p/chromium/issues/detail?id=24507
377gecko-mediaplayer*.so
378EOF
11ad81c4 379
589d90ea
ER
380# find locales
381%find_lang %{name}.lang
e7fa0817 382# always package en-US
f1b276d4 383%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 384
11ad81c4
AM
385%clean
386rm -rf $RPM_BUILD_ROOT
387
f1b276d4 388%post
0eb19b0b 389%update_icon_cache hicolor
b7a6e4ee 390%update_desktop_database
f1b276d4
ER
391%update_browser_plugins
392
393%postun
394if [ "$1" = 0 ]; then
0eb19b0b 395 %update_icon_cache hicolor
f1b276d4
ER
396 %update_browser_plugins
397fi
398
589d90ea 399%files -f %{name}.lang
11ad81c4 400%defattr(644,root,root,755)
f1b276d4
ER
401%{_browserpluginsconfdir}/browsers.d/%{name}.*
402%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
403%dir %{_sysconfdir}/%{name}
404%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
405%attr(755,root,root) %{_bindir}/%{name}
406%{_mandir}/man1/%{name}.1*
11ad81c4 407%{_desktopdir}/*.desktop
0eb19b0b 408%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89
ER
409%dir %{_libdir}/%{name}
410%{_libdir}/%{name}/chrome.pak
c14cd342 411%{_libdir}/%{name}/content_resources.pak
97fac491 412%{_libdir}/%{name}/resources.pak
bbe92394
AM
413%{_libdir}/%{name}/theme_resources_standard.pak
414%{_libdir}/%{name}/ui_resources_standard.pak
589d90ea 415%dir %{_libdir}/%{name}/locales
f1b276d4
ER
416%{_libdir}/%{name}/locales/en-US.pak
417%dir %{_libdir}/%{name}/resources
a3140cd1 418%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
419%dir %{_libdir}/%{name}/themes
420%dir %{_libdir}/%{name}/extensions
421%dir %{_libdir}/%{name}/plugins
422%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 423# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 424%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
425
426# ffmpeg libs
d561483d 427%if %{with ffmpegsumo}
f1b276d4 428%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 429%endif
f1b276d4 430
164020eb
ER
431%if %{with nacl}
432%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
433%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
434%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
435%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
436%endif
437
f1b276d4
ER
438%files l10n -f %{name}.lang
439%defattr(644,root,root,755)
This page took 0.151107 seconds and 4 git commands to generate.