]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
- add chromium and pld to useragent (patch from unbuntu)
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
f1b276d4 3%bcond_with verbose # verbose build (V=1)
0c480b89 4%bcond_with selinux # with SELinux (need policy first)
0e5636cb
KK
5%bcond_with shared_libs # with shared libs
6%bcond_with sse2 # use SSE2 instructions
f1b276d4 7%bcond_with system_sqlite # with system sqlite
0e5636cb 8%bcond_with system_v8 # with system v8
37b05e5e 9%bcond_without ffmpegsumo # build with ffmpegsumo
f1b276d4 10%bcond_without sandboxing # with sandboxing
0e5636cb 11%bcond_without system_zlib # with system zlib
6b113615 12%bcond_without debuginfo # disable debuginfo creation (it is huge)
0c480b89 13
6d92f81c 14# TODO
f1b276d4 15# - check system sqlite linking problems
2351db3b 16
e53ecfb5 17# NOTES:
4fe038cb
ER
18# - mute BEEP mixer if you do not want to hear horrible system bell when
19# pressing home/end in url bar or more ^F search results on page.
f1b276d4
ER
20# - build i686: -bp: ~570MB; bc: ~928MB; -bb: ~1.0GB
21# - build x86_64: -bp: ~570MB; bc: ~990MB; -bb: ~1.0GB
22# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 23# - to look for new tarball, use update-source.sh script
f1b276d4 24
e68aa7e7 25# NOTE TO USERS:
a3cc7091
ER
26# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
27# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 28# or:
a3cc7091 29# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 30
181b99e0
ER
31%define svndate 20110304
32%define svnver 76865
35902862 33%define rel 1
11ad81c4 34
11ad81c4 35Summary: A WebKit powered web browser
05f72ae2 36Name: chromium-browser
181b99e0 37Version: 11.0.691.0
cf823a7a 38Release: 0.%{svnver}.%{rel}
05f72ae2 39License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 40Group: X11/Applications/Networking
f1b276d4 41Source0: http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
181b99e0 42# Source0-md5: 62de113711d3d9ac7b678d407bee4da8
8b53130d
ER
43Source2: %{name}.sh
44Source3: %{name}.desktop
589d90ea 45Source4: find-lang.sh
fe043a0f 46Source5: update-source.sh
48b341f5 47Patch0: system-libs.patch
48Patch1: plugin-searchdirs.patch
49Patch2: gyp-system-minizip.patch
7abc645c 50Patch3: disable_dlog_and_dcheck_in_release_builds.patch
7b454a31
AM
51# http://aur.archlinux.org/packages/chromium-browser-svn/chromium-browser-svn/search-workaround.patch
52Patch4: search-workaround.patch
48b341f5 53Patch5: options-support.patch
0e5636cb 54Patch6: get-webkit_revision.patch
5aa5df39 55Patch7: dlopen_sonamed_gl.patch
4765ddf1 56Patch8: chromium_useragent.patch.in
f1b276d4 57URL: http://code.google.com/chromium/
05f72ae2 58BuildRequires: GConf2-devel
f1b276d4 59BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
60BuildRequires: alsa-lib-devel
61BuildRequires: atk-devel
62BuildRequires: bison
11ad81c4 63BuildRequires: bzip2-devel
0826c245 64BuildRequires: cups-devel
2bc5cf47 65BuildRequires: dbus-glib-devel
11ad81c4 66BuildRequires: flex
11ad81c4 67BuildRequires: fontconfig-devel
f1b276d4 68BuildRequires: glib2-devel
05f72ae2 69BuildRequires: gperf
8b53130d 70BuildRequires: gtk+2-devel
05f72ae2 71BuildRequires: libevent-devel
176c22e6 72BuildRequires: libgnome-keyring-devel
05f72ae2
ER
73BuildRequires: libjpeg-devel
74BuildRequires: libpng-devel
e266589e 75%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 76BuildRequires: libstdc++-devel
c8e3a0be 77BuildRequires: libvpx-devel >= 0.9.5-2
f1b276d4 78BuildRequires: libxml2-devel
11ad81c4 79BuildRequires: libxslt-devel
f1b276d4 80BuildRequires: lzma
11ad81c4 81BuildRequires: minizip-devel
05f72ae2 82BuildRequires: nspr-devel
f1b276d4 83BuildRequires: nss-devel >= 1:3.12.3
35902862 84BuildRequires: pam-devel
f1b276d4 85BuildRequires: pango-devel
48b341f5 86BuildRequires: perl-modules
87BuildRequires: pkgconfig
f1b276d4 88BuildRequires: python
4765ddf1 89BuildRequires: rpm >= 4.4.9-56
181b99e0 90# grep googlecode_url.*gyp src/DEPS |cut -d'"' -f6 | cut -d@ -f2
7b938c02 91BuildRequires: python-gyp >= 1-840
48b341f5 92BuildRequires: python-modules
f1b276d4
ER
93BuildRequires: rpmbuild(macros) >= 1.453
94BuildRequires: sqlite3-devel >= 3.6.1
2303ed45 95BuildRequires: util-linux
e79c688f 96%{?with_system_v8:BuildRequires: v8-devel}
0826c245 97BuildRequires: which
f1b276d4 98BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
99BuildRequires: xorg-lib-libXt-devel
100BuildRequires: xorg-lib-libXtst-devel
196ee8b4 101BuildRequires: yasm
f1b276d4 102%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 103Requires: browser-plugins >= 2.0
ffdddc49 104Requires: libvpx >= 0.9.5-2
4dc49133 105Requires: xdg-utils >= 1.0.2-4
e53ecfb5 106Provides: wwwbrowser
031a146c 107Obsoletes: chromium-browser-bookmark_manager
2351db3b 108ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 109BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 110
589d90ea
ER
111%define find_lang sh find-lang.sh %{buildroot}
112
6b113615
ER
113%if %{without debuginfo}
114%define _enable_debug_packages 0
115%endif
116
11ad81c4 117%description
80838854
ER
118Chromium is an open-source browser project that aims to build a safer,
119faster, and more stable way for all Internet users to experience the
120web.
121
122Chromium serves as a base for Google Chrome, which is Chromium
123rebranded (name and logo) with very few additions such as usage
124tracking and an auto-updater system.
125
f1b276d4
ER
126%package inspector
127Summary: Page inspector for the chromium-browser
128Group: Development/Tools
129Requires: %{name} = %{version}-%{release}
05f72ae2 130
f1b276d4
ER
131%description inspector
132Chromium is an open-source browser project that aims to build a safer,
133faster, and more stable way for all Internet users to experience the
134web.
135
136This package contains 'inspector', allowing web developpers to inspect
137any element of a web page at runtime (html, javascript, css, ..)
138
139%package l10n
140Summary: chromium-browser language packages
141Group: I18n
142Requires: %{name} = %{version}-%{release}
143
144%description l10n
145Chromium is an open-source browser project that aims to build a safer,
146faster, and more stable way for all Internet users to experience the
147web.
148
149This package contains language packages for 50 languages:
150
151ar, bg, bn, ca, cs, da, de, el, en-GB, es-419, es, et, fi, fil, fr,
152gu, he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or,
153pl, pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi,
154zh-CN, zh-TW
155
156%prep
157%setup -q -n %{name}-%{version}~svn%{svndate}r%{svnver}
158lzma -dc %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma | tar x
159rm -f %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma
589d90ea 160
05f72ae2
ER
161# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
162# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
163. ./src/chrome/VERSION
164ver=$MAJOR.$MINOR.$BUILD.$PATCH
05f72ae2
ER
165if [ "$ver" != %{version} ]; then
166 exit 1
167fi
168
f1b276d4
ER
169# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
170echo "%{svnver}" > src/build/LASTCHANGE.in
171
4765ddf1
ER
172# add chromium and pld to useragent
173%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
174sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
175 -e 's/@BUILD_DIST_NAME@/PLD/g' \
176 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
177 < %{PATCH8} | %{__patch} -p0
178
2bc5cf47 179%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
f1b276d4 180
05f72ae2
ER
181%patch0 -p1
182%patch1 -p1
183%patch2 -p1
7abc645c 184%patch3 -p1
97fac491 185%patch4 -p1
05f72ae2 186%patch5 -p1
0e5636cb 187%patch6 -p1
5aa5df39 188%patch7 -p1
0c480b89 189
828bdd1a
AM
190# drop bundled libs, from gentoo
191remove_bundled_lib() {
97fac491
ER
192 echo "Removing bundled library $1 ..."
193 local out
194 out=$(find $1 -mindepth 1 ! -iname '*.gyp' -print -delete)
195 if [ -z "$out" ]; then
196 echo >&2 "No files matched when removing bundled library $1"
197 exit 1
198 fi
828bdd1a
AM
199}
200
201cd src
202remove_bundled_lib "third_party/bzip2"
203remove_bundled_lib "third_party/libevent"
204remove_bundled_lib "third_party/libjpeg"
205remove_bundled_lib "third_party/libpng"
181b99e0
ER
206# third_party/libvpx/libvpx.h should be kept
207#remove_bundled_lib "third_party/libvpx"
828bdd1a
AM
208remove_bundled_lib "third_party/libxml"
209remove_bundled_lib "third_party/libxslt"
6ff7cc9f 210remove_bundled_lib "third_party/zlib"
828bdd1a 211
e266589e 212%build
f1b276d4
ER
213cd src
214%{__python} build/gyp_chromium --format=make build/all.gyp \
215%ifarch %{ix86}
216 -Dtarget_arch=ia32 \
217%endif
218%ifarch %{x8664}
0c480b89
ER
219 -Dtarget_arch=x64 \
220%endif
7b454a31
AM
221%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
222 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
223%endif
224%if %{with sandboxing}
225 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
226 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
227%endif
228 %{!?debug:-Dwerror=} \
2303ed45 229 %{!?debuginfo:-Dfastbuild=1} \
f1b276d4
ER
230 %{?with_shared_libs:-Dlibrary=shared_library} \
231 -Djavascript_engine=%{?with_system_v8:system-v8}%{!?with_system_v8:v8} \
37b05e5e 232 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
0c480b89 233 -Duse_system_bzip2=1 \
f1b276d4 234 -Duse_system_libevent=1 \
0c480b89 235 -Duse_system_libjpeg=1 \
f1b276d4
ER
236 -Duse_system_libpng=1 \
237 -Duse_system_libxml=1 \
238 -Duse_system_libxslt=1 \
239 -Duse_system_sqlite=%{?with_system_sqlite:1}%{!?with_system_sqlite:0} \
240 -Duse_system_zlib=%{?with_system_zlib:1}%{!?with_system_zlib:0} \
888c00c4 241 -Duse_system_vpx=1 \
37b05e5e 242 -Duse_system_yasm=1 \
f1b276d4 243 -Dffmpeg_branding=Chrome \
a5bbd1d5 244 -Dproprietary_codecs=1 \
0e5636cb 245 %{!?with_sse2:-Ddisable_sse2=1} \
0c480b89
ER
246%if %{with selinux}
247 -Dselinux=1 \
248%endif
11ad81c4 249
f1b276d4
ER
250%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
251 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
252 %{?with_verbose:V=1} \
253 CC="%{__cc}" \
254 CXX="%{__cxx}" \
255 CC.host="%{__cc}" \
256 CXX.host="%{__cxx}" \
7b454a31
AM
257 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
258 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
259
260%install
261rm -rf $RPM_BUILD_ROOT
f1b276d4 262install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{themes,locales,plugins,extensions,resources},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
e266589e 263
f1b276d4
ER
264cd src/out/%{!?debug:Release}%{?debug:Debug}
265
266install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
267%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 268cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
f1b276d4
ER
269cp -a chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
270cp -a product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
271install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 272install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 273%if %{with ffmpegsumo}
f1b276d4 274install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 275%endif
f1b276d4 276cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0c480b89
ER
277cd -
278
13840bc2
AM
279%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
280# http://code.google.com/p/chromium/issues/detail?id=24507
281gecko-mediaplayer*.so
282EOF
11ad81c4 283
589d90ea
ER
284# find locales
285%find_lang %{name}.lang
f1b276d4 286%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 287
11ad81c4
AM
288%clean
289rm -rf $RPM_BUILD_ROOT
290
f1b276d4
ER
291%post
292%update_browser_plugins
293
294%postun
295if [ "$1" = 0 ]; then
296 %update_browser_plugins
297fi
298
589d90ea 299%files -f %{name}.lang
11ad81c4 300%defattr(644,root,root,755)
f1b276d4
ER
301%{_browserpluginsconfdir}/browsers.d/%{name}.*
302%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
303%attr(755,root,root) %{_bindir}/%{name}
304%{_mandir}/man1/%{name}.1*
305%{_pixmapsdir}/%{name}.png
11ad81c4 306%{_desktopdir}/*.desktop
0c480b89
ER
307%dir %{_libdir}/%{name}
308%{_libdir}/%{name}/chrome.pak
97fac491 309%{_libdir}/%{name}/resources.pak
589d90ea 310%dir %{_libdir}/%{name}/locales
f1b276d4
ER
311%{_libdir}/%{name}/locales/en-US.pak
312%dir %{_libdir}/%{name}/resources
313%dir %{_libdir}/%{name}/themes
314%dir %{_libdir}/%{name}/extensions
315%dir %{_libdir}/%{name}/plugins
316%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 317# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 318%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
319
320# ffmpeg libs
d561483d 321%if %{with ffmpegsumo}
f1b276d4 322%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 323%endif
f1b276d4 324
f1b276d4
ER
325%files inspector
326%defattr(644,root,root,755)
327%{_libdir}/%{name}/resources/inspector
328
329%files l10n -f %{name}.lang
330%defattr(644,root,root,755)
This page took 0.079136 seconds and 4 git commands to generate.