]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
drop tcmalloc glibc 2.16 patch, siginfo_t is correct
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
ba685303
ER
22%bcond_without system_libusb # system libusb-1
23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
25d4e23c 25%bcond_without system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
543e99ac 29%bcond_without system_re2 # system re2
ba685303 30%bcond_without system_speex # system speex
914ee37c 31%bcond_without system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 32%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 33%bcond_with system_v8 # system v8
4b411ffe 34%bcond_without system_libvpx # system libvpx
ba685303 35%bcond_without system_yasm # system yasm
1c00315b 36%bcond_without system_zlib # system zlib
d2781a31 37%bcond_without tcmalloc # use tcmalloc
7e136323 38%bcond_without verbose # verbose build (V=1)
0c480b89 39
b3fc6cb2
ER
40%ifarch %{ix86}
41# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42%undefine with_system_mesa
43%endif
44
6d92f81c 45# TODO
b363f856 46# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 47# - use_system_skia
a3140cd1 48# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 49# - use_system_stlport (android specific)
7b8f219a 50# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 51
e53ecfb5 52# NOTES:
4fe038cb
ER
53# - mute BEEP mixer if you do not want to hear horrible system bell when
54# pressing home/end in url bar or more ^F search results on page.
7c638678 55# - space considerations:
0bb93ab2 56# - unpacked sources: ~490MiB
c1ecd31f 57# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 58# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 59# - to look for new tarball, use update-source.sh script
f1b276d4 60
e68aa7e7 61# NOTE TO USERS:
c8b02491 62# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 63# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 64# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 65
66bf40a1 66%define branch 27.0.1453
dad35adb 67%define basever 6
92fcbe12 68#define patchver 70
a3140cd1 69%define gyp_rev 1014
11ad81c4 70Summary: A WebKit powered web browser
05f72ae2 71Name: chromium-browser
f73369da
ER
72%if "%{?patchver}" != ""
73Version: %{branch}.%{patchver}
74%else
75Version: %{branch}.%{basever}
76%endif
914ee37c 77Release: 0.4
05f72ae2 78License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 79Group: X11/Applications/Networking
2e9c6158 80Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
9d8fb756 81# Source0-md5: eafd6a919faadc8a7446cd673f460c4c
3c73e180
ER
82%if "%{?patchver}" != ""
83Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
e920d86e 84# Patch0-md5: 7e2f26d76ca6241961276a328a9230cf
3c73e180 85%endif
37ceaf05 86Source1: %{name}.default
8b53130d
ER
87Source2: %{name}.sh
88Source3: %{name}.desktop
56c6e811
ER
89Source5: find-lang.sh
90Source6: update-source.sh
91Source7: clean-source.sh
836b1cac 92Source8: get-source.sh
0562b864 93Source9: master_preferences.json
48b341f5 94Patch1: plugin-searchdirs.patch
7abc645c 95Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 96Patch4: path-libpdf.patch
0e5636cb 97Patch6: get-webkit_revision.patch
5aa5df39 98Patch7: dlopen_sonamed_gl.patch
4765ddf1 99Patch8: chromium_useragent.patch.in
8456d676 100Patch10: system-libxnvctrl.patch
1347c76c
AM
101# https://bugs.gentoo.org/show_bug.cgi?id=393471
102# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 103Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 104Patch12: system-ffmpeg.patch
5997e180
ER
105Patch15: nacl-build-irt.patch
106Patch16: nacl-linkingfix.patch
9516ca97 107Patch18: nacl-no-untar.patch
6897926c 108Patch24: nacl-verbose.patch
c5b396f3
ER
109Patch25: gnome3-volume-control.patch
110Patch26: master-prefs-path.patch
25d4e23c 111Patch28: system-mesa.patch
eda1bb04 112Patch29: speechd-0.8.patch
750b48f7 113URL: http://www.chromium.org/Home
ae3fe89f 114%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3
ER
115%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
116%{?with_system_mesa:BuildRequires: Mesa-libGLES-devel >= 9.1}
7b8f219a 117%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 118%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
119BuildRequires: alsa-lib-devel
120BuildRequires: atk-devel
121BuildRequires: bison
11ad81c4 122BuildRequires: bzip2-devel
5997e180
ER
123%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
124%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
125%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 126%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 127%{?with_cups:BuildRequires: cups-devel}
92965b0e 128BuildRequires: elfutils-devel
77f32fa3 129BuildRequires: expat-devel
7d0dbc8d 130%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 131%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 132BuildRequires: fontconfig-devel
f1b276d4 133BuildRequires: glib2-devel
05f72ae2 134BuildRequires: gperf
71d49434 135%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 136BuildRequires: gtest-devel
8b53130d 137BuildRequires: gtk+2-devel
01b4dc8e 138%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 139%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 140BuildRequires: hicolor-icon-theme
ed514974 141%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 142%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 143BuildRequires: libevent-devel
8456d676 144%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 145%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 146BuildRequires: libicu-devel >= 4.6
39c71b4c 147%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 148%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 149%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 150BuildRequires: libpng-devel
e266589e 151%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 152BuildRequires: libstdc++-devel
ba685303 153%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 154%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 155%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 156BuildRequires: libxml2-devel
11ad81c4 157BuildRequires: libxslt-devel
535cb410 158BuildRequires: man-db
62950103 159%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 160BuildRequires: nspr-devel
f1b276d4 161BuildRequires: nss-devel >= 1:3.12.3
8456d676 162%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 163BuildRequires: pam-devel
f1b276d4 164BuildRequires: pango-devel
ef121064 165BuildRequires: pciutils-devel
48b341f5 166BuildRequires: perl-modules
167BuildRequires: pkgconfig
75a27c2e 168%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 169%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 170BuildRequires: python
46cdefee 171#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 172BuildRequires: python-modules
92965b0e 173BuildRequires: python-ply
543e99ac 174%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 175BuildRequires: rpm >= 4.4.9-56
f1b276d4 176BuildRequires: rpmbuild(macros) >= 1.453
eda1bb04 177BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 178%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 179BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 180%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 181BuildRequires: subversion
0cad051b 182BuildRequires: tar >= 1:1.22
0a424ee2 183BuildRequires: udev-devel
7d1152d4 184BuildRequires: usbutils
2303ed45 185BuildRequires: util-linux
c14cd342 186%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 187BuildRequires: which
f1b276d4 188BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 189BuildRequires: xz
a3140cd1 190%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 191%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 192Requires: browser-plugins >= 2.0
0cad051b 193Requires: desktop-file-utils
8f5f6775 194%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
195# crashes if no fontconfig font present
196Requires: fonts-Type1-urw
0eb19b0b 197Requires: hicolor-icon-theme
56403697 198Requires: libevent >= 2.0.21
c1edaafa 199%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 200%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 201Requires: lsb-release
b2c4ae39 202%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 203Requires: shared-mime-info
4dc49133 204Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 205Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 206Provides: wwwbrowser
c3582150 207Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 208Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 209ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 210BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 211
589d90ea 212%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 213
e7fa0817
ER
214# Usage: gyp_with BCOND_NAME [OPTION_NAME]
215%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 216
6b113615
ER
217%if %{without debuginfo}
218%define _enable_debug_packages 0
219%endif
220
11ad81c4 221%description
80838854
ER
222Chromium is an open-source browser project that aims to build a safer,
223faster, and more stable way for all Internet users to experience the
224web.
225
226Chromium serves as a base for Google Chrome, which is Chromium
227rebranded (name and logo) with very few additions such as usage
228tracking and an auto-updater system.
229
f1b276d4
ER
230%package l10n
231Summary: chromium-browser language packages
232Group: I18n
233Requires: %{name} = %{version}-%{release}
234
235%description l10n
236Chromium is an open-source browser project that aims to build a safer,
237faster, and more stable way for all Internet users to experience the
238web.
239
240This package contains language packages for 50 languages:
241
e7fa0817
ER
242ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
243he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
244pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
245zh-TW
f1b276d4
ER
246
247%prep
3c73e180
ER
248%setup -qc
249%if "%{?patchver}" != ""
250cd %{name}-%{branch}.%{basever}
251%patch0 -p1
252cd ..
253%endif
75f96a39 254mv %{name}-%{branch}.%{basever}/* .
589d90ea 255
05f72ae2
ER
256# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
257# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 258. ./chrome/VERSION
0c480b89 259ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
260test "$ver" = %{version}
261
75f96a39 262gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 263test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 264
75f96a39 265v8_ver=$(awk 'NR=1 {print $NF; exit}' v8/ChangeLog || :)
33b04c7d 266
4765ddf1
ER
267# add chromium and pld to useragent
268%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
269sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
270 -e 's/@BUILD_DIST_NAME@/PLD/g' \
271 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
75f96a39 272 < %{PATCH8} | %{__patch} -p2
4765ddf1 273
56c6e811 274%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
275ln -s %{SOURCE7} .
276
277%patch1 -p2
278%patch3 -p2
279%patch4 -p3
280%patch6 -p2
281%patch7 -p2
282%patch10 -p2
283%patch15 -p2
f4a8da6a 284%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 285%patch12 -p1
5997e180 286%patch16 -p1
41d6a4b1 287%patch28 -p1
75f96a39
ER
288%patch25 -p2
289%patch18 -p2
290%patch24 -p2
291%patch26 -p2
292%patch29 -p2
e9abb380 293
75a27c2e
ER
294sh -x clean-source.sh \
295 %{!?with_nacl:nacl=0} \
bbdce24d
ER
296 %{!?with_system_libvpx:libvpx=0} \
297 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 298 %{!?with_system_mesa:mesa=0} \
75a27c2e 299 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 300 %{!?with_system_re2:re2=0} \
75a27c2e
ER
301 %{!?with_system_v8:v8=0} \
302 %{!?with_system_zlib:zlib=0} \
303 %{nil}
fded59be 304
e266589e 305%build
5997e180 306%if %{with nacl}
108c5f7c 307rm -rf native_client/toolchain/linux_x86_newlib
fded59be 308if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 309# Make symlinks for NaCL
108c5f7c 310install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 311
108c5f7c
ER
312cd native_client/toolchain/linux_x86_newlib
313ln -s x86_64-nacl/bin bin
314cd x86_64-nacl/bin
2e4113fd 315__cc='%{__cc}'
f64e73f6 316if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
317 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
318 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
319 %{__sed} -i -e '1i#!/bin/sh' gcc g++
320 chmod +x gcc g++
321else
322 ln -s %{_bindir}/x86_64-nacl-gcc gcc
323 ln -s %{_bindir}/x86_64-nacl-g++ g++
324fi
108c5f7c
ER
325ln -s gcc x86_64-nacl-gcc
326ln -s g++ x86_64-nacl-g++
327ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
328ln -s %{_bindir}/x86_64-nacl-ar ar
329ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 330ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 331ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 332ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 333ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
334ln -s %{_prefix}/x86_64-nacl/lib ../lib
335ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
336ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
337cd ../../../../..
fded59be 338fi
5997e180
ER
339%endif
340
c5b396f3 341test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
342test -e Makefile || \
343 CC="%{__cc}" \
344 CXX="%{__cxx}" \
345 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
346 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
347 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
348%{__python} build/gyp_chromium \
673aee14 349 --format=make \
75f96a39 350 --depth=. \
673aee14 351 build/all.gyp \
f1b276d4
ER
352%ifarch %{ix86}
353 -Dtarget_arch=ia32 \
354%endif
355%ifarch %{x8664}
0c480b89
ER
356 -Dtarget_arch=x64 \
357%endif
7b454a31
AM
358%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
359 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
360%endif
361%if %{with sandboxing}
362 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
363 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
364%endif
365 %{!?debug:-Dwerror=} \
c980b122 366 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 367 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 368 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
b5a3dda3 369 -Dinclude_tests=0 \
c0808220 370%if %{with nacl}
038f76b9 371 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
372 -Ddisable_glibc_untar=1 \
373 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
374 -Ddisable_glibc=1 \
375 -Ddisable_pnacl=1 \
376 -Dbuild_pnacl_newlib=0 \
c0808220 377%else
8fb1dc98 378 -Ddisable_pnacl_untar=1 \
c0808220
ER
379 -Ddisable_nacl=1 \
380%endif
a3140cd1
ER
381 %{!?with_sse2:-Ddisable_sse2=1} \
382 %{?with_selinux:-Dselinux=1} \
7d1152d4 383 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 384 -Dlinux_link_libpci=1 \
bd827d58 385 -Dlinux_link_libspeechd=1 \
05998197 386 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 387 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
388 -Dlinux_use_gold_binary=0 \
389 -Dlinux_use_gold_flags=0 \
e7fa0817 390 %{gyp_with cups} \
8dda6bbc 391 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 392 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
393 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
394 %{gyp_with pulseaudio} \
41d6a4b1 395 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 396 %{gyp_with system_flac} \
01b4dc8e 397 %{gyp_with system_harfbuzz} \
2d65d095 398 %{gyp_with system_jsoncpp} \
62950103
ER
399 %{gyp_with system_libexif} \
400 %{gyp_with system_libmtp} \
9bd2659c 401 %{gyp_with system_libsrtp} \
581aec44 402 %{gyp_with system_libusb} \
41d6a4b1 403 %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
ba685303 404 %{gyp_with system_libwebp} \
4884fc99 405 %{gyp_with system_libxnvctrl} \
7b8f219a 406 %{gyp_with system_mesa} \
126ea630 407 %{gyp_with system_minizip} \
62950103 408 %{gyp_with system_opus} \
75a27c2e 409 %{gyp_with system_protobuf} \
bbdce24d 410 %{gyp_with system_re2} \
e7fa0817 411 %{gyp_with system_speex} \
914ee37c 412 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
413 %{gyp_with system_v8} \
414 %{gyp_with system_yasm} \
415 %{gyp_with system_zlib} \
0c480b89 416 -Duse_system_bzip2=1 \
62950103 417 -Duse_system_expat=1 \
0b214002 418 -Duse_system_icu=1 \
f1b276d4 419 -Duse_system_libevent=1 \
0c480b89 420 -Duse_system_libjpeg=1 \
f1b276d4
ER
421 -Duse_system_libpng=1 \
422 -Duse_system_libxml=1 \
423 -Duse_system_libxslt=1 \
b363f856 424 -Duse_system_nspr=1 \
7f40f3f4 425 -Duse_system_xdg_utils=1 \
11ad81c4 426
b4d75247 427# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 428%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
429 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
430 %{?with_verbose:V=1} \
f1b276d4
ER
431 CC.host="%{__cc}" \
432 CXX.host="%{__cxx}" \
b4d75247 433 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 434
75f96a39 435cd out/%{!?debug:Release}%{?debug:Debug}
535cb410
ER
436MANWIDTH=80 man ./chrome.1 > man.out
437%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
438
11ad81c4
AM
439%install
440rm -rf $RPM_BUILD_ROOT
56c6e811 441install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 442 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 443
673aee14 444cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 445cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 446install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
447%{__sed} -i -e '
448 s,@libdir@,%{_libdir}/%{name},
449
450 /@OPTIONS@/ {
451 r options.txt
452 d
453 }
454' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 455cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 456cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 457install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 458install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 459%if %{without system_ffmpeg}
f1b276d4 460install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 461%endif
e7fa0817 462cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 463cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 464
c0808220
ER
465%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
466
164020eb
ER
467%if %{with nacl}
468# Install Native Client files on platforms that support it.
469install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
470install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
471%ifarch %{x8664}
472install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
473%endif
474%ifarch %{ix86}
475install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
476%endif
477%endif
478
0c480b89
ER
479cd -
480
75f96a39 481for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
482 size=${icon##*/product_logo_}
483 size=${size%.png}
484
485 # this will skip non-numeric (22_mono_invert, 22_mono)
486 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
487 test -d "$dir" || continue
488
489 install -d $RPM_BUILD_ROOT$dir
490 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
491done
7f40f3f4 492
13840bc2
AM
493%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
494# http://code.google.com/p/chromium/issues/detail?id=24507
495gecko-mediaplayer*.so
496EOF
11ad81c4 497
589d90ea
ER
498# find locales
499%find_lang %{name}.lang
e7fa0817 500# always package en-US
f1b276d4 501%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 502
11ad81c4
AM
503%clean
504rm -rf $RPM_BUILD_ROOT
505
f1b276d4 506%post
0eb19b0b 507%update_icon_cache hicolor
b7a6e4ee 508%update_desktop_database
f1b276d4
ER
509%update_browser_plugins
510
511%postun
512if [ "$1" = 0 ]; then
0eb19b0b 513 %update_icon_cache hicolor
f1b276d4
ER
514 %update_browser_plugins
515fi
516
1d2b9616 517%files
11ad81c4 518%defattr(644,root,root,755)
75f96a39 519%doc AUTHORS LICENSE
f1b276d4
ER
520%{_browserpluginsconfdir}/browsers.d/%{name}.*
521%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
522%dir %{_sysconfdir}/%{name}
523%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 524%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
525%attr(755,root,root) %{_bindir}/%{name}
526%{_mandir}/man1/%{name}.1*
11ad81c4 527%{_desktopdir}/*.desktop
0eb19b0b 528%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 529%dir %{_libdir}/%{name}
e9abb380 530%{_libdir}/%{name}/chrome*.pak
c14cd342 531%{_libdir}/%{name}/content_resources.pak
97fac491 532%{_libdir}/%{name}/resources.pak
589d90ea 533%dir %{_libdir}/%{name}/locales
f1b276d4
ER
534%{_libdir}/%{name}/locales/en-US.pak
535%dir %{_libdir}/%{name}/resources
a3140cd1 536%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
537%dir %{_libdir}/%{name}/themes
538%dir %{_libdir}/%{name}/extensions
539%dir %{_libdir}/%{name}/plugins
540%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 541# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 542%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
543
544# ffmpeg libs
fcc48c19 545%if %{without system_ffmpeg}
f1b276d4 546%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 547%endif
f1b276d4 548
164020eb
ER
549%if %{with nacl}
550%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
551%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
552%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
553%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
554%endif
555
f1b276d4
ER
556%files l10n -f %{name}.lang
557%defattr(644,root,root,755)
This page took 0.556226 seconds and 4 git commands to generate.