]> git.pld-linux.org Git - packages/cgicc.git/blame - cgicc.spec
- updated URLs, updated to 3.2.12
[packages/cgicc.git] / cgicc.spec
CommitLineData
630d973c 1# TODO: - provide subpackages with cgi and fastcgi demos
6b30652b 2#
7202c939 3# Conditional build:
4%bcond_without static_libs # don't build static libraries
5#
e9d74984 6Summary: A C++ library for CGI programming
1d42abc7 7Summary(pl.UTF-8): Biblioteka C++ do programowania CGI
e9d74984 8Name: cgicc
6b30652b
JB
9Version: 3.2.12
10Release: 1
11License: LGPL v3+ (library), FDL v1.1+ (documentation)
e9d74984 12Group: Libraries
6b30652b
JB
13Source0: http://ftp.gnu.org/gnu/cgicc/%{name}-%{version}.tar.gz
14# Source0-md5: 7b91620600d9a889e230617747e515c2
15Patch0: %{name}-link.patch
16URL: http://www.gnu.org/software/cgicc/
17BuildRequires: autoconf >= 2.50
f715ef0f 18BuildRequires: automake
19BuildRequires: doxygen
20BuildRequires: libstdc++-devel
d2048c08 21BuildRequires: libtool >= 2:1.5
e9d74984 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25GNU cgicc is a C++ class library that greatly simplifies the creation
26of CGI applications for the World Wide Web. cgicc performs the
27following functions:
28- Parses both GET and POST form data transparently.
29- Provides string, integer, floating-point and single- and
30 multiple-choice retrieval methods for form data.
31- Provides methods for saving and restoring CGI environments to aid in
32 application debugging.
33- Provides full on-the-fly HTML generation capabilities, with support
34 for cookies.
35- Supports HTTP file upload.
36- Compatible with FastCGI.
37
10eaae4b
JR
38%description -l pl.UTF-8
39GNU cgicc to biblioteka klas C++ znacznie upraszczająca tworzenie
40aplikacji CGI dla WWW. cgicc wykonuje następujące funkcje:
41- w sposób przezroczysty analizuje dane z formularzy GET i POST
42- udostępnia metody uzyskiwania łańcuchów znaków, liczb całkowitych i
d2048c08
JB
43 zmiennoprzecinkowych oraz opcji jednokrotnego i wielokrotnego wyboru
44 z danych formularzy
10eaae4b
JR
45- udostępnia metody do zapisu i odtwarzania środowiska CGI
46 pomagające przy śledzeniu aplikacji
47- udostępnia pełne możliwości generowania HTML-a w locie, z obsługą
d2048c08 48 ciasteczek
10eaae4b 49- obsługuje wysyłanie plików po HTTP
d2048c08
JB
50- jest kompatybilna z FastCGI.
51
e9d74984 52%package devel
53Summary: A C++ library for CGI programming - header files
1d42abc7 54Summary(pl.UTF-8): Biblioteka C++ do programowania CGI - pliki nagłówkowe
e9d74984 55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
6b30652b 57Requires: libstdc++-devel
e9d74984 58
59%description devel
60Header files for cgicc library.
61
10eaae4b
JR
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki cgicc.
e9d74984 64
65%package static
66Summary: A C++ library for CGI programming - static version
1d42abc7 67Summary(pl.UTF-8): Biblioteka C++ do programowania CGI - wersja statyczna
e9d74984 68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static version of cgicc library.
73
10eaae4b 74%description static -l pl.UTF-8
e9d74984 75Statyczna wersja biblioteki cgicc.
76
6b30652b
JB
77%package apidocs
78Summary: API documentation for cgicc library
79Summary(pl.UTF-8): Dokumentacja API biblioteki cgicc
80Group: Documentation
81
82%description apidocs
83API documentation for cgicc library.
84
85%description apidocs -l pl.UTF-8
86Dokumentacja API biblioteki cgicc.
87
e9d74984 88%prep
89%setup -q
6b30652b 90%patch0 -p1
e9d74984 91
92%build
93%{__libtoolize}
94%{__aclocal}
95%{__autoconf}
96%{__autoheader}
97%{__automake}
7202c939 98%configure \
6b30652b
JB
99 --disable-demos \
100 %{!?with_static_libs:--disable-static}
e9d74984 101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
6b30652b
JB
109# packaged as %doc in -apidocs
110%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/%{name}-%{version}
111
e9d74984 112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(644,root,root,755)
3a4b8ac3 120%doc AUTHORS BUGS ChangeLog NEWS README THANKS doc/html/*
6b30652b
JB
121%attr(755,root,root) %{_libdir}/libcgicc.so.*.*.*
122%attr(755,root,root) %ghost %{_libdir}/libcgicc.so.3
e9d74984 123
124%files devel
125%defattr(644,root,root,755)
6b30652b
JB
126%attr(755,root,root) %{_bindir}/cgicc-config
127%attr(755,root,root) %{_libdir}/libcgicc.so
128%{_libdir}/libcgicc.la
e9d74984 129%{_includedir}/cgicc
6b30652b
JB
130%{_pkgconfigdir}/cgicc.pc
131%{_aclocaldir}/cgicc.m4
e9d74984 132
7202c939 133%if %{with static_libs}
e9d74984 134%files static
135%defattr(644,root,root,755)
6b30652b 136%{_libdir}/libcgicc.a
7202c939 137%endif
6b30652b
JB
138
139%files apidocs
140%defattr(644,root,root,755)
141%doc doc/html/*
This page took 0.073969 seconds and 4 git commands to generate.