]> git.pld-linux.org Git - packages/calibre.git/blame - calibre.spec
- fix manpages filenames (patch taken from fc)
[packages/calibre.git] / calibre.spec
CommitLineData
17e051e1 1#
2# NOTE:
3# Upstream packages some unfree fonts which we cannot redistribute,
4# so when upgrading calibre we should download upstream tarball by hand from
5# http://downloads.sourceforge.net/calibre and run below script in order
6# to remove them:
7#
8# #!/bin/sh
9#
10# VERSION=$1
11#
12# rm -rf calibre
13# tar -xvzf calibre-$VERSION.tar.gz
14# rm -f calibre/resources/fonts/liberation/*
15# rm -f calibre/resources/fonts/prs500/*
16#
17# tar -cvjf calibre-$VERSION-nofonts.tar.bz2 calibre
18#
02229893 19Summary: E-book converter and library management
0e501b81 20Name: calibre
21Version: 0.6.53
bdbd4238 22Release: 0.1
6d15f615 23License: GPL v3+
02229893 24Group: Applications/Multimedia
17e051e1 25Source0: %{name}-%{version}-nofonts.tar.bz2
26# Source0-md5: 74f8a83e86820b248eb094bde4f1ab69
0e501b81 27Patch0: %{name}-prefix.patch
7b500ff7 28Patch1: %{name}-manpages.patch
02229893 29URL: http://www.calibre-ebook.com/
0e501b81 30BuildRequires: ImageMagick-devel
31BuildRequires: chmlib-devel
32BuildRequires: podofo-devel
33BuildRequires: poppler-Qt-devel
bdbd4238 34BuildRequires: python-BeautifulSoup
307ba398 35BuildRequires: python-PIL
0e501b81 36BuildRequires: python-PyQt4-devel
37BuildRequires: python-cssutils
307ba398 38BuildRequires: python-dateutil
0e501b81 39BuildRequires: python-lxml
40BuildRequires: python-mechanize
6d15f615 41BuildRequires: python-modules-sqlite
0e501b81 42BuildRequires: python-sip-devel
43BuildRequires: rpm-pythonprov
2f356583 44Requires: python-PIL
6d15f615 45Requires: python-cssutils
2f356583 46Requires: python-dateutil
6d15f615 47Requires: python-lxml
48Requires: python-mechanize
49Requires: python-modules-sqlite
0e501b81 50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
02229893
ER
53Calibre is meant to be a complete e-library solution. It includes
54library management, format conversion, news feeds to ebook conversion
55as well as e-book reader sync features.
56
57Calibre is primarily a ebook cataloging program. It manages your ebook
58collection for you. It is designed around the concept of the logical
59book, i.e. a single entry in the database that may correspond to
60ebooks in several formats. It also supports conversion to and from a
61dozen different ebook formats.
62
63Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
64CBR, CBZ, RTF, TXT, PDF and LRS.
0e501b81 65
66%prep
67%setup -q -n %{name}
68%patch0 -p1
7b500ff7 69%patch1 -p1
0e501b81 70
71%build
72%{__python} setup.py build
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__python} setup.py install \
9c8cebf1 78 --root=$RPM_BUILD_ROOT \
79 --libdir=%{_libdir}
0e501b81 80
7b500ff7 81mv $RPM_BUILD_ROOT%{_datadir}/%{name}/man $RPM_BUILD_ROOT%{_mandir}
82
0e501b81 83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(644,root,root,755)
88%doc COPYRIGHT README
89%attr(755,root,root) %{_bindir}/*
90%{_datadir}/%{name}
91%{_libdir}/%{name}
7b500ff7 92%{_mandir}/man1/*.1*
This page took 0.328623 seconds and 4 git commands to generate.