]> git.pld-linux.org Git - packages/calibre.git/blame - calibre.spec
- note how to upgrade without non-free fonts packaging (somebody has better idea?)
[packages/calibre.git] / calibre.spec
CommitLineData
17e051e1 1#
2# NOTE:
3# Upstream packages some unfree fonts which we cannot redistribute,
4# so when upgrading calibre we should download upstream tarball by hand from
5# http://downloads.sourceforge.net/calibre and run below script in order
6# to remove them:
7#
8# #!/bin/sh
9#
10# VERSION=$1
11#
12# rm -rf calibre
13# tar -xvzf calibre-$VERSION.tar.gz
14# rm -f calibre/resources/fonts/liberation/*
15# rm -f calibre/resources/fonts/prs500/*
16#
17# tar -cvjf calibre-$VERSION-nofonts.tar.bz2 calibre
18#
02229893 19Summary: E-book converter and library management
0e501b81 20Name: calibre
21Version: 0.6.53
bdbd4238 22Release: 0.1
6d15f615 23License: GPL v3+
02229893 24Group: Applications/Multimedia
17e051e1 25Source0: %{name}-%{version}-nofonts.tar.bz2
26# Source0-md5: 74f8a83e86820b248eb094bde4f1ab69
0e501b81 27Patch0: %{name}-prefix.patch
02229893 28URL: http://www.calibre-ebook.com/
0e501b81 29BuildRequires: ImageMagick-devel
30BuildRequires: chmlib-devel
31BuildRequires: podofo-devel
32BuildRequires: poppler-Qt-devel
bdbd4238 33BuildRequires: python-BeautifulSoup
307ba398 34BuildRequires: python-PIL
0e501b81 35BuildRequires: python-PyQt4-devel
36BuildRequires: python-cssutils
307ba398 37BuildRequires: python-dateutil
0e501b81 38BuildRequires: python-lxml
39BuildRequires: python-mechanize
6d15f615 40BuildRequires: python-modules-sqlite
0e501b81 41BuildRequires: python-sip-devel
42BuildRequires: rpm-pythonprov
6d15f615 43Requires: python-cssutils
44Requires: python-lxml
45Requires: python-mechanize
46Requires: python-modules-sqlite
0e501b81 47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
02229893
ER
50Calibre is meant to be a complete e-library solution. It includes
51library management, format conversion, news feeds to ebook conversion
52as well as e-book reader sync features.
53
54Calibre is primarily a ebook cataloging program. It manages your ebook
55collection for you. It is designed around the concept of the logical
56book, i.e. a single entry in the database that may correspond to
57ebooks in several formats. It also supports conversion to and from a
58dozen different ebook formats.
59
60Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
61CBR, CBZ, RTF, TXT, PDF and LRS.
0e501b81 62
63%prep
64%setup -q -n %{name}
65%patch0 -p1
66
67%build
68%{__python} setup.py build
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%{__python} setup.py install \
74 --root=$RPM_BUILD_ROOT
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
81%doc COPYRIGHT README
82%attr(755,root,root) %{_bindir}/*
83%{_datadir}/%{name}
84%{_libdir}/%{name}
This page took 0.06487 seconds and 4 git commands to generate.