]> git.pld-linux.org Git - packages/cacti.git/blame - cacti.spec
- merged from cvs.pld.org.pl
[packages/cacti.git] / cacti.spec
CommitLineData
6587a5d5
JB
1%define name cacti
2%define version 0.6.8a
3%define release 3mdk
4%define webadminroot /var/www/html/admin
5
6Summary: Cacti is a php frontend for rrdtool
7Name: %{name}
8Version: %{version}
9Release: %{release}
10License: GPL
11Group: System/Servers
12URL: http://www.raxnet.net/
13Source0: %{name}-%{version}.tar.bz2
14Patch0: %{name}-%{version}-paths.patch.bz2
15Requires: webserver mysqlserver mod_php php php-common php-gd php-mysql php-snmp
16Requires: net-snmp-utils libnet-snmp50 net-snmp net-snmp-mibs
17Requires: librrdtool0 rrdtool
18BuildRequires: perl
19BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
20BuildArch: noarch
21Prefix: %{webadminroot}
22
23%description
24Cacti is a complete frondend to rrdtool, it stores all of the
25nessesary information to create graphs and populate them with
26data in a MySQL database.
27
28The frontend is completely PHP driven. Along with being able
29to maintain Graphs, Data Sources, and Round Robin Archives in
30a database, cacti handles the data gathering also. There is
31also SNMP support for those used to creating traffic graphs
32with MRTG.
33
34%prep
35
36%setup -q
37%patch0 -p1
38
39%build
40
41# clean up CVS stuff
42for i in `find . -type d -name CVS` `find . -type f -name .cvs\*` `find . -type f -name .#\*`; do
43 if [ -e "$i" ]; then rm -r $i; fi >&/dev/null
44done
45
46# fix dir perms
47find . -type d | xargs chmod 755
48
49# fix file perms
50find . -type f | xargs chmod 644
51
52%install
53[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
54
55mkdir -p %{buildroot}%{webadminroot}/%{name}
56cp -aRf * %{buildroot}%{webadminroot}/%{name}/
57
58%clean
59[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
60
61%files
62%defattr(-, root, root)
63%doc docs/CHANGELOG docs/CONTRIB docs/README
64%config(noreplace) %attr(0644,apache,apache) %{webadminroot}/%{name}/log/rrd.log
65%config(noreplace) %attr(0644,root,root) %{webadminroot}/%{name}/rra/.placeholder
66%config(noreplace) %attr(0644,apache,apache) %{webadminroot}/%{name}/include/config.php
67%{webadminroot}/%{name}/*
68
69%changelog
70* Thu Jan 16 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.6.8a-3mdk
71- build release
72
73* Thu Sep 19 2002 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.6.8a-2mdk
74- misc spec file fixes
75- install in common and relocatable %%{webadminroot}/ directory
76
77* Wed Sep 18 2002 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.6.8a-1mdk
78- security release
79- do not require non existant php extensions
80- misc spec file fixes
81
82* Sun May 12 2002 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.6.8-1mdk
83- initial cooker contrib
This page took 0.045318 seconds and 4 git commands to generate.