]> git.pld-linux.org Git - packages/cacti.git/blame - cacti.spec
- converted to UTF-8
[packages/cacti.git] / cacti.spec
CommitLineData
d28e2507
ER
1# TODO
2# - patch source to use adodb system path instead of symlinking
e90043f8 3%include /usr/lib/rpm/macros.perl
9f35c748 4Summary: Cacti is a PHP frontend for rrdtool
41840fab 5Summary(pl.UTF-8): Cacti - frontend w PHP do rrdtoola
94614147 6Name: cacti
0310f06a
GS
7Version: 0.8.6j
8Release: 1
6587a5d5 9License: GPL
94614147 10Group: Applications/WWW
761b4fb2 11Source0: http://www.cacti.net/downloads/%{name}-%{version}.tar.gz
0310f06a 12# Source0-md5: 29436be46b289d13dfce48e7618129e2
b03aa015 13Patch10: %{name}-plugin-%{version}.diff
991e345f 14Patch11: %{name}-config.patch
761b4fb2 15URL: http://www.cacti.net/
89aea3b3 16BuildRequires: rpm-perlprov
f44cea91 17Requires: adodb >= 4.67-1.17
e9300b9e 18Requires: crondaemon
94614147 19Requires: net-snmp-utils
f5a0e42f
ER
20Requires: php(gd)
21Requires: php(mysql)
22Requires: php(pcre)
23Requires: php(snmp)
24Requires: php(xml)
e9300b9e 25Requires: php-cli
94614147 26Requires: rrdtool
e4f2f951 27Requires: webserver
f5a0e42f 28Requires: webserver(php)
6587a5d5 29BuildArch: noarch
94614147
JB
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
90312589 32%define webadminroot /usr/share/%{name}
6587a5d5
JB
33
34%description
35Cacti is a complete frondend to rrdtool, it stores all of the
94614147
JB
36nessesary information to create graphs and populate them with data in
37a MySQL database.
6587a5d5 38
94614147
JB
39The frontend is completely PHP driven. Along with being able to
40maintain Graphs, Data Sources, and Round Robin Archives in a database,
41cacti handles the data gathering also. There is also SNMP support for
42those used to creating traffic graphs with MRTG.
6587a5d5 43
41840fab
JR
44%description -l pl.UTF-8
45Cacti to pełny frontend do rrdtoola, zapamiętujący wszystkie
46informacje potrzebne do tworzenia wykresów i wypełniające je danymi w
c9dfb888
JB
47bazie MySQL.
48
41840fab
JR
49Frontend jest w pełni oparty na PHP. Oprócz zarządzania wykresami,
50źródłami danych, archiwami Round Robin w bazie danych, cacti obsługuje
51także gromadzenie danych. Ma także obsługę SNMP przydatną przy
52tworzeniu wykresów ruchu przy użyciu MRTG.
c9dfb888 53
6587a5d5 54%prep
6587a5d5 55%setup -q
b03aa015
GS
56%patch10 -p1
57%patch11 -p1
6587a5d5 58
f44cea91 59rm -rf lib/adodb
6587a5d5
JB
60
61%install
94614147 62rm -rf $RPM_BUILD_ROOT
e9300b9e
AM
63install -d $RPM_BUILD_ROOT%{webadminroot}
64install -d $RPM_BUILD_ROOT%{_sysconfdir}/{%{name},cron.d}
c7a01fb3 65install -d $RPM_BUILD_ROOT/var/{log,lib/%{name}}
e9300b9e 66cp -aRf * $RPM_BUILD_ROOT%{webadminroot}
4e7db512 67ln -s . $RPM_BUILD_ROOT%{webadminroot}/%{name}
e9300b9e 68
8a891920
ER
69# TODO: move this to SOURCES. it's a lot better to backtrack changes
70# if it's a separate file.
71cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.cfg
8b0c4935 72<?php
8a891920
ER
73$database_type = 'mysql';
74$database_default = 'cacti';
75$database_hostname = 'localhost';
76$database_username = 'cactiuser';
77$database_password = 'cactiuser';
d0110f91
MWP
78
79$plugins = array();
80// $plugins[] = 'thold';
81// $plugins[] = 'monitor';
82// $plugins[] = 'discovery';
83
84/* Do not edit this line */
85$config = array();
86
87/* This is full URL Path to the Cacti installation
88 For example, if your cacti was accessible by http://server/cacti/ you would user '/cacti/'
89 as the url path. For just http://server/ use '/'
90*/
8a891920 91$config['url_path'] = '/cacti/';
d0110f91 92
8b0c4935
AM
93?>
94EOF
e9300b9e
AM
95
96mv $RPM_BUILD_ROOT%{webadminroot}/log $RPM_BUILD_ROOT/var/log/%{name}
97ln -sf /var/log/cacti $RPM_BUILD_ROOT%{webadminroot}/log
98
99mv $RPM_BUILD_ROOT%{webadminroot}/rra $RPM_BUILD_ROOT/var/lib/%{name}
4e7db512 100ln -sf /var/lib/%{name}/rra $RPM_BUILD_ROOT%{webadminroot}/rra
8d1010a2 101ln -sf /usr/share/php/adodb $RPM_BUILD_ROOT%{webadminroot}/lib/adodb
e9300b9e 102
8a891920 103cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/%{name}
f44cea91 104*/5 * * * * http umask 022; %{_bindir}/php %{webadminroot}/poller.php > /dev/null 2>&1
e9300b9e 105EOF
6587a5d5
JB
106
107%clean
94614147 108rm -rf $RPM_BUILD_ROOT
6587a5d5
JB
109
110%files
94614147 111%defattr(644,root,root,755)
6587a5d5 112%doc docs/CHANGELOG docs/CONTRIB docs/README
e9300b9e 113%attr(750,root,http) %dir %{_sysconfdir}/%{name}
270f88a1 114%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.cfg
f18c97be 115%attr(770,root,http) %dir /var/log/%{name}
e9300b9e 116%attr(660,root,http) %ghost /var/log/%{name}/*.log
271af71b 117%attr(750,root,http) %dir /var/lib/%{name}
cd209fd1 118%attr(770,root,http) %dir /var/lib/%{name}/rra
e9300b9e
AM
119%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
120%{webadminroot}
This page took 0.205356 seconds and 4 git commands to generate.