]> git.pld-linux.org Git - packages/btparser.git/blame - btparser.spec
- updated to 0.25
[packages/btparser.git] / btparser.spec
CommitLineData
7dc4c325 1Summary: Parser and analyzer for backtraces produced by GDB
6d92037a 2Summary(pl.UTF-8): Analizator śladów wywołań tworzonych przez GDB
7dc4c325 3Name: btparser
6d9927ba
JB
4Version: 0.25
5Release: 1
6License: GPL v2+
6d92037a 7Group: Development/Tools
6d9927ba
JB
8Source0: https://fedorahosted.org/released/btparser/%{name}-%{version}.tar.xz
9# Source0-md5: 7fcf3f97dd6df827151638a41855c5bb
10URL: http://fedorahosted.org/btparser/
7dc4c325
JR
11%ifarch %{x8664}
12BuildRequires: binutils-static
13%endif
6d9927ba
JB
14BuildRequires: glib2-devel >= 1:2.21
15BuildRequires: pkgconfig
7dc4c325
JR
16BuildRequires: python-devel
17BuildRequires: python-distribute
18BuildRequires: rpm-pythonprov
6d9927ba
JB
19BuildRequires: rpmbuild(macros) >= 1.219
20BuildRequires: xmlto
7dc4c325
JR
21Requires: %{name}-libs = %{version}-%{release}
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Btparser is a backtrace parser and analyzer, which works with
26backtraces produced by the GNU Project Debugger. It can parse a text
27file with a backtrace to a tree of C structures, allowing to analyze
28the threads and frames of the backtrace and work with them.
29
30Btparser also contains some backtrace manipulation and extraction
31routines:
32- it can find a frame in the crash-time backtrace where the program
33 most likely crashed (a chance is that the function described in that
34 frame is buggy)
35- it can produce a duplication hash of the backtrace, which helps to
36 discover that two crash-time backtraces are duplicates, triggered by
37 the same flaw of the code
38- it can "rate" the backtrace quality, which depends on the number of
39 frames with and without the function name known (missing function
40 name is caused by missing debugging symbols)
41
6d92037a
JB
42%description -l pl.UTF-8
43Btparser to analizator śladów wywołań (backtrace'ów), działający ze
44śladami tworzonymi przez debugger GDB z projektu GNU. Potrafi
45przetworzyć plik tekstowy ze śladem na drzewo struktur C, co pozwala
46na analizę wątków oraz ramek śladu wywołań i dalszą pracę z nimi.
47
48Btparser zawiera także trochę procedur do obróbki i wydobywania śladów
49wywołań:
50- potrafi znaleźć ramkę w pośmiertnym śladzie wywołań, w której
51 najprawdopodobniej nastąpiła wywrotka programu (możliwe, że to
52 funkcja w tej ramce zawiera błąd)
53- potrafi utworzyć skrót (hasz) śladu, pozwalający wykryć, czy dwa
54 zadane ślady pośmiertne są duplikatami spowodowanymi tym samym
55 błędem w kodzie
56- potrafi "ocenić jakość" śladów, zależną od liczby ramek ze znaną i
57 bez znanej nazwy funkcji (brak nazwy funkcji wynika z braku symboli
58 diagnostycznych)
59
7dc4c325
JR
60%package libs
61Summary: Btparser library
62Summary(pl.UTF-8): Biblioteka btparser
63Group: Libraries
6d9927ba 64Requires: glib2 >= 1:2.21
7dc4c325
JR
65
66%description libs
6d92037a 67Btparser library.
7dc4c325
JR
68
69%description libs -l pl.UTF-8
70Biblioteka btparser.
71
72%package devel
73Summary: Header files for %{name} library
74Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
75Group: Development/Libraries
76Requires: %{name}-libs = %{version}-%{release}
6d9927ba 77Requires: glib2-devel >= 1:2.21
7dc4c325
JR
78
79%description devel
80Header files for %{name} library.
81
82%description devel -l pl.UTF-8
83Pliki nagłówkowe biblioteki %{name}.
84
85%package -n python-btparser
86Summary: Python bindings for %{name}
6d92037a
JB
87Summary(pl.UTF-8): Wiązania Pythona do biblioteki btparser
88Group: Libraries/Python
7dc4c325 89Requires: %{name}-libs = %{version}-%{release}
6d9927ba 90Requires: python-modules
7dc4c325
JR
91
92%description -n python-btparser
93Python bindings for %{name}.
94
6d92037a
JB
95%description -n python-btparser -l pl.UTF-8
96Wiązania Pythona do biblioteki btparser.
97
7dc4c325
JR
98%prep
99%setup -q
100
101%build
7dc4c325 102%configure \
6d92037a 103%ifarch %{x8664}
7dc4c325 104 --enable-fingerprints
7dc4c325 105%endif
6d92037a 106
7dc4c325
JR
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
116
6d9927ba
JB
117%py_postclean
118
7dc4c325
JR
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post libs -p /sbin/ldconfig
123%postun libs -p /sbin/ldconfig
124
125%files
126%defattr(644,root,root,755)
127%doc ChangeLog NEWS README RELEASE TODO
128%attr(755,root,root) %{_bindir}/btparser
129%{_mandir}/man1/btparser.1*
130
131%files libs
132%defattr(644,root,root,755)
133%attr(755,root,root) %{_libdir}/libbtparser.so.*.*
134%attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
135
136%files devel
137%defattr(644,root,root,755)
6d92037a 138%attr(755,root,root) %{_libdir}/libbtparser.so
7dc4c325 139%{_includedir}/btparser
6d92037a 140%{_pkgconfigdir}/btparser.pc
7dc4c325
JR
141
142%files -n python-btparser
6d92037a 143%defattr(644,root,root,755)
f277cb5b 144%dir %{py_sitedir}/btparser
6d9927ba
JB
145%{py_sitedir}/btparser/__init__.py[co]
146%attr(755,root,root) %{py_sitedir}/btparser/_btparser.so
This page took 0.087461 seconds and 4 git commands to generate.