]> git.pld-linux.org Git - packages/boost.git/blame - boost.spec
- boost-compressed_pair-devel was obsoleted by boost-devel, no need to
[packages/boost.git] / boost.spec
CommitLineData
c6874538 1#
bde731a5 2# TODO:
09e2803f
PS
3# - think about building MPI.
4# - split shared libs from core package into -iostreams/-serialization.
bde731a5 5#
c6874538 6# Conditional build:
65d4777a 7%bcond_without python # without boost-python support
c6874538 8#
09e2803f 9%define _fver %(echo %{version} | tr . _)
c6874538 10Summary: The Boost C++ Libraries
aa63c3d9 11Summary(pl.UTF-8): Biblioteki C++ "Boost"
49f48a3b 12Name: boost
09e2803f 13Version: 1.35.0
e3b0ba0c 14Release: 2
db639b8e 15License: Boost Software License and others
c6874538 16Group: Libraries
db639b8e 17Source0: http://dl.sourceforge.net/boost/%{name}_%{_fver}.tar.bz2
09e2803f
PS
18# Source0-md5: dce952a7214e72d6597516bcac84048b
19Patch0: %{name}-climits.patch
49f48a3b 20URL: http://www.boost.org/
fe68e457 21BuildRequires: boost-jam >= 3.1.12
afbf1450 22BuildRequires: bzip2-devel
09e2803f 23BuildRequires: expat-devel
7c12a8f9 24BuildRequires: libicu-devel
49f48a3b 25BuildRequires: libstdc++-devel
30964b71 26BuildRequires: perl-base
6725319f 27%{?with_python:BuildRequires: python-devel >= 2.2}
dbf04d57 28BuildRequires: rpm-pythonprov
afbf1450 29BuildRequires: zlib-devel
c6874538 30BuildConflicts: gcc = 5:3.3.1
49f48a3b 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
c6874538 32
33%description
34The Boost web site provides free peer-reviewed portable C++ source
35libraries. The emphasis is on libraries which work well with the C++
36Standard Library. One goal is to establish "existing practice" and
37provide reference implementations so that the Boost libraries are
38suitable for eventual standardization. Some of the libraries have
39already been proposed for inclusion in the C++ Standards Committee's
40upcoming C++ Standard Library Technical Report.
41
4c35df9e 42%description -l pl.UTF-8
49f48a3b 43Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
4c35df9e
JR
44kodem źródłowym. Nacisk położono na biblioteki, które dobrze
45współpracują ze standardową biblioteką C++. Celem jest ustanowienie
46"istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
47"Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
48już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
c6874538 49Raporcie Technicznym Biblioteki Standardowej C++
50
49f48a3b 51%package devel
000cd675 52Summary: Boost C++ development headers
aa63c3d9 53Summary(pl.UTF-8): Pliki nagłówkowe bibliotek C++ Boost
49f48a3b 54Group: Development/Libraries
000cd675 55Requires: %{name} = %{version}-%{release}
09e2803f
PS
56Requires: %{name}-date_time = %{version}-%{release}
57Requires: %{name}-filesystem = %{version}-%{release}
58Requires: %{name}-graph = %{version}-%{release}
59Requires: %{name}-program_options = %{version}-%{release}
60Requires: %{name}-regex = %{version}-%{release}
61Requires: %{name}-signals = %{version}-%{release}
62Requires: %{name}-test = %{version}-%{release}
63Requires: %{name}-thread = %{version}-%{release}
64Requires: %{name}-wave = %{version}-%{release}
49f48a3b 65Requires: libstdc++-devel
09e2803f
PS
66Obsoletes: boost-any-devel
67Obsoletes: boost-array-devel
68Obsoletes: boost-bind-devel
05b0e240 69Obsoletes: boost-call_traits-devel
09e2803f 70Obsoletes: boost-compatibility-devel
470f1aae 71Obsoletes: boost-compose-devel
09e2803f 72Obsoletes: boost-compressed_pair-devel
89fd45a2
JB
73Obsoletes: boost-concept_check-devel
74Obsoletes: boost-conversion-devel
09e2803f
PS
75Obsoletes: boost-crc-devel
76Obsoletes: boost-date_time-devel
77Obsoletes: boost-filesystem-devel
78Obsoletes: boost-graph-devel
79Obsoletes: boost-mem_fn-devel
89fd45a2
JB
80Obsoletes: boost-mpl-devel
81Obsoletes: boost-preprocessor-devel
09e2803f 82Obsoletes: boost-program_options-devel
7c797e1a 83Obsoletes: boost-ref-devel
09e2803f
PS
84Obsoletes: boost-regex-devel
85Obsoletes: boost-signals-devel
86Obsoletes: boost-spirit-devel
87Obsoletes: boost-statechart-devel
89fd45a2 88Obsoletes: boost-static_assert-devel
09e2803f
PS
89Obsoletes: boost-test-devel
90Obsoletes: boost-thread-devel
91Obsoletes: boost-tr1-devel
89fd45a2 92Obsoletes: boost-type_traits-devel
09e2803f
PS
93Obsoletes: boost-typeof-devel
94Obsoletes: boost-uBLAS-devel
89fd45a2 95Obsoletes: boost-utility-devel
09e2803f
PS
96Obsoletes: boost-wave-devel
97Obsoletes: boost-xpressive-devel
49f48a3b
JB
98
99%description devel
000cd675 100Header files for the Boost C++ libraries.
49f48a3b 101
4c35df9e
JR
102%description devel -l pl.UTF-8
103Pliki nagłówkowe bibliotek C++ Boost.
000cd675
JB
104
105%package static
106Summary: Static version of base Boost C++ libraries
aa63c3d9 107Summary(pl.UTF-8): Statyczne wersje podstawowych bibliotek C++ Boost
000cd675
JB
108Group: Development/Libraries
109Requires: %{name}-devel = %{version}-%{release}
09e2803f 110Obsoletes: boost-static < 1.33
000cd675
JB
111
112%description static
113Static version of base Boost C++ libraries.
114
4c35df9e 115%description static -l pl.UTF-8
000cd675 116Statyczne wersje podstawowych bibliotek C++ Boost.
49f48a3b 117
c6874538 118%package python
119Summary: Boost.Python library
aa63c3d9 120Summary(pl.UTF-8): biblioteka Boost.Python
c6874538 121Group: Libraries
6725319f 122%pyrequires_eq python
c6874538 123
124%description python
125Use the Boost Python Library to quickly and easily export a C++
126library to Python such that the Python interface is very similar to
127the C++ interface. It is designed to be minimally intrusive on your
128C++ design. In most cases, you should not have to alter your C++
129classes in any way in order to use them with Boost.Python. The system
130should simply ``reflect'' your C++ classes and functions into Python.
131
4c35df9e
JR
132%description python -l pl.UTF-8
133Biblioteka Boost Python służy do szybkiego i prostego eksportu
134biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
135podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
136narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
137większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
138żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
66ac0d93 139klasy C++ i funkcje do Pythona.
c6874538 140
141%package python-devel
142Summary: Boost.Python development headers
aa63c3d9 143Summary(pl.UTF-8): Pliki nagłówkowe dla Boost.Python
49f48a3b
JB
144Group: Development/Libraries
145Requires: %{name}-devel = %{version}-%{release}
6725319f 146Requires: %{name}-python = %{version}-%{release}
c6874538 147
148%description python-devel
66ac0d93 149Headers for the Boost.Python library.
c6874538 150
4c35df9e
JR
151%description python-devel -l pl.UTF-8
152Pliki nagłówkowe dla biblioteki Boost.Python.
c6874538 153
6725319f
JB
154%package python-static
155Summary: Static version of Boost.Python library
aa63c3d9 156Summary(pl.UTF-8): Statyczna wersja biblioteki Boost.Python
6725319f
JB
157Group: Development/Libraries
158Requires: %{name}-python-devel = %{version}-%{release}
159
160%description python-static
161Static version of Boost.Python library.
162
4c35df9e 163%description python-static -l pl.UTF-8
6725319f
JB
164Statyczna wersja biblioteki Boost.Python.
165
02c23151 166%package date_time
d143171f 167Summary: Date-Time library
aa63c3d9 168Summary(pl.UTF-8): Biblioteka daty-czasu
02c23151 169Group: Libraries
000cd675 170Obsoletes: boost < 1.33
02c23151 171
172%description date_time
173A set of date-time libraries.
174
4c35df9e
JR
175%description date_time -l pl.UTF-8
176Zbiór bibliotek daty-czasu.
02c23151 177
31026e88 178%package filesystem
179Summary: Portable paths, iteration over directories, and other useful filesystem operations
aa63c3d9 180Summary(pl.UTF-8): Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
31026e88 181Group: Libraries
000cd675 182Obsoletes: boost < 1.33
31026e88 183
184%description filesystem
04846599
JB
185The boost::filesystem library provides portable facilities to query
186and manipulate paths, files, and directories.
31026e88 187
4c35df9e
JR
188%description filesystem -l pl.UTF-8
189Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
190operacjach na ścieżkach, plikach i katalogach.
31026e88 191
06ed6468
AM
192%package graph
193Summary: General purpose, generic C++ library for graph data structures and graph algorithms
194Summary(pl.UTF-8): Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
195Group: Libraries
196
197%description graph
198The boost::graph library provides portable facilities to operate on
199graph data structures using graph algorithms.
200
201%description graph -l pl.UTF-8
202Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
203strukturach danych typu graf za pomocą algorytmów związanych z
204grafami.
205
99f4684a 206%package program_options
207Summary: Access to program options, via conventional methods such as command line and config file
aa63c3d9 208Summary(pl.UTF-8): Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
99f4684a 209Group: Libraries
210
211%description program_options
212The program_options library allows program developers to obtain
213program options, that is (name, value) pairs from the user, via
214conventional methods such as command line and config file.
215
4c35df9e
JR
216%description program_options -l pl.UTF-8
217Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
218programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
219jak linia poleceń, czy plik konfiguracyjny.
99f4684a 220
09e2803f
PS
221%package regex
222Summary: Boost C++ regular expressions library
223Summary(pl.UTF-8): Biblioteka wyrażeń regularnych Boost C++
224Group: Libraries
99f4684a 225
09e2803f
PS
226%description regex
227Shared library for Boost C++ regular expressions.
99f4684a 228
09e2803f
PS
229%description regex -l pl.UTF-8
230Biblioteka wyrażeń regularnych dla C++, biblioteki dzielone.
99f4684a 231
db639b8e 232%package signals
75f9f612 233Summary: Signals & slots callback implementation
aa63c3d9 234Summary(pl.UTF-8): Implementacja sygnałów i slotów
db639b8e 235Group: Libraries
000cd675 236Obsoletes: boost < 1.33
db639b8e 237
238%description signals
239The boost::signals library is an implementation of a signals and slots
240system.
241
4c35df9e
JR
242%description signals -l pl.UTF-8
243Biblioteka boost::signals jest implementacją systemu sygnałów i
244slotów.
db639b8e 245
09e2803f
PS
246%package system
247Summary: Support for getting system specific error codes
248Summary(pl.UTF-8): Wsparcie dla pobierania specyficznych dla systemu kodów błędów
249Group: Libraries
06ed6468 250
09e2803f
PS
251%description system
252The Boost System library provides simple, light-weight error_code
253objects that encapsulate system-specific error code values, yet also
254provide access to more abstract and portable error conditions objects.
0651a785 255
c0536c7f 256%package test
09e2803f 257Summary: Support for program testing and execution monitoring
aa63c3d9 258Summary(pl.UTF-8): Wsparcie dla testowania i monitorowania programu
c0536c7f 259Group: Libraries
000cd675 260Obsoletes: boost < 1.33
c0536c7f 261
262%description test
263Support for simple program testing, full unit testing, and for program
264execution monitoring.
265
4c35df9e
JR
266%description test -l pl.UTF-8
267Wsparcie dla prostego testowania programu, pełnego testowania i
c0536c7f 268monitorowania wykonania programu.
269
02c23151 270%package thread
d143171f 271Summary: Portable C++ threads library
aa63c3d9 272Summary(pl.UTF-8): Przenośna biblioteka wątków C++
02c23151 273Group: Libraries
000cd675 274Obsoletes: boost < 1.33
02c23151 275
276%description thread
e4ddb7d1 277Portable C++ threads library - shared library.
02c23151 278
4c35df9e
JR
279%description thread -l pl.UTF-8
280Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
02c23151 281
06ed6468
AM
282%package wave
283Summary: Boost.Wave - a standard compliant C++ preprocessor library
284Summary(pl.UTF-8): Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
285Group: Development/Libraries
286Requires: %{name}-devel = %{version}-%{release}
287
288%description wave
289Boost.Wave - a standard compliant C++ preprocessor library.
290
291%description wave -l pl.UTF-8
292Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
293
c6874538 294%package doc
295Summary: Boost C++ Library documentation
aa63c3d9 296Summary(pl.UTF-8): Dokumentacja dla biblioteki Boost C++
49f48a3b 297Group: Documentation
b0977fb8 298Requires: %{name}-devel = %{version}-%{release}
c6874538 299
300%description doc
66ac0d93 301Documentation for the Boost C++ Library.
c6874538 302
4c35df9e 303%description doc -l pl.UTF-8
66ac0d93 304Dokumentacja dla biblioteki Boost C++.
c6874538 305
306%prep
db639b8e 307%setup -q -n %{name}_%{_fver}
09e2803f 308%patch0 -p1
c6874538 309
9b1806d5
PS
310# - don't know how to pass it through (b)jam -s (no way?)
311# due to oversophisticated build flags system.
312# - pass -fPIC due to <shared-linkable> removal.
09e2803f
PS
313%{__sed} -i 's/<optimization>speed : -O3/<optimization>speed : %{rpmcxxflags} -fPIC/' tools/build/v2/tools/gcc.jam
314
315# cleanup -g switch to avoid override debuginfocflags.
316%{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
317# link against shared expat library.
318%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
502f5d36 319
9b9b3ef7
JB
320%ifarch alpha
321# -pthread gcc parameter doesn't add _REENTRANT to cpp macros on alpha (only)
322# don't know, is it gcc bug or intentional omission?
323# anyway, boost check of -D_REENTRANT in its headers, so it's needed here
324%{__perl} -pi -e 's/(CFLAGS.*-pthread)/$1 -D_REENTRANT/' tools/build/v1/gcc-tools.jam
325%endif
326
09e2803f
PS
327cat << EOF > tools/build/v2/user-config.jam
328using gcc : %(%{__cxx} -dumpversion) : %{__cxx} ;
329EOF
330
c6874538 331%build
49f48a3b 332%if %{with python}
7c12a8f9 333PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
c6874538 334PYTHON_ROOT=%{_prefix}
335%else
336PYTHON_ROOT=
337PYTHON_VERSION=
338%endif
09e2803f
PS
339EXPAT_INCLUDE=%{_includedir} \
340EXPAT_LIBPATH=%{_libdir} \
341ICU_PATH=%{_prefix} \
49f48a3b 342bjam \
9b1806d5 343 -d2 --toolset=gcc \
09e2803f 344 variant=release debug-symbols=on inlining=on link=static,shared threading=multi
9b1806d5 345
c6874538 346%install
347rm -rf $RPM_BUILD_ROOT
30964b71 348install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
c6874538 349
30964b71 350cp -rf boost $RPM_BUILD_ROOT%{_includedir}
c6874538 351
9b1806d5
PS
352install bin.v2/libs/*/build/gcc-*/release/debug-symbols-on/inlining-on/link-static/threading-multi/lib*.a $RPM_BUILD_ROOT%{_libdir}
353install bin.v2/libs/*/build/gcc-*/release/debug-symbols-on/inlining-on/threading-multi/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
fe815c68 354
8dcb94bd 355# create symlinks without -gccXX-mt-* things in names
9b1806d5 356for f in $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*; do
835aa2c4 357 [ -f "$f" ] || continue
fa767695 358 f=$(basename "$f")
8dcb94bd 359 soname=$(basename "$f" | sed -e 's#-gcc..-mt-.*#.so#g')
9b1806d5 360 ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$soname"
fa767695
AM
361done
362for f in $RPM_BUILD_ROOT%{_libdir}/*.a; do
835aa2c4 363 [ -f "$f" ] || continue
fa767695 364 f=$(basename "$f")
8dcb94bd 365 soname=$(basename "$f" | sed -e 's#-gcc..-mt-.*#.a#g')
9b1806d5 366 ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$soname"
fa767695
AM
367done
368
c6874538 369# documentation
370install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
c6874538 371
372# as the documentation doesn't completely reside in a directory of its
373# own, we need to find out ourselves... this looks for HTML files and
374# then collects everything linked from those. this is certainly quite
375# unoptimized wrt mkdir calls, but does it really matter?
7c12a8f9
ER
376installdocs() {
377for i in $(find -type f -name '*.htm*'); do
c6874538 378 # bjam docu is included in the boost-jam RPM
379 if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
7c12a8f9 380 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
30964b71 381 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
c6874538 382 sub rewrite_link
383 {
384 my $link = shift;
385 # rewrite links from boost/* to %{_includedir}/boost/* and
386 # ignore external links as well as document-internal ones.
387 # HTML files are also ignored as they get installed anyway.
388 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
389 {
390 (my $file = $link) =~ s/\#.*//;
391 print "$file\n";
392 }
393 $link;
394 }
395 open IN, @ARGV[0];
396 open OUT, ">@ARGV[1]";
66ac0d93 397 my $in_link;
c6874538 398 while (<IN>)
399 {
66ac0d93 400 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
c6874538 401 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
402 print OUT;
d143171f 403 $in_link = /href|src=\s*$/;
c6874538 404 }
405EOT`; do
7c12a8f9 406 TARGET=${i%/*}/$LINKED
c6874538 407 # ignore non-existant linked files
408 if test -f $TARGET; then
7c12a8f9 409 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
c6874538 410 fi
411 done
412 fi
413done
7c12a8f9 414}; installdocs
c6874538 415
416%clean
417rm -rf $RPM_BUILD_ROOT
418
000cd675
JB
419%post -p /sbin/ldconfig
420%postun -p /sbin/ldconfig
421
3d8dd501
JB
422%post date_time -p /sbin/ldconfig
423%postun date_time -p /sbin/ldconfig
424
04846599
JB
425%post filesystem -p /sbin/ldconfig
426%postun filesystem -p /sbin/ldconfig
427
06ed6468
AM
428%post graph -p /sbin/ldconfig
429%postun graph -p /sbin/ldconfig
430
09e2803f
PS
431%post python -p /sbin/ldconfig
432%postun python -p /sbin/ldconfig
433
434%post program_options -p /sbin/ldconfig
435%postun program_options -p /sbin/ldconfig
c6874538 436
09e2803f
PS
437%post regex -p /sbin/ldconfig
438%postun regex -p /sbin/ldconfig
290ca6f4 439
09e2803f
PS
440%post signals -p /sbin/ldconfig
441%postun signals -p /sbin/ldconfig
c6874538 442
09e2803f
PS
443%post system -p /sbin/ldconfig
444%postun system -p /sbin/ldconfig
3d8dd501 445
09e2803f
PS
446%post test -p /sbin/ldconfig
447%postun test -p /sbin/ldconfig
c0536c7f 448
09e2803f
PS
449%post wave -p /sbin/ldconfig
450%postun wave -p /sbin/ldconfig
06ed6468 451
09e2803f
PS
452%post thread -p /sbin/ldconfig
453%postun thread -p /sbin/ldconfig
3d8dd501 454
000cd675
JB
455%files
456%defattr(644,root,root,755)
457%attr(755,root,root) %{_libdir}/libboost_iostreams*.so.*.*.*
458%attr(755,root,root) %{_libdir}/libboost_serialization*.so.*.*.*
459%attr(755,root,root) %{_libdir}/libboost_wserialization*.so.*.*.*
460
30964b71
JB
461%files devel
462%defattr(644,root,root,755)
09e2803f
PS
463%{_includedir}/boost
464%attr(755,root,root) %{_libdir}/libboost_date_time*.so
465%attr(755,root,root) %{_libdir}/libboost_filesystem*.so
466%attr(755,root,root) %{_libdir}/libboost_graph*.so
000cd675 467%attr(755,root,root) %{_libdir}/libboost_iostreams*.so
09e2803f
PS
468%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor*.so
469%attr(755,root,root) %{_libdir}/libboost_program_options*.so
470%attr(755,root,root) %{_libdir}/libboost_regex*.so
000cd675 471%attr(755,root,root) %{_libdir}/libboost_serialization*.so
09e2803f
PS
472%attr(755,root,root) %{_libdir}/libboost_signals*.so
473%attr(755,root,root) %{_libdir}/libboost_system*.so
474%attr(755,root,root) %{_libdir}/libboost_thread*.so
475%attr(755,root,root) %{_libdir}/libboost_unit_test_framework*.so
476%attr(755,root,root) %{_libdir}/libboost_wave*.so
000cd675 477%attr(755,root,root) %{_libdir}/libboost_wserialization*.so
99f4684a 478
000cd675
JB
479%files static
480%defattr(644,root,root,755)
09e2803f
PS
481%{_libdir}/libboost_date_time*.a
482%{_libdir}/libboost_filesystem*.a
483%{_libdir}/libboost_grap*.a
000cd675 484%{_libdir}/libboost_iostreams*.a
09e2803f
PS
485%{_libdir}/libboost_prg_exec_monitor*.a
486%{_libdir}/libboost_program_options*.a
487%{_libdir}/libboost_regex*.a
99f4684a 488%{_libdir}/libboost_serialization*.a
09e2803f
PS
489%{_libdir}/libboost_signals*.a
490%{_libdir}/libboost_system*.a
491%{_libdir}/libboost_test_exec_monitor*.a
492%{_libdir}/libboost_thread*.a
493%{_libdir}/libboost_unit_test_framework*.a
494%{_libdir}/libboost_wave*.a
99f4684a 495%{_libdir}/libboost_wserialization*.a
db639b8e 496
49f48a3b 497%if %{with python}
30964b71 498%files python
49f48a3b 499%defattr(644,root,root,755)
fa767695 500%attr(755,root,root) %{_libdir}/libboost_python*.so.*.*.*
49f48a3b 501
30964b71 502%files python-devel
c6874538 503%defattr(644,root,root,755)
fa767695 504%attr(755,root,root) %{_libdir}/libboost_python*.so
30964b71
JB
505%{_includedir}/boost/python
506%{_includedir}/boost/python.hpp
507
6725319f
JB
508%files python-static
509%defattr(644,root,root,755)
fa767695 510%{_libdir}/libboost_python*.a
c6874538 511%endif
512
02c23151 513%files date_time
514%defattr(644,root,root,755)
fa767695 515%attr(755,root,root) %{_libdir}/libboost_date_time*.so.*.*.*
02c23151 516
31026e88 517%files filesystem
518%defattr(644,root,root,755)
fa767695 519%attr(755,root,root) %{_libdir}/libboost_filesystem*.so.*.*.*
31026e88 520
06ed6468
AM
521%files graph
522%defattr(644,root,root,755)
523%attr(755,root,root) %{_libdir}/libboost_graph*.so.*.*.*
524
99f4684a 525%files program_options
526%defattr(644,root,root,755)
527%attr(755,root,root) %{_libdir}/libboost_program_options*.so.*.*.*
528
09e2803f 529%files regex
99f4684a 530%defattr(644,root,root,755)
09e2803f 531%attr(755,root,root) %{_libdir}/libboost_regex*.so.*.*.*
99f4684a 532
db639b8e 533%files signals
534%defattr(644,root,root,755)
fa767695 535%attr(755,root,root) %{_libdir}/libboost_signals*.so.*.*.*
db639b8e 536
09e2803f 537%files system
db639b8e 538%defattr(644,root,root,755)
09e2803f 539%attr(755,root,root) %{_libdir}/libboost_system*.so.*.*.*
06ed6468 540
c0536c7f 541%files test
542%defattr(644,root,root,755)
fa767695 543%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor*.so.*.*.*
fa767695 544%attr(755,root,root) %{_libdir}/libboost_unit_test_framework*.so.*.*.*
c0536c7f 545
02c23151 546%files thread
547%defattr(644,root,root,755)
fa767695 548%attr(755,root,root) %{_libdir}/libboost_thread*.so.*.*.*
02c23151 549
06ed6468
AM
550%files wave
551%defattr(644,root,root,755)
552%attr(755,root,root) %{_libdir}/libboost_wave*.so.*.*.*
553
30964b71 554%files doc
fe815c68 555%defattr(644,root,root,755)
75f9f612 556%{_docdir}/%{name}-%{version}
This page took 0.253234 seconds and 4 git commands to generate.