]> git.pld-linux.org Git - packages/bitlbee.git/blame - bitlbee.spec
split skyped to separate package
[packages/bitlbee.git] / bitlbee.spec
CommitLineData
b8f37917
ER
1# TODO
2# - sync pl
b8f37917
ER
3#
4# Conditional build:
5%bcond_without otr # build without OTR
ac1568af 6%bcond_with purple # build with libpurple (not recommended for public servers). http://wiki.bitlbee.org/HowtoPurple
b8f37917 7
762288ea 8Summary: An IRC to other chat networks gateway
e2723aba 9Summary(pl.UTF-8): Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi
762288ea 10Name: bitlbee
b8f37917 11Version: 3.0.5
e93fddab 12Release: 2
b8f37917 13License: GPL v2+ and MIT
762288ea 14Group: Daemons
762288ea 15Source0: http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
b8f37917 16# Source0-md5: 9ff97260a2a7f3a7d102db158a8d9887
1b994aca 17URL: http://www.bitlbee.org/
23eb96be 18Patch0: config.patch
31b34380 19Patch1: systemd.patch
c35d504c 20Patch2: skyped-FD_CLOEXEC.patch
7da1b959 21Patch3: skype-no-groups.patch
f5618a74 22BuildRequires: asciidoc
1b994aca 23BuildRequires: gnutls-devel
b8f37917 24%{?with_otr:BuildRequires: libotr-devel >= 3.2.0}
ac1568af 25%{?with_purple:BuildRequires: libpurple-devel}
23eb96be 26BuildRequires: rpmbuild(macros) >= 1.461
b8f37917 27BuildRequires: systemd-units
23eb96be
ER
28Requires(postun): /usr/sbin/groupdel
29Requires(postun): /usr/sbin/userdel
30Requires(pre): /bin/id
31Requires(pre): /usr/bin/getgid
32Requires(pre): /usr/sbin/groupadd
33Requires(pre): /usr/sbin/useradd
f1503526
JR
34Requires(post,preun,postun): systemd-units >= 38
35Requires: systemd-units >= 38
23eb96be
ER
36Provides: group(bitlbee)
37Provides: user(bitlbee)
762288ea 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
b8f37917
ER
41Bitlbee is an IRC to other chat networks gateway. Bitlbee can be used
42as an IRC server which forwards everything you say to people on other
43chat networks like ICQ/AIM, MSN, XMPP/Jabber (including Google Talk),
44Yahoo or Twitter!
762288ea 45
6b82b92d
JR
46%description -l pl.UTF-8
47Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi. Ten program
48może być używany jako serwer IRC przekazujący wszystko co się mówi do
49ludzi korzystających z innych sieci komunikacyjnych, takich jak
1b994aca
JB
50MSN/ICQ/Jabber.
51
b8f37917
ER
52%package devel
53Summary: Development files for bitlbee
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58The bitlbee-devel package includes header files necessary for building
59and developing programs and plugins which use bitlbee.
60
61%package otr
62Summary: OTR plugin for bitlbee
63Group: Daemons
64Requires: %{name} = %{version}-%{release}
65
66%description otr
67The bitlbee-otr package includes OTR plugin for bitlbee. Not
68completely stable and not 100% foolproof so use at your own risk.
69
f5618a74
ER
70%package protocol-skype
71Summary: Skype protocol support for bitlbee
72Group: Daemons
73Requires: %{name} = %{version}-%{release}
e93fddab 74Suggests: skyped
f5618a74
ER
75
76%description protocol-skype
77Skype protocol support for bitlbee.
78
e93fddab
ER
79%package -n skyped
80Summary: Remote control of the Skype GUI client
81Group: Daemons
82Requires: python-skype
83
84%description -n skyped
85Skype supports remote control of the GUI client only via X11 or DBus
86messages. This is hard in care you want remote control. This daemon
87listens on a TCP port and runs on the same machine where the GUI
88client runs. It passes all the input it gets to Skype directly, except
89for a few commands which is related to authentication. The whole
90communication is done via SSL.
91
762288ea 92%prep
93%setup -q
23eb96be 94%patch0 -p1
31b34380 95%patch1 -p1
c35d504c 96%patch2 -p1
7da1b959 97%patch3 -p1
762288ea 98
b8f37917
ER
99# fix wrong assumption with $DESTDIR
100%{__sed} -i -e 's,$(shell id -u),0,' Makefile
101
f5618a74
ER
102# fix #!%{_bindir}/env python -> #!%{__python}:
103%{__sed} -i -e '1s,^#!.*python.*,#!%{__python},' protocols/skype/*.py
104
105# fix config path
106%{__sed} -i -e 's,/usr/local/etc/skyped,%{_sysconfdir}/skyped,' protocols/skype/*.py
107
762288ea 108%build
b8f37917 109CFLAGS="%{rpmcflags}" \
762288ea 110./configure \
762288ea 111 --prefix=%{_prefix} \
b8f37917
ER
112 --bindir=%{_sbindir} \
113 --etcdir=%{_sysconfdir}/%{name} \
114 --mandir=%{_mandir} \
115 --datadir=%{_datadir}/%{name} \
116 --config=%{_localstatedir}/lib/%{name} \
117 --pcdir=%{_pkgconfigdir} \
118 --plugindir=%{_libdir}/%{name} \
119 --strip=0 \
120 --plugins=1 \
121 --ssl=gnutls \
ac1568af
ER
122%if %{with purple}
123 --purple=1 \
124%endif
b8f37917
ER
125%if %{with otr}
126 --otr=plugin \
127%endif
f5618a74 128 --skype=plugin \
f750a0e7
AG
129
130%{__make}
b8f37917 131
762288ea 132%install
133rm -rf $RPM_BUILD_ROOT
b8f37917 134install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
b8f37917 135%{__make} install install-dev install-etc install-systemd \
1b994aca 136 DESTDIR=$RPM_BUILD_ROOT
762288ea 137
762288ea 138%clean
139rm -rf $RPM_BUILD_ROOT
140
23eb96be
ER
141%pre
142%groupadd -g 280 bitlbee
143%useradd -u 280 -d /var/lib/bitlbee -g bitlbee -c "Bitlbee User" bitlbee
31b34380
ER
144%systemd_post bitlbee.service
145
146%preun
147%systemd_preun bitlbee.service
23eb96be
ER
148
149%postun
150if [ "$1" = "0" ]; then
151 %userremove bitlbee
152 %groupremove bitlbee
153fi
31b34380 154%systemd_reload
23eb96be 155
762288ea 156%files
157%defattr(644,root,root,755)
ac1568af 158%doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README} utils
23eb96be
ER
159%dir %attr(750,root,bitlbee) %{_sysconfdir}/%{name}
160%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
161%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
b8f37917
ER
162%attr(755,root,root) %{_sbindir}/bitlbee
163%{_mandir}/man5/bitlbee.conf.5*
164%{_mandir}/man8/bitlbee.8*
1b994aca 165%{_datadir}/bitlbee
f5618a74 166%dir %{_libdir}/%{name}
23eb96be 167%attr(770,root,bitlbee) %{_localstatedir}/lib/bitlbee
b8f37917
ER
168%{systemdunitdir}/bitlbee.service
169%{systemdunitdir}/bitlbee.socket
170%{systemdunitdir}/bitlbee@.service
171
172%files devel
173%defattr(644,root,root,755)
174%doc doc/example_plugin.c
175%{_includedir}/%{name}
176%{_pkgconfigdir}/%{name}.pc
177
178%if %{with otr}
179%files otr
180%defattr(644,root,root,755)
181%attr(755,root,root) %{_libdir}/%{name}/otr.so
182%endif
f5618a74
ER
183
184%files protocol-skype
185%defattr(644,root,root,755)
e93fddab 186%doc protocols/skype/{HACKING,NEWS,README}
f5618a74 187%attr(755,root,root) %{_libdir}/%{name}/skype.so
e93fddab
ER
188
189%files -n skyped
190%defattr(644,root,root,755)
191%doc protocols/skype/{skyped.txt,client.sh}
192%dir %{_sysconfdir}/skyped
193%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.cnf
194%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.conf
f5618a74
ER
195%attr(755,root,root) %{_sbindir}/skyped
196%{_mandir}/man1/skyped.1*
This page took 0.210972 seconds and 4 git commands to generate.