]> git.pld-linux.org Git - packages/bitbake.git/blame - bitbake.spec
- cosmetics
[packages/bitbake.git] / bitbake.spec
CommitLineData
1821f023 1Summary: BitBake build tool
2Name: bitbake
3Version: 1.2
4Release: 1
5License: GPL
6Group: Development
7Source0: http://download.berlios.de/bitbake/%{name}-%{version}.tar.gz
8# Source0-md5: 62c799d91d291a17078d6c23a94e793e
9URL: http://developer.berlios.de/projects/bitbake/
10BuildRequires: python-devel >= 2.0
11%pyrequires_eq python
12Requires: python-modules
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17BitBake is a simple tool for the execution of tasks. It is derived
18from Portage, which is the package management system used by the
19Gentoo Linux distribution. It is most commonly used to build packages,
20as it can easily use its rudamentary inheritence to abstract common
21operations, such as fetching sources, unpacking them, patching them,
22compiling them, and so on. It is the basis of the OpenEmbedded
23project, which is being used for OpenZaurus, Familiar, and a number of
24other Linux distributions.
25
26%prep
27%setup -q
28
29%build
30python setup.py build
31
32%install
33rm -rf $RPM_BUILD_ROOT
a9ff8806 34install -d $RPM_BUILD_ROOT%{_sysconfdir}
1821f023 35python setup.py install \
36 --prefix=%{_prefix} \
a9ff8806 37 --root=$RPM_BUILD_ROOT
1821f023 38
a9ff8806 39mv $RPM_BUILD_ROOT%{_prefix}/%{name} $RPM_BUILD_ROOT%{_sysconfdir}
1821f023 40
41%clean
42rm -rf ${RPM_BUILD_ROOT}
43
44%files
45%defattr(644,root,root,755)
46%attr(755,root,root) %{_bindir}/*
47%{_sysconfdir}/%{name}
48%dir %{py_sitescriptdir}/bb
49%{py_sitescriptdir}/bb/*py[co]
50%dir %{py_sitescriptdir}/bb/parse
51%{py_sitescriptdir}/bb/parse/*py[co]
This page took 0.058182 seconds and 4 git commands to generate.