]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- up to 2.3.2 "Moonshine"
[packages/amarok.git] / amarok.spec
CommitLineData
a74cde9c 1# TODO
2# - try not to link with static mysql
3
4%define state stable
ac4fcc4e 5%define qtver 4.6.3
6%define kdever 4.5.0
b5eaa586 7
3dce540f 8Summary: A KDE audio player
78ae220a 9Summary(pl.UTF-8): Odtwarzacz audio dla KDE
3dce540f 10Name: amarok
68864201 11Version: 2.3.2
12Release: 1
3dce540f 13License: GPL
14Group: X11/Applications/Multimedia
d3b2a786 15Source0: ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
68864201 16# Source0-md5: 4e03dc009f8b44d9b8dfb5f6d1034081
d3b2a786 17Patch0: %{name}-disable_qtscriptbindings_check_fix.patch
567ab89c 18URL: http://amarok.kde.org/
a74cde9c 19BuildRequires: QtNetwork-devel >= %{qtver}
a74cde9c 20BuildRequires: QtSql-devel >= %{qtver}
3138c2ac 21BuildRequires: automoc4 >= 0.9.88
30124835 22BuildRequires: cmake >= 2.8.0
a74cde9c 23BuildRequires: curl-devel
f3a2739c 24BuildRequires: gettext-devel
a74cde9c 25BuildRequires: glib2-devel
63a59d76 26BuildRequires: kde4-kdelibs-devel >= %{kdever}
aa9500c3 27BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
a74cde9c 28BuildRequires: libgpod-devel >= 0.7.0
214a918d 29BuildRequires: liblastfm-devel
a74cde9c 30BuildRequires: libmtp-devel >= 0.3.0
68864201 31BuildRequires: libwrap-devel
a74cde9c 32BuildRequires: loudmouth-devel
a74cde9c 33BuildRequires: mysql-devel >= 5.1.31-3
6fc2033f 34BuildRequires: pcre-devel
f0306acf 35BuildRequires: pkgconfig
5bb3705c 36BuildRequires: qca-devel
a74cde9c 37BuildRequires: qt4-build >= %{qtver}
38BuildRequires: qt4-qmake >= %{qtver}
39BuildRequires: qtscriptbindings
68864201 40BuildRequires: rpmbuild(macros) >= 1.577
41BuildRequires: soprano-devel
30124835 42BuildRequires: strigi-devel >= 0.7.0
214a918d
SP
43BuildRequires: taglib-devel >= 1.6
44BuildRequires: taglib-extras-devel >= 1.0.0
a74cde9c 45BuildRequires: xorg-lib-libXpm-devel
46Requires(post,postun): /sbin/ldconfig
a74cde9c 47Requires: kde4-kdemultimedia-audiocd
48Requires: kde4-phonon
49Requires: qtscriptbindings
8028f5c0
PG
50Suggests: libvisual-plugin-actor-JESS
51Suggests: libvisual-plugin-actor-bumpscope
52Suggests: libvisual-plugin-actor-corona
53Suggests: libvisual-plugin-actor-flower
54Suggests: libvisual-plugin-actor-gdkpixbuf
55Suggests: libvisual-plugin-actor-gforce
a74cde9c 56Suggests: libvisual-plugin-actor-gstreamer
8028f5c0
PG
57Suggests: libvisual-plugin-actor-infinite
58Suggests: libvisual-plugin-actor-jakdaw
59Suggests: libvisual-plugin-actor-lv_analyzer
60Suggests: libvisual-plugin-actor-lv_gltest
61Suggests: libvisual-plugin-actor-lv_scope
62Suggests: libvisual-plugin-actor-madspin
63Suggests: libvisual-plugin-actor-nastyfft
64Suggests: libvisual-plugin-actor-oinksie
65Suggests: libvisual-plugin-input-alsa
66Suggests: libvisual-plugin-input-esd
67Suggests: libvisual-plugin-input-jack
68Suggests: libvisual-plugin-input-mplayer
69Suggests: libvisual-plugin-morph-alphablend
70Suggests: libvisual-plugin-morph-flash
71Suggests: libvisual-plugin-morph-slide
72Suggests: libvisual-plugin-morph-tentacle
86666641 73Obsoletes: amarok-arts
1581e7f4 74Obsoletes: amarok-xmms
a74cde9c 75# It should require mysql-embeded
76Requires: mysql >= 5.1.31-3
77Conflicts: mysql < 5.1.31-3
3be5e8cd 78# sr@Latn vs. sr@latin
79Conflicts: glibc-misc < 6:2.7
3dce540f 80BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82%description
83A KDE audio player.
84
86426fe7 85%description -l pl.UTF-8
3dce540f 86Odtwarzacz audio dla KDE.
87
9d393535
ER
88%package scripts
89Summary: amaroK scripts
78ae220a 90Summary(pl.UTF-8): Skrypty amaroKa
9d393535
ER
91Group: X11/Applications/Multimedia
92Requires: %{name} = %{version}-%{release}
a74cde9c 93Requires: kde4-kdebase-kdialog
9d393535
ER
94
95%description scripts
96amaroK scripts allow you extend amaroK functionality.
97
98You can learn more about scripts in amaroK from here:
2fde3dac 99<http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
9d393535 100
86426fe7
JR
101%description scripts -l pl.UTF-8
102Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
cb7dcc83 103
86426fe7 104Więcej o skryptach w amaroKu można dowiedzieć się stąd:
2fde3dac 105<http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
cb7dcc83 106
3dce540f 107%prep
d6f0ca1c 108%setup -q
d3b2a786 109%patch0 -p1
b5eaa586 110
3dce540f 111%build
a74cde9c 112install -d build
113cd build
68864201 114%cmake ..
3dce540f 115
9a083733 116%{__make}
3dce540f 117
118%install
119rm -rf $RPM_BUILD_ROOT
120
a74cde9c 121%{__make} -C build install \
3dce540f 122 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 123 kde_htmldir=%{_kdedocdir} \
124 kde_libs_htmldir=%{_kdedocdir}
43342c86 125
3248aa1e 126# remove bogus dir
127rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
128
d3b2a786 129# remove unsupported locale
b10a2a5e 130rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
d3b2a786 131
bcfb337c 132# remove .so symlinks so that noone gets the stupid idea to package them
9d30ab8f 133rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
bcfb337c 134
d3b2a786 135%find_lang %{name} --all-name --with-kde
3dce540f 136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
a74cde9c 140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
b5eaa586 142
aed7613d 143%files -f %{name}.lang
3dce540f 144%defattr(644,root,root,755)
2f1d9ab2 145%doc AUTHORS ChangeLog README
d4535bda 146%attr(755,root,root) %{_bindir}/amarok
214a918d 147%attr(755,root,root) %{_bindir}/amarokpkg
b5eaa586 148%attr(755,root,root) %{_bindir}/amarokcollectionscanner
a74cde9c 149%attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
150%attr(755,root,root) %{_bindir}/amarok_afttagger
1712a7ec 151%attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
152%attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
1712a7ec 153%attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
154%attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
a74cde9c 155%attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
156%attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
a74cde9c 157%attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
158%attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
a19a7a80 159%attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
160%attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
a74cde9c 161%attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
162%attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
1712a7ec 163%attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
164%attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
165%attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
166%attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
167%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
168%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
169%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
170%attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
a74cde9c 171%attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
1712a7ec 172%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
a74cde9c 173%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
1712a7ec 174%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
68864201 175%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
a74cde9c 176%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
1712a7ec 177%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
a19a7a80 178%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
179%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
1712a7ec 180%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
181%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
a74cde9c 182%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
1712a7ec 183%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
68864201 184%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
a74cde9c 185%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
1712a7ec 186%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
187%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
188%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
189%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
a74cde9c 190%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
1712a7ec 191%attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
192%attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
a74cde9c 193%attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
194%attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
195%attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
196%attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
197%attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
a19a7a80 198%attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
a74cde9c 199%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
200%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
201%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
202%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
9d393535
ER
203%dir %{_datadir}/apps/amarok
204%dir %{_datadir}/apps/amarok/scripts
9d393535
ER
205%{_datadir}/apps/amarok/data
206%{_datadir}/apps/amarok/icons
207%{_datadir}/apps/amarok/images
5bb3705c 208%{_datadir}/apps/amarok/amarok.notifyrc
a74cde9c 209%{_datadir}/apps/desktoptheme
214a918d 210%{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
a74cde9c 211%{_datadir}/config.kcfg/amarokconfig.kcfg
212%{_datadir}/config/amarok.knsrc
214a918d 213%{_datadir}/config/amarokapplets.knsrc
a74cde9c 214%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
215%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
216%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
214a918d
SP
217%{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
218%{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
a74cde9c 219%{_datadir}/kde4/services/amarok.protocol
220%{_datadir}/kde4/services/amaroklastfm.protocol
d3b2a786 221%{_datadir}/kde4/services/amarokitpc.protocol
a74cde9c 222%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
1712a7ec 223%{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
224%{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
225%{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
226%{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
227%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
228%{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
229%{_datadir}/kde4/services/amarok_collection-umscollection.desktop
a74cde9c 230%{_datadir}/kde4/services/amarok-containment-vertical.desktop
1712a7ec 231%{_datadir}/kde4/services/amarok-context-applet-albums.desktop
a74cde9c 232%{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
1712a7ec 233%{_datadir}/kde4/services/amarok-context-applet-info.desktop
68864201 234%{_datadir}/kde4/services/amarok-context-applet-labels.desktop
a74cde9c 235%{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
1712a7ec 236%{_datadir}/kde4/services/amarok-context-applet-photos.desktop
a19a7a80 237%{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
238%{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
1712a7ec 239%{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
240%{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
a74cde9c 241%{_datadir}/kde4/services/amarok-data-engine-current.desktop
1712a7ec 242%{_datadir}/kde4/services/amarok-data-engine-info.desktop
68864201 243%{_datadir}/kde4/services/amarok-data-engine-labels.desktop
a74cde9c 244%{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
1712a7ec 245%{_datadir}/kde4/services/amarok-data-engine-photos.desktop
246%{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
247%{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
248%{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
a74cde9c 249%{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
1712a7ec 250%{_datadir}/kde4/services/amarok_massstorage-device.desktop
a74cde9c 251%{_datadir}/kde4/services/amarok_service_ampache.desktop
252%{_datadir}/kde4/services/amarok_service_ampache_config.desktop
253%{_datadir}/kde4/services/amarok_service_jamendo.desktop
254%{_datadir}/kde4/services/amarok_service_lastfm.desktop
255%{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
256%{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
257%{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
258%{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
259%{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
a74cde9c 260%{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
214a918d
SP
261%{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
262%{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
1712a7ec 263%{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
a74cde9c 264%{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
265%{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
266%{_datadir}/kde4/servicetypes/amarok_plugin.desktop
a74cde9c 267%{_desktopdir}/kde4/amarok.desktop
60b883ee 268%{_iconsdir}/*/*/apps/amarok.*
a74cde9c 269%{_datadir}/config/amarok_homerc
9d393535
ER
270
271%files scripts
272%defattr(644,root,root,755)
a74cde9c 273%dir %{_datadir}/apps/amarok/scripts/radio_station_service
274%{_datadir}/apps/amarok/scripts/radio_station_service/main.js
275%{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
276%dir %{_datadir}/apps/amarok/scripts/script_console
277%{_datadir}/apps/amarok/scripts/script_console/main.js
278%{_datadir}/apps/amarok/scripts/script_console/script.spec
279%dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
280%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
281%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
282%dir %{_datadir}/apps/amarok/scripts/librivox_service
283%{_datadir}/apps/amarok/scripts/librivox_service/main.js
284%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
214a918d 285%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
a74cde9c 286%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
287%{_datadir}/apps/amarok/scripts/librivox_service/script.spec
aed7613d 288%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
289%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
290%{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.110563 seconds and 4 git commands to generate.