]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
- use versioned url
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
e9cc6da3 1#
aa3cbbce 2# Conditional build:
3%bcond_with license_agreement # generates package
19d7e29f 4
e6d2385a 5%ifarch %{ix86}
c4cbb2ec 6%define ver 10.3.181.34
e6d2385a
ER
7%define libmark %{nil}
8%endif
e0aacdca 9%ifarch %{x8664}
e6d2385a
ER
10%define ver 10.3.162.29
11%define libmark ()(64bit)
b18d4034 12%endif
19d7e29f 13
fdeb48aa 14%define base_name adobe-flash
0422b44b 15%define rel 1
53f15d83 16Summary: Flash plugin for Netscape-compatible WWW browsers
989db712 17Summary(pl.UTF-8): Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 18%if %{with license_agreement}
19Name: %{base_name}
20%else
21Name: %{base_name}-installer
22%endif
e6d2385a 23Version: %{ver}
5e11dd18 24Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 25Epoch: 1
53f15d83 26License: Free to use, non-distributable
01b5e1fb 27Group: X11/Applications/Multimedia
aa3cbbce 28%if %{with license_agreement}
28b6a6b0 29#Source0: http://download.macromedia.com/pub/labs/flashplatformruntimes/flashplayer10-3/flashplayer10-3_rc1_lin_042011.tar.gz
bab0a031 30Source0: http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz#/%{name}-%{version}.tgz
c4cbb2ec 31# NoSource0-md5: 26770108412158b710e633b06a71ca25
364b3cd0 32NoSource: 0
f4a110d9 33##Source1: http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
aa56ec7e 34Source1: http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
35b7834e 35# NoSource1-md5: 49b55c7eb8044453e5f6f2e4b3cb4084
e0aacdca 36NoSource: 1
63f88470 37Source2: mms.cfg
18284157 38%else
63f88470
ER
39Source3: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
40# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
aa3cbbce 41%endif
d6511d55 42Source4: memcpy-to-memmove.sh
ba9bcac5 43URL: http://www.adobe.com/products/flashplayer/
b68eb59b 44%if %{with license_agreement}
df79ad5e 45BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 46BuildRequires: sed >= 4.0
df79ad5e 47Requires: browser-plugins >= 2.0
15b3da69 48# dlopened by player
b18d4034
AM
49Requires: libasound.so.2%{libmark}
50Requires: libcurl.so.4%{libmark}
94ae04b2 51%else
1fe695bf 52Requires: rpm-build-tools >= 4.4.37
9377eeca 53Requires: rpmbuild(macros) >= 1.544
533db319 54%endif
bcccd50e 55Provides: browser(flash)
5f855dbc 56Provides: macromedia-flash
533db319 57Obsoletes: flash-plugin
533db319 58Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 59Obsoletes: macromedia-flash
a00d2cc2
ER
60Obsoletes: mozilla-firefox-plugin-macromedia-flash
61Obsoletes: mozilla-plugin-macromedia-flash
e0aacdca 62ExclusiveArch: %{ix86} %{x8664}
01b5e1fb
PG
63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
ed1085d2
ER
65%define _sysconfdir /etc/adobe
66
0fa08e0e
ER
67# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
68%define _noautoreqdep libstdc++.so.6
69
1fe30e9c
ER
70# No debuginfo to be stored
71%define _enable_debug_packages 0
72
01b5e1fb 73%description
65fff478 74Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 75runtime for engaging with Flash content and applications on Linux.
53f15d83 76
5f2286aa
JR
77%description -l pl.UTF-8
78Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
79treści i aplikacji we Flashu pod Linuksem.
53f15d83 80
01b5e1fb 81%prep
aa3cbbce 82%if %{with license_agreement}
b18d4034
AM
83%ifarch %{x8664}
84%setup -q -T -c -b 1
85%else
3170126a 86%setup -q -T -c -b 0
b18d4034 87%endif
d4052f7c
ER
88
89%build
e6d2385a 90s=$(echo 'LNX %{version}' | tr . ,)
7673fff0 91v=$(strings libflashplayer.so | grep '^LNX ')
d4052f7c
ER
92if [ "$v" != "$s" ]; then
93 : wrong version
94 exit 1
95fi
d6511d55
AM
96
97%ifarch %{x8664}
98# Bug #354073: Patch binary to use memmove instead of memcpy from
99# Redhat's bug https://bugzilla.redhat.com/show_bug.cgi?id=638477#c94
100cp libflashplayer.so libflashplayer.so.orig
101/bin/bash %{SOURCE4} libflashplayer.so \
102|| (echo "memcpy-to-memmove.sh failed" && exit 1)
103%endif
aa3cbbce 104%endif
01b5e1fb
PG
105
106%install
107rm -rf $RPM_BUILD_ROOT
ed1085d2 108%if %{without license_agreement}
aa3cbbce 109install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
110
18284157
ER
111sed -e '
112 s/@BASE_NAME@/%{base_name}/g
113 s/@TARGET_CPU@/%{_target_cpu}/g
114 s-@VERSION@-%{version}-g
115 s-@RELEASE@-%{release}-g
116 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
03482652 117 s,@DATADIR@,%{_datadir}/%{base_name},g
63f88470 118' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 119
63f88470 120cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
aa3cbbce 121
122%else
123
ed1085d2 124install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
63f88470
ER
125cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
126install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
aa3cbbce 127%endif
128
01b5e1fb
PG
129%clean
130rm -rf $RPM_BUILD_ROOT
131
df79ad5e 132%if %{without license_agreement}
ae33c71b 133%post
18284157 134%{_bindir}/%{base_name}.install
533db319 135%else
df79ad5e
ER
136%post
137%update_browser_plugins
533db319 138
df79ad5e
ER
139%postun
140if [ "$1" = 0 ]; then
141 %update_browser_plugins
142fi
533db319
ER
143%endif
144
aa3cbbce 145%files
146%defattr(644,root,root,755)
df79ad5e 147%if %{without license_agreement}
aa3cbbce 148%attr(755,root,root) %{_bindir}/%{base_name}.install
149%{_datadir}/%{base_name}
aa3cbbce 150%else
ed1085d2
ER
151%dir %{_sysconfdir}
152%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
df79ad5e 153%attr(755,root,root) %{_browserpluginsdir}/*.so
aa3cbbce 154%endif
This page took 0.093902 seconds and 4 git commands to generate.