]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
- fix md5
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
e9cc6da3 1#
aa3cbbce 2# Conditional build:
3%bcond_with license_agreement # generates package
19d7e29f 4
0b37c64a 5%define ver_major 10
d8f782bf 6%define ver_minor 1
cbe4f2e7
KK
7%define ver_patch 82
8%define ver_serial 76
19d7e29f
ER
9
10%ifarch %{x8664}
11%define libmark ()(64bit)
12%else
b18d4034
AM
13%define libmark %{nil}
14%endif
19d7e29f 15
fdeb48aa 16%define base_name adobe-flash
0422b44b 17%define rel 1
53f15d83 18Summary: Flash plugin for Netscape-compatible WWW browsers
989db712 19Summary(pl.UTF-8): Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 20%if %{with license_agreement}
21Name: %{base_name}
22%else
23Name: %{base_name}-installer
24%endif
5e11dd18
ER
25Version: %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
26Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 27Epoch: 1
53f15d83 28License: Free to use, non-distributable
01b5e1fb 29Group: X11/Applications/Multimedia
aa3cbbce 30%if %{with license_agreement}
0422b44b 31Source0: http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
cbe4f2e7 32# NoSource0-md5: 7f122a6bf62403c2916f37df48c18768
364b3cd0 33NoSource: 0
d8f782bf 34#Source1: http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
d281bb18 35# NoSource1-md5: 4a4561e456612a6751653b58342d53df
d8f782bf 36#NoSource: 1
18284157 37%else
d9720229 38Source2: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
832ca3ec 39# Source2-md5: 4fb1600353dd57fe088e0b12fb0ecac2
aa3cbbce 40%endif
ba9bcac5 41URL: http://www.adobe.com/products/flashplayer/
b68eb59b 42%if %{with license_agreement}
df79ad5e 43BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 44BuildRequires: sed >= 4.0
df79ad5e 45Requires: browser-plugins >= 2.0
15b3da69 46# dlopened by player
b18d4034
AM
47Requires: libasound.so.2%{libmark}
48Requires: libcurl.so.4%{libmark}
94ae04b2 49%else
1fe695bf 50Requires: rpm-build-tools >= 4.4.37
9377eeca 51Requires: rpmbuild(macros) >= 1.544
533db319 52%endif
bcccd50e 53Provides: browser(flash)
5f855dbc 54Provides: macromedia-flash
533db319 55Obsoletes: flash-plugin
533db319 56Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 57Obsoletes: macromedia-flash
a00d2cc2
ER
58Obsoletes: mozilla-firefox-plugin-macromedia-flash
59Obsoletes: mozilla-plugin-macromedia-flash
0422b44b
AM
60ExclusiveArch: %{ix86}
61# %{x8664}
01b5e1fb
PG
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
ed1085d2
ER
64%define _sysconfdir /etc/adobe
65
0fa08e0e
ER
66# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
67%define _noautoreqdep libstdc++.so.6
68
1fe30e9c
ER
69# No debuginfo to be stored
70%define _enable_debug_packages 0
71
01b5e1fb 72%description
65fff478 73Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 74runtime for engaging with Flash content and applications on Linux.
53f15d83 75
5f2286aa
JR
76%description -l pl.UTF-8
77Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
78treści i aplikacji we Flashu pod Linuksem.
53f15d83 79
01b5e1fb 80%prep
aa3cbbce 81%if %{with license_agreement}
b18d4034
AM
82%ifarch %{x8664}
83%setup -q -T -c -b 1
84%else
3170126a 85%setup -q -T -c -b 0
b18d4034 86%endif
d4052f7c
ER
87
88%build
89s='LNX %{ver_major},%{ver_minor},%{ver_patch},%{ver_serial}'
90v=$(strings libflashplayer.so | grep "$s")
91if [ "$v" != "$s" ]; then
92 : wrong version
93 exit 1
94fi
aa3cbbce 95%endif
01b5e1fb
PG
96
97%install
98rm -rf $RPM_BUILD_ROOT
ed1085d2 99%if %{without license_agreement}
aa3cbbce 100install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
101
18284157
ER
102sed -e '
103 s/@BASE_NAME@/%{base_name}/g
104 s/@TARGET_CPU@/%{_target_cpu}/g
105 s-@VERSION@-%{version}-g
106 s-@RELEASE@-%{release}-g
107 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
03482652 108 s,@DATADIR@,%{_datadir}/%{base_name},g
cdd7950d 109' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 110
111install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
112
113%else
114
ed1085d2
ER
115install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
116cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
117# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
e953e2c9 118# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
ed1085d2
ER
119AutoUpdateDisable=1
120AutoUpdateInterval=0
be05c7b7 121# OverrideGPUValidation=true
ed1085d2 122EOF
df79ad5e 123install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
aa3cbbce 124%endif
125
01b5e1fb
PG
126%clean
127rm -rf $RPM_BUILD_ROOT
128
df79ad5e 129%if %{without license_agreement}
ae33c71b 130%post
18284157 131%{_bindir}/%{base_name}.install
533db319 132%else
df79ad5e
ER
133%post
134%update_browser_plugins
533db319 135
df79ad5e
ER
136%postun
137if [ "$1" = 0 ]; then
138 %update_browser_plugins
139fi
533db319
ER
140%endif
141
aa3cbbce 142%files
143%defattr(644,root,root,755)
df79ad5e 144%if %{without license_agreement}
aa3cbbce 145%attr(755,root,root) %{_bindir}/%{base_name}.install
146%{_datadir}/%{base_name}
aa3cbbce 147%else
ed1085d2
ER
148%dir %{_sysconfdir}
149%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
df79ad5e 150%attr(755,root,root) %{_browserpluginsdir}/*.so
aa3cbbce 151%endif
This page took 0.07186 seconds and 4 git commands to generate.