]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
- license-installer.sh updated to r11289
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
e9cc6da3 1#
aa3cbbce 2# Conditional build:
3%bcond_with license_agreement # generates package
19d7e29f 4
0b37c64a
JB
5%define ver_major 10
6%define ver_minor 0
d281bb18
TP
7%define ver_patch 45
8%define ver_serial 2
19d7e29f
ER
9
10%ifarch %{x8664}
11%define libmark ()(64bit)
12%else
b18d4034
AM
13%define libmark %{nil}
14%endif
19d7e29f 15
fdeb48aa 16%define base_name adobe-flash
1fe695bf 17%define rel 2
53f15d83 18Summary: Flash plugin for Netscape-compatible WWW browsers
989db712 19Summary(pl.UTF-8): Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 20%if %{with license_agreement}
21Name: %{base_name}
22%else
23Name: %{base_name}-installer
24%endif
5e11dd18
ER
25Version: %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
26Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 27Epoch: 1
53f15d83 28License: Free to use, non-distributable
01b5e1fb 29Group: X11/Applications/Multimedia
aa3cbbce 30%if %{with license_agreement}
6fa8c0e6 31Source0: http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
d281bb18 32# NoSource0-md5: dbfc776cd4310250cde078e0bf0472e7
19d7e29f 33Source1: http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
d281bb18 34# NoSource1-md5: 4a4561e456612a6751653b58342d53df
18284157 35%else
d9720229 36Source2: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
1fe695bf 37# Source2-md5: 329c25f457fea66ec502b7ef70cb9ede
aa3cbbce 38%endif
ba9bcac5 39URL: http://www.adobe.com/products/flashplayer/
b68eb59b 40%if %{with license_agreement}
df79ad5e 41BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 42BuildRequires: sed >= 4.0
df79ad5e 43Requires: browser-plugins >= 2.0
15b3da69 44# dlopened by player
b18d4034
AM
45Requires: libasound.so.2%{libmark}
46Requires: libcurl.so.4%{libmark}
94ae04b2 47%else
1fe695bf 48Requires: rpm-build-macros >= 1.544
49Requires: rpm-build-tools >= 4.4.37
533db319 50%endif
bcccd50e 51Provides: browser(flash)
5f855dbc 52Provides: macromedia-flash
533db319 53Obsoletes: flash-plugin
533db319 54Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 55Obsoletes: macromedia-flash
a00d2cc2
ER
56Obsoletes: mozilla-firefox-plugin-macromedia-flash
57Obsoletes: mozilla-plugin-macromedia-flash
b18d4034 58ExclusiveArch: %{ix86} %{x8664}
01b5e1fb
PG
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
ed1085d2
ER
61%define _sysconfdir /etc/adobe
62
0fa08e0e
ER
63# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
64%define _noautoreqdep libstdc++.so.6
65
1fe30e9c
ER
66# No debuginfo to be stored
67%define _enable_debug_packages 0
68
01b5e1fb 69%description
65fff478 70Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 71runtime for engaging with Flash content and applications on Linux.
53f15d83 72
5f2286aa
JR
73%description -l pl.UTF-8
74Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
75treści i aplikacji we Flashu pod Linuksem.
53f15d83 76
01b5e1fb 77%prep
aa3cbbce 78%if %{with license_agreement}
b18d4034
AM
79%ifarch %{x8664}
80%setup -q -T -c -b 1
81%else
3170126a 82%setup -q -T -c -b 0
b18d4034 83%endif
d4052f7c
ER
84
85%build
86s='LNX %{ver_major},%{ver_minor},%{ver_patch},%{ver_serial}'
87v=$(strings libflashplayer.so | grep "$s")
88if [ "$v" != "$s" ]; then
89 : wrong version
90 exit 1
91fi
aa3cbbce 92%endif
01b5e1fb
PG
93
94%install
95rm -rf $RPM_BUILD_ROOT
ed1085d2 96%if %{without license_agreement}
aa3cbbce 97install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
98
18284157
ER
99sed -e '
100 s/@BASE_NAME@/%{base_name}/g
101 s/@TARGET_CPU@/%{_target_cpu}/g
102 s-@VERSION@-%{version}-g
103 s-@RELEASE@-%{release}-g
104 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
03482652 105 s,@DATADIR@,%{_datadir}/%{base_name},g
cdd7950d 106' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 107
108install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
109
110%else
111
ed1085d2
ER
112install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
113cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
114# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
e953e2c9 115# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
ed1085d2
ER
116AutoUpdateDisable=1
117AutoUpdateInterval=0
be05c7b7 118# OverrideGPUValidation=true
ed1085d2 119EOF
df79ad5e 120install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
aa3cbbce 121%endif
122
01b5e1fb
PG
123%clean
124rm -rf $RPM_BUILD_ROOT
125
df79ad5e 126%if %{without license_agreement}
ae33c71b 127%post
18284157 128%{_bindir}/%{base_name}.install
533db319 129%else
df79ad5e
ER
130%post
131%update_browser_plugins
533db319 132
df79ad5e
ER
133%postun
134if [ "$1" = 0 ]; then
135 %update_browser_plugins
136fi
533db319
ER
137%endif
138
aa3cbbce 139%files
140%defattr(644,root,root,755)
df79ad5e 141%if %{without license_agreement}
aa3cbbce 142%attr(755,root,root) %{_bindir}/%{base_name}.install
143%{_datadir}/%{base_name}
aa3cbbce 144%else
ed1085d2
ER
145%dir %{_sysconfdir}
146%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
df79ad5e 147%attr(755,root,root) %{_browserpluginsdir}/*.so
aa3cbbce 148%endif
This page took 0.097597 seconds and 4 git commands to generate.