]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
- simplify
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
e9cc6da3 1#
aa3cbbce 2# Conditional build:
3%bcond_with license_agreement # generates package
19d7e29f 4
0b37c64a
JB
5%define ver_major 10
6%define ver_minor 0
286a7771
AM
7%define ver_patch 32
8%define ver_serial 18
19d7e29f
ER
9
10%ifarch %{x8664}
11%define libmark ()(64bit)
12%else
b18d4034
AM
13%define libmark %{nil}
14%endif
19d7e29f 15
fdeb48aa 16%define base_name adobe-flash
6fa8c0e6 17%define rel 1
53f15d83 18Summary: Flash plugin for Netscape-compatible WWW browsers
989db712 19Summary(pl.UTF-8): Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 20%if %{with license_agreement}
21Name: %{base_name}
22%else
23Name: %{base_name}-installer
24%endif
5e11dd18
ER
25Version: %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
26Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 27Epoch: 1
53f15d83 28License: Free to use, non-distributable
01b5e1fb 29Group: X11/Applications/Multimedia
aa3cbbce 30%if %{with license_agreement}
6fa8c0e6 31Source0: http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
286a7771 32# NoSource0-md5: 6306980e40a3266b4b6c173bfcfdc946
19d7e29f 33Source1: http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
286a7771 34# NoSource1-md5: 332e60275e9c7a92059f286a2bad6e41
18284157 35%else
cdd7950d 36Source2: license-installer.sh
aa3cbbce 37%endif
ba9bcac5 38URL: http://www.adobe.com/products/flashplayer/
b68eb59b 39%if %{with license_agreement}
df79ad5e 40BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 41BuildRequires: sed >= 4.0
df79ad5e 42Requires: browser-plugins >= 2.0
15b3da69 43# dlopened by player
b18d4034
AM
44Requires: libasound.so.2%{libmark}
45Requires: libcurl.so.4%{libmark}
94ae04b2 46%else
f68af2cb 47Requires: rpm-build-tools
533db319 48%endif
bcccd50e 49Provides: browser(flash)
5f855dbc 50Provides: macromedia-flash
533db319 51Obsoletes: flash-plugin
533db319 52Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 53Obsoletes: macromedia-flash
a00d2cc2
ER
54Obsoletes: mozilla-firefox-plugin-macromedia-flash
55Obsoletes: mozilla-plugin-macromedia-flash
b18d4034 56ExclusiveArch: %{ix86} %{x8664}
01b5e1fb
PG
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
ed1085d2
ER
59%define _sysconfdir /etc/adobe
60
0fa08e0e
ER
61# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
62%define _noautoreqdep libstdc++.so.6
63
1fe30e9c
ER
64# No debuginfo to be stored
65%define _enable_debug_packages 0
66
01b5e1fb 67%description
65fff478 68Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 69runtime for engaging with Flash content and applications on Linux.
53f15d83 70
5f2286aa
JR
71%description -l pl.UTF-8
72Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
73treści i aplikacji we Flashu pod Linuksem.
53f15d83 74
01b5e1fb 75%prep
aa3cbbce 76%if %{with license_agreement}
b18d4034
AM
77%ifarch %{x8664}
78%setup -q -T -c -b 1
79%else
80%setup -q -T -b 0 -n install_flash_player_%{ver_major}_linux
81%endif
aa3cbbce 82%endif
01b5e1fb
PG
83
84%install
85rm -rf $RPM_BUILD_ROOT
ed1085d2 86%if %{without license_agreement}
aa3cbbce 87install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
88
18284157
ER
89sed -e '
90 s/@BASE_NAME@/%{base_name}/g
91 s/@TARGET_CPU@/%{_target_cpu}/g
92 s-@VERSION@-%{version}-g
93 s-@RELEASE@-%{release}-g
94 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
cdd7950d 95' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 96
97install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
98
99%else
100
ed1085d2
ER
101install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
102cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
103# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
e953e2c9 104# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
ed1085d2
ER
105AutoUpdateDisable=1
106AutoUpdateInterval=0
be05c7b7 107# OverrideGPUValidation=true
ed1085d2 108EOF
df79ad5e 109install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
aa3cbbce 110%endif
111
01b5e1fb
PG
112%clean
113rm -rf $RPM_BUILD_ROOT
114
df79ad5e 115%if %{without license_agreement}
ae33c71b 116%post
18284157 117%{_bindir}/%{base_name}.install
533db319 118%else
df79ad5e
ER
119%post
120%update_browser_plugins
533db319 121
df79ad5e
ER
122%postun
123if [ "$1" = 0 ]; then
124 %update_browser_plugins
125fi
533db319
ER
126%endif
127
aa3cbbce 128%files
129%defattr(644,root,root,755)
df79ad5e 130%if %{without license_agreement}
aa3cbbce 131%attr(755,root,root) %{_bindir}/%{base_name}.install
132%{_datadir}/%{base_name}
aa3cbbce 133%else
ed1085d2
ER
134%dir %{_sysconfdir}
135%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
df79ad5e 136%attr(755,root,root) %{_browserpluginsdir}/*.so
aa3cbbce 137%endif
This page took 0.076911 seconds and 4 git commands to generate.