]> git.pld-linux.org Git - packages/acpid.git/blame - acpid.spec
- raw spec
[packages/acpid.git] / acpid.spec
CommitLineData
11f5d39c
AM
1Summary: ACPI Event Daemon
2Name: acpid
3Version: 1.0.0
4Release: 1
5Copyright: GPL
6Group: Daemons
7Source: acpid-1.0.0.tar.gz
8BuildRoot: /var/tmp/acpid
9URL: http://acpid.sourceforge.net
10
11
12%description
13acpid is a daemon that dispatches ACPI events to user-space programs.
14
15
16%changelog
17* Thu Aug 16 2001 Tim Hockin <thockin@sun.com>
18 - Added commandline options to actions
19
20* Wed Aug 15 2001 Tim Hockin <thockin@sun.com>
21 - Added UNIX domain socket support
22 - Changed /etc/acpid.d to /etc/acpid/events
23
24* Mon Aug 13 2001 Tim Hockin <thockin@sun.com>
25 - added changelog
26 - 0.99.1-1
27
28%prep
29%setup
30
31
32%build
33make
34
35
36%install
37rm -rf $RPM_BUILD_ROOT
38mkdir -p $RPM_BUILD_ROOT
39make install INSTPREFIX=$RPM_BUILD_ROOT
40
41mkdir -p $RPM_BUILD_ROOT/etc/acpi/events
42mkdir -p $RPM_BUILD_ROOT/etc/acpi/actions
43chmod 755 $RPM_BUILD_ROOT/etc/acpi/events
44install -o root -g root -m 644 samples/sample.conf \
45 $RPM_BUILD_ROOT/etc/acpi/events
46
47mkdir -p $RPM_BUILD_ROOT/var/log
48touch $RPM_BUILD_ROOT/var/log/acpid
49chmod 640 $RPM_BUILD_ROOT/var/log/acpid
50
51mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
52install -o root -g root redhat/acpid.init $RPM_BUILD_ROOT/etc/rc.d/init.d/acpid
53chmod 755 $RPM_BUILD_ROOT/etc/rc.d/init.d/acpid
54
55
56%files
57%defattr(-,root,root)
58%dir /etc/acpi
59%dir /etc/acpi/events
60%dir /etc/acpi/actions
61/etc/acpi/events/sample.conf
62/var/log/acpid
63/usr/sbin/acpid
64/etc/rc.d/init.d/acpid
65/usr/share/man/man8/acpid.8.gz
66
67
68%post
69# only run on install, not upgrade
70if [ "$1" = "1" ]; then
71 /sbin/chkconfig --add acpid
72fi
73
74
75%preun
76# only run if this is the last instance to be removed
77if [ "$1" = "0" ]; then
78 /sbin/chkconfig --del acpid
79fi
This page took 0.102398 seconds and 4 git commands to generate.