]> git.pld-linux.org Git - packages/ParaView.git/blame - ParaView.spec
- rel 1
[packages/ParaView.git] / ParaView.spec
CommitLineData
72d81c28
JR
1Summary: Parallel visualization application
2Name: ParaView
3Version: 3.12.0
02a25d54 4Release: 1
72d81c28
JR
5License: BSD
6Group: Applications/Engineering
7URL: http://www.paraview.org/
8Source0: http://www.paraview.org/files/v3.12/%{name}-%{version}.tar.gz
9# Source0-md5: 8feabc6261e2060648eaac593d85b1de
10Source1: %{name}_22x22.png
11Source2: %{name}.xml
12Patch0: %{name}-3.8.0-include.patch
13Patch1: %{name}-3.12.0-boost-1.48.0-bfs.patch
14Patch2: %{name}-gcc47.patch
15Patch3: %{name}-3.2.2-hdf5.patch
8626142d
JR
16BuildRequires: Mesa-libOSMesa-devel
17BuildRequires: QtDesigner-devel
18BuildRequires: QtHelp-devel
19BuildRequires: QtSql-devel
20BuildRequires: QtSql-sqlite
21BuildRequires: QtUiTools-devel
22BuildRequires: QtWebKit-devel
72d81c28
JR
23BuildRequires: boost-devel
24BuildRequires: cmake
25BuildRequires: desktop-file-utils
26BuildRequires: doxygen
27BuildRequires: expat-devel
28BuildRequires: freetype-devel
29BuildRequires: gnuplot
30BuildRequires: graphviz
31BuildRequires: hdf5-devel
32BuildRequires: libjpeg-devel
33BuildRequires: libpng-devel
34BuildRequires: libtheora-devel
35BuildRequires: libtiff-devel
72d81c28
JR
36BuildRequires: openssl-devel
37BuildRequires: python-devel
38BuildRequires: qt4-build
72d81c28
JR
39BuildRequires: readline-devel
40BuildRequires: tk-devel
41BuildRequires: wget
42BuildRequires: zlib-devel
72d81c28
JR
43Requires(post): desktop-file-utils
44Requires(postun): desktop-file-utils
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
8f94022e
JR
47%define skip_post_check_so lib.*Python.*\.so.*
48
72d81c28
JR
49%description
50ParaView is an application designed with the need to visualize large
51data sets in mind. The goals of the ParaView project include the
52following:
53
54 - Develop an open-source, multi-platform visualization application.
55 - Support distributed computation models to process large data sets.
56 - Create an open, flexible, and intuitive user interface.
57 - Develop an extensible architecture based on open standards.
58
59ParaView runs on distributed and shared memory parallel as well as
60single processor systems and has been successfully tested on Windows,
61Linux and various Unix workstations and clusters. Under the hood,
62ParaView uses the Visualization Toolkit as the data processing and
63rendering engine and has a user interface written using a unique blend
64of Tcl/Tk and C++.
65
66NOTE: The version in this package has NOT been compiled with MPI
67support.
68
72d81c28
JR
69%package devel
70Summary: Development files for %{name}
71Group: Development/Libraries
72Requires: %{name}%{?_isa} = %{version}-%{release}
73
74%description devel
75The %{name}-devel package contains libraries and header files for
76developing applications that use %{name}.
77
72d81c28
JR
78%prep
79%setup -q
80%patch0 -p1
8626142d
JR
81# We don't have boot 1.48 yet
82#%patch1 -p1
72d81c28
JR
83%patch2 -p1
84%patch3 -p1
85#Remove included hdf5 just to be sure
86rm -r VTK/Utilities/vtkhdf5
87
88%build
89mkdir build
90cd build
91%cmake .. \
92 -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
93 -DPV_INSTALL_LIB_DIR:PATH=%{_lib}/paraview \
94 -DTCL_LIBRARY:PATH=tcl \
95 -DTK_LIBRARY:PATH=tk \
96 -DPARAVIEW_BUILD_PLUGIN_AdiosReader:BOOL=ON \
97 -DPARAVIEW_BUILD_PLUGIN_CoProcessingScriptGenerator:BOOL=ON \
98 -DPARAVIEW_BUILD_PLUGIN_EyeDomeLighting:BOOL=ON \
99 -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
100 -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
101 -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
102 -DPARAVIEW_INSTALL_DEVELOPMENT:BOOL=ON \
103 -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
104 -DVTK_USE_BOOST:BOOL=ON \
105 -DVTK_USE_INFOVIS:BOOL=OFF \
106 -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
107 -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
108 -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
109 -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
110 -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
111 -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
112 -DVTK_USE_SYSTEM_PNG:BOOL=ON \
113 -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
114 -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
115 -DXDMF_WRAP_PYTHON:BOOL=ON \
116 -DBUILD_DOCUMENTATION:BOOL=ON \
117 -DBUILD_EXAMPLES:BOOL=ON
118
119%{__make} VERBOSE=1
120
121%install
122rm -rf $RPM_BUILD_ROOT
8f94022e 123install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/mime/packages}
72d81c28 124
8f94022e
JR
125install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
126install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/mime/packages
72d81c28
JR
127
128cd build
8626142d
JR
129%{__make} install \
130 DESTDIR=$RPM_BUILD_ROOT
72d81c28
JR
131
132#Create desktop file
8f94022e 133cat > $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop <<EOF
72d81c28
JR
134[Desktop Entry]
135Encoding=UTF-8
136Name=ParaView Viewer
137GenericName=Data Viewer
138Comment=ParaView allows viewing of large data sets
139Type=Application
140Terminal=false
8f94022e 141Icon=ParaView_22x22
72d81c28
JR
142MimeType=application/x-paraview;
143Categories=Application;Graphics;
144Exec=paraview
145EOF
146
8f94022e 147# Install vtk*Python.so by hand for now
72d81c28
JR
148cp -p bin/vtk*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/
149mv $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/vtkPV*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/
150
8f94022e 151# Cleanup vtk binaries
72d81c28
JR
152rm $RPM_BUILD_ROOT%{_bindir}/vtk*
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/ldconfig
159%update_desktop_database
8f94022e 160%update_mime_database
72d81c28
JR
161
162%postun
163/sbin/ldconfig
164%update_desktop_database
72d81c28
JR
165%update_mime_database
166
167%files
168%defattr(644,root,root,755)
169%doc License_v1.2.txt
170%attr(755,root,root) %{_bindir}/paraview
171%attr(755,root,root) %{_bindir}/pvbatch
172%attr(755,root,root) %{_bindir}/pvblot
173%attr(755,root,root) %{_bindir}/pvdataserver
174%attr(755,root,root) %{_bindir}/pvpython
175%attr(755,root,root) %{_bindir}/pvrenderserver
176%attr(755,root,root) %{_bindir}/pvserver
177%attr(755,root,root) %{_bindir}/smTestDriver
8f94022e
JR
178%dir %{_libdir}/paraview/
179%attr(755,root,root) %{_libdir}/paraview/paraview
180%attr(755,root,root) %{_libdir}/paraview/pvbatch
181%attr(755,root,root) %{_libdir}/paraview/pvdataserver
182%attr(755,root,root) %{_libdir}/paraview/pvpython
183%attr(755,root,root) %{_libdir}/paraview/pvrenderserver
184%attr(755,root,root) %{_libdir}/paraview/pvserver
185%attr(755,root,root) %{_libdir}/paraview/smTestDriver
186%attr(755,root,root) %{_libdir}/paraview/lib*.so*
187%{_libdir}/paraview/CMake
188%{_libdir}/paraview/*.cmake
189%{_libdir}/paraview/doc
190%{_libdir}/paraview/*.py
191%{_libdir}/paraview/testing
192%{_libdir}/paraview/.plugins
193%{_libdir}/paraview/SESAMEConversions.xml
194%{_libdir}/paraview/hints
195%{_libdir}/paraview/ParaViewCore
196%dir %{_libdir}/paraview/site-packages
197%dir %{_libdir}/paraview/site-packages/paraview
198%{_libdir}/paraview/site-packages/paraview/pv_compile_complete
199%{_libdir}/paraview/site-packages/paraview/*.py*
200%attr(755,root,root) %{_libdir}/paraview/site-packages/paraview/*.so
201%{_libdir}/paraview/site-packages/paraview/demos
202%{_libdir}/paraview/site-packages/paraview/vtk
203%{_desktopdir}/ParaView.desktop
204%{_pixmapsdir}/ParaView_22x22.png
205%{_datadir}/mime/packages/ParaView.xml
206%{_datadir}/doc/paraview-3.12/paraview.qch
72d81c28
JR
207
208%files devel
209%defattr(644,root,root,755)
210%attr(755,root,root) %{_bindir}/kwProcessXML
211%{_includedir}/paraview/
This page took 0.081247 seconds and 4 git commands to generate.