]> git.pld-linux.org Git - packages/OpenGTL.git/blame - OpenGTL.spec
- added llvm-3.3 patch (from gentoo, LLVM 3.3 support)
[packages/OpenGTL.git] / OpenGTL.spec
CommitLineData
e08dcf37 1#
2c344bb5
JB
2# Conditional build:
3%bcond_with tests # perform "make test"
e08dcf37
AM
4#
5Summary: Graphics Transformation Languages
2c344bb5 6Summary(pl.UTF-8): Graphics Transformation Languages - języki przekształceń graficznych
e08dcf37
AM
7Name: OpenGTL
8Version: 0.9.18
2c344bb5
JB
9Release: 1
10License: LGPL v2+
e08dcf37 11Group: Libraries
e08dcf37
AM
12Source0: http://download.opengtl.org/%{name}-%{version}.tar.bz2
13# Source0-md5: 8a9673c648ef5af4fcc7f60bb8282811
14%{?with_tests:Source1: http://download.opengtl.org/tests-data-%{version}.tar.bz2}
2c344bb5
JB
15Patch0: %{name}-llvm-3.3.patch
16Patch1: %{name}-includes.patch
17Patch2: %{name}-link.patch
18URL: http://opengtl.org/
e08dcf37 19BuildRequires: ImageMagick
2c344bb5 20BuildRequires: cmake >= 2.6
e08dcf37
AM
21BuildRequires: doxygen
22BuildRequires: ghostscript
23BuildRequires: graphviz
24BuildRequires: libpng-devel
2c344bb5 25BuildRequires: llvm-devel >= 3.3
e08dcf37
AM
26BuildRequires: texlive-dvips
27BuildRequires: texlive-latex
28BuildRequires: zlib-devel
29Requires: %{name}-libs = %{version}-%{release}
2c344bb5 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e08dcf37
AM
31
32%description
33OpenGTL provides tools, languages and libraries to create generic
34transformations for graphics. These transformations can be used by
35different programs, e.g. Krita, Gimp, CinePaint, etc.
36
2c344bb5
JB
37%description -l pl.UTF-8
38OpenGTL udostępnia narzędzia, języki i biblioteka do tworzenia
39ogólnych przekształceń grafiki. Przekształcenia te mogą być później
40wykorzystywane przez różne programy, takie jak Krita, Gimp czy
41CinePaint.
42
e08dcf37 43%package libs
2c344bb5
JB
44Summary: Runtime OpenGTL libraries
45Summary(pl.UTF-8): Biblioteki współdzielone OpenGTL
46Group: Libraries
e08dcf37
AM
47
48%description libs
2c344bb5
JB
49OpenGTL shared libraries.
50
51%description libs -l pl.UTF-8
52Biblioteki współdzielone OpenGTL.
e08dcf37
AM
53
54%package devel
2c344bb5
JB
55Summary: Header files for OpenGTL
56Summary(pl.UTF-8): Pliki nagłówkowe OpenGTL
e08dcf37
AM
57Group: Development/Languages
58Requires: %{name}-libs = %{version}-%{release}
2c344bb5 59Requires: llvm-devel >= 3.3
e08dcf37
AM
60
61%description devel
2c344bb5
JB
62This package contains the header files needed to develop new native
63programs that use the OpenGTL libraries.
64
65%description devel -l pl.UTF-8
66Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia nowych
67programów wykorzystujących biblioteki OpenGTL.
e08dcf37
AM
68
69%prep
70%setup -q %{?with_tests:-a1}
2c344bb5
JB
71%patch0 -p1
72%patch1 -p1
73%patch2 -p1
e08dcf37
AM
74
75%build
76install -d build
77cd build
2c344bb5
JB
78%cmake .. \
79 -DOPENGTL_BUILD_OpenRIJN:BOOL=ON \
80 -DOPENGTL_BUILD_TESTS:BOOL=ON \
81 %{?with_tests:-DOPENGTL_TESTS_DATA:PATH=$PWD/../tests-data}
e08dcf37
AM
82
83%{__make}
84
85cd ..
86doxygen OpenGTL.doxy
87
88%if %{with tests}
2c344bb5 89export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_npkgconfigdir}:$RPM_BUILD_ROOT%{_pkgconfigdir}
e08dcf37
AM
90test "$(pkg-config --modversion GTLCore)" = "%{version}"
91test "$(pkg-config --modversion GTLImageIO)" = "%{version}"
92test "$(pkg-config --modversion OpenCTL)" = "%{version}"
93test "$(pkg-config --modversion OpenShiva)" = "%{version}"
94# some known failures due to missing test data , 17 tests failed out of 189
95# *with* test data, down to 2:
96# The following tests FAILED:
97# 177 - PerlinNoise.shiva (Failed)
98# 189 - grayscaliser.shiva (Failed)
99%{__make} test -C %{_target_platform} ||:
100%endif
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%{__make} -C build install/fast \
106 DESTDIR=$RPM_BUILD_ROOT
107
2c344bb5
JB
108# unpackaged files
109%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenGTL
e08dcf37
AM
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
2c344bb5
JB
114%post libs -p /sbin/ldconfig
115%postun libs -p /sbin/ldconfig
116
e08dcf37
AM
117%files
118%defattr(644,root,root,755)
119%doc COPYING OpenGTL/README
120%attr(755,root,root) %{_bindir}/ctli
121%attr(755,root,root) %{_bindir}/ctltc
122%attr(755,root,root) %{_bindir}/gtlconvert
123%attr(755,root,root) %{_bindir}/imagecompare
124%attr(755,root,root) %{_bindir}/shiva
125%attr(755,root,root) %{_bindir}/shivacheck
126%attr(755,root,root) %{_bindir}/shivainfo
127%attr(755,root,root) %{_bindir}/shivanimator
128%{_datadir}/OpenGTL
129
e08dcf37
AM
130%files libs
131%defattr(644,root,root,755)
2c344bb5
JB
132%attr(755,root,root) %{_libdir}/libGTLCore.so.%{version}
133%attr(755,root,root) %ghost %{_libdir}/libGTLCore.so.0.8
134%attr(755,root,root) %{_libdir}/libGTLFragment.so.%{version}
135%attr(755,root,root) %ghost %{_libdir}/libGTLFragment.so.0.8
136%attr(755,root,root) %{_libdir}/libGTLImageIO.so.%{version}
137%attr(755,root,root) %ghost %{_libdir}/libGTLImageIO.so.0.8
138%attr(755,root,root) %{_libdir}/libOpenCTL.so.%{version}
139%attr(755,root,root) %ghost %{_libdir}/libOpenCTL.so.0.8
140%attr(755,root,root) %{_libdir}/libOpenShiva.so.%{version}
141%attr(755,root,root) %ghost %{_libdir}/libOpenShiva.so.0.8
142%dir %{_libdir}/GTLImageIO
143%dir %{_libdir}/GTLImageIO/Extensions
144%attr(755,root,root) %{_libdir}/GTLImageIO/Extensions/lib*.so
e08dcf37
AM
145
146%files devel
147%defattr(644,root,root,755)
148%doc html/* build/OpenShiva/doc/reference/ShivaRef.pdf
149%attr(755,root,root) %{_bindir}/ctlc
150%attr(755,root,root) %{_bindir}/shivac
151%attr(755,root,root) %{_bindir}/shivatester
2c344bb5
JB
152%attr(755,root,root) %{_libdir}/libGTLCore.so
153%attr(755,root,root) %{_libdir}/libGTLFragment.so
154%attr(755,root,root) %{_libdir}/libGTLImageIO.so
155%attr(755,root,root) %{_libdir}/libOpenCTL.so
156%attr(755,root,root) %{_libdir}/libOpenShiva.so
e08dcf37
AM
157%{_includedir}/GTLCore
158%{_includedir}/GTLFragment
159%{_includedir}/GTLImageIO
160%{_includedir}/OpenCTL
161%{_includedir}/OpenShiva
e08dcf37
AM
162%{_pkgconfigdir}/GTLCore.pc
163%{_pkgconfigdir}/GTLImageIO.pc
164%{_pkgconfigdir}/OpenCTL.pc
165%{_pkgconfigdir}/OpenShiva.pc
This page took 0.098603 seconds and 4 git commands to generate.