]> git.pld-linux.org Git - packages/Lunchbox.git/blame - Lunchbox.spec
noarch apidoc
[packages/Lunchbox.git] / Lunchbox.spec
CommitLineData
7c02bafe
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_with mpi # MPI support
5%bcond_with skv # SKV (Scalable Key-Value Store) support
3da0d941 6
7c02bafe
JB
7Summary: Lunchbox - C++ library for multi-threading programming
8Summary(pl.UTF-8): Lunchbox - biblioteka C++ do programowania wielowątkowego
9Name: Lunchbox
10Version: 1.10.0
3da0d941 11Release: 6
7c02bafe
JB
12License: LGPL v2.1
13Group: Libraries
14Source0: https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
15# Source0-md5: 3e01c3a2ddeeb7b3682e88092831d5a5
16Source1: https://github.com/Eyescale/CMake/archive/139ce7d/Eyescale-CMake-139ce7d.tar.gz
17# Source1-md5: 4a6abcd9e0fc417528a8ca68a97e65eb
c428797b
JR
18Patch0: disable-broken-cmakefiles.patch
19Patch1: boost-1.57.0.patch
7c02bafe
JB
20URL: http://pogl.wordpress.com/category/lunchbox/
21BuildRequires: avahi-devel
22BuildRequires: boost-devel >= 1.41.0
23BuildRequires: cmake >= 2.8
24%{?with_apidocs:BuildRequires: doxygen}
25BuildRequires: gcc-c++ >= 6:4.2
26BuildRequires: hwloc-devel >= 1.3
27BuildRequires: leveldb-devel
28BuildRequires: libgomp-devel
29BuildRequires: libjpeg-turbo-devel >= 1.2.1
30BuildRequires: libstdc++-devel
31%{?with_mpi:BuildRequires: mpi-devel}
32BuildRequires: pkgconfig
33%{?with_skv:BuildRequires: skv-devel}
34Requires: hwloc-libs >= 1.3
35Requires: libjpeg-turbo >= 1.2.1
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
40formerly known as eq::base or co::base, the foundation for the
41Equalizer parallel rendering framework and the Collage network
42library. It is intended for all application developers creating
43high-performance multi-threaded programs.
44
45%description -l pl.UTF-8
46Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
47była znana jako eq::base lub co::base - podstawa szkieletu do
48renderowania wielowątkowego Equalizer lub biblioteki sieciowej
49Collage. Biblioteka jest przeznaczona dla wszystkich programistów
50tworzących wysoko wydajne, wielowątkowe aplikacje.
51
52%package devel
53Summary: Header files for Lunchbox library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lunchbox
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: boost-devel >= 1.41.0
58Requires: libgomp-devel
59Requires: libstdc++-devel
60
61%description devel
62Header files for Lunchbox library.
63
64%description devel -l pl.UTF-8
65Pliki nagłówkowe biblioteki Lunchbox.
66
67%package apidocs
68Summary: Lunchbox API documentation
69Summary(pl.UTF-8): Dokumentacja API biblioteki Lunchbox
70Group: Documentation
3da0d941
ER
71%if "%{_rpmversion}" >= "5"
72BuildArch: noarch
73%endif
7c02bafe
JB
74
75%description apidocs
76API documentation for Lunchbox library.
77
78%description apidocs -l pl.UTF-8
79Dokumentacja API biblioteki Lunchbox.
80
81%prep
82%setup -q -a1
83
84%{__mv} CMake-* CMake/common
85%{__rm} .gitexternals
86
c428797b
JR
87%patch0 -p1
88%patch1 -p1
89
7c02bafe
JB
90%build
91install -d build
92cd build
93%cmake .. \
94 -DBUILDYARD_DISABLED=ON \
95 %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON} \
96 %{!?with_skv:-DCMAKE_DISABLE_FIND_PACKAGE_skv=ON}
97%{__make}
98
99%if %{with apidocs}
100doxygen doc/Doxyfile
101%endif
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} -C build install \
107 DESTDIR=$RPM_BUILD_ROOT
108
109%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
119%doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/RelNotes.md
120%attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.3
122
123%files devel
124%defattr(644,root,root,755)
125%attr(755,root,root) %{_libdir}/libLunchbox.so
126%{_includedir}/lunchbox
127%{_pkgconfigdir}/Lunchbox.pc
128%dir %{_datadir}/Lunchbox
129%{_datadir}/Lunchbox/CMake
130
131%if %{with apidocs}
132%files apidocs
133%defattr(644,root,root,755)
134%doc build/doc/html/*
135%endif
This page took 0.040528 seconds and 4 git commands to generate.