]> git.pld-linux.org Git - packages/Lunchbox.git/blame - Lunchbox.spec
boost rebuild
[packages/Lunchbox.git] / Lunchbox.spec
CommitLineData
7c02bafe
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_with mpi # MPI support
3da0d941 5
7c02bafe
JB
6Summary: Lunchbox - C++ library for multi-threading programming
7Summary(pl.UTF-8): Lunchbox - biblioteka C++ do programowania wielowątkowego
8Name: Lunchbox
7c79b477 9Version: 1.17.0
b0ed2b3f 10Release: 4
7c02bafe
JB
11License: LGPL v2.1
12Group: Libraries
7c79b477 13#Source0Download: https://github.com/Eyescale/Lunchbox/releases
7c02bafe 14Source0: https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
7c79b477 15# Source0-md5: 76bcd79003c9b9d58d5f772cfdd812c7
382ae9ec 16Patch2: cxx.patch
7c02bafe 17URL: http://pogl.wordpress.com/category/lunchbox/
7c79b477 18BuildRequires: Eyescale-CMake >= 2018.02
99b90907 19BuildRequires: Servus-devel >= 1.5.0
7c02bafe
JB
20BuildRequires: avahi-devel
21BuildRequires: boost-devel >= 1.41.0
7c79b477 22BuildRequires: cmake >= 3.1
7c02bafe 23%{?with_apidocs:BuildRequires: doxygen}
7c02bafe 24BuildRequires: hwloc-devel >= 1.3
1b7bae68 25BuildRequires: hwloc-devel < 2
7c02bafe
JB
26BuildRequires: libstdc++-devel
27%{?with_mpi:BuildRequires: mpi-devel}
28BuildRequires: pkgconfig
7c79b477 29Requires: Servus >= 1.5.0
7c02bafe 30Requires: hwloc-libs >= 1.3
7c02bafe
JB
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
35formerly known as eq::base or co::base, the foundation for the
36Equalizer parallel rendering framework and the Collage network
37library. It is intended for all application developers creating
38high-performance multi-threaded programs.
39
40%description -l pl.UTF-8
41Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
42była znana jako eq::base lub co::base - podstawa szkieletu do
43renderowania wielowątkowego Equalizer lub biblioteki sieciowej
44Collage. Biblioteka jest przeznaczona dla wszystkich programistów
45tworzących wysoko wydajne, wielowątkowe aplikacje.
46
47%package devel
48Summary: Header files for Lunchbox library
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lunchbox
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
7c79b477 52Requires: Servus-devel >= 1.5.0
7c02bafe 53Requires: boost-devel >= 1.41.0
7c02bafe
JB
54Requires: libstdc++-devel
55
56%description devel
57Header files for Lunchbox library.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe biblioteki Lunchbox.
61
62%package apidocs
63Summary: Lunchbox API documentation
64Summary(pl.UTF-8): Dokumentacja API biblioteki Lunchbox
65Group: Documentation
3da0d941 66BuildArch: noarch
7c02bafe
JB
67
68%description apidocs
69API documentation for Lunchbox library.
70
71%description apidocs -l pl.UTF-8
72Dokumentacja API biblioteki Lunchbox.
73
74%prep
c6de7caf 75%setup -q
7c02bafe 76
7c79b477 77rmdir CMake/common
c6de7caf 78ln -s %{_datadir}/Eyescale-CMake CMake/common
7c02bafe 79
382ae9ec 80%patch2 -p1
c428797b 81
7c02bafe
JB
82%build
83install -d build
84cd build
85%cmake .. \
87a51c8c 86 -DCOMMON_DISABLE_WERROR:BOOL=ON \
7c79b477
JB
87 %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
88
7c02bafe
JB
89%{__make}
90
91%if %{with apidocs}
92doxygen doc/Doxyfile
93%endif
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%{__make} -C build install \
99 DESTDIR=$RPM_BUILD_ROOT
100
101%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108
109%files
110%defattr(644,root,root,755)
c6de7caf 111%doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
7c02bafe 112%attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
7c79b477
JB
113%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
114%dir %{_datadir}/Lunchbox
115%{_datadir}/Lunchbox/benchmarks
7c02bafe
JB
116
117%files devel
118%defattr(644,root,root,755)
119%attr(755,root,root) %{_libdir}/libLunchbox.so
120%{_includedir}/lunchbox
7c02bafe
JB
121%{_datadir}/Lunchbox/CMake
122
123%if %{with apidocs}
124%files apidocs
125%defattr(644,root,root,755)
126%doc build/doc/html/*
127%endif
This page took 0.08828 seconds and 4 git commands to generate.