]> git.pld-linux.org Git - packages/FHS.git/blame - FHS.spec
- updated to FHS 3.0 specs
[packages/FHS.git] / FHS.spec
CommitLineData
fa94c830 1# TODO
a336bdac 2# - provide -doc-text, -doc-pdf, -doc-html as offline reference for the spec
2fccd05c
ER
3# NOTE
4# - don't use %{_*dir} macros for paths defined by FHS
05fbeea7
ER
5# - do not add any dependencies to this pkg, FHS should be the first package being installed
6# - do not use any other user/group than "root", as then we have to depend on "setup" package.
4e9a06c3
JB
7# But: root %attr+chown in %post means integrity verification (rpm -V) error.
8# Maybe use non-root %attr+numeric chown in %post (without setup dependency)? The only disadvantage
9# seems to be a warning message on install.
10Summary: Basic FHS %{version} filesystem layout
d280bbd7
ER
11Summary(de.UTF-8): Grundlegende Dateisystemstruktur
12Summary(fr.UTF-8): Arborescence de base du système de fichiers
4e9a06c3 13Summary(pl.UTF-8): Podstawowy układ katalogów systemu Linux zgodny z FHS %{version}
d280bbd7 14Summary(tr.UTF-8): Temel dosya sistemi yapısı
b3b300be 15Name: FHS
4e9a06c3
JB
16Version: 3.0
17Release: 1
15c9b486 18License: GPL
19Group: Base
e38ba8ca 20URL: http://refspecs.linuxfoundation.org/fhs.shtml
4e9a06c3 21# list of languages for localized man pages directories
38ec8b96 22Source0: locale-dirs
2fccd05c 23BuildRequires: mktemp
73559f52 24BuildRequires: rpmbuild(macros) >= 1.213
05fbeea7 25Conflicts: setup < 2.7
8ad4c704 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15c9b486 27
5a4e441c
ER
28# nothing to put there
29%define _enable_debug_packages 0
30
335736da
JB
31%if "%{_lib}" == "lib64"
32%define with_lib64 1
335736da
JB
33%endif
34%if "%{_lib}" == "libx32"
35%define with_libx32 1
57d439f5 36%define with_lib64 1
335736da
JB
37%else
38%ifarch %{x8664}
39# x32 as additional ABI
40%define with_libx32 1
41%endif
42%endif
43
5a4e441c
ER
44# avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
45%define __spec_clean_body %{nil}
46
6c95f275 47# doesn't contain any files, but we're not noarch package
99177468 48%define no_install_post_strip 1
6c95f275
ER
49%define no_install_post_chrpath 1
50%define no_install_post_compress_modules 1
0fa811e0 51
05fbeea7
ER
52# we have to use numeric uids/groups. see comment above
53
54%define gid_uucp 14
55%define gid_mail 12
56
15c9b486 57%description
aac153be 58This package contains the basic directory layout for a Linux system,
59including the proper permissions for the directories. This layout
4e9a06c3 60conforms to the Filesystem Hierarchy Standard (FHS) %{version}.
15c9b486 61
fdedb1f3
JR
62%description -l de.UTF-8
63Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
64Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
4e9a06c3 65Struktur entspricht dem Filesystem Hierarchy Standard (FHS) %{version}.
15c9b486 66
fdedb1f3
JR
67%description -l fr.UTF-8
68Ce package contient l'arborescence type pour système Linux y compris
69les permissions adéquates pour les répertoires. Cette arborescence est
4e9a06c3 70conforme au standard "Filesystem Hierarchy Standard" (FHS) %{version}.
15c9b486 71
fdedb1f3
JR
72%description -l pl.UTF-8
73Pakiet ten zawiera informacje o podstawowej strukturze katalogów
74systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
4e9a06c3 75%{version}.
aac153be 76
15c9b486 77%prep
40188a0f 78%setup -qcT
38ec8b96 79cp -a %{SOURCE0} .
15c9b486 80
81%install
82rm -rf $RPM_BUILD_ROOT
83
d8cf4cdf 84install -d \
4e9a06c3 85 $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,run,srv,sys} \
d8cf4cdf
JB
86 $RPM_BUILD_ROOT/etc/{X11,opt} \
87 $RPM_BUILD_ROOT/lib/modules \
d13739ad 88 $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
d8cf4cdf 89 $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
4e9a06c3 90 $RPM_BUILD_ROOT/usr/share/{color/icc,dict,doc,games,info,misc,ppd,tmac,xml} \
d8cf4cdf 91 $RPM_BUILD_ROOT/usr/lib/games \
4e9a06c3
JB
92 $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{color/icc,doc,info,man},src} \
93 $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/{color,misc},local,lock,log,mail,opt,run,spool,tmp,yp}
d8cf4cdf 94
335736da 95%if %{with lib64}
d8cf4cdf 96install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
9d2de01c 97%endif
335736da 98%if %{with libx32}
9d2de01c 99install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
76796e14
JB
100%endif
101
42b7266a 102install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
4e9a06c3 103install -d $RPM_BUILD_ROOT/usr/local/share/man/man{1,2,3,4,5,6,7,8}
9d1c44e3 104
42b7266a
ER
105> %{name}.lang
106for mloc in $(cat locale-dirs); do
107 echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
108 for manp in man{1,2,3,4,5,6,7,8}; do
109 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
110 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
111 done
112done
113
15c9b486 114%clean
fa9aa6bf 115cd $RPM_BUILD_ROOT
0a75495b 116
2fccd05c 117check_filesystem_dirs() {
2fccd05c
ER
118 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
119 TMPFILE=$(mktemp)
48e57f98 120 find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
2fccd05c
ER
121
122 # find finds also '.', so use option -B for diff
123 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
124 rm -rf $RPM_BUILD_ROOT
125 else
126 echo -e "\nNot so good, some directories are not included in package\n"
127 exit 1
128 fi
129 rm -f $TMPFILE
130}
131check_filesystem_dirs
15c9b486 132
4e9a06c3
JB
133%pretrans -p <lua>
134if posix.stat("/usr/local/share/man", "type") == "link" then os.remove("/usr/local/share/man") end
135
05fbeea7
ER
136# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
137%post -p <lua>
138posix.chown("/var/mail", 0, %{gid_mail})
139posix.chown("/var/lock", 0, %{gid_uucp})
140
42b7266a 141%files -f %{name}.lang
bfef5768 142%defattr(644,root,root,755)
52e00ac5 143%dir /
d8cf4cdf
JB
144%dir /bin
145%dir /boot
146%dir /dev
2d4f80d5 147%dir /etc
d8cf4cdf
JB
148%dir /etc/X11
149%dir /etc/opt
b9fc8087 150%dir /home
d8cf4cdf
JB
151%dir /lib
152%dir /lib/modules
d13739ad 153%dir /media
d8cf4cdf
JB
154%dir /mnt
155%dir /opt
6c511447
ER
156%dir %attr(555,root,root) %verify(not group) /proc
157%dir %attr(700,root,root) /root
ef2d028b 158%dir %attr(700,root,root) /root/tmp
4e9a06c3 159%dir /run
15c9b486 160%dir /sbin
6c511447 161%dir %attr(755,root,root) /srv
4e9a06c3 162%dir /sys
6c511447 163%dir %attr(1777,root,root) /tmp
d8cf4cdf
JB
164%dir /usr
165%dir /usr/bin
166%dir /usr/games
167%dir /usr/include
168%dir /usr/lib
169%dir /usr/lib/games
170%dir /usr/sbin
171%dir /usr/share
4e9a06c3
JB
172%dir /usr/share/color
173%dir /usr/share/color/icc
d8cf4cdf
JB
174%dir /usr/share/dict
175%dir /usr/share/doc
176%dir /usr/share/games
177%dir /usr/share/info
d8cf4cdf
JB
178%dir /usr/share/man
179%dir /usr/share/man/man[1-8]
d8cf4cdf 180%dir /usr/share/misc
4e9a06c3 181%dir /usr/share/ppd
d8cf4cdf 182%dir /usr/share/tmac
017dd5c9 183%dir /usr/share/xml
d8cf4cdf
JB
184%dir /usr/src
185%dir /usr/local
186%dir /usr/local/bin
187%dir /usr/local/etc
188%dir /usr/local/games
189%dir /usr/local/include
190%dir /usr/local/lib
191%dir /usr/local/sbin
192%dir /usr/local/share
4e9a06c3
JB
193%dir /usr/local/share/color
194%dir /usr/local/share/color/icc
d8cf4cdf
JB
195%dir /usr/local/share/doc
196%dir /usr/local/share/info
4e9a06c3
JB
197%dir /usr/local/share/man
198%dir /usr/local/share/man/man[1-8]
d8cf4cdf 199%dir /usr/local/src
15c9b486 200%dir /var
d8cf4cdf 201%dir /var/cache
0a75495b 202%dir /var/crash
15c9b486 203%dir /var/db
15c9b486 204%dir /var/games
dff2ec9d 205%dir /var/lib
4e9a06c3
JB
206%dir /var/lib/color
207%dir /var/lib/color/icc
0a75495b 208%dir /var/lib/misc
e7f27a78 209%dir /var/local
6c511447
ER
210%dir %attr(1771,root,root) /var/lock
211%dir %attr(751,root,root) /var/log
212%dir %attr(2775,root,root) /var/mail
15c9b486 213%dir /var/opt
0a75495b 214%dir /var/run
2d4f80d5 215%dir /var/spool
48784dc4 216%dir /var/yp
6c511447 217%dir %attr(1777,root,root) /var/tmp
335736da 218%if %{with lib64}
d8cf4cdf
JB
219%dir /lib64
220%dir /usr/lib64
221%dir /usr/lib64/games
222%dir /usr/local/lib64
9d2de01c 223%endif
335736da 224%if %{with libx32}
9d2de01c
JR
225%dir /libx32
226%dir /usr/libx32
227%dir /usr/libx32/games
228%dir /usr/local/libx32
76796e14 229%endif
This page took 0.109337 seconds and 4 git commands to generate.