]> git.pld-linux.org Git - packages/CEGUI.git/blame - CEGUI.spec
- fix irrlicht detection (use C++)
[packages/CEGUI.git] / CEGUI.spec
CommitLineData
a7c52a89 1# TODO:
a7c52a89 2# - gcc33 patch only for AC-branch
54df35ea 3# - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
c549a2c3 4# - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
dab1ca85
BZ
5# - if You want have irrlight renderer enabled pass CC=athlon-pld-linux-g++ to configure
6# because irrlight.h test is compiled by CC
7#
8# Conditional build:
9%bcond_with xercesc
a7c52a89 10#
71dc0787
JB
11Summary: CEGUI - a free library providing windowing and widgets
12Summary(pl.UTF-8): CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
a7c52a89
ŁK
13Name: CEGUI
14Version: 0.5.0
15Release: 1
16License: LGPL
17Group: Libraries
ec6fb841
BZ
18Source0: http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}b.tar.gz
19# Source0-md5: b42322a33c6a06eede76b15f75694a17
a7c52a89
ŁK
20Source1: http://dl.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
21# Source1-md5: e268b5812f146ee1ff9ba4c07ff501b7
c549a2c3 22Patch0: %{name}-gcc33.patch
54df35ea 23Patch1: %{name}-link.patch
a7c52a89 24URL: http://www.cegui.org.uk/
ae21b5c7 25BuildRequires: DevIL-devel
7e74cc56 26BuildRequires: FreeImage-devel
27BuildRequires: OpenGL-GLU-devel
54df35ea 28BuildRequires: OpenGL-glut-devel
296738c2 29BuildRequires: SILLY-devel >= 0.1.0
54df35ea 30BuildRequires: autoconf >= 2.59
a7c52a89 31BuildRequires: automake
296738c2 32BuildRequires: corona-devel >= 1.0.2
54df35ea
JB
33BuildRequires: expat-devel
34BuildRequires: freetype-devel >= 2.0
a1a8dadd 35BuildRequires: irrlicht-devel
7e74cc56 36BuildRequires: libstdc++-devel
54df35ea
JB
37BuildRequires: libtool >= 2:1.5
38BuildRequires: libxml2-devel >= 1:2.6
39BuildRequires: lua50-devel >= 5.0
40BuildRequires: pcre-devel >= 5.0
7e74cc56 41BuildRequires: pkgconfig
dab1ca85 42%if %{with xercesc}
54df35ea 43BuildRequires: xerces-c-devel
dab1ca85
BZ
44BuildConflicts: xerces-c-devel >= 2.8.0
45Conflicts: xerces-c >= 2.8.0
46%endif
ae21b5c7
JB
47# for irrlicht
48BuildRequires: xorg-lib-libXxf86vm-devel
a7c52a89
ŁK
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52CEGUI stands for Crazy Eddie's Gui System; a free library providing
53windowing and widgets for graphics APIs / engines where such
54functionality is not natively available, or severely lacking. The
55library is object orientated, written in C++, and targeted at games
56developers who should be spending their time creating great games, not
57building GUI sub-systems!
58
71dc0787
JB
59%description -l pl.UTF-8
60CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
61zapewniającą okienka i widgety dla graficznych API i silników tam,
62gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
63braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
64skierowana dla programistów gier, którzy powinni spędzać czas na
65pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
66
a7c52a89
ŁK
67%package devel
68Summary: Development files for CEGUI
71dc0787 69Summary(pl.UTF-8): Pliki programistyczne dla CEGUI
a7c52a89
ŁK
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
54df35ea
JB
72Requires: freetype-devel >= 2.0
73Requires: libstdc++-devel
74Requires: pcre-devel >= 5.0
a7c52a89
ŁK
75
76%description devel
77CEGUI headers and documentation.
78
71dc0787
JB
79%description devel -l pl.UTF-8
80Pliki nagłówkowe i dokumentacja do CEGUI.
81
a7c52a89
ŁK
82%prep
83%setup -q -b 1
84%patch0 -p1
54df35ea 85%patch1 -p1
a7c52a89
ŁK
86
87%build
88%{__libtoolize}
89%{__aclocal}
90%{__autoconf}
91%{__autoheader}
92%{__automake}
54df35ea
JB
93%configure \
94 --with-default-image-codec=FreeImageImageCodec \
dab1ca85
BZ
95 --with-default-parser=LibxmlParser \
96%if %{with xercesc}
97 --enable-xerces-c
98%else
99 --disable-xerces-c
100%endif
a7c52a89
ŁK
101
102%{__make}
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107%{__make} install \
108 DESTDIR=$RPM_BUILD_ROOT
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
118%doc AUTHORS ChangeLog README
54df35ea 119%attr(755,root,root) %{_libdir}/libCEGUI*.so.*.*.*
a7c52a89
ŁK
120
121%files devel
122%defattr(644,root,root,755)
123%doc documentation
54df35ea
JB
124%attr(755,root,root) %{_libdir}/libCEGUI*.so
125%{_libdir}/libCEGUI*.la
71dc0787 126%{_includedir}/%{name}
54df35ea
JB
127%{_pkgconfigdir}/CEGUI.pc
128%{_pkgconfigdir}/CEGUI-OPENGL.pc
This page took 0.081432 seconds and 4 git commands to generate.