]> git.pld-linux.org Git - packages/CEGUI.git/blame - CEGUI.spec
- remove double packaged files
[packages/CEGUI.git] / CEGUI.spec
CommitLineData
a7c52a89 1# TODO:
a7c52a89 2# - gcc33 patch only for AC-branch
54df35ea 3# - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
c549a2c3 4# - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
dab1ca85
BZ
5#
6# Conditional build:
06eb5540
BZ
7%bcond_without xercesc # build XercesParser
8%bcond_with ogre # build samples with ogre3d
9%bcond_with samples # build samples
a7c52a89 10#
71dc0787
JB
11Summary: CEGUI - a free library providing windowing and widgets
12Summary(pl.UTF-8): CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
a7c52a89 13Name: CEGUI
06eb5540 14Version: 0.6.0
715a1989 15Release: 2
779edc3e 16License: LGPL v2.1+ (with MIT parts)
a7c52a89 17Group: Libraries
06eb5540
BZ
18Source0: http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
19# Source0-md5: a7772b20a4e3530298e3e28c4eaec1bb
a7c52a89 20Source1: http://dl.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
06eb5540 21# Source1-md5: 8abece86ea0b8a52737579ac2e801978
c549a2c3 22Patch0: %{name}-gcc33.patch
54df35ea 23Patch1: %{name}-link.patch
779edc3e 24Patch2: %{name}-irrlicht.patch
a7c52a89 25URL: http://www.cegui.org.uk/
ae21b5c7 26BuildRequires: DevIL-devel
7e74cc56 27BuildRequires: FreeImage-devel
28BuildRequires: OpenGL-GLU-devel
54df35ea 29BuildRequires: OpenGL-glut-devel
296738c2 30BuildRequires: SILLY-devel >= 0.1.0
54df35ea 31BuildRequires: autoconf >= 2.59
a7c52a89 32BuildRequires: automake
296738c2 33BuildRequires: corona-devel >= 1.0.2
54df35ea
JB
34BuildRequires: expat-devel
35BuildRequires: freetype-devel >= 2.0
779edc3e 36BuildRequires: irrlicht-devel >= 1.4
7e74cc56 37BuildRequires: libstdc++-devel
54df35ea
JB
38BuildRequires: libtool >= 2:1.5
39BuildRequires: libxml2-devel >= 1:2.6
40BuildRequires: lua50-devel >= 5.0
41BuildRequires: pcre-devel >= 5.0
7e74cc56 42BuildRequires: pkgconfig
06eb5540
BZ
43%if %{with ogre}
44BuildRequires: ois-devel
45BuildRequires: ogre-devel
46%endif
779edc3e
JB
47# for irrlicht renderer
48BuildRequires: xorg-lib-libXxf86vm-devel
49Requires: irrlicht >= 1.4
dab1ca85 50%if %{with xercesc}
54df35ea 51BuildRequires: xerces-c-devel
dab1ca85 52%endif
a7c52a89
ŁK
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55%description
56CEGUI stands for Crazy Eddie's Gui System; a free library providing
57windowing and widgets for graphics APIs / engines where such
58functionality is not natively available, or severely lacking. The
59library is object orientated, written in C++, and targeted at games
60developers who should be spending their time creating great games, not
61building GUI sub-systems!
62
71dc0787
JB
63%description -l pl.UTF-8
64CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
65zapewniającą okienka i widgety dla graficznych API i silników tam,
66gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
67braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
68skierowana dla programistów gier, którzy powinni spędzać czas na
69pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
70
a7c52a89
ŁK
71%package devel
72Summary: Development files for CEGUI
71dc0787 73Summary(pl.UTF-8): Pliki programistyczne dla CEGUI
a7c52a89
ŁK
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
54df35ea
JB
76Requires: freetype-devel >= 2.0
77Requires: libstdc++-devel
78Requires: pcre-devel >= 5.0
a7c52a89
ŁK
79
80%description devel
715a1989 81CEGUI headers.
a7c52a89 82
71dc0787 83%description devel -l pl.UTF-8
715a1989
BZ
84Pliki nagłówkowe CEGUI.
85
86%package docs
87Summary: Documentation files for CEGUI
88Summary(pl.UTF-8): Pliki dokumentacji CEGUI
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91
92%description docs
93CEGUI documentation.
94
95%description docs -l pl.UTF-8
96Dokumentacja CEGUI.
97
71dc0787 98
a7c52a89
ŁK
99%prep
100%setup -q -b 1
101%patch0 -p1
06eb5540
BZ
102#%patch1 -p1
103#%patch2 -p1
a7c52a89
ŁK
104
105%build
106%{__libtoolize}
107%{__aclocal}
108%{__autoconf}
109%{__autoheader}
110%{__automake}
54df35ea
JB
111%configure \
112 --with-default-image-codec=FreeImageImageCodec \
dab1ca85 113 --with-default-parser=LibxmlParser \
06eb5540
BZ
114 %{!?with_samples:--disable-samples} \
115 %{!?with_ogre:--without-ogre-renderer} \
116 --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
a7c52a89
ŁK
117
118%{__make}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123%{__make} install \
124 DESTDIR=$RPM_BUILD_ROOT
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130%postun -p /sbin/ldconfig
131
132%files
133%defattr(644,root,root,755)
134%doc AUTHORS ChangeLog README
715a1989 135%attr(755,root,root) %{_libdir}/libCEGUI*.so.*
3b0715c7
BZ
136%attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
137%attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
138%attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
139%attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
140%attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
141%attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
142%attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
143%attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
144%attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
145%attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
146%attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
147%attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
715a1989
BZ
148
149%files docs
150%doc documentation
151%dir %{_datadir}/%{name}
152%dir %{_datadir}/%{name}/XMLRefSchema
153%{_datadir}/%{name}/XMLRefSchema/*.xsd
154%{_datadir}/%{name}/XMLRefSchema/Readme.txt
a7c52a89
ŁK
155
156%files devel
157%defattr(644,root,root,755)
3b0715c7
BZ
158%attr(755,root,root) %{_libdir}/libCEGUIBase.so
159%attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
54df35ea 160%{_libdir}/libCEGUI*.la
71dc0787 161%{_includedir}/%{name}
54df35ea
JB
162%{_pkgconfigdir}/CEGUI.pc
163%{_pkgconfigdir}/CEGUI-OPENGL.pc
This page took 0.05934 seconds and 4 git commands to generate.