]> git.pld-linux.org Git - packages/apache1-mod_pointer.git/blame - apache1-mod_pointer.spec
- mysql_query fix
[packages/apache1-mod_pointer.git] / apache1-mod_pointer.spec
CommitLineData
32cdfe24
ER
1# TODO
2# - apache config
3# - package split by backend
4%define mod_name pointer
5%define apxs %{_sbindir}/apxs1
6Summary: Apache module for making domain redirects
7Name: apache1-mod_%{mod_name}
8Version: 0.8
9Release: 0.1
10License: Apache
11Group: Networking/Daemons
12Source0: http://stderr.net/mod_pointer/dist/mod_pointer-%{version}.tar.gz
13# Source0-md5: 2f6529c49f1d10ecd06d3f6bc8503a5f
14URL: http://stderr.net/mod_pointer/
15BuildRequires: apache1-devel >= 1.3.33-2
16BuildRequires: gdbm-devel
17BuildRequires: mysql-devel
18BuildRequires: postgresql-devel
19BuildRequires: rpmbuild(macros) >= 1.268
20Requires: apache1 >= 1.3.33-2
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26%description
27mod_pointer is an Apache module for making domain redirects easy - the
28known service of many hosting providers that lets a domain point to
29your webpage on another server.
30
31The configuration part of the mappings are handled in either a MySQL
32or Postgresql database or a NDBM or SDBM db file, so it's easy to
33build a webbased interface for letting users change it on their own.
34
35%prep
36%setup -q -n mod_%{mod_name}-%{version}
37
38%build
39%{__make} all \
40 WITH_APXS=%{apxs}
41
42%install
43rm -rf $RPM_BUILD_ROOT
44install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
45
46%{__make} install \
47 APXS="%{apxs} -S DESTDIR=$RPM_BUILD_ROOT"
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%post
53%service -q apache restart
54
55%postun
56if [ "$1" = "0" ]; then
57 %service -q apache restart
58fi
59
60%files
61%defattr(644,root,root,755)
62%doc README CHANGES
63#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
64%attr(755,root,root) %{_pkglibdir}/*
This page took 0.055236 seconds and 4 git commands to generate.