]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache-apxs.patch
- up to 2.4.59
[packages/apache.git] / apache-apxs.patch
index f4bed195e2af8f342982e12a78e49403aab24fd8..7dc3930e3cf0260234fe996334029c8db030e8af 100644 (file)
@@ -1,40 +1,39 @@
---- httpd-2.0.46/support/apxs.in.orig  Wed May 21 13:39:52 2003
-+++ httpd-2.0.46/support/apxs.in       Thu May 29 07:27:40 2003
-@@ -64,11 +64,11 @@
- my %config_vars = ();
- my $installbuilddir = "@exp_installbuilddir@";
--get_config_vars("$installbuilddir/config_vars.mk",\%config_vars);
-+get_config_vars("/usr/lib/apache/build/config_vars.mk",\%config_vars);
- # read the configuration variables once
--my $prefix         = get_vars("prefix");
-+my $prefix         = "/usr/lib/apache";
- my $CFG_PREFIX     = $prefix;
+diff -urNp -x '*.orig' httpd-2.4.46.org/support/apxs.in httpd-2.4.46/support/apxs.in
+--- httpd-2.4.46.org/support/apxs.in   2020-03-20 14:00:44.000000000 +0100
++++ httpd-2.4.46/support/apxs.in       2021-06-16 09:20:17.513003551 +0200
+@@ -45,6 +45,7 @@ my $CFG_PREFIX     = $prefix;
  my $exec_prefix    = get_vars("exec_prefix");
  my $datadir        = get_vars("datadir");
-@@ -228,9 +228,7 @@
- my $httpd = get_vars("sbindir") . "/" . get_vars("progname");
- $httpd = eval qq("$httpd");
- $httpd = eval qq("$httpd");
--my $envvars = get_vars("sbindir") . "/envvars";
--$envvars = eval qq("$envvars");
--$envvars = eval qq("$envvars");
-+my $envvars = "";
- #allow apxs to be run from the source tree, before installation
- if ($0 =~ m:support/apxs$:) {
-@@ -376,9 +374,9 @@
-     exit(1);
- }
+ my $localstatedir  = get_vars("localstatedir");
++my $libdir       = get_vars("libdir");
+ my $CFG_TARGET     = get_vars("progname");
+ my $CFG_SYSCONFDIR = get_vars("sysconfdir");
+ my $CFG_CFLAGS     = join ' ', map { get_vars($_) }
+@@ -56,6 +57,7 @@ my $CFG_INCLUDEDIR = eval qq("$includedi
+ my $CFG_CC         = get_vars("CC");
+ my $libexecdir     = $destdir . get_vars("libexecdir");
+ my $CFG_LIBEXECDIR = eval qq("$libexecdir");
++my $CFG_DESTDIR    = '';
+ my $sbindir        = get_vars("sbindir");
+ my $CFG_SBINDIR    = eval qq("$sbindir");
+ my $ltflags        = $ENV{'LTFLAGS'};
+@@ -183,7 +185,7 @@ if (@opt_S) {
+           my ($val) = $2;
+           my $oldval = eval "\$CFG_$var";
  
--my $libtool = `$apr_bindir/apr-config --installbuilddir`;
--chomp($libtool);
--$libtool = "$libtool/libtool";
-+#my $libtool = `$apr_bindir/apr-config --installbuilddir`;
-+#chomp($libtool);
-+$libtool = "/usr/bin/libtool";
+-          unless ($var and $oldval) {
++          unless ($var and defined $oldval) {
+               print STDERR "apxs:Error: no config variable $var\n";
+               &usage;
+           }
+@@ -512,8 +514,8 @@ if ($opt_i or $opt_e) {
+         $t =~ s|\.[^./\\]+$|\.so|;
+         if ($opt_i) {
+           push(@cmds, $destdir . "$installbuilddir/instdso.sh SH_LIBTOOL='" .
+-                 "$libtool' $f $CFG_LIBEXECDIR");
+-          push(@cmds, "chmod 755 $CFG_LIBEXECDIR/$t");
++                 "$libtool' $f $CFG_DESTDIR$CFG_LIBEXECDIR");
++          push(@cmds, "chmod 755 $CFG_DESTDIR$CFG_LIBEXECDIR/$t");
+         }
  
- my $apr_includedir = `$apr_bindir/apr-config --includes`;
- chomp($apr_includedir);
+         #   determine module symbolname and filename
This page took 0.098464 seconds and 4 git commands to generate.