]> git.pld-linux.org Git - packages/apache-mod_epp.git/blame - apache-mod_epp.spec
- URLs
[packages/apache-mod_epp.git] / apache-mod_epp.spec
CommitLineData
687cab59 1# TODO:
2# - example/minimal configuration file
687cab59 3%define mod_name epp
4%define apxs /usr/sbin/apxs
737483df 5%include /usr/lib/rpm/macros.perl
687cab59 6Summary: An EPP (Extensible Provisioning Protocol) implementation for Apache2
07cd93ce 7Summary(pl.UTF-8): Implementacja EPP (Extensible Provisioning Protocol) dla Apache2
687cab59 8Name: apache-mod_%{mod_name}
df9334ab 9Version: 1.10
8a51e947 10Release: 0.2
687cab59 11License: Apache
edbb084a 12Group: Networking/Daemons/HTTP
f5859826 13Source0: http://dl.sourceforge.net/aepps/%{version}/mod_%{mod_name}-%{version}.tar.gz
df9334ab 14# Source0-md5: 1418187bf2b478ef2769271000f2b2c8
f5859826 15Source1: http://dl.sourceforge.net/aepps/20030122/epp-erd-20030122.tar.gz
df9334ab 16# Source1-md5: 6c20f40dce10db638e19af17904854df
687cab59 17URL: http://aepps.sourceforge.net/
d57fdca1 18BuildRequires: %{apxs}
687cab59 19BuildRequires: apache-devel >= 2.0.43
20BuildRequires: rpm-perlprov
20545a98 21BuildRequires: rpmbuild(macros) >= 1.268
737483df 22Requires: apache(modules-api) = %apache_modules_api
687cab59 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
737483df 25%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
a4442373 26%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
687cab59 27
28%description
29This Apache 2.0 module implements the EPP over TCP protocol as defined
30in draft-ietf-provreg-epp-tcp-05.txt and the session management parts
31of draft-ietf-provreg-epp-0(6|7).txt.
32
33This is *not* a full implementation of EPP, this module just makes it
34possible to write an EPP server as a set of CGI scripts.
35
ea01e4d6
JR
36%description -l pl.UTF-8
37Ten moduł Apache 2.0 jest implementacją protokołu EPP po TCP zgodną z
38dokumentem draft-ietf-provreg-epp-tcp-05.txt oraz częściami
39dotyczącymi zarządzania sesją z draft-ietf-provreg-epp-0(6|7).txt.
5d28c916 40
ea01e4d6
JR
41*Nie* jest to pełna implementacja EPP, ten moduł jedynie umożliwia
42pisanie serwera EPP jako zestawu skryptów CGI.
687cab59 43
44%prep
82003490 45%setup -q -n mod_%{mod_name}-%{version} -a1
687cab59 46
47%build
48%{apxs} -c mod_%{mod_name}.c
49
50%install
51rm -rf $RPM_BUILD_ROOT
a4442373 52install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
687cab59 53
737483df
ER
54libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
55rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
82003490 56
a4442373 57install -p epptelnet.pl $RPM_BUILD_ROOT%{_bindir}
737483df 58cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
687cab59 59
737483df 60echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
a4442373 61 $RPM_BUILD_ROOT%{_sysconfdir}/68_mod_%{mod_name}.conf
82003490 62
687cab59 63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%post
20545a98 67%service -q httpd restart
687cab59 68
335d68d6 69%postun
687cab59 70if [ "$1" = "0" ]; then
20545a98 71 %service -q httpd restart
687cab59 72fi
73
74%files
75%defattr(644,root,root,755)
82003490 76%doc README TODO epp-erd*
a4442373 77%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
82003490 78%attr(755,root,root) %{_pkglibdir}/*.so
737483df 79%attr(755,root,root) %{_bindir}/*
687cab59 80%{_examplesdir}/%{name}-%{version}
This page took 0.06569 seconds and 4 git commands to generate.