]> git.pld-linux.org Git - packages/apache-mod_clamav.git/blame - apache-mod_clamav.spec
- mod_clamav, antivirus proxy filter for apache2 httpd server
[packages/apache-mod_clamav.git] / apache-mod_clamav.spec
CommitLineData
d418d050 1# $Revision: 1.1 $
2%define apxs /usr/sbin/apxs
3%define mod_name clamav
4Summary: an Apache virus scanning filter
5Name: apache-mod_%{mod_name}
6Version: 0.12
7Release: 1
8License: GPL
9Group: Networking/Daemons
10Source0: http://software.othello.ch/mod_clamav/mod_%{mod_name}-%{version}.tar.gz
11Source1: %{name}.conf
12Patch0: %{name}-libtool-tag.patch
13URL: http://software.othello.ch/mod_clamav/
14BuildRequires: %{apxs}
15BuildRequires: autoconf
16BuildRequires: automake
17BuildRequires: apache-devel
18BuildRequires: apr-devel
19BuildRequires: apr-util-devel
20Requires: apache >= 2
21Requires: apache-mod_proxy
22Requires: clamav
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _pkglibdir %(%{apxs} -q LIBEXECDIR)
26%define _sysconfdir /etc/httpd
27%define _libexecdir %{_libdir}/apache
28
29%description
30mod_clamav is an Apache 2 filter which scans the content delivered by
31the proxy module (mod_proxy) for viruses using the Clamav virus
32scanning engine.
33
34%prep
35%setup -q -n mod_%{mod_name}-%{version}
36%patch0 -p0
37
38%build
39%{__aclocal}
40%{__autoconf}
41%{__automake}
42
43CPPFLAGS="${CPPFLAGS} -I `/usr/bin/apr-config --includedir`"
44CPPFLAGS="${CPPFLAGS} -I `/usr/bin/apu-config --includedir`"
45export CPPFLAGS
46
47%configure \
48 --with-apxs=%{apxs}
49
50%{__make}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
56install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
57
58CFG="$RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf"
59install %{SOURCE1} ${CFG}/32_mod_clamav.conf
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post
65if [ -f /var/lock/subsys/httpd ]; then
66 /etc/rc.d/init.d/httpd restart 1>&2
67else
68 echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
69fi
70
71%preun
72if [ "$1" = "0" ]; then
73 if [ -f /var/lock/subsys/httpd ]; then
74 /etc/rc.d/init.d/httpd restart 1>&2
75 fi
76fi
77
78%files
79%defattr(644,root,root,755)
80%doc AUTHORS ChangeLog COPYING INSTALL mod_clamav.html NEWS README TODO
81%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/32_mod_clamav.conf
82%attr(755,root,root) %{_libexecdir}/mod_%{mod_name}.so
This page took 0.093798 seconds and 4 git commands to generate.