]> git.pld-linux.org Git - packages/acx.git/blobdiff - acx.spec
- obsoleted
[packages/acx.git] / acx.spec
index 93b0cc1354970639b3367dc9fa06fa3b75a704b0..df7cbd4e6230df9a19ad803001dbb61616be8646 100644 (file)
--- a/acx.spec
+++ b/acx.spec
@@ -1,96 +1,97 @@
+# TODO:
+# - add firmware download?
 #
 # Conditional build:
 %bcond_without dist_kernel     # without distribution kernel
+%bcond_without smp             # don't build SMP module
 #
-Summary:       Linux driver for WLAN card base on ACX100
-Summary(pl):   Sterownik dla Linuksa do kart bezprzewodowych na uk³adzie ACX100
-Name:          kernel-net-acx100
-Version:       0.2.0pre8_plus_fixes_8
+%ifarch sparc
+%undefine      with_smp
+%endif
+#
+Summary:       Linux driver for WLAN card base on ACX100/ACX111
+Summary(pl):   Sterownik dla Linuksa do kart bezprzewodowych na uk³adzie ACX100/ACX111
+Name:          acx
+Version:       20070101
 %define        _rel    1
-Release:       %{_rel}@%{_kernel_ver_str}
+Release:       %{_rel}
 License:       MPL or GPL
 Group:         Base/Kernel
-Source0:       http://rhlx01.fht-esslingen.de/~andi/acx100/acx100-%{version}.tar.bz2
-# Source0-md5: 6bc8a7f94fcb079643e18b3d6fd301a6
-URL:           http://acx100.sourcefroge.net/index.html
-%{?with_dist_kernel:BuildRequires:     kernel-headers >= 2.4.0}
-BuildRequires: %{kgcc_package}
-BuildRequires: rpmbuild(macros) >= 1.118
-%{?with_dist_kernel:%requires_releq_kernel_up}
-Requires(post,postun): /sbin/depmod
-Obsoletes:     kernel-net-acx100
+Source0:       http://www.cmartin.tk/acx/%{name}-%{version}.tar.bz2
+# Source0-md5: ec6322b9c82781897a9433ef0cefda6f
+URL:           http://acx100.sourceforge.net/
+%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.16}
+BuildRequires: rpmbuild(macros) >= 1.330
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-This is driver for WLAN card based on ACX100 for Linux.
+This is driver for WLAN card based on ACX100/ACX111 for Linux.
 
 %description -l pl
-Sterownik dla Linuksa do kart WLAN opartych o uk³ad ACX100.
+Sterownik dla Linuksa do kart WLAN opartych o uk³ad ACX100/ACX111.
+
+%package -n kernel%{_alt_kernel}-net-acx100
+Summary:       Linux driver for WLAN card base on ACX100/ACX111
+Summary(pl):   Sterownik dla Linuksa do kart bezprzewodowych na uk³adzie ACX100/ACX111
+Release:       %{_rel}@%{_kernel_ver_str}
+Group:         Base/Kernel
+%{?with_dist_kernel:%requires_releq_kernel_up}
+Requires(post,postun): /sbin/depmod
 
-%package -n kernel-smp-net-acx100
-Summary:       Linux SMP driver for WLAN card base on ACX100
-Summary(pl):   Sterownik dla Linuksa SMP do kart bezprzewodowych na uk³adzie ACX100
+%description -n kernel%{_alt_kernel}-net-acx100
+This is driver for WLAN card based on ACX100/ACX111 for Linux.
+
+%description -n kernel%{_alt_kernel}-net-acx100 -l pl
+Sterownik dla Linuksa do kart WLAN opartych o uk³ad ACX100/ACX111.
+
+%package -n kernel%{_alt_kernel}-smp-net-acx100
+Summary:       Linux SMP driver for WLAN card base on ACX100/ACX111
+Summary(pl):   Sterownik dla Linuksa SMP do kart bezprzewodowych na uk³adzie ACX100/ACX111
+Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_smp}
 Requires(post,postun): /sbin/depmod
 
-%description -n kernel-smp-net-acx100
-Linux SMP driver for WLAN card base on ACX100.
+%description -n kernel%{_alt_kernel}-smp-net-acx100
+Linux SMP driver for WLAN card base on ACX100/ACX111.
 
-%description -n kernel-smp-net-acx100 -l pl
-Sterownik dla Linuksa SMP do kart bezprzewodowych na uk³adzie ACX100.
+%description -n kernel%{_alt_kernel}-smp-net-acx100 -l pl
+Sterownik dla Linuksa SMP do kart bezprzewodowych na uk³adzie ACX100/ACX111.
 
 %prep
-%setup -q -n acx100-%{version}
+%setup -q
 
 %build
-cat > config.mk <<EOF
-KERNEL_BUILD=%{_kernelsrcdir}
-VERSION_CODE=`grep LINUX_VERSION_CODE %{_kernelsrcdir}/include/linux/version.h | sed -e 's/[^0-9]//g'`
-EOF
-%{__make} \
-       CC="%{kgcc}" \
-       CPPFLAGS="-D__KERNEL__ -DMODULE -DACX_DEBUG=1 -DWLAN_HOSTIF=WLAN_PCI -I%{_kernelsrcdir}/include -I../include" \
-       CFLAGS="%{rpmcflags} -fno-strict-aliasing -fno-common -fomit-frame-pointer -Wall -Wstrict-prototypes -Wno-trigraphs"
-mv -f src/acx_pci.o acx_pci-up.o
-mv -f src/acx_usb.o acx_usb-up.o
-
-%{__make} clean -C src
-%{__make} \
-       CC="%{kgcc}" \
-       CPPFLAGS="-D__KERNEL__ -D__KERNEL_SMP -DMODULE -DACX_DEBUG=1 -DWLAN_HOSTIF=WLAN_PCI -I%{_kernelsrcdir}/include -I../include" \
-       CFLAGS="%{rpmcflags} -fno-strict-aliasing -fno-common -fomit-frame-pointer -Wall -Wstrict-prototypes -Wno-trigraphs"
+%build_kernel_modules -m acx
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
 
-install acx_pci-up.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/acx_pci.o
-install acx_usb-up.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/acx_usb.o
-install src/acx_pci.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/acx_pci.o
-install src/acx_usb.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/acx_usb.o
+%install_kernel_modules -m acx -d misc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
+%post  -n kernel%{_alt_kernel}-net-acx100
 %depmod %{_kernel_ver}
 
-%postun
+%postun        -n kernel%{_alt_kernel}-net-acx100
 %depmod %{_kernel_ver}
 
-%post  -n kernel-smp-net-acx100
+%post  -n kernel%{_alt_kernel}-smp-net-acx100
 %depmod %{_kernel_ver}smp
 
-%postun        -n kernel-smp-net-acx100
+%postun        -n kernel%{_alt_kernel}-smp-net-acx100
 %depmod %{_kernel_ver}smp
 
-%files
+%files -n kernel%{_alt_kernel}-net-acx100
 %defattr(644,root,root,755)
-%doc ChangeLog README TODO doc/*
-/lib/modules/%{_kernel_ver}/misc/*.o*
+%doc Changelog README
+/lib/modules/%{_kernel_ver}/misc/*.ko*
 
-%files -n kernel-smp-net-acx100
+%if %{with smp}
+%files -n kernel%{_alt_kernel}-smp-net-acx100
 %defattr(644,root,root,755)
-%doc ChangeLog README TODO doc/*
-/lib/modules/%{_kernel_ver}smp/misc/*.o*
+%doc Changelog README
+/lib/modules/%{_kernel_ver}smp/misc/*.ko*
+%endif
This page took 0.127251 seconds and 4 git commands to generate.